Browse Source

w3m-el-1.4.437-1.cvs20110421

git-svn-id: http://trac.vinelinux.org/repos/projects/specs@3604 ec354946-7b23-47d6-9f5a-488ba84defc7
iwaim 11 years ago
parent
commit
0267d00551
1 changed files with 15 additions and 11 deletions
  1. 15 11
      w/w3m-el/w3m-el-vl.spec

+ 15 - 11
w/w3m-el/w3m-el-vl.spec

@@ -1,13 +1,13 @@
 %define _noVersionedDependencies        1
-%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
 %define _libdir %{_prefix}/lib
 
 %define	      cvs	    1
 
-%define       origver       1.4.148
+# from (emacs-w3m-version) in w3m.el
+%define       origver       1.4.437
 %define       origname      w3m
-%define	      rel	    7
-%define	      cvsdate	    20100124
+%define	      rel	    1
+%define	      cvsdate	    20110421
 
 Summary:      an simple interface program of w3m, which works on Emacsen
 Summary(ja):  Emacsen 用の w3m インタフェースプログラム
@@ -39,21 +39,18 @@ Group:        Applications/Editors/Emacs
 BuildRoot:    %{_tmppath}/%{name}-%{version}-root
 BuildArch:    noarch
 
-Requires(post): emacsen
+Requires(post): emacsen emacsen-common
 Requires(post): autoconf
+Requires(post): apel flim w3m
 ##Requires(post): texinfo tetex
 BuildRequires:  w3m
 BuildRequires:  emacs
 BuildRequires: texinfo
-BuildRequires: tetex
-
-%prereq_ge    emacsen-common
-%prereq_ge    flim
-%prereq_ge    w3m
+BuildRequires: texlive
 
 Vendor:       Project Vine
 Distribution: Vine Linux
-Packager:     MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
+Packager:     shaolin
 
 
 %description
@@ -207,6 +204,13 @@ fi
  
 
 %changelog
+* Thu Apr 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.437-1.cvs20110421
+- new upstream cvs head
+- add Requires: apel: <BTS:VineLinux:1014>
+- replace BuildRequires: tetex to texlive
+- drop defining prereq_ge macro: using Requires(post) tag
+- update Packager syntax
+
 * Fri Feb 19 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.148-7.cvs20100124
 - update %%files: politely for info files