Browse Source

2014-12-11 Ryoichi INAGAKI <ryo1@toki.waseda.jp>

	* cryptsetup, gwenhywfar, vpnc: rebuilt
	


git-svn-id: http://trac.vinelinux.org/repos/projects/specs@9144 ec354946-7b23-47d6-9f5a-488ba84defc7
inagaki 8 years ago
parent
commit
52753c34e4
3 changed files with 31 additions and 12 deletions
  1. 20 9
      c/cryptsetup/cryptsetup-vl.spec
  2. 7 2
      g/gwenhywfar/gwenhywfar-vl.spec
  3. 4 1
      v/vpnc/vpnc-vl.spec

+ 20 - 9
c/cryptsetup/cryptsetup-vl.spec

@@ -5,17 +5,23 @@ Summary:	A utility for setting up encrypted disks
 Summary(ja):	暗号化ファイルシステム設定用ユーティリティ
 Name:		cryptsetup
 Version:	1.4.1
-Release:	3%{?_dist_release}
+Release:	4%{?_dist_release}
 License:	GPLv2 and LGPLv2+
 Group:		Applications/System
 URL:		http://cryptsetup.googlecode.com/
-BuildRequires:	libgcrypt-devel, popt-devel, device-mapper-devel
-BuildRequires:	libgpg-error-devel, libuuid-devel
+
+Source0:	http://cryptsetup.googlecode.com/files/cryptsetup-%{upstream_version}.tar.bz2
+
+BuildRoot:      %{_tmppath}/%{name}-%{version}-root
+BuildRequires:	libgcrypt-devel
+BuildRequires:  popt-devel
+BuildRequires:  device-mapper-devel
+BuildRequires:	libgpg-error-devel
+BuildRequires:  libuuid-devel
 BuildRequires:	python-devel
 Provides:	cryptsetup-luks = %{version}-%{release}
 Obsoletes:	cryptsetup-luks < 1.4.0
 Requires:	cryptsetup-libs = %{version}-%{release}
-Source0:	http://cryptsetup.googlecode.com/files/cryptsetup-%{upstream_version}.tar.bz2
 
 %description
 The cryptsetup package contains a utility for setting up
@@ -27,12 +33,14 @@ cryptsetup パッケージには、dm-crypt カーネルモジュールを使っ
 
 
 %package devel
+Summary: Headers and libraries for using encrypted file systems
+Summary(ja): 暗号化ファイルシステムを使うためのヘッダとライブラリ
 Group: Development/Libraries
 Requires: %{name} = %{version}-%{release}
-Requires: libgcrypt-devel > 1.1.42, device-mapper-devel, libuuid-devel
+Requires: libgcrypt-devel > 1.1.42
+Requires: device-mapper-devel
+Requires: libuuid-devel
 Requires: pkgconfig
-Summary: Headers and libraries for using encrypted file systems
-Summary(ja): 暗号化ファイルシステムを使うためのヘッダとライブラリ
 Provides: cryptsetup-luks-devel = %{version}-%{release}
 Obsoletes: cryptsetup-luks-devel < 1.4.0
 
@@ -46,9 +54,9 @@ cryptsetup-devel パッケージには、ディスクの暗号化を使うコー
 
 
 %package libs
-Group: System Environment/Libraries
 Summary: Cryptsetup shared library
 Summary(ja): Cryptsetup 共有ライブラリ
+Group: System Environment/Libraries
 Provides: cryptsetup-luks-libs = %{version}-%{release}
 Obsoletes: cryptsetup-luks-libs < 1.4.0
 
@@ -61,9 +69,9 @@ This package contains the cryptsetup shared library, libcryptsetup.
 
 
 %package python
-Group: System Environment/Libraries
 Summary: Python bindings for libcryptsetup
 Summary(ja): libcryptsetup の Python バインディング
+Group: System Environment/Libraries
 Requires: %{name}-libs = %{version}-%{release}
 Provides: python-cryptsetup = %{version}-%{release}
 Obsoletes: python-cryptsetup < 1.4.0
@@ -143,6 +151,9 @@ rm -rf %{buildroot}
 
 
 %changelog
+* Sat Dec  6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.4.1-4
+- rebuilt with libgcrypt 1.6.0
+
 * Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.1-3
 - updated to 1.4.1; spec revamp; Japanese summary & description
 

+ 7 - 2
g/gwenhywfar/gwenhywfar-vl.spec

@@ -1,7 +1,7 @@
 Summary: A multi-platform helper library for other libraries
 Name: gwenhywfar
 Version: 4.3.3
-Release: 1%{?_dist_release}
+Release: 2%{?_dist_release}
 
 Group: System Environment/Libraries
 License: LGPLv2+
@@ -77,8 +77,10 @@ find $RPM_BUILD_ROOT -name *.la -exec rm -f {} \;
 %{_bindir}/gct-tool
 %{_libdir}/libgwenhywfar.so.*
 %{_libdir}/%{name}
-%{_datadir}/%{name}
+%dir %{_datadir}/%{name}
 %config(noreplace) %{_datadir}/%{name}/ca-bundle.crt
+%{_datadir}/%{name}/dialogs
+%{_datadir}/%{name}/typemaker2
 %{_datadir}/locale/*/LC_MESSAGES/gwenhywfar.mo
 %exclude %{_datadir}/%{name}/typemaker*
 
@@ -102,6 +104,9 @@ find $RPM_BUILD_ROOT -name *.la -exec rm -f {} \;
 
 
 %changelog
+* Sat Dec  6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.3.3-2
+- rebuilt with libgcrypt 1.6.0 and gnutls 3.2.20
+
 * Sun Sep 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.3.3-1
 - new upstream release
 - add BuildRequires: gtk2-devel, qt4-devel

+ 4 - 1
v/vpnc/vpnc-vl.spec

@@ -1,6 +1,6 @@
 Name:           vpnc
 Version:        0.5.3
-Release:        3%{?_dist_release}
+Release:        4%{?_dist_release}
 
 Summary:        IPSec VPN client compatible with Cisco equipment
 Summary(ja):    Cisco 機器互換の IPSec VPN クライアント
@@ -105,6 +105,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_sbindir}/vpnc-helper
 
 %changelog
+* Sat Dec  6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.5.3-4
+- rebuilt with libgcrypt 1.6.0
+
 * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.3-3
 - rebuild with VineSeed environment