Browse Source

updated 13 packages

amtk-5.2.0-1

gedit-40.0-1

gspell-1.8.4-1

gtksourceview4-4.8.1-1

iso-codes-4.6.0-1

libpeas-1.30.0-1

python-mallard-ducktype-1.0.2-9

tepl-6.00.0-1

uchardet-0.0.7-1

vte3-0.62.3-1

yelp-tools-40.0-1

yelp-xsl-40.0-1

yelp-40.0-1
Tomohiro "Tomo-p" KATO 1 year ago
parent
commit
5283e4f3df

+ 11 - 2
a/amtk/amtk-vl.spec

@@ -1,7 +1,8 @@
 Name:           amtk
-Version:        5.0.2
-Release:        3%{?_dist_release}
+Version:        5.2.0
+Release:        1%{?_dist_release}
 Summary:        Actions, Menus and Toolbars Kit for GTK+ applications
+Group:          system
 Vendor:         Project Vine
 Distribution:   Vine Linux
 
@@ -24,6 +25,7 @@ traditional UI or a modern UI with a GtkHeaderBar.
 
 %package        devel
 Summary:        Development files for %{name}
+Group:          programming
 Requires:       %{name}%{?_isa} = %{version}-%{release}
 
 %description    devel
@@ -33,6 +35,7 @@ developing applications that use %{name}.
 
 %package        tests
 Summary:        Tests for the %{name} package
+Group:          programming
 Requires:       %{name}%{?_isa} = %{version}-%{release}
 
 %description    tests
@@ -40,6 +43,9 @@ The %{name}-tests package contains tests that can be used to verify
 the functionality of the installed %{name} package.
 
 
+%debug_package
+
+
 %prep
 %autosetup
 
@@ -81,6 +87,9 @@ find $RPM_BUILD_ROOT -name '*.la' -delete
 
 
 %changelog
+* Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.2.0-1
+- new upstream release.
+
 * Tue May 05 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.0.2-3
 - initial build for Vine Linux.
 

+ 16 - 19
g/gedit/gedit-vl.spec

@@ -2,7 +2,7 @@ Summary:	gedit is a small but powerful text editor for GNOME.
 Summary(ja):	GNOME 用の小さくかつ強力なテキストエディタ
 Name:		gedit
 Group:		accessories,desktop-gnome
-Version:	3.36.2
+Version:	40.0
 Release:	1%{?_dist_release}
 Vendor:		Project Vine
 Distribution:	Vine Linux
@@ -10,7 +10,8 @@ Packager:	daisuke, inagaki
 
 License:	GPLv2
 URL:		https://wiki.gnome.org/Apps/Gedit
-%global		shortver %(echo %{version} | cut -d . -f 1,2)
+%global		shortver %(echo %{version} | cut -d . -f 1)
+%global		apiver %{version}
 Source0:	https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
 # https://gitlab.gnome.org/GNOME/gedit/-/commit/5e0909c19f267b4023131881fac89c58a2a17453
 Patch1:		restore-overlay-scrollbars.patch
@@ -20,6 +21,7 @@ BuildRoot:	%{_tmppath}/%{name}-%{version}-root
 Requires: python3-pygobject
 
 BuildRequires: meson
+BuildRequires: symlinks
 BuildRequires: gnome-common
 BuildRequires: glib2-devel
 BuildRequires: gtk3-devel
@@ -29,9 +31,8 @@ BuildRequires: libpeas-devel
 BuildRequires: gspell-devel
 BuildRequires: libX11-devel
 BuildRequires: gobject-introspection-devel
-BuildRequires: vala-tools
+BuildRequires: vala
 BuildRequires: vala-devel
-BuildRequires: python3-rpm-macros
 BuildRequires: python3-pygobject
 BuildRequires: pygobject3-devel
 BuildRequires: gsettings-desktop-schemas-devel
@@ -82,6 +83,9 @@ gedit は GNOME 用の小さく、それでいて、強力なテキストエデ
 gedit のプラグインを開発する場合には gedit-devel をインストールしてください。
 
 
+%debug_package
+
+
 %prep
 %setup -n gedit-%{version} -q
 
@@ -95,6 +99,8 @@ gedit のプラグインを開発する場合には gedit-devel をインスト
 rm -rf $RPM_BUILD_ROOT
 %meson_install
 
+for l in $(find %{buildroot}%{_datadir}/help -type l); do symlinks -cdov $l; done
+
 %find_lang %{name} --with-gnome
 
 
@@ -102,26 +108,13 @@ rm -rf $RPM_BUILD_ROOT
 rm -rf $RPM_BUILD_ROOT
 
 
-%post
-update-desktop-database %{_datadir}/applications >& /dev/null ||:
-
-%postun
-update-desktop-database %{_datadir}/applications >& /dev/null ||:
-glib-compile-schemas %{_datadir}/glib-2.0/schemas >& /dev/null ||:
-gtk-update-icon-cache %{_datadir}/icons/hicolor >& /dev/null || :
-
-%posttrans
-glib-compile-schemas %{_datadir}/glib-2.0/schemas >& /dev/null ||:
-gtk-update-icon-cache %{_datadir}/icons/hicolor >& /dev/null || :
-
-
 %files -f %{name}.lang
 %defattr(-, root, root)
 %license COPYING
 %doc NEWS README*
 %{_bindir}/gedit
 %{_libdir}/%{name}
-%{python3_sitearch}/gi/overrides/Gedit.*
+%{python3_sitelib}/gi/overrides/Gedit.*
 %{_datadir}/applications/org.gnome.gedit.desktop
 %{_datadir}/metainfo/org.gnome.gedit.appdata.xml
 %{_datadir}/dbus-1/services/org.gnome.gedit.service
@@ -133,7 +126,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor >& /dev/null || :
 
 %files devel
 %defattr(-, root, root)
-%{_includedir}/%{name}-3.36
+%{_includedir}/%{name}-%{apiver}
 %{_libdir}/pkgconfig/*.pc
 %{_datadir}/%{name}/gir-1.0/*.gir
 %dir %{_datadir}/vala
@@ -142,6 +135,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor >& /dev/null || :
 
 
 %changelog
+* Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 40.0-1
+- new upstream release.
+- dropped scriptlets.
+
 * Sun Aug 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.36.2-1
 - new upstream release.
 - unified gedit-python3-plugins into main package.

+ 12 - 7
g/gspell/gspell-vl.spec

@@ -4,8 +4,9 @@
 Name:           gspell
 Summary:        Spell-checking library for GTK+
 Summary(ja):    GTK+用スペルチェックライブラリ
-Version:        1.8.3
+Version:        1.8.4
 Release:        1%{?_dist_release}
+Group:          system
 Vendor:         Project Vine
 Distribution:   Vine Linux
 
@@ -20,7 +21,7 @@ BuildRequires:  enchant2-devel
 BuildRequires:  glib2-devel >= %{glib2_version}
 BuildRequires:  gtk3-devel >= %{gtk3_version}
 BuildRequires:  iso-codes
-BuildRequires:  vala-devel, vala-tools
+BuildRequires:  vala-devel, vala
 BuildRequires:  gtk-doc
 
 Requires:       glib2%{?_isa} >= %{glib2_version}
@@ -34,6 +35,7 @@ in a GTK+ application.
 
 %package        devel
 Summary:        Development files for %{name}
+Group:          programming
 Requires:       %{name}%{?_isa} = %{version}-%{release}
 
 %description    devel
@@ -43,6 +45,7 @@ developing applications that use %{name}.
 
 %package        doc
 Summary:        API documentation for %{name}
+Group:          documentation
 BuildArch:      noarch
 Requires:       %{name} = %{version}-%{release}
 
@@ -50,6 +53,9 @@ Requires:       %{name} = %{version}-%{release}
 This package contains the full API documentation for %{name}.
 
 
+%debug_package
+
+
 %prep
 %setup -q
 
@@ -66,11 +72,6 @@ find $RPM_BUILD_ROOT -name '*.la' -delete
 %find_lang gspell-1
 
 
-%post -p /sbin/ldconfig
-
-%postun -p /sbin/ldconfig
-
-
 %files -f gspell-1.lang
 %license COPYING
 %{_libdir}/girepository-1.0/
@@ -89,6 +90,10 @@ find $RPM_BUILD_ROOT -name '*.la' -delete
 
 
 %changelog
+* Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.8.4-1
+- new upstream release.
+- dropped ldconfig scriptlets.
+
 * Tue May 05 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.8.3-1
 - new upstream release.
 

+ 11 - 2
g/gtksourceview4/gtksourceview4-vl.spec

@@ -2,10 +2,11 @@
 %global gtk_version 3.22
 
 Name:           gtksourceview4
-Version:        4.6.0
-Release:        2%{?_dist_release}
 Summary:        Source code editing widget
 Summary(ja):    ソースコード編集ウィジェット
+Version:        4.8.1
+Release:        1%{?_dist_release}
+Group:          system
 Vendor:         Project Vine
 Distribution:   Vine Linux
 
@@ -53,6 +54,7 @@ undo/redo、ファイル読込・保存、検索・置換、入力補完、印
 
 %package        devel
 Summary:        Development files for %{name}
+Group:          programming
 Requires:       %{name}%{?_isa} = %{version}-%{release}
 
 %description    devel
@@ -62,6 +64,7 @@ developing applications that use %{name}.
 
 %package        tests
 Summary:        Tests for the %{name} package
+Group:          programming
 Requires:       %{name}%{?_isa} = %{version}-%{release}
 
 %description    tests
@@ -69,6 +72,9 @@ The %{name}-tests package contains tests that can be used to verify
 the functionality of the installed %{name} package.
 
 
+%debug_package
+
+
 %prep
 %autosetup -n gtksourceview-%{version}
 
@@ -116,6 +122,9 @@ the functionality of the installed %{name} package.
 
 
 %changelog
+* Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.8.1-1
+- new upstream release.
+
 * Tue May 05 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.6.0-2
 - initial build for Vine Linux.
 

+ 6 - 3
i/iso-codes/iso-codes-vl.spec

@@ -1,9 +1,9 @@
 Name:		iso-codes
 Summary:        ISO code lists and translations
 Summary(ja):    ISO コード一覧および翻訳
-Version:        4.4
+Version:        4.6.0
 Release:        1%{?_dist_release}
-Group:          System Environment/Base
+Group:          system
 Vendor:         Project Vine
 Distribution:   Vine Linux
 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
@@ -11,7 +11,7 @@ BuildArch:      noarch
 
 License:        LGPLv2+
 URL:            https://salsa.debian.org/iso-codes-team/iso-codes
-Source:         https://salsa.debian.org/iso-codes-team/%{name}/-/archive/%{name}-%{version}/%{name}-%{name}-%{version}.tar.gz
+Source:         https://salsa.debian.org/iso-codes-team/%{name}/-/archive/%{name}-%{version}/%{name}-%{name}-%{version}.tar.bz2
 
 BuildRequires:   gettext
 BuildRequires:   python3
@@ -59,6 +59,9 @@ translations in gettext .po form.
 
 
 %changelog
+* Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.6.0-1
+- new upstream release.
+
 * Sat Apr 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.4-1
 - new upstream release.
 

+ 11 - 11
lib/libp/libpeas/libpeas-vl.spec

@@ -1,7 +1,7 @@
 Summary:	Plug-ins implementation convenience library
 Name:		libpeas
-Version:	1.26.0
-Release:	2%{?_dist_release}
+Version:	1.30.0
+Release:	1%{?_dist_release}
 Group:		system
 Vendor:		Project Vine
 Distribution:	Vine Linux
@@ -28,7 +28,7 @@ to GTK+ and glib-based applications.
 
 %package	devel
 Summary:	Development files for libpeas
-Group:		Development/Libraries
+Group:		programming
 Requires:	%{name} = %{version}-%{release}
 Requires:	gobject-introspection-devel
 
@@ -40,7 +40,7 @@ that are needed to write applications that use libpeas.
 %package        docs
 Summary:        Documentation for %{name}
 Summary(ja):    %{name} 用のドキュメント
-Group:          Documentation
+Group:          documentation
 BuildArch:      noarch
 
 %description    docs
@@ -49,7 +49,7 @@ This package contains documentation for %{name}.
 
 %package	python3
 Summary:	Python3 loader for %{name}
-Group:		System Environment/Libraries
+Group:		programming
 Requires:	%{name} = %{version}-%{release}
 Requires:	python3
 Provides:	python3-%{name} = %{version}-%{release}
@@ -58,6 +58,9 @@ Provides:	python3-%{name} = %{version}-%{release}
 %{summary}
 
 
+%debug_package
+
+
 %prep
 %setup -q
 
@@ -74,19 +77,13 @@ Provides:	python3-%{name} = %{version}-%{release}
 
 
 %post
-/sbin/ldconfig
 touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
 
 %postun
-/sbin/ldconfig
 if [ $1 -eq 0 ]; then
   touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
-  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
 fi
 
-%posttrans
-gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
-
 
 %files -f libpeas-1.0.lang
 %defattr(-,root,root,-)
@@ -121,6 +118,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
 
 
 %changelog
+* Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.30.0-1
+- new upstream release.
+
 * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.26.0-2
 - rebuilt with python-3.8.
 

+ 6 - 1
p/python-mallard-ducktype/python-mallard-ducktype-vl.spec

@@ -3,7 +3,8 @@
 Summary:	Parse Ducktype files and convert them to Mallard
 Name:		python-mallard-ducktype
 Version:	1.0.2
-Release:	8%{?_dist_release}
+Release:	9%{?_dist_release}
+Group:		programming
 Vendor:		Project Vine
 Distribution:	Vine Linux
 
@@ -20,6 +21,7 @@ Parse Ducktype files and convert them to Mallard.
 
 %package -n python3-mallard-ducktype
 Summary:	Parse Ducktype files and convert them to Mallard
+Group:		programming
 BuildRequires:	python3-rpm-macros
 BuildRequires:	python3-devel
 BuildRequires:	python3-setuptools
@@ -52,6 +54,9 @@ Parse Ducktype files and convert them to Mallard.
 
 
 %changelog
+* Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.2-9
+- rebuilt with current environment.
+
 * Mon Aug 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.2-8
 - initial build for Vine Linux.
 

+ 26 - 21
t/tepl/tepl-vl.spec

@@ -1,7 +1,7 @@
 Summary:        Text editor product line
 Name:           tepl
-Version:        4.4.0
-Release:        2%{?_dist_release}
+Version:        6.00.0
+Release:        1%{?_dist_release}
 Group:          system
 Vendor:         Project Vine
 Distribution:   Vine Linux
@@ -9,10 +9,13 @@ Distribution:   Vine Linux
 License:        LGPLv2+
 URL:            https://wiki.gnome.org/Projects/Tepl
 %global         shortver %(echo %{version} | cut -d . -f 1,2)
+%global         apiver %(echo %{version} | cut -d . -f 1)
 Source0:        https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
 
 BuildRequires:  gcc
 BuildRequires:  gettext
+BuildRequires:  gtk-doc
+BuildRequires:  meson
 BuildRequires:  pkgconfig(amtk-5)
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(gobject-introspection-1.0)
@@ -37,45 +40,47 @@ The %{name}-devel package contains libraries and header files for
 developing applications that use %{name}.
 
 
+%debug_package
+
+
 %prep
 %autosetup
 
 
 %build
-%configure
-%make_build V=1
+%meson -Dgtk_doc=true
+%meson_build
 
 
 %install
-%make_install
-find $RPM_BUILD_ROOT -name '*.la' -delete
-
-%find_lang tepl-4
+%meson_install
 
+%find_lang tepl-%{apiver}
 
-%post -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
 
-
-%files -f tepl-4.lang
-%license COPYING
-%doc AUTHORS NEWS README
+%files -f tepl-%{apiver}.lang
+%license LICENSES/*
+%doc NEWS README.md
 %dir %{_libdir}/girepository-1.0
-%{_libdir}/girepository-1.0/Tepl-4.typelib
-%{_libdir}/libtepl-4.so.0*
+%{_libdir}/girepository-1.0/Tepl-%{apiver}.typelib
+%{_libdir}/libtepl-%{apiver}.so.0*
 
 %files devel
-%{_includedir}/tepl-4/
-%{_libdir}/libtepl-4.so
-%{_libdir}/pkgconfig/tepl-4.pc
+%{_includedir}/tepl-%{apiver}/
+%{_libdir}/libtepl-%{apiver}.so
+%{_libdir}/pkgconfig/tepl-%{apiver}.pc
 %dir %{_datadir}/gir-1.0
-%{_datadir}/gir-1.0/Tepl-4.gir
+%{_datadir}/gir-1.0/Tepl-%{apiver}.gir
 %dir %{_datadir}/gtk-doc
 %dir %{_datadir}/gtk-doc/html
-%{_datadir}/gtk-doc/html/tepl-4.0/
+%{_datadir}/gtk-doc/html/tepl-%{apiver}/
 
 
 %changelog
+* Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.00.0-1
+- new upstream release.
+- dropped ldconfig scriptlets.
+
 * Sat Aug 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.0-2
 - initial build for Vine Linux.
 

+ 13 - 22
u/uchardet/uchardet-vl.spec

@@ -1,8 +1,8 @@
 %undefine __cmake_in_source_build
 
 Name:           uchardet
-Version:        0.0.6
-Release:        12%{?_dist_release}
+Version:        0.0.7
+Release:        1%{?_dist_release}
 Summary:        An encoding detector library ported from Mozilla
 Group:          system
 Vendor:         Project Vine
@@ -33,40 +33,27 @@ The %{name}-devel package contains headers and shared libraries
 for developing tools for uchardet.
 
 
+%debug_package
+
+
 %prep
 %autosetup
 
 
 %build
-mkdir -p build
-pushd build
 %cmake \
   -DCMAKE_INSTALL_LIBDIR=%{_libdir} \
   -DBUILD_STATIC=OFF \
-  ..
-make %{?_smp_mflags}
-popd
+  %{nil}
+%cmake_build
 
 
 %install
-pushd build
-make DESTDIR=%{buildroot} install
-popd
+%cmake_install
 
 
 %check
-pushd build
-  ctest -VV \
-  %ifarch %{ix86}
-    || :
-  %else
-    ;
-  %endif
-popd
-
-
-%post -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+%ctest
 
 
 %files
@@ -83,6 +70,10 @@ popd
 
 
 %changelog
+* Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.0.7-1
+- new upstream release.
+- dropped ldconfig scriptlets.
+
 * Sat Aug 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.0.6-12
 - initial build for Vine Linux.
 

+ 29 - 21
v/vte3/vte3-vl.spec

@@ -1,11 +1,14 @@
 %bcond_with systemd
 
+# this package provides libvte-2.91.so
+%global abiver 2.91
+
 Summary: An terminal emulator.
 Summary(ja): ターミナルエミュレータ
 Name: vte3
-Version: 0.60.2
+Version: 0.62.3
 Release: 1%{?_dist_release}%{?with_systemd:.systemd}
-Group: System Environment/Libraries
+Group: system
 Vendor: Project Vine
 Distribution: Vine Linux
 
@@ -21,7 +24,7 @@ BuildRequires: gobject-introspection-devel
 BuildRequires: ncurses-devel
 BuildRequires: gnutls-devel
 BuildRequires: vala-devel
-BuildRequires: vala-tools
+BuildRequires: vala
 BuildRequires: fribidi-devel
 BuildRequires: libicu-devel
 BuildRequires: pcre2-devel >=  10.21
@@ -35,12 +38,13 @@ VTE is an experimental terminal emulator widget for use with GTK+ 3.0.
 %description -l ja
 VTE は GTK+3.0 用のターミナルエミュレータウィジェットです。
 
-%package devel
-Summary: Files needed for developing applications which use vte.
-Summary(ja): VTE を使用したアプリケーションの開発に必要なファイル群
-Group: Development/Libraries
-Requires: %{name} = %{version}-%{release}
-Requires: gtk3-devel
+
+%package        devel
+Summary:        Files needed for developing applications which use vte.
+Summary(ja):    VTE を使用したアプリケーションの開発に必要なファイル群
+Group:          programming
+Requires:       %{name} = %{version}-%{release}
+Requires:       gtk3-devel
 
 %description devel
 VTE is an experimental terminal emulator widget for use with GTK+ 3.0.  This
@@ -50,8 +54,8 @@ package contains the files needed for building applications using VTE.
 %package        docs
 Summary:        Documentation for %{name}
 Summary(ja):    %{name} 用のドキュメント
-Group:          Documentation
-BuildArch:	noarch
+Group:          documentation
+BuildArch:      noarch
 
 %description    docs
 This package contains documentation for %{name}.
@@ -60,7 +64,7 @@ This package contains documentation for %{name}.
 %package        vala
 Summary:        Vala bindings for %{name}
 Summary(ja):    %{name} の Vala バインディング
-Group:          Development/Libraries
+Group:          programming
 Requires:       %{name} = %{version}-%{release}
 Requires:       vala
 
@@ -68,6 +72,9 @@ Requires:       vala
 Vala bindings for %{name}.
 
 
+%debug_package
+
+
 %prep
 %setup -q -n vte-%{version}
 
@@ -88,25 +95,20 @@ Vala bindings for %{name}.
 rm -fr $RPM_BUILD_ROOT
 %meson_install
 
-%find_lang vte-2.91
+%find_lang vte-%{abiver}
 
 
 %clean
 rm -fr $RPM_BUILD_ROOT
 
 
-%post -p /sbin/ldconfig
-
-%postun -p /sbin/ldconfig
-
-
-%files -f vte-2.91.lang
+%files -f vte-%{abiver}.lang
 %defattr(-,root,root)
 %license COPYING*
 %doc AUTHORS NEWS README*
 %doc doc/boxes.txt
 %{_sysconfdir}/profile.d/*
-%{_bindir}/vte-2.91
+%{_bindir}/vte-%{abiver}
 %{_libdir}/*.so.*
 %{_libdir}/girepository-1.0/*.typelib
 %{_libexecdir}/vte3
@@ -123,14 +125,20 @@ rm -fr $RPM_BUILD_ROOT
 
 %files docs
 %defattr(-,root,root)
-%{_datadir}/gtk-doc/html/vte-2.91
+%{_datadir}/gtk-doc/html/vte-%{abiver}
 
 %files vala
 %defattr(-,root,root)
+%dir %{_datadir}/vala
+%dir %{_datadir}/vala/vapi
 %{_datadir}/vala/vapi/*
 
 
 %changelog
+* Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.62.3-1
+- new upstream release.
+- dropped ldconfig scriptlets.
+
 * Tue May 05 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.60.2-1
 - new upstream relese.
 

+ 20 - 21
y/yelp-tools/yelp-tools-vl.spec

@@ -2,28 +2,33 @@
 Summary:	a collection of scripts and build utilities to help create
 Summary(ja):	ヘルプ作成のためのスクリプトとビルドユーティリティのコレクション
 Name:		yelp-tools
-Version:	3.32.2
+Version:	40.0
 Release:	1%{?_dist_release}
+Group:		desktop-gnome,publishing
 Vendor:		Project Vine
 Distribution:	Vine Linux
 Packager:	yasumichi
 
 License:	GPLv2+
 URL:		https://wiki.gnome.org/Apps/Yelp/Tools
-%global		shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
+%global		shortver %(echo %{version} | cut -d . -f 1)
 Source0:	https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
 BuildRoot:	%{_tmppath}/%{name}-%{version}-root
 BuildArch:	noarch
 
 # Dependency
-Requires:	itstool
-Requires:	libxslt
-Requires:	libxml2
-Requires:	yelp-xsl
+BuildRequires:	meson
 BuildRequires:	itstool
 BuildRequires:	libxslt-devel
 BuildRequires:	libxml2-devel
 BuildRequires:	yelp-xsl-devel
+BuildRequires:	python3-lxml
+Requires:	itstool
+Requires:	libxslt
+Requires:	libxml2
+Requires:	yelp-xsl
+Requires:	python3-lxml
+Requires:	mallard-rng
 
 %description
 yelp-tools is a collection of scripts and build utilities to help create,
@@ -43,13 +48,13 @@ yelp-tools は、 Yelp および web 向け文書の作成、管理および発
 
 
 %build
-%configure
-%{__make} %{?_smp_mflags}
+%meson
+%meson_build
 
 
 %install
 %{__rm} -rf ${RPM_BUILD_ROOT}
-%{__make} install DESTDIR=${RPM_BUILD_ROOT}
+%meson_install
 
 
 %clean
@@ -58,25 +63,19 @@ yelp-tools は、 Yelp および web 向け文書の作成、管理および発
 
 %files
 %defattr(-,root,root)
-%license COPYING
-%doc ChangeLog NEWS README
+%license COPYING*
+%doc AUTHORS README
 %{_bindir}/yelp-build
 %{_bindir}/yelp-check
 %{_bindir}/yelp-new
+%{_datadir}/yelp-tools
 %{_datadir}/aclocal/yelp.m4
-%{_datadir}/yelp-tools/templates/task.page
-%{_datadir}/yelp-tools/xslt/comments.xsl
-%{_datadir}/yelp-tools/xslt/mal-epub.xsl
-%{_datadir}/yelp-tools/xslt/mal-files.xsl
-%{_datadir}/yelp-tools/xslt/mal-license.xsl
-%{_datadir}/yelp-tools/xslt/mal-ncx.xsl
-%{_datadir}/yelp-tools/xslt/mal-opf.xsl
-%{_datadir}/yelp-tools/xslt/mal-rng.xsl
-%{_datadir}/yelp-tools/xslt/mal-status.xsl
-%{_datadir}/yelp-tools/xslt/media.xsl
 
 
 %changelog
+* Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 40.0-1
+- new upstream release.
+
 * Mon Aug 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.32.2-1
 - new upstream release.
 

+ 7 - 3
y/yelp-xsl/yelp-xsl-vl.spec

@@ -1,14 +1,15 @@
 Summary:        XSL stylesheets for the yelp help browser
 Summary(ja):    Yelp ヘルプブラウザ用の XSL スタイルシート
 Name:           yelp-xsl
-Version:        3.36.0
+Version:        40.0
 Release:        1%{?_dist_release}
+Group:          publishing
 Vendor:         Project Vine
 Distribution:   Vine Linux
 
 License:        LGPLv2+
 URL:            https://download.gnome.org/sources/yelp-xsl
-%global         shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
+%global         shortver %(echo %{version} | cut -d . -f 1)
 Source0:        https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
 BuildArch:      noarch
 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
@@ -26,7 +27,7 @@ This package contains XSL stylesheets that are used by the yelp help browser.
 %package devel
 Summary: Developer documentation for yelp-xsl
 Summary(ja): yelp-xsl の開発用ファイル
-Group: Development/Libraries
+Group: programming
 Requires: pkgconfig
 Requires: %{name} = %{version}-%{release}
 
@@ -61,6 +62,9 @@ make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
 
 
 %changelog
+* Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 40.0-1
+- new upstream release.
+
 * Mon Aug 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.36.0-1
 - new upstream release.
 

+ 15 - 26
y/yelp/yelp-vl.spec

@@ -8,16 +8,17 @@
 Summary: A system documentation reader from the Gnome project. 
 Summary(ja): GNOME プロジェクトのシステムドキュメントリーダ
 Name: yelp
-Version: 3.36.0
+Version: 40.0
 Release: 1%{?_dist_release}
+Group: desktop-gnome,accesories
 Vendor: Project Vine
 Distribution: Vine Linux
 
 License: GPL
 URL: https://wiki.gnome.org/Apps/Yelp
-%global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
+%global shortver %(echo %{version} | cut -d . -f 1)
 Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
-Source10: man-convert-helper
+
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 Requires: gtk3 >= %{gtk3_version}
@@ -58,7 +59,7 @@ Yelp は Gnome 3 のヘルプ/ドキュメントブラウザです。このツ
 %package libs
 Summary: Libraries for yelp
 Summary(ja): Yelp のライブラリ
-Group: System Environment/Libraries
+Group: system
 Requires: %{name} = %{version}-%{release}
 
 %description libs
@@ -68,7 +69,7 @@ This package contains libraries used by the yelp help browser.
 %package devel
 Summary: Development files for yelp-libs
 Summary(ja): yelp-libs の開発用ファイル
-Group: Development/Libraries
+Group: programming
 Requires: %{name}-libs = %{version}-%{release}
 
 %description devel
@@ -79,14 +80,17 @@ the libraries in the yelp-libs package.
 %package        docs
 Summary:        Documentation for %{name}
 Summary(ja):    %{name} のドキュメント
-Group:          Documentation
+Group:          documentation
 Requires:       %{name} = %{version}-%{release}
-BuildArch:	noarch
+BuildArch:      noarch
 
 %description    docs
 This package contains documentation for %{name}.
 
 
+%debug_package
+
+
 %prep
 %setup -q
 
@@ -101,8 +105,6 @@ make %{?_smp_mflags}
 rm -rf $RPM_BUILD_ROOT
 make install DESTDIR=$RPM_BUILD_ROOT
 
-install -m755 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/yelp/
-
 find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
 
 %find_lang %{name} --with-gnome
@@ -112,23 +114,6 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
 rm -rf $RPM_BUILD_ROOT
 
 
-%post
-update-desktop-database %{_datadir}/applications >& /dev/null ||:
-update-mime-database %{_datadir}/mime >& /dev/null ||:
-
-%postun
-update-desktop-database %{_datadir}/applications >& /dev/null ||:
-update-mime-database %{_datadir}/mime >& /dev/null ||:
-glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
-
-%posttrans
-glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
-
-%post libs -p /sbin/ldconfig
-
-%postun libs -p /sbin/ldconfig
-
-
 %files -f %{name}.lang
 %defattr(-,root,root)
 %{_bindir}/*
@@ -155,6 +140,10 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
 
 
 %changelog
+* Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 40.0-1
+- new upstream release.
+- dropped scriptlets.
+
 * Mon Aug 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.36.0-1
 - new upstream release.