Browse Source

self-build-ffmpeg: change BuildRequires

git-svn-id: http://trac.vinelinux.org/repos/projects/specs@12248 ec354946-7b23-47d6-9f5a-488ba84defc7
ara_t 2 years ago
parent
commit
6abd02c823

+ 36 - 30
nonfree/self-build-ffmpeg/ffmpeg-vl.spec

@@ -1,18 +1,18 @@
 #TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
 #TODO: add make test to %%check section
 
-#% define svndate	20100625
-%global with_faac	1
-%global with_vaapi	1
-%global with_libvpx	1
-
-%global major_version	2.8
-
-Summary:	Digital VCR and streaming server
-Name:		ffmpeg
-Version:	%{major_version}.6
-Release:	2%{?svndate:.%svndate}%{?_dist_release}
-Source:		http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
+#% define svndate 20100625
+%global with_faac 1
+%global with_vaapi  1
+%global with_libvpx 1
+
+%global major_version 2.8
+
+Summary:  Digital VCR and streaming server
+Name:   ffmpeg
+Version:  %{major_version}.7
+Release:  3%{?svndate:.%svndate}%{?_dist_release}
+Source:   http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
 ## prebuilt man pages
 
 %if 0%{?_with_amr:1}
@@ -20,8 +20,8 @@ License:        GPLv3+
 %else
 License:        GPLv2+
 %endif
-Group:		Applications/Multimedia
-URL:		http://ffmpeg.org/
+Group:    Applications/Multimedia
+URL:    http://ffmpeg.org/
 
 BuildRequires:  bzip2-devel
 BuildRequires:  celt-devel
@@ -29,21 +29,21 @@ BuildRequires:  celt-devel
 BuildRequires:  freetype2-devel
 ##BuildRequires: frei0r-devel
 BuildRequires:  gnutls-devel
-BuildRequires:	gsm-devel
-BuildRequires:	imlib2-devel
-BuildRequires:	libdc1394-devel
-BuildRequires:	libogg-devel
+BuildRequires:  gsm-devel
+BuildRequires:  imlib2-devel
+BuildRequires:  libdc1394-devel
+BuildRequires:  libogg-devel
 BuildRequires:  libass-devel
 %{!?_without_cdio:BuildRequires: libcdio-devel}
 %{!?_without_cdio:BuildRequires: libcdio-paranoia-devel}
 #libcrystalhd is currently broken
 %{?_with_crystalhd:BuildRequires: libcrystalhd-devel}
-BuildRequires:	libraw1394-devel
-BuildRequires:	librtmp-devel >= 2.3
-BuildRequires:	libtheora-devel
+BuildRequires:  libraw1394-devel
+BuildRequires:  librtmp-devel >= 2.3
+BuildRequires:  libtheora-devel
 %{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
 BuildRequires:  libvdpau-devel
-BuildRequires:	libvorbis-devel
+BuildRequires:  libvorbis-devel
 %{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.7}
 BuildRequires:  libXvMC-devel
 %{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
@@ -51,23 +51,23 @@ BuildRequires:  libXvMC-devel
 %{?_with_opencv:BuildRequires: opencv-devel}
 %{?_with_openjpeg:BuildRequires:  openjpeg-devel}
 ##BuildRequires:  schroedinger-devel
-BuildRequires:	SDL-devel
+BuildRequires:  SDL-devel
 BuildRequires:  speex-devel
-##BuildRequires:	texi2html
-BuildRequires:	zlib-devel 
-BuildRequires:	yasm
+##BuildRequires:  texi2html
+BuildRequires:  zlib-devel 
+BuildRequires:  yasm
 # *-devel packages provided by other self-build-* should only be listed
 # in self-build-%{name}.spec as PreReq.
-#BuildRequires: a52dec-devel
+##BuildRequires: a52dec-devel
 #BuildRequires: faac-devel
-#BuildRequires: lame-devel
+##BuildRequires: lame-devel
 #BuildRequires: libdca-devel
 #BuildRequires: x264-devel >= 0.0.0-18.20111216
 #BuildRequires: xvidcore-devel
 
-Requires:	%{name}-libs = %{version}-%{release}
+Requires: %{name}-libs = %{version}-%{release}
 
-BuildRoot:	%{_tmppath}/%{name}-%{version}-root
+BuildRoot:  %{_tmppath}/%{name}-%{version}-root
 
 Obsoletes:      ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
 
@@ -226,6 +226,12 @@ export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
 
 
 %changelog
+* Wed Oct 09 2019 Toshiaki Ara <ara_t@384.jp> 2.8.6-3
+- change BR: self-build-{a52dec,lame} to {a52dec,lame}-devel
+
+* Mon Nov 05 2018 Toshiaki Ara <ara_t@384.jp> 2.8.6-2
+- rebuild
+
 * Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-2
 - rebuild with libcdio-0.93
 

+ 8 - 3
nonfree/self-build-ffmpeg/self-build-ffmpeg-vl.spec

@@ -16,7 +16,7 @@
 %global major_version 2.8
 %global version %{major_version}.7
 #% define svndate 20110326
-%global release 2%{?svndate:.%svndate}%{?_dist_release}
+%global release 3%{?svndate:.%svndate}%{?_dist_release}
 
 %global sourceurl0  http://ffmpeg.org/releases/%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
 
@@ -77,10 +77,12 @@ Requires(post):  speex-devel
 Requires(post): zlib-devel 
 Requires(post): libogg-devel
 Requires(post):   yasm
-Requires(post):   self-build-a52dec
+Requires(post):   a52dec-devel
+Requires(post):   lame-devel
+# Requires(post):   self-build-a52dec
 Requires(post):   self-build-faac
 Requires(post):   self-build-faad2
-Requires(post):   self-build-lame 
+# Requires(post):   self-build-lame
 Requires(post):   self-build-libdca
 Requires(post):   self-build-x264 >= 0.142
 Requires(post):   self-build-x265 >= 1.4
@@ -219,6 +221,9 @@ Rebuild_x264_$LOCALE
 %{_datadir}/%{name}
 
 %changelog
+* Wed Oct 09 2019 Toshiaki Ara <ara_t@384.jp> 2.8.6-3
+- change BR: self-build-{a52dec,lame} to {a52dec,lame}-devel
+
 * Mon Nov 05 2018 Toshiaki Ara <ara_t@384.jp> 2.8.6-2
 - rebuild