Name: quota
Summary: System administration tools for monitoring users' disk usage.
Summary(ja): ユーザのディスク使用量をモニタするシステム管理ツール
Version: 4.04
Release: 1%{?_dist_release}
License: BSD
Group: System Environment/Base
URL: http://sourceforge.net/projects/linuxquota/
Vendor: Project Vine
Distribution: Vine Linux
#Source0: http://downloads.sourceforge.net/linuxquota/quota-%{version}.tar.gz
Source0: quota-%{version}.tar.gz
Source1: quota_nld.init
Source2: quota_nld.sysconfig
# Not accepted changes (378a64006bb1e818e84a1c77808563b802b028fa)
Patch0: quota-4.04-warnquota-configuration-tunes.patch
Patch1: quota-4.03-Validate-upper-bound-of-RPC-port.patch
# Install rquotad(3) only if RPC is enabled,
# , in upstream after 4.04
Patch2: quota-4.04-Install-rquota-3-only-if-RPC-is-enabled.patch
# Pass TIRPC header files location to all RPC compilation units,
# , in upstream after 4.04
Patch3: quota-4.04-Add-TIRPC_CFLAGS-globally-to-CFLAGS-for-RPC-support-.patch
# Do not iterate over negative UIDs in repquota,
# , in upstream after 4.04
Patch4: quota-4.04-repquota-Fix-output-when-user-2-exists.patch
# Fix snprintf overflows in warnquota,
# , in upstream after 4.04
Patch5: quota-4.04-warnquota-Check-snprintf-for-overflows.patch
# Fix user name search in utmp log,
# , in upstream after 4.04
Patch6: quota-4.04-warnquota-Fix-comparing-user-name-to-non-null-termin.patch
# Avoid questions in quotacheck non-interactive mode, in upstream after 4.04
Patch7: quota-4.04-quotacheck-Avoid-question-in-non-interactive-mode.patch
# Report an error when quotacheck fails to cache quota files,
# in upstream after 4.04
Patch8: quota-4.04-quotacheck-Report-error-when-caching-of-quota-file-f.patch
# Report an error if quota file magic is invalid, in upstream after 4.04
Patch9: quota-4.04-quotacheck-Fail-check-if-quota-file-magic-is-invalid.patch
# Fix busy loop in rpc.rquotad, bug #1575956, in upstream after 4.04,
#
Patch10: quota-4.04-Listen-on-a-TCP-socket.patch
# Fix current block usage limit in RPC client, in upstream after 4.04,
#
Patch11: quota-4.04-rpc-Fix-wrong-limit-for-space-usage.patch
# Distinguish between none quota limits and no allocated resources in quota(1)
# tool output, proposed to upstream,
#
Patch12: quota-4.04-quota-1-Distinguish-between-none-quota-limits-and-no.patch
# Fix a descriptor leak, proposed to upstream,
#
Patch13: quota-4.04-convertquota-Fix-a-file-descriptor-leak-in-convert_e.patch
# Fix a descriptor leak, proposed to upstream,
#
Patch14: quota-4.04-quotackeck-Fix-a-directory-descriptor-leak-in-scan_d.patch
# Fix a descriptor leak, proposed to upstream,
#
Patch15: quota-4.04-xqmstats-Fix-a-file-descriptor-leak-in-main.patch
BuildRoot: %{_tmppath}/%{name}-root
Requires: kernel >= 2.4, initscripts >= 6.38
Requires(post): chkconfig
Requires(preun): chkconfig
Conflicts: nfs-utils < 1.0.1
BuildRequires: e2fsprogs-devel, gettext
BuildRequires: tcp_wrappers, nss-devel
BuildRequires: openldap-devel, openssl-devel, dbus-devel, libnl3-devel
%description
The quota package contains system administration tools for monitoring
and limiting user and or group disk usage per filesystem.
%description -l ja
quota パッケージには,ユーザやグループのディスク使用量を監視したり
制限したりできるシステム管理ツールが収録されています.これらの操作
はファイルシステム単位で行うことが出来ます.
ユーザやグループのディスク使用量を監視/制限した場合は quota をイン
ストールして下さい.
%prep
%setup -q
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
%patch11 -p1
%patch12 -p1
%patch13 -p1
%patch14 -p1
%patch15 -p1
# Regenerate build scripts
autoreconf -f -i
%build
%configure \
--enable-bsd-behaviour \
--enable-ext2direct=yes \
--enable-ldapmail=yes \
--enable-netlink=yes \
--enable-rootsbin=yes \
--enable-rpc=yes \
--enable-rpcsetquota=yes \
--enable-strip-binaries=no \
--enable-nls \
--disable-rpath \
--disable-silent-rules \
--disable-xfs-roothack
make
%install
rm -fr %{buildroot}
mkdir -p %{buildroot}/sbin
mkdir -p %{buildroot}%{_sysconfdir}
mkdir -p %{buildroot}%{_sbindir}
mkdir -p %{buildroot}%{_bindir}
mkdir -p %{buildroot}%{_mandir}/{man1,man3,man8}
make install DESTDIR=%{buildroot}
install -m 644 warnquota.conf %{buildroot}%{_sysconfdir}
mv %{buildroot}%{_sbindir}/quota{check,off,on} %{buildroot}/sbin/
# we don't support XFS yet
#
rm -f %{buildroot}%{_sbindir}/quot
rm -f %{buildroot}%{_sbindir}/xqmstats
rm -f %{buildroot}%{_mandir}/man8/quot.*
rm -f %{buildroot}%{_mandir}/man8/xqmstats.*
install -p -m755 -D %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/quota_nld
install -p -m644 -D %{SOURCE2} \
$RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/quota_nld
rm -rf %{buildroot}%{_datadir}/doc/%{name}
%find_lang %{name}
%clean
rm -rf %{buildroot}
%post
/sbin/chkconfig --add quota_nld
%preun
if [ $1 = 0 ] ; then
/sbin/service quota_nld stop >/dev/null 2>&1
/sbin/chkconfig --del quota_nld
fi
%files -f %{name}.lang
%defattr(-,root,root)
%license COPYING
%doc Changelog doc/ README*
%config(noreplace) %{_sysconfdir}/warnquota.conf
%config(noreplace) %{_sysconfdir}/quotagrpadmins
%config(noreplace) %{_sysconfdir}/quotatab
%config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/quota_nld
%{_initrddir}/quota_nld
/sbin/*
%{_bindir}/*
%{_sbindir}/*
%{_includedir}/rpcsvc/*
%{_mandir}/man1/*
%{_mandir}/man3/*
%{_mandir}/man5/*
%{_mandir}/man8/*
%changelog
* Thu Nov 29 2018 Tomohiro "Tomo-p" KATO 4.04-1
- new upstram release.
- dropped BR:libnl-devel.
- added BR:libnl3-devel.
- dropped all patches.
- imported patched from rawhide.
* Mon Mar 12 2012 Daisuke SUZUKI 4.00-1
- new upstram release
- add BR: tcp_wrappers, nss-devel, openldap-devel,
openssl-devel, dbus-devel, libnl-devel
* Sun Apr 17 2011 Shu KONNO 3.15-2
- rebuilt with rpm-4.8.1-3
* Fri Aug 15 2008 Shu KONNO 3.15-1vl5
- applied new versioning policy, spec in utf-8
* Thu Dec 20 2007 Shu KONNO 3.15-0vl1
- updated quota to 3.15
* Wed Apr 27 2005 MATSUBAYASHI Kohji 3.12-5vl2
- oops, removed unnecessary Patch3
* Tue Apr 26 2005 MATSUBAYASHI Kohji 3.12-5vl1
- based on 3.12-5, being merged into 3.06-7vl1
- Sun Sep 26 2004 Rik van Riel 3.12-5
- add URL (bz# 131862)
- Fri Sep 24 2004 Steve Dickson
- Fixed typos in warnquota.conf patch
(bz# 82250 and bz# 83974)
- Mon Sep 13 2004 Steve Dickson
- upgraded to 3.12
- Tue Jan 27 2004 Florian La Roche
- add -pie support
- update to 3.10
- Sat Aug 16 2003 Steve Dickson
- upgraded to 3.0.9
- added quota-3.09-root_sbindir.patch
* Sun Feb 9 2003 Daisuke SUZUKI 3.06-7vl1
- merged with Vine Linux package (quota-2.00stable-0vl1)
- based on rawhide release 3.06-7
* Wed May 30 2001 Jun Nishii
- 2.00stable-0vl1
- ver.up
* Wed May 30 2001 Jun Nishii
- 2.00pre3-8vl2
- added documents
* Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji
- 2.00pre3-8vl1
- based on 2.00pre3-8 from Rawhide
- added Japanese summary and description
* Wed Jan 22 2003 Tim Powers
- rebuilt
* Mon Nov 18 2002 Tim Powers
- rebuild on all arches
* Fri Sep 6 2002 Philip Copeland 3.06-5
- added --with-ext2direct=no to fix #73244
without this users with UID's > 65535 will not
be able to exist on a quota enabled FS
* Wed Aug 7 2002 Philip Copeland 3.06-4
- Man page change. #60108
* Tue Aug 6 2002 Philip Copeland 3.06-3
- Bah, I'd dropped epoch from the spec file but seems
we need this if you want to upgrade as the epoch
number has precedence over the version/release
numbers.
* Wed Jul 17 2002 Philip Copeland 3.06-2
- Lets stop the makefile from stripping the
binaries as thats rpms job (apparently)
* Mon Jul 01 2002 Philip Copeland 3.06-1
- Ditched the 3.01-pre9 src base for 3.06
Rebuilt without any patchs
============================================================
* Fri Jun 21 2002 Tim Powers
- automated rebuild
* Thu May 23 2002 Tim Powers
- automated rebuild
* Mon Feb 25 2002 Elliot Lee
- IfArch the badkernelinclude patch for ppc-only.
- Update to 3.03
* Wed Dec 12 2001 Guy Streeter
- Make #include of kernel header file work on non-x86
* Wed Sep 5 2001 Preston Brown
- require new initscripts
* Thu Aug 30 2001 Preston Brown
- fixed bug #52075 (problem with ext2 labels)
- backup data files off by default in quotacheck, optional backup flag added
- fix bug where giving a bad directory or device would cause
quotaon/quotacheck to simulate "-a" behaviour
- if a device name (i.e /dev/hda1) is passed, look up the corresponding mount
point
* Wed Aug 29 2001 Preston Brown
- return an error code in more cases in convertquota
* Tue Aug 28 2001 Preston Brown
- 3.01pre9
* Fri Jul 20 2001 Preston Brown
- more cleanups on 3.01pre8
* Mon Jul 2 2001 Preston Brown
- 3.01 version, everything has changed again. :(
* Sun Jun 24 2001 Elliot Lee
- Bump release + rebuild.
* Fri Mar 30 2001 Preston Brown
- use rpc.rquotad from here again (#33738)
* Thu Mar 15 2001 Preston Brown
- enable ALT_FORMAT for edquota
* Tue Mar 13 2001 Preston Brown
- I broke passing devices on the cmd line. Fixed.
* Fri Mar 09 2001 Preston Brown
- quota 3.00 is required by recent kernel 2.4 changes
- no warnquota included this time, not yet ported
- quite a bit of work on quotacheck to make is backwards compatible
- we will likely go back to "quota 2.00" as these projects merge...
* Fri Feb 09 2001 Florian La Roche
- use "rm -f" instead of only "rm"
* Wed Feb 7 2001 Preston Brown
- fix quotacheck man page for -a option (#26380)
* Thu Feb 1 2001 Preston Brown
- 2.00 final, rolls in pretty much all our patches. :)
- fix reporting of in use dquot entries from quotastats
- change repquota man page to fix documentation of -v (#10330)
- include warnquota.conf
* Mon Nov 20 2000 Bill Nottingham
- fix ia64 build
* Mon Aug 21 2000 Jeff Johnson
- add LABEL=foo support (#16390).
* Thu Jul 27 2000 Jeff Johnson
- remote NFS quotas with different blocksize converted incorrectly (#11932).
* Wed Jul 12 2000 Prospector
- automatic rebuild
* Thu Jun 15 2000 Jeff Johnson
- FHS packaging.
* Wed May 10 2000 Jeff Johnson
- apply patch5 (H.J. Lu)
* Wed Feb 02 2000 Cristian Gafton
- fix description
- man pages are compressed
* Tue Jan 18 2000 Preston Brown
- quota 2.00 series
- removed unnecessary patches
* Thu Aug 5 1999 Jeff Johnson
- fix man page FUD (#4369).
* Thu May 13 1999 Peter Hanecak
- changes to allow non-root users to build too (Makefile patch, %attr)
* Tue Apr 13 1999 Jeff Johnson
- fix for sparc64 quotas (#2147)
* Sun Mar 21 1999 Cristian Gafton
- auto rebuild in the new build environment (release 5)
* Mon Dec 28 1998 Cristian Gafton
- don't install rpc.rquotad - we will use the one from the knfsd package
instead
* Thu Dec 17 1998 Jeff Johnson
- merge ultrapenguin 1.1.9 changes.
* Thu May 07 1998 Prospector System
- translations modified for de, fr, tr
* Thu Apr 30 1998 Cristian Gafton
- removed patch for mntent
* Fri Mar 27 1998 Jakub Jelinek
- updated to quota 1.66
* Tue Jan 13 1998 Erik Troan
- builds rquotad
- installs rpc.rquotad.8 symlink
* Mon Oct 20 1997 Erik Troan
- removed /usr/include/rpcsvc/* from filelist
- uses a buildroot and %attr
* Thu Jun 19 1997 Erik Troan
- built against glibc
* Tue Mar 25 1997 Erik Troan
- Moved /usr/sbin/quota to /usr/bin/quota