elfutils-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %global nocheck false
  3. Summary: A collection of utilities and DSOs to handle compiled objects
  4. Summary(ja): コンパイル済みオブジェクトを扱うためのユーティリティ集
  5. Name: elfutils
  6. Version: 0.183
  7. Release: 2%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPLv3+ and (GPLv2+ or LGPLv3+) and GFDL
  12. URL: https://sourceware.org/elfutils/
  13. Source: https://sourceware.org/elfutils/ftp/%{version}/%{name}-%{version}.tar.bz2
  14. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  15. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: bison >= 1.875
  18. BuildRequires: flex >= 2.5.4a
  19. BuildRequires: gcc >= 9.0.0
  20. BuildRequires: gettext
  21. BuildRequires: m4
  22. BuildRequires: bzip2-devel
  23. BuildRequires: libzstd-devel
  24. BuildRequires: xz-devel
  25. BuildRequires: zlib-devel
  26. # Need <byteswap.h> that gives unsigned bswap_16 etc.
  27. BuildRequires: glibc-headers >= 2.3.4-11
  28. BuildRequires: bzip2
  29. BuildRequires: zstd
  30. %define _gnu %{nil}
  31. %define _program_prefix eu-
  32. %description
  33. Elfutils is a collection of utilities, including ld (a linker),
  34. nm (for listing symbols from object files), size (for listing the
  35. section sizes of an object or archive file), strip (for discarding
  36. symbols), readelf (to see the raw ELF file structures), and elflint
  37. (to check for well-formed ELF files).
  38. %package libs
  39. Summary: Libraries to handle compiled objects
  40. Summary(ja): コンパイル済オブジェクトを扱うためのライブラリ
  41. License: GPLv2+ or LGPLv3+
  42. Group: system
  43. Provides: elfutils-libs-%{_arch} = %{version}-%{release}
  44. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  45. Conflicts: elfutils < %{version}-%{release}
  46. Conflicts: elfutils > %{version}-%{release}
  47. Conflicts: elfutils-devel < %{version}-%{release}
  48. Conflicts: elfutils-devel > %{version}-%{release}
  49. %description libs
  50. The elfutils-libs package contains libraries which implement DWARF, ELF,
  51. and machine-specific ELF handling. These libraries are used by the programs
  52. in the elfutils package. The elfutils-devel package enables building
  53. other programs using these libraries.
  54. %package devel
  55. Summary: Development libraries to handle compiled objects
  56. Summary(ja): コンパイル済オブジェクトを扱うための開発用ライブラリ
  57. License: GPLv2+ or LGPLv3+
  58. Group: programming
  59. Provides: elfutils-devel-%{_arch} = %{version}-%{release}
  60. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  61. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  62. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  63. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  64. %description devel
  65. The elfutils-devel package contains the libraries to create
  66. applications for handling compiled objects. libebl provides some
  67. higher-level ELF access functionality. libdw provides access to
  68. the DWARF debugging information. libasm provides a programmable
  69. assembler interface.
  70. %package devel-static
  71. Summary: Static archives to handle compiled objects
  72. Summary(ja): コンパイル済オブジェクトを扱うための静的ライブラリ
  73. License: GPLv2+ or LGPLv3+
  74. Group: programming
  75. Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
  76. Requires: elfutils-devel-%{_arch} = %{version}-%{release}
  77. Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  78. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  79. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  80. %description devel-static
  81. The elfutils-devel-static package contains the static archives
  82. with the code to handle compiled objects.
  83. %package libelf
  84. Summary: Library to read and write ELF files
  85. Summary(ja): ELF ファイルを読み書きするためのライブラリ
  86. License: GPLv2+ or LGPLv3+
  87. Group: system
  88. Provides: libelf = %{version}-%{release}
  89. Obsoletes: libelf <= 0.8.2-2
  90. Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
  91. Conflicts: elfutils < %{version}-%{release}
  92. Conflicts: elfutils > %{version}-%{release}
  93. Conflicts: elfutils-libs < %{version}-%{release}
  94. Conflicts: elfutils-libs > %{version}-%{release}
  95. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  96. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  97. %description libelf
  98. The elfutils-libelf package provides a DSO which allows reading and
  99. writing ELF files on a high level. Third party programs depend on
  100. this package to read internals of ELF files. The programs of the
  101. elfutils package use it also to generate new ELF files.
  102. %package libelf-devel
  103. Summary: Development support for libelf
  104. Summary(ja): libelf の開発用ライブラリ
  105. License: GPLv2+ or LGPLv3+
  106. Group: programming
  107. Provides: libelf-devel = %{version}-%{release}
  108. Obsoletes: libelf-devel <= 0.8.2-2
  109. Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  110. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  111. Conflicts: libelf-devel < %{version}-%{release}
  112. %description libelf-devel
  113. The elfutils-libelf-devel package contains the libraries to create
  114. applications for handling compiled objects. libelf allows you to
  115. access the internals of the ELF object file format, so you can see the
  116. different sections of an ELF file.
  117. %package libelf-devel-static
  118. Summary: Static archive of libelf
  119. Summary(ja): libelf の静的ライブラリ
  120. License: GPLv2+ or LGPLv3+
  121. Group: programming
  122. Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  123. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  124. %description libelf-devel-static
  125. The elfutils-libelf-static package contains the static archive
  126. for libelf.
  127. # compat32
  128. %package -n compat32-%{name}-libelf
  129. Summary: Library to read and write ELF files
  130. Summary(ja): ELF ファイルを読み書きするためのライブラリ
  131. License: GPLv2+ or LGPLv3+
  132. Group: system
  133. Provides: compat32-libelf = %{version}-%{release}
  134. %description -n compat32-%{name}-libelf
  135. The elfutils-libelf package provides a DSO which allows reading and
  136. writing ELF files on a high level. Third party programs depend on
  137. this package to read internals of ELF files. The programs of the
  138. elfutils package use it also to generate new ELF files.
  139. %debug_package
  140. %prep
  141. %setup -q
  142. autoreconf -f -v -i
  143. find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
  144. %build
  145. # This package uses top level ASM constructs which are incompatible with LTO.
  146. # Top level ASMs are often used to implement symbol versioning. gcc-10
  147. # introduces a new mechanism for symbol versioning which works with LTO.
  148. # Converting packages to use that mechanism instead of toplevel ASMs is
  149. # recommended.
  150. # Disable LTO
  151. %define _lto_cflags %{nil}
  152. # Remove -Wall from default flags. The makefiles enable enough warnings
  153. # themselves, and they use -Werror. Appending -Wall defeats the cases where
  154. # the makefiles disable some specific warnings for specific code.
  155. # But add -Wformat explicitly for use with -Werror=format-security which
  156. # doesn't work without -Wformat (enabled by -Wall).
  157. RPM_OPT_FLAGS="${RPM_OPT_FLAGS/-Wall/}"
  158. RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -Wformat"
  159. %configure \
  160. CFLAGS="$RPM_OPT_FLAGS -fexceptions" \
  161. --disable-debuginfod \
  162. --disable-libdebuginfod
  163. make -s %{?_smp_mflags}
  164. %install
  165. rm -rf ${RPM_BUILD_ROOT}
  166. make -s install DESTDIR=${RPM_BUILD_ROOT}
  167. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
  168. %find_lang %{name}
  169. # XXX Nuke unpackaged files
  170. { cd ${RPM_BUILD_ROOT}
  171. rm -f .%{_bindir}/eu-ld
  172. }
  173. # failed on i686 container hosted by x86_64
  174. %ifarch x86_64
  175. %check
  176. %make_build -s check || (cat tests/test-suite.log; %{nocheck})
  177. %endif
  178. %clean
  179. rm -rf ${RPM_BUILD_ROOT}
  180. %files -f %{name}.lang
  181. %defattr(-,root,root)
  182. %license COPYING COPYING-GPLV2 COPYING-LGPLV3 doc/COPYING-GFDL
  183. %doc README TODO CONTRIBUTING
  184. %{_bindir}/eu-addr2line
  185. %{_bindir}/eu-ar
  186. %{_bindir}/eu-elfclassify
  187. %{_bindir}/eu-elfcmp
  188. %{_bindir}/eu-elflint
  189. %{_bindir}/eu-findtextrel
  190. %{_bindir}/eu-nm
  191. %{_bindir}/eu-objdump
  192. %{_bindir}/eu-ranlib
  193. %{_bindir}/eu-readelf
  194. %{_bindir}/eu-size
  195. %{_bindir}/eu-stack
  196. %{_bindir}/eu-strings
  197. %{_bindir}/eu-strip
  198. #%{_bindir}/eu-ld
  199. %{_bindir}/eu-unstrip
  200. %{_bindir}/eu-make-debug-archive
  201. %{_bindir}/eu-elfcompress
  202. %{_mandir}/man1/eu-*
  203. %files libs
  204. %defattr(-,root,root)
  205. %license COPYING-GPLV2 COPYING-LGPLV3
  206. %{_libdir}/libasm-%{version}.so
  207. %{_libdir}/libasm.so.*
  208. %{_libdir}/libdw-%{version}.so
  209. %{_libdir}/libdw.so.*
  210. %files devel
  211. %defattr(-,root,root)
  212. %{_includedir}/dwarf.h
  213. %dir %{_includedir}/elfutils
  214. %{_includedir}/elfutils/elf-knowledge.h
  215. %{_includedir}/elfutils/known-dwarf.h
  216. %{_includedir}/elfutils/libasm.h
  217. %{_includedir}/elfutils/libdw.h
  218. %{_includedir}/elfutils/libdwelf.h
  219. %{_includedir}/elfutils/libdwfl.h
  220. %{_includedir}/elfutils/version.h
  221. %{_libdir}/libasm.so
  222. %{_libdir}/libdw.so
  223. %{_libdir}/pkgconfig/libdw.pc
  224. %files devel-static
  225. %defattr(-,root,root)
  226. %{_libdir}/libasm.a
  227. %{_libdir}/libdw.a
  228. %files libelf
  229. %defattr(-,root,root)
  230. %{_libdir}/libelf-%{version}.so
  231. %{_libdir}/libelf.so.*
  232. %files libelf-devel
  233. %defattr(-,root,root)
  234. %{_includedir}/libelf.h
  235. %{_includedir}/gelf.h
  236. %{_includedir}/nlist.h
  237. %{_libdir}/libelf.so
  238. %{_libdir}/pkgconfig/libelf.pc
  239. %{_mandir}/man3/elf_*
  240. %files libelf-devel-static
  241. %defattr(-,root,root)
  242. %{_libdir}/libelf.a
  243. %if %{build_compat32}
  244. %files -n compat32-%{name}-libelf
  245. %defattr(-,root,root)
  246. %{_libdir}/libelf-%{version}.so
  247. %{_libdir}/libelf.so.*
  248. %endif
  249. %changelog
  250. * Sat Apr 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.183-2
  251. - rebuilt with current environment.
  252. * Tue Feb 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.183-1
  253. - new upstream release.
  254. * Fri Oct 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.177-1
  255. - new upstream release.
  256. * Sat Jan 13 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.170-3
  257. - rebuilt
  258. - 2vl7 was skipped (used for vl6)
  259. * Sun Sep 10 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.170-1
  260. - updated to 0.170.
  261. - dropped all patches.
  262. * Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-3
  263. - rebuild with gcc-5.4.0
  264. * Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-2
  265. - create compat32-elfutils-libelf subpackage
  266. * Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.161-1
  267. - update to 0.161
  268. - added Japanese summary
  269. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.157-1
  270. - update to 0.157
  271. * Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
  272. - add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
  273. * Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
  274. - update to 0.152
  275. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
  276. - elfutils-libs: changed Group to System Environment/Libraries
  277. - elfutils-libelf: changed Group to System Environment/Libraries
  278. - elfutils-devel: changed Group to Development/Libraries
  279. - elfutils-devel-static: changed Group to Development/Libraries
  280. - elfutils-libelf-devel: changed Group to Development/Libraries
  281. - elfutils-libelf-devel-static: changed Group to Development/Libraries
  282. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
  283. - merged with Fedora 9 0.135-1
  284. - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
  285. - applied new versioning policy
  286. - added elfutils-0.131-readelf_c.patch
  287. - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
  288. - new upstream release
  289. - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
  290. - remove Obsoletes: libelf, libelf-devel from elfutils
  291. - add Obsoletes: libelf to elfutils-libelf
  292. - add Obsoletes: libelf-devel to elfutils-libelf-devel
  293. * Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
  294. - Update to 0.135
  295. - libdwfl: bug fixes
  296. - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
  297. * Wed Apr 9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
  298. - Update to 0.134
  299. - elflint: backend improvements for sparc, alpha (#204170)
  300. - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
  301. - Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
  302. * Sun Mar 2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
  303. - Update to 0.133
  304. - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
  305. - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
  306. - libdwfl: bug fixes and optimization in relocation handling
  307. - elfcmp: bug fix for non-allocated section handling
  308. - ld: implement newer features of binutils linker.
  309. - Install eu-objdump and libasm, now has limited disassembler support.
  310. * Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
  311. - Update to 0.132
  312. - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
  313. - eu-readelf: Fix handling of ET_REL files in archives.
  314. - libcpu: Implement x86 and x86-64 disassembler.
  315. - libasm: Add interface for disassembler.
  316. - all programs: add debugging of branch prediction.
  317. - libelf: new function elf_scnshndx.
  318. * Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
  319. - Update to 0.131
  320. - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
  321. bug fixes for oddly-formatted DWARF
  322. - libdwfl: bug fixes in offline archive support, symbol table handling;
  323. apply partial relocations for dwfl_module_address_section on ET_REL
  324. - libebl: powerpc backend support for Altivec registers
  325. * Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
  326. - Fix ET_REL support.
  327. - Fix odd indentation in eu-readelf -x output.
  328. * Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
  329. - Update to 0.130
  330. - eu-readelf -p option can take an argument like -x for one section
  331. - eu-readelf --archive-index (or -c)
  332. - eu-readelf -n improved output for core dumps
  333. - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
  334. - eu-elflint: ditto
  335. - eu-elflint: stricter checks on debug sections
  336. - eu-unstrip: new options, --list (or -n), --relocate (or -R)
  337. - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
  338. new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
  339. - libebl: backend improvements (#324031)
  340. - libdwfl: build_id support, new functions for it
  341. - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
  342. - libdwfl offline archive support, new script eu-make-debug-archive
  343. * Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
  344. - Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
  345. * Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
  346. - Update to 0.129
  347. - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
  348. - addr2line: new option --symbols (or -S)
  349. - libdw: dwarf_getscopes fixes (#230235)
  350. - libdwfl: dwfl_module_addrsym fixes (#249490)
  351. * Fri Jun 8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
  352. - Update to 0.128
  353. - new program: unstrip
  354. - elfcmp: new option --hash-inexact
  355. - Replace Conflicts: with Provides/Requires using -arch
  356. * Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
  357. - Update to 0.127
  358. - libdw: new function dwarf_getsrcdirs
  359. - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
  360. dwfl_module_address_section
  361. * Mon Feb 5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
  362. - Update to 0.126
  363. - New program eu-ar.
  364. - libdw: fix missing dwarf_getelf (#227206)
  365. - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
  366. - Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
  367. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
  368. - Fix overeager warn_unused_result build failures.
  369. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
  370. - Update to 0.125
  371. - elflint: Compare DT_GNU_HASH tests.
  372. - move archives into -static RPMs
  373. - libelf, elflint: better support for core file handling
  374. - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
  375. - Resolves: RHBZ #220817, RHBZ #213792
  376. * Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
  377. - eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
  378. - Update to 0.124
  379. - libebl: fix ia64 reloc support (#206981)
  380. - libebl: sparc backend support for return value location
  381. - libebl, libdwfl: backend register name support extended with more info
  382. - libelf, libdw: bug fixes for unaligned accesses on machines that care
  383. - readelf, elflint: trivial bugs fixed
  384. * Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
  385. - Update to 0.123
  386. - libebl: Backend build fixes, thanks to Stepan Kasal.
  387. - libebl: ia64 backend support for register names, return value location
  388. - libdwfl: Handle truncated linux kernel module section names.
  389. - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
  390. - elflint: Fix checks to permit --hash-style=gnu format.
  391. * Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
  392. - Fix warnings in elflint compilation.
  393. * Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
  394. - Update to 0.122
  395. - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
  396. - libebl: add function to test for relative relocation
  397. - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
  398. - elflint, readelf: add support for DT_GNU_HASH
  399. - libelf: add elf_gnu_hash
  400. - elflint, readelf: add support for 64-bit SysV-style hash tables
  401. - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
  402. * Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
  403. - Update to 0.121
  404. - libelf: bug fixes for rewriting existing files when using mmap (#187618).
  405. - make all installed headers usable in C++ code (#193153).
  406. - eu-readelf: better output format.
  407. - eu-elflint: fix tests of dynamic section content.
  408. - libdw, libdwfl: handle files without aranges info.
  409. * Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
  410. - rebuild to pick up -devel deps
  411. * Tue Apr 4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
  412. - Update to 0.120
  413. - License changed to GPL, with some exceptions for using
  414. the libelf, libebl, libdw, and libdwfl library interfaces.
  415. Red Hat elfutils is an included package of the Open Invention Network.
  416. - dwarf.h updated for DWARF 3.0 final specification.
  417. - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
  418. - libdwfl: New function dwfl_version; fixes for offline.
  419. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
  420. - bump again for double-long bug on ppc(64)
  421. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
  422. - rebuilt for new gcc4.1 snapshot and glibc changes
  423. * Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
  424. - update to 0.119
  425. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  426. - rebuilt
  427. * Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
  428. - update to 0.118
  429. - elflint: more tests.
  430. - libdwfl: New function dwfl_module_register_names.
  431. - libebl: New backend hook for register names.
  432. - Make sure -fexceptions is always in CFLAGS.
  433. * Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
  434. - update to 0.117
  435. - libdwfl: New function dwfl_module_return_value_location (#166118)
  436. - libebl: Backend improvements for several CPUs
  437. * Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
  438. - update to 0.116
  439. - libdw fixes, API changes and additions
  440. - libdwfl fixes (#169672)
  441. - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
  442. * Fri Sep 9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
  443. - Update requires/conflicts for better biarch update behavior.
  444. * Mon Sep 5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
  445. - update to 0.115
  446. - New program eu-strings.
  447. - libdw: New function dwarf_getscopes_die.
  448. - libelf: speed-ups of non-mmap reading.
  449. - Implement --enable-gcov option for configure.
  450. * Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
  451. - update to 0.114
  452. - new program eu-ranlib
  453. - libdw: new calls for inlines
  454. - libdwfl: new calls for offline modules
  455. * Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
  456. - update to 0.113
  457. - elflint: relax a bit. Allow version definitions for defined symbols
  458. against DSO versions also for symbols in nobits sections.
  459. Allow .rodata section to have STRINGS and MERGE flag set.
  460. - strip: add some more compatibility with binutils.
  461. - libdwfl: bug fixes.
  462. - Separate libdw et al into elfutils-libs subpackage.
  463. * Sat Aug 6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
  464. - update to 0.112
  465. - elfcmp: some more relaxation.
  466. - elflint: many more tests, especially regarding to symbol versioning.
  467. - libelf: Add elfXX_offscn and gelf_offscn.
  468. - libasm: asm_begin interface changes.
  469. - libebl: Add three new interfaces to directly access machine, class,
  470. and data encoding information.
  471. * Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
  472. - update portability patch
  473. * Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
  474. - update to 0.111
  475. - libdwfl library now merged into libdw
  476. * Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
  477. - update to 0.110
  478. * Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
  479. - update to 0.109
  480. - verify that libebl modules are from the same build
  481. - new eu-elflint checks on copy relocations
  482. - new program eu-elfcmp
  483. - new experimental libdwfl library
  484. * Thu Jun 9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
  485. - robustification of eu-strip and eu-readelf
  486. * Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
  487. - more robustification
  488. * Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
  489. - robustification
  490. * Mon May 9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
  491. - update to 0.108
  492. - merge strip fixes
  493. - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
  494. - update elf.h from glibc
  495. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
  496. - fix strip -f byte-swapping bug
  497. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
  498. - update to 0.107
  499. - readelf: improve DWARF output format
  500. - elflint: -d option to support checking separate debuginfo files
  501. - strip: fix ET_REL debuginfo files (#156341)
  502. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
  503. - fix some bugs in new code, reenable make check
  504. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
  505. - disable make check for most arches, for now
  506. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
  507. - update to 0.106
  508. * Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
  509. - update to 0.104
  510. * Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
  511. - update to 0.103
  512. * Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
  513. - update to 0.101.
  514. - use %%configure macro to get CFLAGS etc. right
  515. * Sat Feb 5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
  516. - upgrade to 0.99.
  517. * Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
  518. - upgrade to 0.97.
  519. * Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
  520. - upgrade to 0.96.
  521. * Mon Jul 5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
  522. - rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
  523. warning
  524. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  525. - rebuilt
  526. * Fri Apr 2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
  527. - upgrade to 0.95.
  528. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  529. - rebuilt
  530. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  531. - rebuilt
  532. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
  533. - upgrade to 0.94
  534. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
  535. - upgrade to 0.93
  536. * Thu Jan 8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
  537. - full version
  538. - macroized spec file for GPL or OSL builds
  539. - include only libelf under GPL plus wrapper scripts
  540. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
  541. - macroized spec file for GPL or OSL builds
  542. * Wed Jan 7 2004 Ulrich Drepper <drepper@redhat.com>
  543. - split elfutils-devel into two packages.
  544. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
  545. - include only libelf under GPL plus wrapper scripts
  546. * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
  547. - readelf, not readline, in %%description (#111214).
  548. * Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
  549. - update to 0.89 (fix eu-strip)
  550. * Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
  551. - update to 0.86 (fix eu-strip on s390x/alpha)
  552. - libebl is an archive now; remove references to DSO
  553. * Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
  554. - upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
  555. * Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
  556. - upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
  557. * Wed Jul 9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
  558. - upgrade to 0.82 (strip tests fixed on big-endian).
  559. * Tue Jul 8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
  560. - upgrade to 0.81 (strip excludes unused symtable entries, test borked).
  561. * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
  562. - upgrade to 0.80 (debugedit changes for kernel in progress).
  563. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  564. - rebuilt
  565. * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
  566. - upgrade to 0.79 (correct formats for size_t, more of libdw "works").
  567. * Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
  568. - upgrade to 0.78 (libdwarf bugfix, libdw additions).
  569. * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
  570. - debuginfo rebuild
  571. * Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
  572. - use the correct way of identifying the section via the sh_info link.
  573. * Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
  574. - update to 0.75 (eu-strip -g fix)
  575. * Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
  576. - update to 0.74 (fix for writing with some non-dirty sections)
  577. * Thu Feb 6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
  578. - another -0.73 update (with sparc fixes).
  579. - do "make check" in %%check, not %%install, section.
  580. * Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
  581. - update to 0.73 (with s390 fixes).
  582. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  583. - rebuilt
  584. * Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
  585. - fix arguments to gelf_getsymshndx and elf_getshstrndx
  586. - fix other warnings
  587. - reenable checks on s390x
  588. * Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
  589. - temporarily disable checks on s390x, until someone has
  590. time to look at it
  591. * Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
  592. - update to 0.72
  593. * Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
  594. - update to 0.71
  595. * Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
  596. - update to 0.69.
  597. - add "make check" and segfault avoidance patch.
  598. - elfutils-libelf needs to run ldconfig.
  599. * Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
  600. - update to 0.68.
  601. * Fri Dec 6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
  602. - update to 0.67.
  603. * Tue Dec 3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
  604. - update to 0.65.
  605. * Mon Dec 2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
  606. - update to 0.64.
  607. * Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
  608. - split packages further into elfutils-libelf
  609. * Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
  610. - update to 0.63.
  611. * Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
  612. - Adjust for dropping libtool
  613. * Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
  614. - update to 0.59
  615. * Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
  616. - update to 0.56
  617. * Thu Nov 7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
  618. - update to 0.54
  619. * Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
  620. - update to 0.53
  621. - drop x86_64 hack, ICE fixed in gcc-3.2-11.
  622. * Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
  623. - get beehive to punch a rhpkg generated package.
  624. * Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
  625. - build in 8.0.1.
  626. - x86_64: avoid gcc-3.2 ICE on x86_64 for now.
  627. * Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
  628. - Add libelf-devel to conflicts for elfutils-devel
  629. * Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
  630. - Split into runtime and devel package
  631. * Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
  632. - integrate into official sources
  633. * Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
  634. - Swaddle.