libmemcached-vl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271
  1. %bcond_with tests
  2. Name: libmemcached
  3. Summary: Client library and command line tools for memcached server
  4. Version: 1.0.18
  5. Release: 3%{?_dist_release}
  6. Group: System Environment/Libraries
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. Packager: tomop
  10. License: BSD
  11. URL: http://libmemcached.org/
  12. # Original sources:
  13. # http://launchpad.net/libmemcached/1.0/%{version}/+download/libmemcached-%{version}.tar.gz
  14. # The source tarball must be repackaged to remove the Hsieh hash
  15. # code, since the license is non-free. When upgrading, download the new
  16. # source tarball, and run "./strip-hsieh.sh <version>" to produce the
  17. # "-exhsieh" tarball.
  18. Source0: libmemcached-%{version}-exhsieh.tar.gz
  19. Source1: strip-hsieh.sh
  20. Patch0: move-ax_confix_aux_dir.patch
  21. Patch1: fix-gcc7-build.diff
  22. Patch2: c++11.patch
  23. Patch3: m4_pthread.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  25. BuildRequires: cyrus-sasl-devel
  26. BuildRequires: flex bison
  27. %if %{with tests}
  28. BuildRequires: memcached
  29. %endif
  30. BuildRequires: libevent-devel
  31. %description
  32. libmemcached is a C/C++ client library and tools for the memcached server
  33. (http://memcached.org/). It has been designed to be light on memory
  34. usage, and provide full access to server side methods.
  35. It also implements several command line tools:
  36. memcapable Checking a Memcached server capibilities and compatibility
  37. memcat Copy the value of a key to standard output
  38. memcp Copy data to a server
  39. memdump Dumping your server
  40. memerror Translate an error code to a string
  41. memexist Check for the existance of a key
  42. memflush Flush the contents of your servers
  43. memparse Parse an option string
  44. memping Test to see if a server is available.
  45. memrm Remove a key(s) from the server
  46. memslap Generate testing loads on a memcached cluster
  47. memstat Dump the stats of your servers to standard output
  48. memtouch Touches a key
  49. %package devel
  50. Summary: Header files and development libraries for %{name}
  51. Group: Development/Libraries
  52. Requires: %{name}%{?_isa} = %{version}-%{release}
  53. Requires: pkgconfig
  54. Requires: cyrus-sasl-devel%{?_isa}
  55. %description devel
  56. This package contains the header files and development libraries
  57. for %{name}. If you like to develop programs using %{name},
  58. you will need to install %{name}-devel.
  59. %prep
  60. %setup -q
  61. %autopatch -p1
  62. mkdir examples
  63. cp -p tests/*.{cc,h} examples/
  64. # Will be regenerated during build
  65. rm -f libmemcached/csl/{parser,scanner}.cc
  66. # Temporary fix for SASL detection
  67. sed -i -e s/ax_cv_sasl/ac_enable_sasl/ configure
  68. # fix library dependency
  69. # perl -pi -e 's/^(Libs:.+)$/$1 -lpthread/' ./support/libmemcached.pc.in
  70. %build
  71. autoreconf -fiv
  72. # option --with-memcached=false to disable server binary check (as we don't run test)
  73. %configure --disable-static \
  74. %if ! %{with tests}
  75. --with-memcached=false
  76. %endif
  77. make %{_smp_mflags}
  78. %install
  79. rm -rf %{buildroot}
  80. make install DESTDIR="%{buildroot}" AM_INSTALL_PROGRAM_FLAGS=""
  81. %check
  82. %if %{with tests}
  83. # test suite cannot run in mock (same port use for memcache servers on all arch)
  84. # All tests completed successfully
  85. # diff output.res output.cmp fails but result depend on server version
  86. make test
  87. %else
  88. echo 'Test suite disabled (missing "--with tests" option)'
  89. %endif
  90. %clean
  91. rm -rf %{buildroot}
  92. %post
  93. /sbin/ldconfig
  94. %postun
  95. /sbin/ldconfig
  96. %files
  97. %defattr (-,root,root,-)
  98. %license COPYING
  99. %doc AUTHORS README THANKS TODO ChangeLog
  100. %{_bindir}/mem*
  101. %exclude %{_libdir}/lib*.la
  102. %{_libdir}/lib*.so.*
  103. %{_mandir}/man1/mem*
  104. %files devel
  105. %defattr (-,root,root,-)
  106. %doc examples
  107. %{_datadir}/aclocal/ax_libmemcached.m4
  108. %{_includedir}/*
  109. %{_libdir}/lib*.so
  110. %{_libdir}/pkgconfig/libmemcached.pc
  111. %{_mandir}/man3/libmemcached*
  112. %{_mandir}/man3/libhashkit*
  113. %{_mandir}/man3/memcached*
  114. %{_mandir}/man3/hashkit*
  115. %changelog
  116. * Tue May 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.18-3
  117. - rebuilt with current environment.
  118. - imported Patch0-3 from debian.
  119. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.18-2
  120. - rebuild with gcc-5.4.0
  121. * Fri Apr 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.18-1
  122. - new upstream release.
  123. - removed all patches (fixed in upstream).
  124. * Sat Jan 18 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.17-1
  125. - new upstream release.
  126. * Thu May 03 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.7-2
  127. - built for Vine Linux.
  128. * Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.7-1
  129. - update to 1.0.7
  130. - regenerate parser using flex/bison (#816766)
  131. * Sun Apr 22 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-2
  132. - workaround for SASL detection
  133. * Sat Apr 21 2012 Remi Collet <remi@fedoraproject.org> - 1.0.6-1
  134. - update to 1.0.6
  135. - soname bump to libmemcached.so.10 and libhashkit.so.2
  136. * Sat Mar 03 2012 Remi Collet <remi@fedoraproject.org> - 1.0.4-1
  137. - update to 1.0.4
  138. - soname bump to libmemcached.so.9
  139. - update description
  140. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-3
  141. - Rebuilt for c++ ABI breakage
  142. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
  143. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  144. * Thu Oct 27 2011 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
  145. - update to 1.0.2
  146. * Sun Oct 16 2011 Remi Collet <remi@fedoraproject.org> - 0.53-1
  147. - update to 0.53
  148. * Sat Sep 17 2011 Remi Collet <remi@fedoraproject.org> - 0.52-1
  149. - update to 0.52
  150. * Sun Jul 31 2011 Remi Collet <remi@fedoraproject.org> - 0.51-1
  151. - update to 0.51 (soname bump libmemcached.so.8)
  152. * Thu Jun 02 2011 Remi Collet <Fedora@famillecollet.com> - 0.49-1
  153. - update to 0.49
  154. - add build option : --with tests
  155. * Mon Feb 28 2011 Remi Collet <Fedora@famillecollet.com> - 0.47-1
  156. - update to 0.47
  157. - remove patch merged upstream
  158. * Sun Feb 20 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-2
  159. - patch Makefile.in instead of include.am (to avoid autoconf)
  160. - donc requires pkgconfig with arch
  161. * Fri Feb 18 2011 Remi Collet <Fedora@famillecollet.com> - 0.46-1
  162. - update to 0.46
  163. * Sat Feb 12 2011 Remi Collet <Fedora@famillecollet.com> - 0.44-6
  164. - arch specific requires
  165. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.44-5
  166. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  167. * Wed Nov 24 2010 Joe Orton <jorton@redhat.com> - 0.44-4
  168. - repackage source tarball to remove non-free Hsieh hash code
  169. * Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-3
  170. - improves SASL patch
  171. * Sat Oct 02 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-2
  172. - enable SASL support
  173. * Fri Oct 01 2010 Remi Collet <Fedora@famillecollet.com> - 0.44-1
  174. - update to 0.44
  175. - add soname version in %%file to detect change
  176. * Fri Jul 30 2010 Remi Collet <Fedora@famillecollet.com> - 0.43-1
  177. - update to 0.43
  178. * Wed Jul 07 2010 Remi Collet <Fedora@famillecollet.com> - 0.42-1
  179. - update to 0.42
  180. * Tue May 04 2010 Remi Collet <Fedora@famillecollet.com> - 0.40-1
  181. - update to 0.40 (new soname for libmemcached.so.5)
  182. - new URI (site + source)
  183. * Sat Mar 13 2010 Remi Collet <Fedora@famillecollet.com> - 0.38-1
  184. - update to 0.38
  185. * Sat Feb 06 2010 Remi Collet <Fedora@famillecollet.com> - 0.37-1
  186. - update to 0.37 (soname bump)
  187. - new libhashkit (should be a separated project in the futur)
  188. * Sun Sep 13 2009 Remi Collet <Fedora@famillecollet.com> - 0.31-1
  189. - update to 0.31
  190. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.30-2
  191. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  192. * Sun Jun 14 2009 Remi Collet <Fedora@famillecollet.com> - 0.30-1
  193. - update to 0.30
  194. * Tue May 19 2009 Remi Collet <Fedora@famillecollet.com> - 0.29-1
  195. - update to 0.29
  196. * Fri May 01 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-2
  197. - add upstream patch to disable nonfree hsieh hash method
  198. * Sat Apr 25 2009 Remi Collet <Fedora@famillecollet.com> - 0.28-1
  199. - Initial RPM from Brian Aker spec
  200. - create -devel subpackage
  201. - add %%post %%postun %%check section