libtirpc-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307
  1. %define _root_libdir /%{_lib}
  2. Name: libtirpc
  3. Version: 1.3.1
  4. Release: 2%{?_dist_release}
  5. Summary: Transport Independent RPC Library
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: SISSL and BSD
  10. URL: http://nfsv4.bullopensource.org/
  11. Source0: https://downloads.sourceforge.net/libtirpc/libtirpc-%{version}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: automake, autoconf, libtool, pkgconfig
  14. BuildRequires: krb5-devel
  15. %description
  16. This package contains SunLib's implementation of transport-independent
  17. RPC (TI-RPC) documentation. This library forms a piece of the base of
  18. Open Network Computing (ONC), and is derived directly from the
  19. Solaris 2.3 source.
  20. TI-RPC is an enhanced version of TS-RPC that requires the UNIX System V
  21. Transport Layer Interface (TLI) or an equivalent X/Open Transport Interface
  22. (XTI). TI-RPC is on-the-wire compatible with the TS-RPC, which is supported
  23. by almost 70 vendors on all major operating systems. TS-RPC source code
  24. (RPCSRC 4.0) remains available from several internet sites.
  25. %package devel
  26. Summary: Development files for the libtirpc library
  27. Group: programming
  28. Requires: %{name} = %{version}-%{release}
  29. Requires: pkgconfig
  30. %description devel
  31. This package includes header files and libraries necessary for
  32. developing programs which use the tirpc library.
  33. %debug_package
  34. %prep
  35. %autosetup -p1
  36. # Remove .orig files
  37. find . -name "*.orig" | xargs rm -f
  38. %build
  39. sh autogen.sh
  40. autoreconf -fisv
  41. %configure --disable-static
  42. make all
  43. %install
  44. rm -rf %{buildroot}
  45. mkdir -p %{buildroot}/etc
  46. mkdir -p %{buildroot}%{_root_libdir}
  47. mkdir -p %{buildroot}%{_libdir}/pkgconfig
  48. make install DESTDIR=%{buildroot} \
  49. libdir=%{_root_libdir} pkgconfigdir=%{_libdir}/pkgconfig
  50. # Don't package .a or .la files
  51. rm -f %{buildroot}%{_root_libdir}/*.{a,la}
  52. # Creat the man diretory
  53. mv %{buildroot}%{_mandir}/man3 %{buildroot}%{_mandir}/man3t
  54. %clean
  55. rm -rf %{buildroot}
  56. %files
  57. %defattr(-,root,root)
  58. %license COPYING
  59. %doc AUTHORS ChangeLog NEWS README
  60. %{_root_libdir}/libtirpc.so.*
  61. %config(noreplace) %{_sysconfdir}/netconfig
  62. %config(noreplace) %{_sysconfdir}/bindresvport.blacklist
  63. %files devel
  64. %defattr(0644,root,root,755)
  65. %dir %{_includedir}/tirpc
  66. %dir %{_includedir}/tirpc/rpc
  67. %dir %{_includedir}/tirpc/rpcsvc
  68. %{_root_libdir}/libtirpc.so
  69. %{_libdir}/pkgconfig/libtirpc.pc
  70. %{_includedir}/tirpc/netconfig.h
  71. %{_includedir}/tirpc/rpc/auth.h
  72. %{_includedir}/tirpc/rpc/auth_des.h
  73. %{_includedir}/tirpc/rpc/auth_gss.h
  74. %{_includedir}/tirpc/rpc/auth_unix.h
  75. %{_includedir}/tirpc/rpc/des.h
  76. %{_includedir}/tirpc/rpc/des_crypt.h
  77. %{_includedir}/tirpc/rpc/rpcsec_gss.h
  78. %{_includedir}/tirpc/rpc/clnt.h
  79. %{_includedir}/tirpc/rpc/clnt_soc.h
  80. %{_includedir}/tirpc/rpc/clnt_stat.h
  81. %{_includedir}/tirpc/rpc/key_prot.h
  82. %{_includedir}/tirpc/rpc/nettype.h
  83. %{_includedir}/tirpc/rpc/pmap_clnt.h
  84. %{_includedir}/tirpc/rpc/pmap_prot.h
  85. %{_includedir}/tirpc/rpc/pmap_rmt.h
  86. %{_includedir}/tirpc/rpc/raw.h
  87. %{_includedir}/tirpc/rpc/rpc.h
  88. %{_includedir}/tirpc/rpc/rpc_com.h
  89. %{_includedir}/tirpc/rpc/rpc_msg.h
  90. %{_includedir}/tirpc/rpc/rpcb_clnt.h
  91. %{_includedir}/tirpc/rpc/rpcb_prot.h
  92. %{_includedir}/tirpc/rpc/rpcb_prot.x
  93. %{_includedir}/tirpc/rpc/rpcent.h
  94. %{_includedir}/tirpc/rpc/svc.h
  95. %{_includedir}/tirpc/rpc/svc_auth.h
  96. %{_includedir}/tirpc/rpc/svc_auth_gss.h
  97. %{_includedir}/tirpc/rpc/svc_dg.h
  98. %{_includedir}/tirpc/rpc/svc_mt.h
  99. %{_includedir}/tirpc/rpc/svc_soc.h
  100. %{_includedir}/tirpc/rpc/types.h
  101. %{_includedir}/tirpc/rpc/xdr.h
  102. %{_includedir}/tirpc/rpcsvc/crypt.h
  103. %{_includedir}/tirpc/rpcsvc/crypt.x
  104. %{_mandir}/*/*
  105. %changelog
  106. * Sat Apr 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-2
  107. - rebuilt with gcc-10.3.
  108. - dropped ldconfig scriptlets.
  109. * Tue Feb 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-1
  110. - updated to 1.3.1.
  111. * Tue Mar 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.5-1
  112. - updated to 1.2.5.
  113. - dropped Patch1: fixed in upstream.
  114. * Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.4-1
  115. - updated to 1.1.4.
  116. * Thu Feb 19 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.2.5-1
  117. - updated to 0.2.5
  118. - BR: krb5-devel instead of libgssglue-devel
  119. * Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.1-4
  120. - rebuild with VineSeed environment
  121. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.1-3
  122. - rebuild with rpm-4.8.1 for pkg-config file
  123. * Sun Feb 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.1-2
  124. - Initial build for Vine Linux
  125. * Mon Nov 30 2009 Steve Dickson <steved@redhat.com> 0.2.1-1
  126. - Updated to latest upstream version: 0.2.1
  127. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.0-4
  128. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  129. * Thu Jul 9 2009 Steve Dickson <steved@redhat.com> 0.2.0-3
  130. - Updated to latest upstream tag: 0-2-1-rc3
  131. Fixed the --disable-gss options
  132. Fixed a number of warnings
  133. Change how architectures are define in xdr_float.c
  134. * Mon Jun 29 2009 Steve Dickson <steved@redhat.com> 0.2.0-2
  135. - Updated to latest upstream tag: 0-2-1-rc2
  136. rpcb_clnt: RPC_PROGNOTREGISTERED is a permanent error
  137. clnt_dg: Fix infinite loop when datagram call times ou
  138. Updated .gitignore file
  139. Replace the hard coded path name with the top_srcdir macrc
  140. Added 'doc' to the SUBDIRS list so make install work correctly.
  141. * Fri May 29 2009 Steve Dickson <steved@redhat.com> 0.2.0-1
  142. - Updated to latest upstream version: 0.2.0
  143. * Tue May 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> 0.1.11-3
  144. - Replace the Sun RPC license with the BSD license, with the explicit permission of Sun Microsystems
  145. * Mon Apr 20 2009 Steve Dickson <steved@redhat.com> 0.1.11-2
  146. - Updated to libtirpc-0.1.12-rc1
  147. * Mon Apr 20 2009 Steve Dickson <steved@redhat.com> 0.1.11-1
  148. - Updated to the latest release: 0.1.11
  149. * Fri Mar 13 2009 Steve Dickson <steved@redhat.com> 0.1.10-6
  150. - libtirpc: set r_netid and r_owner in __rpcb_findaddr_timed
  151. - libtirpc: be sure to free cl_netid and cl_tp
  152. - libtirpc: must free saved wire verifier when destroying context
  153. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.10-5
  154. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  155. * Wed Jan 28 2009 Steve Dickson <steved@redhat.com> 0.1.10-4
  156. - Converted all uids and uids to type uid_t and gid_t (sf 2446314)
  157. * Wed Jan 28 2009 Steve Dickson <steved@redhat.com> 0.1.10-3
  158. - backwards compatibility: fix order of fields in TI-RPC's
  159. svc_req (bz 481388)
  160. - Removed a number warnings.
  161. * Thu Jan 22 2009 Steve Dickson <steved@redhat.com> 0.1.10-2
  162. - Header file fixes for C++
  163. * Thu Nov 20 2008 Steve Dickson <steved@redhat.com> 0.1.10-1
  164. - Updated to latest upstream version: 0.1.10
  165. * Tue Oct 28 2008 Steve Dickson <steved@redhat.com> 0.1.9-7
  166. - Fixed some incorrect function declarations (bz468815)
  167. * Mon Oct 27 2008 Steve Dickson <steved@redhat.com> 0.1.9-6
  168. - Fix bad assumption taddr2uaddr processing that
  169. caused a segfault (bz468014)
  170. * Tue Sep 16 2008 Steve Dickson <steved@redhat.com> 0.1.9-5
  171. - Fix for taddr2addr conversion bug of local addresses
  172. - Fixed some of warnings in: src/auth_time.c, src/clnt_dg.c and
  173. src/clnt_raw.c
  174. - Added some #ifdef NOTUSED around some code in src/rpbc_clnt.c
  175. that was not being used...
  176. * Thu Sep 4 2008 Steve Dickson <steved@redhat.com> 0.1.9-4
  177. - Always make IPv6 sockets V6ONLY
  178. - Fix incorrect sizeof() in __rpc_getbroadifs
  179. * Thu Aug 7 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.1.9-3
  180. - fix license tag
  181. * Wed Jul 9 2008 Steve Dickson <steved@redhat.com> 0.1.9-1
  182. - Update to latest upstream version 0.1.9
  183. * Fri Jun 27 2008 Steve Dickson <steved@redhat.com> 0.1.8-2
  184. - Added super-H(sh3,4) architecture support (bz 446559)
  185. * Tue Jun 10 2008 Steve Dickson <steved@redhat.com> 0.1.8-1
  186. - Update to latest upstream version 0.1.8
  187. * Wed Mar 12 2008 Steve Dickson <steved@redhat.com> 0.1.7-18
  188. - Install man pages in the 3t section
  189. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.7-17
  190. - Autorebuild for GCC 4.3
  191. * Mon Feb 18 2008 Steve Dickson <steved@redhat.com> 0.1.7-16
  192. - Added patch that creates a libtirpc.pc used by the
  193. pkg-config command.
  194. * Thu Jan 24 2008 Steve Dickson <steved@redhat.com> 0.1.7-15
  195. - Protect from buffer overflow in the GSS code. (bz 362121)
  196. * Mon Dec 17 2007 Steve Dickson <steved@redhat.com> 0.1.7-14
  197. - Fixed typo in /etc/netconfig file (bz 414471)
  198. * Thu Oct 25 2007 Steve Dickson <steved@redhat.com> 0.1.7-13
  199. - Added a check for the ARM arch (bz 351071)
  200. * Wed Oct 17 2007 Steve Dickson <steved@redhat.com> 0.1.7-12
  201. - Switch the libgssapi dependency to libgssglue
  202. * Mon Oct 15 2007 Steve Dickson <steved@redhat.com> 0.1.7-11
  203. - Made tcp6/udp6 network ids no longer visible in the netconfig
  204. file since the ipv6 code is not fully baked yet in rpcbind. (bz 249121)
  205. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.1.7-10
  206. - Rebuild for selinux ppc32 issue.
  207. * Mon Jul 30 2007 <steved@redhat.com> 0.1.7-9
  208. - Fixed mutex lock problem in clnt_raw_create()
  209. - Ignore the return value of snprintf() and use strlen() instead
  210. to bump the pointer in clnt_sperror()
  211. - A couple ntohs() were needed in bindresvport_sa()
  212. - Added IP_RECVERR processing with to clnt_dg_call() so
  213. application will see errors instead of timing out
  214. - Make sure remote address (xp_rtaddr) is populated
  215. with the correct type of address.
  216. - Change the order of network ids in /etc/netconfg
  217. putting ipv4 ids before ipv6.
  218. - Bumped up Release from 8 to 9.
  219. * Mon Jul 9 2007 <steved@redhat.com> 0.1.7-7
  220. - Fixed infinite loop in svc_run() (bz 246677)
  221. * Thu Apr 26 2007 <steved@redhat.com> 0.1.7-6
  222. - Fixed potential buffer overflow in xdr_strings
  223. - Added a optimization to bindresvport that allows more
  224. ports to be tried.
  225. * Mon Mar 26 2007 Steve Dickson <steved@redhat.com> 0.1.7-5
  226. - Fixed Unowned Directory RPM problem (bz 233873)
  227. * Mon Aug 28 2006 Steve Dickson <steved@redhat.com> 0.1.7-4
  228. - Fixed undefined symbol (bz 204296)
  229. * Mon Aug 14 2006 Steve Dickson <steved@redhat.com> 0.1.7-3
  230. - Added in svc_auth_none needed by the GSSAPI code.
  231. - Added compile define for ppc64 archs
  232. * Fri Aug 11 2006 Steve Dickson <steved@redhat.com> 0.1.7-2
  233. - Uncommented tcp6 and udp6 in the default /etc/netconfig file.
  234. - Added hooks to used the libgssapi library.
  235. * Fri Aug 4 2006 Steve Dickson <steved@redhat.com> 0.1.7-1
  236. - Initial commit