libxcrypt-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578
  1. %bcond_with fipstest
  2. %if 0%{?__isa_bits} == 64
  3. %bcond_without check
  4. %else
  5. %bcond_with check
  6. %endif
  7. Name: libxcrypt
  8. Summary: Extended crypt library for descrypt, md5crypt, bcrypt, and others
  9. Version: 4.4.19
  10. Release: 1%{?_dist_release}
  11. Group: system
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. # For explicit license breakdown, see the
  15. # LICENSING file in the source tarball.
  16. License: LGPLv2+ and BSD and Public Domain
  17. URL: https://github.com/besser82/%{name}
  18. Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
  19. # Patch 0000 - 2999: Backported patches from upstream.
  20. # Patch 3000 - 5999: Backported patches from pull requests.
  21. # Patch 6000 - 9999: Downstream patches.
  22. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  23. # Build with new api?
  24. %bcond_without new_api
  25. # Build the compat package?
  26. %bcond_without compat_pkg
  27. # Shared object version of libcrypt.
  28. %if %{with new_api}
  29. %global soc 2
  30. %global sol 0
  31. %global sof 0
  32. %global sov %{soc}.%{sol}.%{sof}
  33. %if %{with compat_pkg}
  34. %global csoc 1
  35. %global csol 1
  36. %global csof 0
  37. %global csov %{csoc}.%{csol}.%{csof}
  38. %endif
  39. %else
  40. %global soc 1
  41. %global sol 1
  42. %global sof 0
  43. %global sov %{soc}.%{sol}.%{sof}
  44. %endif
  45. # Hash methods and API supported by libcrypt.
  46. # NEVER EVER touch this, if you do NOT know what you are doing!
  47. %if %{with new_api}
  48. %global hash_methods fedora,glibc,strong
  49. %global obsolete_api no
  50. %if %{with compat_pkg}
  51. %global compat_methods glibc
  52. %global compat_api glibc
  53. %endif
  54. %else
  55. %global hash_methods all
  56. %global obsolete_api glibc
  57. %endif
  58. # Needed for the distribution README file.
  59. %global distname .vine
  60. # Needed for out-of-tree builds.
  61. %global _configure ../"configure"
  62. # Common configure options.
  63. %global common_configure_options \\\
  64. --libdir=/%{_lib} \\\
  65. --disable-failure-tokens \\\
  66. --disable-silent-rules \\\
  67. --enable-shared \\\
  68. --enable-static \\\
  69. --disable-valgrind \\\
  70. --srcdir=.. \\\
  71. --with-pkgconfigdir=%{_libdir}/pkgconfig
  72. %if %{with fipstest}
  73. # Add generation of HMAC checksums of the final stripped
  74. # binaries. %%define with lazy globbing is used here
  75. # intentionally, because using %%global does not work.
  76. BuildRequires: fipscheck
  77. %define __spec_install_post \
  78. %{?__debug_package:%{__debug_install_post}} \
  79. %{__arch_install_post} \
  80. %{__os_install_post} \
  81. %{_bindir}/fipshmac %{buildroot}/%{_lib}/libcrypt.a \
  82. %{__ln_s} .libcrypt.a.hmac \\\
  83. %{buildroot}/%{_lib}/.libxcrypt.a.hmac \
  84. %{_bindir}/fipshmac %{buildroot}/%{_lib}/libcrypt.so.%{sov} \
  85. %{__ln_s} .libcrypt.so.%{sov}.hmac \\\
  86. %{buildroot}/%{_lib}/.libcrypt.so.%{soc}.hmac \
  87. if [[ %{with new_api} == 1 && %{with compat_pkg} == 1 ]]; then \
  88. %{_bindir}/fipshmac %{buildroot}/%{_lib}/libcrypt.so.%{csov} \
  89. %{__ln_s} .libcrypt.so.%{csov}.hmac \\\
  90. %{buildroot}/%{_lib}/.libcrypt.so.%{csoc}.hmac \
  91. fi \
  92. %{nil}
  93. %endif
  94. BuildRequires: libtool
  95. %if %{with check}
  96. BuildRequires: glibc-debuginfo
  97. %endif
  98. # We do not need to keep this forever.
  99. # We need a version of glibc, that doesn't build libcrypt anymore.
  100. Requires: glibc%{?_isa} >= 2.26.9000-46
  101. %if 0%{?fedora} >= 30
  102. Recommends: mkpasswd
  103. %endif
  104. %description
  105. libxcrypt is a modern library for one-way hashing of passwords. It
  106. supports a wide variety of both modern and historical hashing methods:
  107. yescrypt, gost-yescrypt, scrypt, bcrypt, sha512crypt, sha256crypt,
  108. %if %{with new_api}
  109. md5crypt, and descrypt.
  110. %else
  111. md5crypt, SunMD5, sha1crypt, NT, bsdicrypt, bigcrypt, and descrypt.
  112. %endif
  113. It provides the traditional Unix crypt and crypt_r interfaces, as well
  114. as a set of extended interfaces pioneered by Openwall Linux, crypt_rn,
  115. crypt_ra, crypt_gensalt, crypt_gensalt_rn, and crypt_gensalt_ra.
  116. libxcrypt is intended to be used by login(1), passwd(1), and other
  117. similar programs; that is, to hash a small number of passwords during
  118. an interactive authentication dialogue with a human. It is not suitable
  119. for use in bulk password-cracking applications, or in any other situation
  120. where speed is more important than careful handling of sensitive data.
  121. However, it is intended to be fast and lightweight enough for use in
  122. servers that must field thousands of login attempts per minute.
  123. %if %{with new_api}
  124. This version of the library does not provide the legacy API functions
  125. that have been provided by glibc's libcrypt.so.1.
  126. %endif
  127. %if %{with new_api} && %{with compat_pkg}
  128. %package compat
  129. Summary: Compatibility library providing legacy API functions
  130. Group: system
  131. Requires: %{name}%{?_isa} == %{version}-%{release}
  132. %description compat
  133. This package contains the library providing the compatibility API
  134. for applications that are linked against glibc's libxcrypt, or that
  135. are still using the unsafe and deprecated, encrypt, encrypt_r,
  136. setkey, setkey_r, and fcrypt functions, which are still required by
  137. recent versions of POSIX, the Single UNIX Specification, and various
  138. other standards.
  139. All existing binary executables linked against glibc's libcrypt should
  140. work unmodified with the library supplied by this package.
  141. %endif
  142. %package devel
  143. Summary: Development files for %{name}
  144. Group: programming
  145. Conflicts: man-pages < 4.15-3
  146. Requires: %{name}%{?_isa} == %{version}-%{release}
  147. Requires: glibc-devel%{?_isa}
  148. %description devel
  149. The %{name}-devel package contains libraries and header files for
  150. developing applications that use %{name}.
  151. %package static
  152. Summary: Static library for -static linking with %{name}
  153. Group: programming
  154. Requires: %{name}-devel%{?_isa} == %{version}-%{release}
  155. Requires: glibc-static%{?_isa}
  156. %description static
  157. This package contains the libxcrypt static library for -static
  158. linking.
  159. You don't need this, unless you link statically, which is highly
  160. discouraged.
  161. %package -n compat32-%{name}
  162. Summary: Extended crypt library for descrypt, md5crypt, bcrypt, and others
  163. Group: system
  164. %description -n compat32-%{name}
  165. libxcrypt is a modern library for one-way hashing of passwords. It
  166. supports a wide variety of both modern and historical hashing methods:
  167. yescrypt, gost-yescrypt, scrypt, bcrypt, sha512crypt, sha256crypt,
  168. %if %{with new_api}
  169. md5crypt, and descrypt.
  170. %else
  171. md5crypt, SunMD5, sha1crypt, NT, bsdicrypt, bigcrypt, and descrypt.
  172. %endif
  173. It provides the traditional Unix crypt and crypt_r interfaces, as well
  174. as a set of extended interfaces pioneered by Openwall Linux, crypt_rn,
  175. crypt_ra, crypt_gensalt, crypt_gensalt_rn, and crypt_gensalt_ra.
  176. libxcrypt is intended to be used by login(1), passwd(1), and other
  177. similar programs; that is, to hash a small number of passwords during
  178. an interactive authentication dialogue with a human. It is not suitable
  179. for use in bulk password-cracking applications, or in any other situation
  180. where speed is more important than careful handling of sensitive data.
  181. However, it is intended to be fast and lightweight enough for use in
  182. servers that must field thousands of login attempts per minute.
  183. %if %{with new_api}
  184. This version of the library does not provide the legacy API functions
  185. that have been provided by glibc's libcrypt.so.1.
  186. %endif
  187. %package -n compat32-%{name}-devel
  188. Summary: Development files for cpmpat32-%{name}
  189. Group: programming
  190. Requires: %{name}-devel == %{version}-%{release}
  191. Requires: compat32-glibc-devel
  192. %description -n compat32-%{name}-devel
  193. The compat32-%{name}-devel package contains libraries and header files for
  194. developing applications that use compat32-%{name}.
  195. %debug_package
  196. %prep
  197. %autosetup -p 1
  198. ./autogen.sh
  199. %if %{with new_api}
  200. %{__cat} << EOF >> README%{distname}
  201. This version of the %{name} package ships the libcrypt.so.2
  202. library and does not provide the legacy API functions that have
  203. been provided by glibc's libcrypt.so.1. The removed functions
  204. by name are encrypt, encrypt_r, setkey, setkey_r, and fcrypt.
  205. %if %{with compat_pkg}
  206. If you are using a third-party application that links against
  207. those functions, or that is linked against glibc's libcrypt,
  208. you may need to install the %{name}-compat package manually.
  209. All existing binary executables linked against glibc's libcrypt
  210. should work unmodified with the libcrypt.so.1 library supplied
  211. by the %{name}-compat package.
  212. %endif
  213. EOF
  214. %endif
  215. %{__mkdir_p} %{_vpath_builddir}{,-compat}
  216. %build
  217. # Build the default system library.
  218. pushd %{_vpath_builddir}
  219. %configure \
  220. %{common_configure_options} \
  221. --enable-hashes=%{hash_methods} \
  222. --enable-obsolete-api=%{obsolete_api}
  223. %make_build
  224. popd
  225. %if %{with new_api} && %{with compat_pkg}
  226. # Build the compatibility library.
  227. pushd %{_vpath_builddir}-compat
  228. %configure \
  229. %{common_configure_options} \
  230. --enable-hashes=%{compat_methods} \
  231. --enable-obsolete-api=%{compat_api}
  232. %make_build
  233. popd
  234. %endif
  235. %install
  236. rm -rf %{buildroot}
  237. %if %{with new_api} && %{with compat_pkg}
  238. # Install the compatibility library.
  239. %make_install -C %{_vpath_builddir}-compat
  240. # Cleanup everything we do not need from the compatibility library.
  241. %{__rm} -fr %{buildroot}%{_bindir} \
  242. %{buildroot}%{_includedir} \
  243. %{buildroot}/%{_lib}/lib{,x}crypt.{a,so} \
  244. %{buildroot}%{_libdir}/pkgconfig \
  245. %{buildroot}%{_mandir} \
  246. %{buildroot}%{_sbindir}
  247. %endif
  248. # Install the default system library.
  249. %make_install -C %{_vpath_builddir}
  250. # Get rid of libtool crap.
  251. %{_bindir}/find %{buildroot} -name '*.la' -print -delete
  252. %if %{with check}
  253. %check
  254. build_dirs="%{_vpath_builddir}"
  255. %if %{with new_api} && %{with compat_pkg}
  256. build_dirs="${build_dirs} %{_vpath_builddir}-compat"
  257. %endif
  258. for dir in ${build_dirs}; do
  259. %make_build -C ${dir} check || \
  260. {
  261. rc=$?;
  262. echo "-----BEGIN TESTLOG: ${dir}-----";
  263. %{__cat} ${dir}/test-suite.log;
  264. echo "-----END TESTLOG: ${dir}-----";
  265. exit $rc;
  266. }
  267. done
  268. %endif
  269. %files
  270. %doc NEWS README* THANKS
  271. %license AUTHORS COPYING.LIB LICENSING
  272. %if %{with fipstest}
  273. /%{_lib}/.libcrypt.so.%{soc}.hmac
  274. /%{_lib}/.libcrypt.so.%{sov}.hmac
  275. %endif
  276. /%{_lib}/libcrypt.so.%{soc}
  277. /%{_lib}/libcrypt.so.%{sov}
  278. %{_mandir}/man5/crypt.5.*
  279. %if %{with new_api} && %{with compat_pkg}
  280. %files compat
  281. %if %{with fipstest}
  282. /%{_lib}/.libcrypt.so.%{csoc}.hmac
  283. /%{_lib}/.libcrypt.so.%{csov}.hmac
  284. %endif
  285. /%{_lib}/libcrypt.so.%{csoc}
  286. /%{_lib}/libcrypt.so.%{csov}
  287. %endif
  288. %files devel
  289. %doc ChangeLog TODO
  290. /%{_lib}/lib*crypt.so
  291. %{_includedir}/*crypt.h
  292. %{_libdir}/pkgconfig/libcrypt.pc
  293. %{_libdir}/pkgconfig/%{name}.pc
  294. %{_mandir}/man3/crypt*.3*
  295. %files static
  296. %if %{with fipstest}
  297. /%{_lib}/.lib*crypt.a.hmac
  298. %endif
  299. /%{_lib}/lib*crypt.a
  300. %if 0%{?build_compat32}
  301. %files -n compat32-%{name}
  302. %if %{with fipstest}
  303. /%{_lib}/.libcrypt.so.%{soc}.hmac
  304. /%{_lib}/.libcrypt.so.%{sov}.hmac
  305. %endif
  306. /%{_lib}/libcrypt.so.%{soc}
  307. /%{_lib}/libcrypt.so.%{sov}
  308. %files -n compat32-%{name}-devel
  309. /%{_lib}/lib*crypt.so
  310. %{_libdir}/pkgconfig/libcrypt.pc
  311. %{_libdir}/pkgconfig/%{name}.pc
  312. %endif
  313. %changelog
  314. * Sat Apr 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.19-1
  315. - new upstream release.
  316. - dropped ldconfig scriptlets.
  317. * Tue Feb 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.17-1
  318. - new upstream release.
  319. * Sat Mar 28 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.15-1
  320. - new upstream release.
  321. * Sat Jan 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.2-6
  322. - initial build for Vine Linux.
  323. * Mon Jan 14 2019 Björn Esser <besser82@fedoraproject.org> - 4.4.2-5
  324. - Build the compat package with glibc hashing methods only
  325. - Add an option to disable the compat-package for future use
  326. * Mon Jan 14 2019 Björn Esser <besser82@fedoraproject.org> - 4.4.2-4
  327. - Bump SO-name for Fedora >= 30 and enable compat package (#1666033)
  328. - Add distribution README file
  329. - Update description of the compat package
  330. - Conditionally remove non-built hashing methods from description
  331. * Sun Dec 23 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.2-3
  332. - Remove architecture bits from Recommends
  333. * Sun Dec 23 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.2-2
  334. - Update summary
  335. * Sat Dec 22 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.2-1
  336. - New upstream release
  337. * Thu Dec 06 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.1-1
  338. - New upstream release
  339. * Tue Dec 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-5
  340. - Sync -fno-plt patch with upstream commit
  341. * Tue Dec 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-4
  342. - Backport upstream commit to fix a memory leak from a static pointer
  343. * Tue Dec 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-3
  344. - Backport upstream PR to build with -fno-plt optimization
  345. * Mon Nov 26 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-2
  346. - Backport upstream commit to use a safer strcpy for the NT method
  347. - Backport upstream generating base64 encoded output for NT gensalt
  348. - Backport upstream commit to require less rbytes for NT gensalt
  349. - Backport upstream commit to test incremental hmac-sha256 computation
  350. - Add Recommends: mkpasswd for Fedora >= 30
  351. * Tue Nov 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-1
  352. - New upstream release
  353. * Wed Nov 14 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.4-1
  354. - New upstream release
  355. * Wed Nov 14 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-4
  356. - Bump release for proper obsoletion of former common sub-package
  357. * Wed Nov 14 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-3
  358. - Add two upstream patches with minor fixes
  359. - Add HMAC checksum file for the static library
  360. - Drop the common sub-package
  361. - Some spec-file optimizations
  362. * Tue Nov 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-2
  363. - Add a patch to define crypt_gensalt_r as macro, so applications
  364. link the identical crypt_gensalt_rn directly
  365. * Sun Nov 11 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-1
  366. - New upstream release
  367. * Sun Nov 11 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.2-1
  368. - New upstream release
  369. * Sun Nov 11 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.1-2
  370. - Backport two patches from upstream fixing the gensalt function for
  371. NT to properly terminate its returned output
  372. * Sat Nov 10 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.1-1
  373. - New upstream release
  374. * Sat Nov 10 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.0-1
  375. - New upstream release
  376. * Fri Oct 26 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.3-1
  377. - New upstream release
  378. * Thu Oct 25 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.2-2
  379. - Add patch updating to recent development version
  380. - Run valgrind-memcheck
  381. - Use bootstrap script
  382. * Thu Oct 18 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.2-1
  383. - New upstream release
  384. * Mon Oct 01 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.1-3
  385. - Drop compat-devel package
  386. - Set configure options from globals
  387. * Sun Sep 30 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.1-2
  388. - Build out-of-tree
  389. - Split off noarch-bits into common sub-package
  390. - Update %%description
  391. - Prepare to remove legacy API from library and to provide a compatibilty
  392. package for the legacy API
  393. * Sat Sep 29 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.1-1
  394. - New upstream release
  395. - Add new manpages
  396. * Sat Sep 29 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.0-1
  397. - New upstream release
  398. * Fri Aug 24 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.2-1
  399. - New upstream release
  400. * Wed Aug 08 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-4
  401. - Move *.3 manpages to devel subpackage (#1613762)
  402. - Add needed Conflicts: man-pages < 4.15-3
  403. * Wed Aug 08 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-3
  404. - Make crypt{,_r} return NULL on failure (#1611784)
  405. * Sat Aug 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-2
  406. - Add manpages for crypt{,_r,_ra}.3 (#1610307)
  407. * Wed Aug 01 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-1
  408. - New upstream release
  409. * Fri Jul 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.0-1
  410. - New upstream release
  411. * Fri Jul 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.1-6
  412. - Make testsuite fail on error again
  413. - Update patch0 with more upstream fixes
  414. * Fri Jul 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.1-5
  415. - Add patch to update to recent development branch
  416. - Re-enable SUNMD5 support as it is BSD licensed now
  417. - Build compatibility symbols for glibc only
  418. - Skip failing testsuite once
  419. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.1-4
  420. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  421. * Fri Jun 29 2018 Florian Weimer <fweimer@redhat.com> - 4.0.1-3
  422. - Remove CDDL from license list (#1592445)
  423. * Fri Jun 29 2018 Florian Weimer <fweimer@redhat.com> - 4.0.1-2
  424. - Remove SUNMD5 support (#1592445)
  425. * Wed May 16 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.1-1
  426. - New upstream release
  427. * Sat Feb 17 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-5
  428. - Switch to %%ldconfig_scriptlets
  429. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.0-4
  430. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  431. * Thu Feb 01 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-3
  432. - Add patch to fix unintialize value in badsalt test
  433. * Wed Jan 31 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-2
  434. - Add patch to fix bcrypt test with GCC8
  435. * Sat Jan 27 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-1
  436. - New upstream release
  437. * Mon Jan 22 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 4.0.0-0.204.20180120git3436e7b
  438. - Fix Obsoletes
  439. * Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.203.20180120git3436e7b
  440. - Update to new snapshot fixing cast-align
  441. * Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.202.20180120gitde99d27
  442. - Update to new snapshot (rhbz#1536752)
  443. * Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.201.20171109git15447aa
  444. - Use archful Obsoletes for libcrypt
  445. - Add versioned Requires on glibc packages not shipping libcrypt
  446. - Add comments about the packaging logic for replacing former libcrypt
  447. * Fri Jan 12 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.200.20171109git15447aa
  448. - Initial import (rhbz#1532794)
  449. - Add Obsoletes/Provides for libcrypt
  450. * Wed Jan 10 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.101.20171109git15447aa
  451. - Fix style of %%git_{rel,ver}
  452. * Tue Jan 09 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.100.git20171109.15447aa
  453. - Initial rpm release (rhbz#1532794)
  454. - Start revision at 0.100 to superseed builds from COPR