SysVinit-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374
  1. Summary: Programs which control basic system processes.
  2. Summary(ja): 基本的なシステムプロセスを制御するプログラム
  3. Name: SysVinit
  4. Version: 2.88dsf
  5. Release: 4%{_dist_release}
  6. License: GPLv2+
  7. Group: System Environment/Base
  8. Source: http://download.savannah.gnu.org/releases/sysvinit/sysvinit-%{version}.tar.bz2
  9. URL: http://savannah.nongnu.org/projects/sysvinit/
  10. Patch1: sysvinit-2.78-man.patch
  11. Patch2: sysvinit-2.86-autofsck.patch
  12. Patch3: sysvinit-2.86-loginshell.patch
  13. Patch4: sysvinit-2.86-inittab.patch
  14. Patch5: sysvinit-2.86-single.patch
  15. Patch6: sysvinit-2.88-quiet.patch
  16. Patch14: sysvinit-2.88-ipv6.patch
  17. Patch15: sysvinit-2.88-omit.patch
  18. Patch16: sysvinit-2.88-wall-maxlines.patch
  19. Patch17: sysvinit-2.88-wall-broadcast-message.patch
  20. Buildroot: %{_tmppath}/%{name}-%{version}-root
  21. Requires: pam >= 0.66-5
  22. Requires: %{name}-tools = %{version}-%{release}
  23. Requires: filesystem
  24. Requires: util-linux >= 2.30.1
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. Packager: daisuke
  28. %description
  29. The SysVinit package contains a group of processes that control
  30. the very basic functions of your system. SysVinit includes the init
  31. program, the first program started by the Linux kernel when the
  32. system boots. Init then controls the startup, running, and shutdown
  33. of all other programs.
  34. %description -l ja
  35. SysVinit パッケージには,システムの非常に基本的な機能を制御する
  36. プロセスが収められています.例えば,システム起動時に Linux カーネルに
  37. よって最初に起動されるプログラムである init 等です.init はその後
  38. システムの起動や,他のプログラムの起動/終了を制御します.
  39. %package tools
  40. Summary: Tools used for process management.
  41. Summary(ja): プロセス管理に使用するツール
  42. Group: System Environment/Base
  43. Requires: util-linux >= 2.30.1
  44. %description tools
  45. The sysvinit-tools package contains various tools used for process
  46. management.
  47. $description -l ja tools
  48. SysVinit-tools パッケージにはプロセス管理に使用するさまざまなツール
  49. が含まれています。
  50. %prep
  51. %setup -q -n sysvinit-%{version}
  52. # We use a shell, not sulogin. Other random man fixes go here (such as #192804)
  53. %patch1 -p1 -b .manpatch
  54. # Unlink /.autofsck on shutdown -f
  55. %patch2 -p1 -b .autofsck
  56. # Invoke single-user shell as a login shell (#105653)
  57. %patch3 -p1 -b .loginshell
  58. # Adjust examples in inittab(5) to more accurately reflect RH/Fedora
  59. # usage (#173572)
  60. %patch4 -p1 -b .inittabdocs
  61. # Fix single user mode (#176348)
  62. %patch5 -p1 -b .single
  63. # Be less verbose when booted with 'quiet'
  64. %patch6 -p1 -b .quiet
  65. # Change accepted ipv6 addresses (#573346)
  66. %patch14 -p1 -b .ipv6
  67. # Add option to pidof to exclude similar processes to omitted processes (#632321)
  68. %patch15 -p1 -b .omit
  69. # Fix counting MAXLINES in wall
  70. %patch16 -p1 -b .maxlines
  71. # Raise limit for broadcast message
  72. %patch17 -p1 -b .broadcast
  73. %build
  74. make %{?_smp_mflags} CC=%{__cc} CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE" LDFLAGS="-lcrypt" -C src
  75. %install
  76. rm -rf $RPM_BUILD_ROOT
  77. for I in bin sbin %{_bindir} %{_mandir}/man{1,3,5,8} etc var/run dev %{_includedir}; do
  78. mkdir -p $RPM_BUILD_ROOT/$I
  79. done
  80. make -C src ROOT=$RPM_BUILD_ROOT MANDIR=%{_mandir} STRIP=/bin/true \
  81. BIN_OWNER=`id -nu` BIN_GROUP=`id -ng` install
  82. rm -f $RPM_BUILD_ROOT/bin/pidof
  83. ln -snf killall5 $RPM_BUILD_ROOT/sbin/pidof
  84. rm -f $RPM_BUILD_ROOT/sbin/bootlogd
  85. rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/bootlogd*
  86. chmod 755 $RPM_BUILD_ROOT/usr/bin/utmpdump
  87. # Remove these files, as we use upstart as /sbin/init.
  88. rm -f $RPM_BUILD_ROOT/sbin/{halt,init,poweroff,reboot,runlevel,shutdown,telinit}
  89. rm -f $RPM_BUILD_ROOT/%{_includedir}/initreq.h
  90. rm -f $RPM_BUILD_ROOT/%{_mandir}/man5/*
  91. rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/{halt,init,poweroff,reboot,runlevel,shutdown,telinit}*
  92. # /sbin/fstab-decode is part of initscripts
  93. rm -f $RPM_BUILD_ROOT/sbin/fstab-decode
  94. rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/fstab-decode.8
  95. # /bin/mountpoint is part of util-linux >= 2.20
  96. rm -f $RPM_BUILD_ROOT/bin/mountpoint
  97. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/mountpoint.*
  98. # utmpdump and sulogin is part of util-linux >= 2.22
  99. rm -f $RPM_BUILD_ROOT%{_bindir}/utmpdump
  100. rm -f $RPM_BUILD_ROOT/sbin/sulogin
  101. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/utmpdump.*
  102. rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/sulogin.*
  103. rm -f $RPM_BUILD_ROOT%{_bindir}/*
  104. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*
  105. %post
  106. [ -x /sbin/telinit -a -p /dev/initctl -a -f /proc/1/exe -a -d /proc/1/root ] && /sbin/telinit u
  107. exit 0
  108. %clean
  109. rm -rf $RPM_BUILD_ROOT
  110. %files tools
  111. %defattr(-,root,root)
  112. %doc doc/Changelog COPYRIGHT
  113. /sbin/pidof
  114. /sbin/killall5
  115. %{_mandir}/man8/killall5*
  116. %{_mandir}/man8/pidof*
  117. %changelog
  118. * Sat Sep 09 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.88dsf-4
  119. - removed last,lastb,mesg and wall which is part of util-linux = 2.30.
  120. * Tue Nov 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.88dsf-3
  121. - remove sulogin and utmpdump which are part of util-linux >= 2.22
  122. * Tue Feb 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.88dsf-2
  123. - remove mountpoint which is part of util-linux >= 2.20
  124. * Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.88dsf-1
  125. - update to 2.88dsf
  126. - only build -tools subpackage
  127. * Fri Apr 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.87dsf-1
  128. - new upstream release (2.87dsf)
  129. - remove upstreamed or obsoleted patches
  130. - split off a -tools subpackage to avoid upstart conflicts
  131. * Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.86-1
  132. - new upstream release
  133. * Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 2.85-5vl3
  134. - add script to create $RPM_BUILD_ROOT/bin in %%install section
  135. * Wed Dec 10 2003 <tkoba@vinelinux.org> 2.85-5vl2
  136. - install initreq.h
  137. * Fri Nov 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.85-5vl1
  138. - new upstream release
  139. - merged with fedora package.
  140. * Tue Jul 17 2001 <sagami@vinelinux.org>
  141. - 2.78-10vl3: fix orphan symlink in %%doc
  142. * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  143. - 2.78-10vl1
  144. - rebuilt under new %%{_mandir} definition
  145. - added Japanese summary and description
  146. * Sat Nov 18 2000 Satoshi MACHINO <machino@vinelinux.org> 2.78-10vl1
  147. - build with gcc-2.95.3
  148. - partially used rpmmacros
  149. * Mon Sep 22 2003 Bill Nottingham <notting@redhat.com> 2.85-5
  150. - add change_console, for changing console used by init
  151. * Wed Jun 25 2003 Bill Nottingham <notting@redhat.com> 2.85-4
  152. - block signals when calling syslog() (#97534, <joden@lee.k12.nc.us>)
  153. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  154. - rebuilt
  155. * Fri May 23 2003 Bill Nottingham <notting@redhat.com> 2.85-2
  156. - clean up killall5 some
  157. * Thu May 22 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  158. - update to 2.85, remove already applied patches
  159. * Mon Feb 10 2003 Bill Nottingham <notting@redhat.com> 2.84-13
  160. - fix s390x build
  161. - fix silly warning (#83943)
  162. * Mon Feb 10 2003 Arjan van de Ven <arjanv@redhat.com>
  163. - fix wait() handling wrt setting SIGCHLD to SIG_IGN in shutdown
  164. - fix segfault in spawn() function in shutdown
  165. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  166. - rebuilt
  167. * Thu Dec 05 2002 Elliot Lee <sopwith@redhat.com> 2.84-7
  168. - Pass __cc macro to build, to facilitate cross-compiling
  169. - _smp_mflags
  170. * Mon Dec 2 2002 Bill Nottingham <notting@redhat.com> 2.84-6
  171. - rebuild on all arches
  172. - change sulogin message to be slightly more correct (#65828)
  173. * Thu Jul 18 2002 Bill Nottingham <notting@redhat.com>
  174. - don't strip binaries
  175. - have wall not write to non-ttys (#65412)
  176. - update usage for halt/reboot (#57753)
  177. - allow '-t' argument to last for checking state at certain times (#56863)
  178. - make 'pidof /foo/bar' not match /baz/bar (#53918)
  179. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  180. - automated rebuild
  181. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  182. - automated rebuild
  183. * Tue Mar 12 2002 Bill Nottingham <notting@redhat.com> 2.84-2
  184. - add patch to log messages on shutdown/reboot
  185. * Fri Feb 22 2002 Bill Nottingham <notting@redhat.com> 2.84-1
  186. - update to 2.84
  187. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  188. - automated rebuild
  189. * Fri Nov 9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.79-2
  190. - Fix pidof -o (#55954)
  191. - Handle RPM_OPT_FLAGS
  192. - s/Copyright/License/
  193. * Mon Sep 17 2001 Bill Nottingham <notting@redhat.com>
  194. - update to 2.79
  195. * Tue Aug 28 2001 Bill Nottingham <notting@redhat.com>
  196. - unlink /.autofsck on shutdown -f
  197. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  198. - Bump release + rebuild.
  199. * Thu Jun 21 2001 Bill Nottingham <notting@redhat.com>
  200. - update 'no logout' patch
  201. - fix setting of CREAD to work with 2.4.3+ kernels (#45284)
  202. * Tue Jun 12 2001 Bill Nottingham <notting@redhat.com>
  203. - show users with no login pid but no logout record as gone (#42550,
  204. <cwolf@starclass.com>)
  205. - fix sulogin to *always* work without a tty (#40934)
  206. * Tue Apr 3 2001 Bill Nottingham <notting@redhat.com>
  207. - set umask 022 on startup
  208. - manpage tweaks (#21628, #27173)
  209. * Mon Apr 2 2001 Bill Nottingham <notting@redhat.com>
  210. - fix dangling symlink in %%doc (#34383)
  211. * Thu Mar 15 2001 Bill Nottingham <notting@redhat.com>
  212. - don't run telinit u if we don't appear to be on the root fs
  213. * Fri Feb 16 2001 Bill Nottingham <notting@redhat.com>
  214. - run telinit u on upgrade
  215. * Wed Jan 31 2001 Bill Nottingham <notting@redhat.com>
  216. - document '-n' option to wall, make it root-only (#18672)
  217. - don't open files in sulogin unless they're really ttys (#21862)
  218. * Tue Aug 8 2000 Bill Nottingham <notting@redhat.com>
  219. - set SHLVL in sulogin so /etc/profile.d stuff isn't run by default
  220. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  221. - automatic rebuild
  222. * Thu Jun 8 2000 Bill Nottingham <notting@redhat.com>
  223. - fix the md5 code (#11534)
  224. - rebuild for FHS & the like
  225. * Wed Apr 19 2000 Bill Nottingham <notting@redhat.com>
  226. - ignore sigint in sulogin (#9803)
  227. - touch file in root directory if powering off (#7318)
  228. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  229. - rebuild for sparc baud rates > 38400.
  230. * Thu Feb 24 2000 Bill Nottingham <notting@redhat.com>
  231. - update to 2.78-final
  232. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  233. - handle compressed manpages
  234. * Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
  235. - build to fix dependency problem
  236. * Mon Jan 10 2000 Bill Nottingham <notting@redhat.com>
  237. - update to 2.78
  238. * Mon Sep 06 1999 Jakub Jelinek <jj@ultra.linux.cz>
  239. - on big endian machines use a kludge for broken pam md5 passwords
  240. * Fri Aug 27 1999 Bill Nottingham <notting@redhat.com>
  241. - update to 2.77
  242. * Tue Jul 06 1999 Bill Nottingham <notting@redhat.com>
  243. - move pam_console stuff to usermode package
  244. * Fri Jul 02 1999 Cristian Gafton <gafton@redhat.com>
  245. - requires usermode to express the dependency on /usr/bin/consolehelper
  246. (#2813)
  247. * Wed Jun 23 1999 Bill Nottingham <notting@redhat.com>
  248. - make man page references to single-user mode consistent with RH usage
  249. * Sat Apr 17 1999 Jeff Johnson <jbj@redhat.com>
  250. - remove /etc/initlvl compatibility symlink from file list (#2236).
  251. * Fri Mar 26 1999 Michael Johnson <johnsonm@redhat.com>
  252. - pam.d files marked noreplace
  253. - added poweroff as a console application
  254. * Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
  255. - marked config files as such in consolehelper part of filelist
  256. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  257. - auto rebuild in the new build environment (release 8)
  258. * Fri Mar 19 1999 Michael Johnson <johnsonm@redhat.com>
  259. - consolehelper support
  260. * Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
  261. - glibc 2.1
  262. * Sun Aug 23 1998 Jeff Johnson <jbj@redhat.com>
  263. - poweroff symlink not included (problem #762)
  264. * Thu Jul 09 1998 Chris Evans <chris@ferret.lmh.ox.ac.uk>
  265. - Fix a securelevel releated security hole. Go on, try and break append
  266. only files + securelevel now ;-)
  267. * Wed Jul 8 1998 Jeff Johnson <jbj@redhat.com>
  268. - remove /etc/nologin at end of shutdown.
  269. - compile around missing SIGPWR on sparc
  270. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  271. - translations modified for de, fr, tr
  272. * Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
  273. - upgraded to 2.74
  274. - fixed the package source url... (yeah, it was wrong !)
  275. * Wed Oct 1 1997 Cristian Gafton <gafton@redhat.com>
  276. - fixed the MD5 check in sulogin (128 hash bits encoded with base64 gives
  277. 22 bytes, not 24...). Fix in -md5.patch
  278. * Thu Sep 11 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
  279. - /etc/initrunlvl gets linked to /tmp/init-root/var/run/initrunlvl which is
  280. just plain wrong..
  281. - /usr/bin/utmpdump was missing in the files section, although it was
  282. explicitly patched into PROGS.
  283. - added attr's to the files section.
  284. - various small fixes.
  285. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  286. - updated to 2.71
  287. - built against glibc 2.0.4
  288. * Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
  289. - Added sulogin.8 man page to file list.