chrony-vl.spec 7.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226
  1. Name: chrony
  2. Version: 3.0
  3. Release: 1%{?_dist_release}
  4. Summary: An NTP client/server
  5. Group: System Environment/Daemons
  6. License: GPLv2
  7. URL: http://chrony.tuxfamily.org
  8. Source0: http://download.tuxfamily.org/chrony/chrony-%{version}%{?prerelease}.tar.gz
  9. Source1: chrony.conf
  10. Source2: chrony.dhclient
  11. Source3: chronyd.sysconfig
  12. Source4: chronyd.init
  13. Source5: chrony.logrotate
  14. # Debian's patches
  15. Patch101: fix_time_smoothing_in_interleaved_mode.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  17. BuildRequires: libcap-devel readline-devel ncurses-devel bison
  18. Requires(pre): shadow-utils
  19. Requires(post): chkconfig
  20. Requires(preun): chkconfig initscripts
  21. Requires(postun): initscripts
  22. Obsoletes: ntp < 4.2.6p5
  23. Obsoletes: networkmanager-dispatcher-chrony
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. Packager: tomop
  27. %description
  28. A client/server for the Network Time Protocol, this program keeps your
  29. computer's clock accurate. It was specially designed to support
  30. systems with intermittent internet connections, but it also works well
  31. in permanently connected environments. It can use also hardware reference
  32. clocks, system real-time clock or manual input as time references.
  33. %prep
  34. %setup -q -n %{name}-%{version}%{?prerelease}
  35. %patch101 -p1
  36. echo '# Keys used by chronyd for command and NTP authentication' > chrony.keys
  37. # regenerate the file from getdate.y
  38. rm -f getdate.c
  39. %build
  40. #CFLAGS="$RPM_OPT_FLAGS"
  41. #%ifarch %{sparc}
  42. #CFLAGS="$CFLAGS -pie -fPIE"
  43. #%else
  44. #CFLAGS="$CFLAGS -pie -fpie"
  45. #%endif
  46. #export CFLAGS
  47. #export LDFLAGS="-Wl,-z,relro,-z,now"
  48. %configure \
  49. --docdir=%{_docdir} \
  50. --with-user=chrony \
  51. --with-sendmail=%{_sbindir}/sendmail \
  52. --enable-forcednsretry
  53. make %{?_smp_mflags} all docs
  54. %install
  55. rm -rf $RPM_BUILD_ROOT
  56. make install install-docs DESTDIR=$RPM_BUILD_ROOT
  57. rm -rf $RPM_BUILD_ROOT%{_docdir}
  58. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/{sysconfig,logrotate.d}
  59. mkdir -p $RPM_BUILD_ROOT%{_initrddir}
  60. mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/{lib,log}/chrony
  61. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/dispatcher.d
  62. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dhcp/dhclient.d
  63. install -m 644 -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/chrony.conf
  64. install -m 640 -p chrony.keys $RPM_BUILD_ROOT%{_sysconfdir}/chrony.keys
  65. install -m 755 -p examples/chrony.nm-dispatcher \
  66. $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/dispatcher.d/20-chrony
  67. install -m 755 -p %{SOURCE2} \
  68. $RPM_BUILD_ROOT%{_sysconfdir}/dhcp/dhclient.d/chrony.sh
  69. install -m 644 -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/chronyd
  70. install -m 755 -p %{SOURCE4} $RPM_BUILD_ROOT%{_initrddir}/chronyd
  71. install -m 644 -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/chrony
  72. touch $RPM_BUILD_ROOT%{_localstatedir}/lib/chrony/{drift,rtc}
  73. %clean
  74. rm -rf $RPM_BUILD_ROOT
  75. %pre
  76. getent group chrony > /dev/null || /usr/sbin/groupadd -r chrony
  77. getent passwd chrony > /dev/null || /usr/sbin/useradd -r -g chrony \
  78. -d %{_localstatedir}/lib/chrony -s /sbin/nologin chrony
  79. :
  80. %post
  81. /sbin/chkconfig --add chronyd
  82. :
  83. %preun
  84. if [ "$1" -eq 0 ]; then
  85. /sbin/service chronyd stop &> /dev/null
  86. /sbin/chkconfig --del chronyd
  87. fi
  88. :
  89. %postun
  90. if [ "$1" -ge 1 ]; then
  91. /sbin/service chronyd condrestart &> /dev/null
  92. fi
  93. :
  94. %files
  95. %defattr(-,root,root,-)
  96. %doc COPYING FAQ NEWS README examples/*
  97. %config(noreplace) %{_sysconfdir}/chrony.conf
  98. %config(noreplace) %verify(not md5 size mtime) %attr(640,root,chrony) %{_sysconfdir}/chrony.keys
  99. %config(noreplace) %{_sysconfdir}/sysconfig/chronyd
  100. %config(noreplace) %{_sysconfdir}/logrotate.d/chrony
  101. %{_initrddir}/chronyd
  102. %{_sysconfdir}/NetworkManager/dispatcher.d/20-chrony
  103. %{_sysconfdir}/dhcp/dhclient.d/chrony.sh
  104. %{_bindir}/chronyc
  105. %{_sbindir}/chronyd
  106. %{_mandir}/man[158]/%{name}*.[158]*
  107. %dir %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony
  108. %ghost %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony/drift
  109. %ghost %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony/rtc
  110. %dir %attr(-,chrony,chrony) %{_localstatedir}/log/chrony
  111. %changelog
  112. * Thu May 18 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 3.0-1
  113. - update to 3.0
  114. - add patch to fix time smoothing in interleaved mode (Patch101); from Debian 3.0-4
  115. - drop chrony.txt in %%doc; upstream dropped
  116. - drop info file; upstream dropped
  117. - drop R: info
  118. - drop BR: texinfo
  119. - drop scripts for info
  120. * Mon Jul 11 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.2.1-2
  121. - Obsoletes: networkmanager-dispatcher-chrony
  122. * Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.1-1
  123. - new upstream release.
  124. * Fri Oct 23 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2-1
  125. - new upstream release.
  126. * Sat Jul 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
  127. - new upstream release.
  128. * Tue Dec 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.31-1
  129. - new upstream release.
  130. * Sat Jun 7 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.1-1
  131. - new upstream release.
  132. - initial build for Vine Linux.
  133. * Fri Aug 09 2013 Miroslav Lichvar <mlichvar@redhat.com> 1.25-3
  134. - fix buffer overflow when processing crafted command packets (CVE-2012-4502)
  135. - don't send uninitialized data in command replies (CVE-2012-4503)
  136. * Thu May 19 2011 Miroslav Lichvar <mlichvar@redhat.com> 1.25-2
  137. - remove timepps.h, NM and dhclient scripts
  138. - build with readline
  139. * Thu May 05 2011 Miroslav Lichvar <mlichvar@redhat.com> 1.25-1
  140. - update to 1.25
  141. - link with -Wl,-z,relro,-z,now options
  142. - use iburst, four pool servers, rtcsync, stratumweight in default config
  143. - suppress install-info errors
  144. * Thu Apr 29 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-4.20100428git73d775
  145. - update to 20100428git73d775
  146. - replace initstepslew directive with makestep in default config
  147. - add NetworkManager dispatcher script
  148. - add dhclient script
  149. - retry server/peer name resolution at least once to workaround
  150. NetworkManager race condition on boot
  151. - don't verify chrony.keys
  152. * Fri Mar 12 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-3.20100302git5fb555
  153. - update to snapshot 20100302git5fb555
  154. - compile with PPS API support
  155. * Thu Feb 04 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-1
  156. - update to 1.24 (#555367, CVE-2010-0292 CVE-2010-0293 CVE-2010-0294)
  157. - modify default config
  158. - step clock on start if it is off by more than 100 seconds
  159. - disable client log
  160. - build with -fPIE on sparc
  161. * Tue Dec 15 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.24-0.1.pre1
  162. - update to 1.24-pre1
  163. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23-7.20081106gitbe42b4
  164. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  165. * Fri Jul 17 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.23-6.20081106gitbe42b4
  166. - switch to editline
  167. - support arbitrary chronyc commands in init script
  168. * Mon Jun 08 2009 Dan Horak <dan[at]danny.cz> 1.23-5.20081106gitbe42b4
  169. - add patch with support for s390/s390x
  170. * Mon Mar 09 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.23-4.20081106gitbe42b4
  171. - fix building with broken libcap header (#483548)
  172. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23-3.20081106gitbe42b4
  173. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  174. * Wed Nov 19 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.23-2.20081106gitbe42b4
  175. - fix info uninstall
  176. - generate random command key in init script
  177. - support cyclelogs, online, offline commands in init script
  178. - add logrotate script
  179. * Tue Nov 11 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.23-1.20081106gitbe42b4
  180. - initial release