perl-IO-String-vl.spec 2.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697
  1. Name: perl-IO-String
  2. Version: 1.08
  3. Release: 1%{?_dist_release}
  4. Summary: Emulate file interface for in-core strings
  5. Group: Development/Libraries
  6. License: GPL or Artistic
  7. URL: http://search.cpan.org/dist/IO-String/
  8. Source0: http://www.cpan.org/authors/id/G/GA/GAAS/IO-String-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildArch: noarch
  11. BuildRequires: perl >= 5.6.1
  12. Requires: perl >= 5.6.1
  13. %description
  14. The "IO::String" module provides the "IO::File" interface for in-core
  15. strings. An "IO::String" object can be attached to a string, and
  16. makes it possible to use the normal file operations for reading or
  17. writing data, as well as for seeking to various locations of the
  18. string. This is useful when you want to use a library module that
  19. only provides an interface to file handles on data that you have in a
  20. string variable.
  21. Note that perl-5.8 and better has built-in support for "in memory"
  22. files, which are set up by passing a reference instead of a filename
  23. to the open() call. The reason for using this module is that it makes
  24. the code backwards compatible with older versions of Perl.
  25. %prep
  26. %setup -q -n IO-String-%{version}
  27. %build
  28. perl Makefile.PL INSTALLDIRS=vendor
  29. make %{?_smp_mflags}
  30. %install
  31. rm -rf $RPM_BUILD_ROOT
  32. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  33. #find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  34. #find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  35. #chmod -R u+w $RPM_BUILD_ROOT/*
  36. find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
  37. find $RPM_BUILD_ROOT/usr -type f -print |
  38. sed "s@^$RPM_BUILD_ROOT@@g" |
  39. grep -v %{_mandir} |
  40. grep -v perllocal.pod |
  41. grep -v "\.packlist" > IO-String-%{version}-filelist
  42. if [ "$(cat IO-String-%{version}-filelist)X" = "X" ] ; then
  43. echo "ERROR: EMPTY FILE LIST"
  44. exit -1
  45. fi
  46. %check || :
  47. make test
  48. %clean
  49. rm -rf $RPM_BUILD_ROOT
  50. %files -f IO-String-%{version}-filelist
  51. %defattr(-,root,root,-)
  52. %doc Changes README
  53. %dir %{perl_vendorlib}/IO/
  54. #{perl_vendorlib}/IO/*
  55. %{_mandir}/man3/*.3*
  56. %changelog
  57. * Tue Nov 4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.08-1vl5
  58. - applied new versioning policy
  59. - rebuilt with perl 5.10.0
  60. * Sat Feb 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.08-0vl1
  61. - new upstream release
  62. - changed Group to Development/Libraries
  63. * Sat Feb 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.08-0vl1
  64. - new upstream release
  65. - changed Group to Development/Libraries
  66. * Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
  67. - rebuilt for Vine
  68. * Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
  69. - rebuilt
  70. * Wed Nov 24 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.06-1
  71. - Update to 1.06.
  72. * Sun Jul 04 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.05-0.fdr.1
  73. - First build.