123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164 |
- Name: preload
- Version: 0.6.4
- Release: 4%{?_dist_release}
- Summary: an adaptive readahead daemon
- Summary(ja): 適応的先読みデーモン
- Group: Applications/System
- License: GPLv2+
- URL: http://preload.sf.net/
- Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
- #Patch0: preload-0.6-start-late.patch
- Patch0: preload.init.in.patch
- #This patch prefered to http://sourceforge.net/tracker/index.php?func=detail&aid=2183212&group_id=143398&atid=755420
- Patch1: preload-conf.patch
- #This patch from http://preload.svn.sourceforge.net/viewvc/preload/trunk/src/cmdline.c?revision=122
- #Patch2: fix_segfault.patch
- #This patch from Mandriva
- #Patch3: preload-0.6.3-glib214.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: basesystem, glib2-devel
- Requires: basesystem, logrotate
- Requires(post): /sbin/chkconfig
- Requires(post): /sbin/service
- Requires(preun): /sbin/chkconfig
- Requires(preun): /sbin/service
- Requires(postun): /sbin/service
- %description
- preload monitors applications that users run, and by analyzing this data,
- predicts what applications users might run, and fetches those binaries and
- their dependencies into memory for faster startup times.
- %description -l ja
- preload は起動中のアプリケーションを監視し、監視したデータを分析することで、
- 度のアプリケーションユーザが起動されるかを予想し、バイナリと依存する
- ライブラリをメモリに取り込み、起動時間を高速にします。
- %prep
- %setup -q
- %patch0 -p1
- %patch1 -p1
- #%patch2 -p1
- #%patch3 -p1
- %build
- %configure
- %{__make}
- %install
- %{__rm} -rf $RPM_BUILD_ROOT
- %{__make} install DESTDIR=$RPM_BUILD_ROOT
- %clean
- %{__rm} -rf $RPM_BUILD_ROOT
- %post
- /sbin/service preload restart >/dev/null 2>&1
- /sbin/chkconfig --add preload
- /sbin/chkconfig preload on
- %preun
- if [ $1 = 0 ]; then
- /sbin/service preload stop >/dev/null 2>&1
- /sbin/chkconfig --del preload
- fi
- %postun
- if [ "$1" -ge "1" ]; then
- /sbin/service preload condrestart >/dev/null 2>&1 || :
- fi
- %files
- %defattr(-,root,root, -)
- %doc README AUTHORS COPYING ChangeLog TODO THANKS NEWS
- %{_sbindir}/preload
- %{_datadir}/man/man8/preload.8.gz
- %{_sysconfdir}/rc.d/init.d/preload
- %config(noreplace) %{_sysconfdir}/preload.conf
- %config(noreplace) %{_sysconfdir}/sysconfig/preload
- %config(noreplace) %{_sysconfdir}/logrotate.d/preload
- %attr(0644,root,root) %ghost %config(missingok,noreplace) %{_localstatedir}/log/preload.log
- %attr(0644,root,root) %ghost %config(missingok,noreplace) %{_localstatedir}/lib/preload/preload.state
- %attr(0755,root,root) %dir %{_localstatedir}/lib/preload
- %changelog
- * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.6.4-4
- - rebuilt with gcc-4.4.3-3 on ppc
- * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.6.4-3
- - rebuilt with rpm-4.8.0-3 (on ppc)
- * Wed Feb 3 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.6.4-2
- - rebuilt with new toolchain
- * Tue May 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.4-1
- - new upstream release
- - dropped Patch2,3 (merged)
- * Thu Mar 12 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.3-4
- - added patch3 (import from Mandriva 2009.1)
- * Mon Dec 22 2008 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.3-3
- - changed patch0 (Prefered to Mandriva 2009.0 package in preload-0.6.3-prcsys.patch)
- * Mon Dec 8 2008 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.3-2
- - Removed preload-0.6-start-late.patch
- - Added patch0, patch1, patch2
- Patch0: start preload daemon later, changed default-start
- Patch1: changed mapprefix&exeprefix section
- added /opt, for some applicaton (ex. Adobe Reader, OpenOffice.org)
- Patch2: fix segfault src/cmdline.c
- * Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
- - new upstream release
- - drop all patches, they are all obsolete by upstream.
- - add Patch0 to start preload daemon lator. (use readahead daemon for bootup)
- * Wed Aug 27 2008 Shu KONNO <owa@bg.wakwak.com> 0.4-1vl5
- - applied new versioning policy, spec in utf-8
- * Sat Mar 15 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4-0vl1
- - initial build for VineSeed based on Fedora package
- # * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4-0vlmp0
- # - rebuild for Vine Linux 4.2
- #
- # * Wed Mar 5 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4-0vlmp1
- # - initial build for VineSeed based on Fedora package
- * Wed Jan 16 2008 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-5
- - Removed auto start from init
- - Added all the CVS patches prior to next release
- * Sun Jan 6 2008 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-4
- - Removed debian patch and added patches from upstream instead
- - Patches fix 64 bit, ionice, sysconfig and loading.
- * Fri Nov 9 2007 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-3
- - Used Debian Patch it consists of:
- - Close the file descriptor when writing state to a file in src/state.c,
- - Parse the dev field in /proc/%%d/maps as hexadecimal, not as unsigned
- integer. Thanks to Johan Kiviniemi for the patch.
- - Sort the readahead file list by device, block and inode and not file
- path to reduce seeking. Adapted by Johan from a patch for readahead
- by Scott James Remnant.
- - Added my patch to verbosity to 1 due to 30 second log writing
-
- * Thu Nov 8 2007 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-2
- - Fixed config lines
- - Fixed source lines
- - Added Requires: Logrotate
- - Default preload sequence is stopped
- - %{?_smp_mflags} does not work
- * Sat Oct 16 2007 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-1
- - Creation from start
- ### end of file
|