123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240 |
- %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
- %global upstream_name Sphinx
- Name: python-sphinx
- Version: 1.0.5
- Release: 1%{?_dist_release}
- Summary: Python documentation generator
- Group: Development/Tools
- # Unless otherwise noted, the license for code is BSD
- # sphinx/util/stemmer.py Public Domain
- # sphinx/pycode/pgen2 Python
- # jquery (MIT or GPLv2)
- License: BSD and Public Domain and Python and (MIT or GPLv2)
- URL: http://sphinx.pocoo.org/
- Source0: http://pypi.python.org/packages/source/S/%{upstream_name}/%{upstream_name}-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildArch: noarch
- BuildRequires: python-devel >= 2.4
- BuildRequires: python-setuptools
- BuildRequires: python-docutils
- BuildRequires: python-jinja2
- BuildRequires: python-nose
- Requires: python-docutils
- Requires: python-jinja2
- Requires: python-pygments
- %description
- Sphinx is a tool that makes it easy to create intelligent and
- beautiful documentation for Python projects (or other documents
- consisting of multiple reStructuredText sources), written by Georg
- Brandl. It was originally created to translate the new Python
- documentation, but has now been cleaned up in the hope that it will be
- useful to many other projects.
- Sphinx uses reStructuredText as its markup language, and many of its
- strengths come from the power and straightforwardness of
- reStructuredText and its parsing and translating suite, the Docutils.
- Although it is still under constant development, the following
- features are already present, work fine and can be seen "in action" in
- the Python docs:
- * Output formats: HTML (including Windows HTML Help) and LaTeX,
- for printable PDF versions
- * Extensive cross-references: semantic markup and automatic links
- for functions, classes, glossary terms and similar pieces of
- information
- * Hierarchical structure: easy definition of a document tree, with
- automatic links to siblings, parents and children
- * Automatic indices: general index as well as a module index
- * Code handling: automatic highlighting using the Pygments highlighter
- * Various extensions are available, e.g. for automatic testing of
- snippets and inclusion of appropriately formatted docstrings.
- %package doc
- Summary: Documentation for %{name}
- Group: Documentation
- License: BSD
- Requires: %{name} = %{version}-%{release}
- %description doc
- Sphinx is a tool that makes it easy to create intelligent and
- beautiful documentation for Python projects (or other documents
- consisting of multiple reStructuredText sources), written by Georg
- Brandl. It was originally created to translate the new Python
- documentation, but has now been cleaned up in the hope that it will be
- useful to many other projects.
- This package contains documentation in reST and HTML formats.
- %prep
- %setup -q -n %{upstream_name}-%{version}
- %__sed '1d' -i sphinx/pycode/pgen2/token.py
- %build
- %{__python} setup.py build
- pushd doc
- %__make html
- %__rm -rf _build/html/.buildinfo
- %__mv _build/html ..
- %__rm -rf _*
- popd
- %install
- %__rm -rf %{buildroot}
- %{__python} setup.py install --skip-build --root %{buildroot}
- # Manpages not in beta release yet
- #pushd doc
- # Deliver man pages
- #install -d %{buildroot}%{_mandir}/man1
- #mv sphinx-*.1 %{buildroot}%{_mandir}/man1/
- #popd
- # Deliver rst files
- %__mv doc reST
- # Move language files to /usr/share in association with %patch1
- pushd %{buildroot}%{python_sitelib}
- for lang in `find sphinx/locale -maxdepth 1 -mindepth 1 -type d -printf "%f "`;
- do
- install -d %{buildroot}%{_datadir}/sphinx/locale/$lang
- install -d %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES
- %__mv sphinx/locale/$lang/LC_MESSAGES/sphinx.js \
- %{buildroot}%{_datadir}/sphinx/locale/$lang/
- %__mv sphinx/locale/$lang/LC_MESSAGES/sphinx.mo \
- %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/
- %__rm -rf sphinx/locale/$lang
- done
- popd
- %find_lang sphinx
- # Language files; Since these are javascript, it's not immediately obvious to
- # find_lang that they need to be marked with a language.
- (cd %{buildroot} && find . -name 'sphinx.js') | %__sed -e 's|^.||' | %__sed -e \
- 's:\(.*/locale/\)\([^/_]\+\)\(.*\.js$\):%lang(\2) \1\2\3:' \
- >> sphinx.lang
- %clean
- %__rm -rf %{buildroot}
- %check
- %__make test
- %files -f sphinx.lang
- %defattr(-,root,root,-)
- %doc AUTHORS CHANGES EXAMPLES LICENSE README TODO
- %{_bindir}/sphinx-*
- %{python_sitelib}/*
- %{_datadir}/sphinx/
- %exclude %{_datadir}/sphinx/locale/*/sphinx.js
- #%{_mandir}/man1/*
- %files doc
- %defattr(-,root,root,-)
- %doc html reST
- %changelog
- * Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.5-1
- - update sphinx to 1.0.5
- * Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-1.b2
- - initial build based on Fedora development
- * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.0-0.1.b2.1
- - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
- * Mon May 31 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 1.0-0.2.b2
- - Update to 1.0 beta 2
- - Fixes problem building html documentation in non-English locales
- * Wed May 26 2010 Michel Salim <salimma@fedoraproject.org> - 1.0-0.1.b1
- - Update to 1.0 beta 1
- * Tue May 25 2010 Michel Salim <salimma@fedoraproject.org> - 0.6.6-1
- - Update to 0.6.6
- * Fri May 21 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.5-2
- - Few minor tweaks to Gareth's spec file update
- * Mon May 10 2010 Gareth Armstrong <gareth.armstrong@hp.com> - 0.6.5-1.hp
- - Update to 0.6.5
- - Initial import of python-sphinx from Fedora Rawhide for use in HP CMS
- - Enforce that Sphinx requires Python 2.4 or later via an explicit BR
- - Minor tweaks to spec file
- - Move language files to %%{_datadir}, idea borrowed from Debian's sphinx
- package
- - Deliver man pages for sphinx-build & sphinx-quickstart
- - Deliver rst documentation files to reST directory in doc sub-package
- - Add %%check section for Python2 and add BR on python-nose
- * Wed Jan 13 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.4-1
- - Update to 0.6.4
- - Fixes a problem using autodoc with pylons projects.
- * Fri Sep 4 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.3-1
- - Update to 0.6.3
- * Mon Aug 17 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.2-1
- - Update to 0.6.2 -- upstream bugfix requested inside bz#512438
- * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Fri Jun 05 2009 Luke Macken <lmacken@redhat.com> - 0.6.1-2
- - Add a patch to use our own setuptools package
- * Fri Apr 17 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
- - Update to 0.6.1
- * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Fri Jan 2 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
- - Update to 0.5.1
- * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.5-2
- - Rebuild for Python 2.6
- * Mon Nov 24 2008 Michel Salim <salimma@fedoraproject.org> - 0.5-1
- - Update to 0.5
- * Fri Oct 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.4.3-1
- - Update to 0.4.3
- * Wed Aug 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 0.4.2-1.1
- - Fix for EL-5 build.
- * Mon Aug 25 2008 Michel Salim <salimma@fedoraproject.org> - 0.4.2-1
- - Update to 0.4.2
- * Mon May 26 2008 Michel Salim <salimma@fedoraproject.org> - 0.3-1
- - Update to 0.3
- * Fri May 2 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.61950-3
- - Split documentation into subpackage
- - Exclude C files (not built by default anyway)
- * Wed Apr 16 2008 José Matos <jamatos@fc.up.pt> - 0.1.61950-2
- - Build html documentation, include it and include the rst
- documentation.
- * Thu Mar 27 2008 Michel Salim <michel.sylvan@gmail.com> 0.1.61950-1
- - Initial package
|