nant-vl.spec 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. %define nant_dir %{_datadir}/NAnt/bin
  2. Summary: A .NET based build tool
  3. Summary(ja): .NET をベースにしたビルドツール
  4. Name: nant
  5. Version: 0.90
  6. Release: 2%{?_dist_release}
  7. License: GPL v2+
  8. Group: Development/Tools
  9. URL: http://nant.sourceforge.net/
  10. Source: %{name}-%{version}-src.tar.gz
  11. BuildArch: noarch
  12. BuildRequires: mono-core
  13. BuildRequires: mono-devel
  14. BuildRequires: pkgconfig
  15. Requires: mono-core
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. %description
  20. NAnt is a .NET based build tool. In theory it is kind of like make
  21. without make's wrinkles. In practice it's a lot like Ant.
  22. %prep
  23. %setup -q
  24. %build
  25. %{__make}
  26. %install
  27. rm -rf $RPM_BUILD_ROOT
  28. mono bootstrap/NAnt.exe -f:NAnt.build install-linux -D:install.prefix=$RPM_BUILD_ROOT%{_prefix}
  29. mkdir -p $RPM_BUILD_ROOT%{_datadir}/pkgconfig
  30. mv $RPM_BUILD_ROOT%{_prefix}/lib/pkgconfig/%{name}.pc $RPM_BUILD_ROOT%{_datadir}/pkgconfig
  31. ## script nant is exist, but fix it
  32. cat << EOF > $RPM_BUILD_ROOT%{_bindir}/nant
  33. #!/bin/sh
  34. exec mono %{_datadir}/NAnt/bin/NAnt.exe "\$@"
  35. EOF
  36. %clean
  37. rm -rf $RPM_BUILD_ROOT
  38. %files
  39. %defattr(-,root,root)
  40. %doc COPYING.txt README.txt doc/*
  41. %{_bindir}/nant
  42. %{_datadir}/pkgconfig/%{name}.pc
  43. %dir %{nant_dir}
  44. %{nant_dir}/*
  45. %changelog
  46. * Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 0.90-2
  47. - rebuilt with mono-2.10.1
  48. * Tue Oct 12 2010 Shu KONNO <owa@bg.wakwak.com> 0.90-1
  49. - initial build for VineSeed