wbar-vl.spec 8.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284
  1. # -*- coding: utf-8-unix -*-
  2. %define wbarconfversion 0.5
  3. %define wbar_utilversion 1.0
  4. %if %{?_dist_release} == "vl5"
  5. #%define ttfontdir /usr/share/fonts
  6. %define ttfontdir /usr/share/fonts/TrueType-vlgothic
  7. %define vlgothic TrueType-vlgothic
  8. %endif
  9. %if %{?_dist_release} == "vl4"
  10. %define ttfontdir /usr/X11R6/lib/X11/fonts/TrueType
  11. %define vlgothic TrueType-sazanami
  12. %endif
  13. Version: 1.3.3
  14. Release: 6%{?_dist_release}
  15. Name: wbar
  16. Summary: Quick Launch Bar such as a Dock of Max OS X
  17. Summary(ja): Mac OS X の Dock のようなクイックランチャーバー
  18. Source: http://www.tecapli.com.ar/warlock/%{name}-%{version}.tbz2
  19. Source2: http://kapsi.fi/ighea/wbarconf/%{name}conf-%{wbarconfversion}.tar.gz
  20. Patch1: wbar-makefile.patch
  21. Patch2: wbar-kde-above-desk.patch
  22. ## vine
  23. Source1: wbar.desktop
  24. Source3: http://home.arcor.de/max.federle/wbarutil/downloads/%{name}_util-%{wbar_utilversion}.tar.bz2
  25. Source4: wbar_util-bytecompile.py
  26. # scripts
  27. Source12: wbar_session
  28. Source13: wbar_gen
  29. Source14: wbar_readme
  30. # icons
  31. Source20: mlterm.png
  32. Source21: urxvt.png
  33. Source22: rox-filer.png
  34. Source23: wbar_util-2.png
  35. Source24: vine-wbar.png
  36. Source25: readme.png
  37. Source26: default.png
  38. Source27: grape.png
  39. Source28: xterm.png
  40. Source29: unicode-term.png
  41. Source30: mailer.png
  42. # conf-file template
  43. Source40: dot.wbar.jp
  44. # documents
  45. Source41: vine_readme_wbar.html
  46. Source42: vine_readme_wbar.txt
  47. #Patch10: wbar-default-setting.patch
  48. Patch11: wbar_util-1.0-vine.patch
  49. #Patch12: wbar-dot-bar-default.patch
  50. Patch13: wbar-dot-bar-default2.patch
  51. Patch14: wbar-session.patch
  52. ## ja_po
  53. Source11: wbar_util-1.0-ja.po
  54. URL: http://freshmeat.net/projects/wbar/
  55. Group: User Interface/Desktops
  56. License: GPLv2
  57. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  58. BuildRequires: imlib2-devel
  59. BuildRequires: XOrg-devel
  60. BuildRequires: freetype2-devel
  61. BuildRequires: zlib-devel
  62. BuildRequires: gcc-c++
  63. BuildRequires: libstdc++34-devel
  64. BuildRequires: make
  65. BuildRequires: glibc-devel
  66. Requires: imlib2-loader
  67. %if %{?_dist_release} == "vl5"
  68. Requires: pyxdg zenity
  69. %endif
  70. ## vine
  71. Requires: %{vlgothic}
  72. ## ja_po
  73. BuildRequires: gettext
  74. %description
  75. wbar is a quick launch bar. Its fast, light and cool eye-candy.
  76. Its hacked in c++ trying to keep code as readable as possible with out
  77. sacrificing speed. It works directly on top of X to avoid going throug a lot
  78. of layers.
  79. Initially developed for Fluxbox, then tested on WindowMaker, Xfce, Gnome, etc.
  80. Since version 1.0 can run on top of desktops such as xfdesktop or nautilus
  81. with the -above-desk switch.
  82. This package contained in some wbar configuration utilityies:
  83. - wbarconf
  84. - wbar_util
  85. %description -l ja
  86. wbar は(Dock でありませんが Dock 風な)クイックランチャーバーです.
  87. 速くて,軽くて,見た目にもクールです.
  88. wbar は可能な限り可読性のあるコードの保守を試みて C++ でハックされています.
  89. with out sacrificing speed.
  90. たくさんのレイヤーを通していくのを避けるために X 上で直接的に動作します.
  91. 当初は Fluxbox に対して開発されていましたが、それから
  92. WindowMaker, Xfce, Gnome 上で試みていました。
  93. バージョン 1.0 以降、-above-desk オプションを付けることで
  94. Xfdesktop あるいは Nautilus のようなデスクトップの最前面で起動できます。
  95. このパッケージには、いくつかの wbar 環境設定ユーティリティーを同梱しています:
  96. - wbarconf
  97. - wbar_util
  98. %prep
  99. %setup -q -a 3
  100. %patch1
  101. %patch2
  102. ## vine
  103. #% patch10
  104. %patch11 -p1
  105. #%patch12 -p1
  106. %patch13 -p1
  107. ## tools
  108. %__install -m0755 %{SOURCE12} %{SOURCE13} %{SOURCE14} wbar_util/usr/local/bin/
  109. ## icons
  110. %__install -m0644 %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23} %{SOURCE24} \
  111. %{SOURCE25} %{SOURCE26} %{SOURCE27} %{SOURCE28} %{SOURCE29} %{SOURCE30} \
  112. iconpack/wbar.osx/
  113. %patch14 -p1
  114. ## ja_po
  115. %__install -d -m0755 wbar_util/opt/wbar_util/locale/ja/LC_MESSAGES
  116. %__install %{SOURCE11} wbar_util/opt/wbar_util/locale/ja/LC_MESSAGES/main.po
  117. pushd wbar_util/opt/wbar_util/locale/ja/LC_MESSAGES/
  118. msgfmt -o main.mo main.po
  119. popd
  120. %build
  121. %__make \
  122. CXXFLAGS="`imlib2-config --cflags` %{optflags}" \
  123. LDFLAGS="`imlib2-config --libs`" \
  124. PREFIX="%{_datadir}/wbar"
  125. %install
  126. %{__rm} -rf $RPM_BUILD_ROOT
  127. #% makeinstall DESTDIR=%{buildroot} PREFIX=%{_datadir}/wbar
  128. %{__make} DESTDIR=$RPM_BUILD_ROOT install
  129. ## make sybolic link to ttf font for subtitle
  130. #%if %{?_dist_release} == "vl5"
  131. #ln -sf %{ttfontdir}/TrueType-vlgothic/VL-PGothic-Regular.ttf \
  132. ln -sf %{ttfontdir}/VL-PGothic-Regular.ttf \
  133. ${RPM_BUILD_ROOT}%{_datadir}/wbar/iconpack/wbar.osx/font.ttf;
  134. #%endif
  135. #%if %{?_dist_release} == "vl4"
  136. #ln -sf %{ttfontdir}/VL-PGothic-Regular.ttf \
  137. # ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
  138. #%endif
  139. ## install Gnome menu
  140. desktop-file-install \
  141. --vendor vine \
  142. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  143. %{SOURCE1}
  144. ## install wbarconf
  145. pushd $RPM_BUILD_ROOT%{_datadir}
  146. tar zxf %{SOURCE2}
  147. popd
  148. pushd $RPM_BUILD_ROOT%{_bindir}
  149. ln -sf %{_datadir}/wbarconf/wbarconf.py wbarconf
  150. popd
  151. ## install wbar_util
  152. pushd wbar_util
  153. %__python %{SOURCE4}
  154. %__rm -f ./usr/share/wbar_util/wbar.desktop
  155. yes | DESTDIR=$RPM_BUILD_ROOT ./install.sh
  156. desktop-file-install \
  157. --vendor "vine" \
  158. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  159. $(pwd)/usr/share/applications/wbar_util.desktop
  160. popd
  161. ## install Japanese template
  162. %__install -m0644 %{SOURCE40} $RPM_BUILD_ROOT%{_datadir}/wbar/
  163. ## install Vine documents
  164. %__install -m0644 %{SOURCE41} %{SOURCE42} \
  165. $RPM_BUILD_ROOT%{_datadir}/wbar/
  166. %clean
  167. %__rm -rf "%{buildroot}"
  168. %post
  169. %{_bindir}/update-desktop-database %{_datadir}/applications || :
  170. %postun
  171. %{_bindir}/update-desktop-database %{_datadir}/applications
  172. %files
  173. %defattr(-,root,root)
  174. %doc gpl.txt AUTHORS COPYING NEWS README
  175. %{_bindir}/wbar*
  176. %dir %{_datadir}/wbar
  177. %config(noreplace) %{_datadir}/wbar/dot.wbar
  178. %{_datadir}/wbar/dot.wbar.jp
  179. %{_datadir}/wbar/vine_readme_wbar.*
  180. %dir %{_datadir}/wbar/iconpack
  181. %{_datadir}/wbar/iconpack/*.ttf
  182. %dir %{_datadir}/wbar/iconpack/wbar.*
  183. %{_datadir}/wbar/iconpack/*/*
  184. %{_datadir}/applications/*.desktop
  185. %{_datadir}/wbarconf
  186. %{_datadir}/wbar_util
  187. %changelog
  188. * Mon May 18 2009 KATO Masashi <mkato@par.odn.ne.jp> 1.3.3-6
  189. - added Requires for pyxdg (for main.py) and zenity (for warning messages)
  190. - updated wbar.desktop:
  191. - changed Icon=/usr/share/wbar/iconpack/wbar.osx/vine-wbar.png
  192. - added dot.wbar.jp
  193. - for Japanese title support
  194. - update wbar-dot-bar-default.patch:
  195. - corrected a command name (soffice -> oofice)
  196. - added some items (xterm,synaptic...etc.)
  197. - added wbar_gen (for Vine Linux):
  198. - for extracting only executable items from dot.wbar
  199. - applied wbar-session-vine.patch (for wbar_session)
  200. - generating initial user config file ('$HOME/.wbar'; by wbar_gen)
  201. - overwritable options
  202. - verification of icon-path
  203. - supported help message
  204. - setting '-above-desk' option automatically. (detecting DE or WM)
  205. * Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-5
  206. - applied wbar-dot-bar-default.patch
  207. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-4
  208. - added %%description -l ja
  209. * Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-3
  210. - added wbar_util-1.0-ja.po
  211. - added wbar_session (for Vine Linux)
  212. - updated wbar.desktop:
  213. - changed Exec=wbar_session
  214. - updated wbar_util-1.0-vine.patch:
  215. - for restarting wbar
  216. * Sun Feb 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-2
  217. - changed to Group: User Interface/Desktops
  218. - added comment[ja] in wbar.desktop
  219. - added wbar_util v1.0
  220. - applied wbar_util-1.0-vine.patch
  221. * Sat Apr 11 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.3-1
  222. - initial build
  223. * Tue Oct 23 2007 Pascal Bleser <guru@unixtech.be> 1.3.3-0.pm.2
  224. - added Requires for imlib2-loaders (for PNG support)
  225. * Fri Sep 28 2007 Pascal Bleser <guru@unixtech.be> 1.3.3-0.pm.1
  226. - new upstream version
  227. * Sun Sep 16 2007 Pascal Bleser <guru@unixtech.be> 1.3.2-0.pm.1
  228. - new package