star-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451
  1. Summary: An archiving tool with ACL support
  2. Summary(ja): An archiving tool with ACL support
  3. Name: star
  4. Version: 1.5.2
  5. Release: 1%{?_dist_release}
  6. License: CDDL
  7. Group: Applications/Archiving
  8. URL: http://cdrecord.berlios.de/old/private/star.html
  9. Source: ftp://ftp.berlios.de/pub/star/%{name}-%{version}.tar.bz2
  10. #use gcc for compilation, change defaults for Linux
  11. Patch1: star-1.5-newMake.patch
  12. #do not segfault with data-change-warn option (#255261)
  13. Patch3: star-1.5-changewarnSegv.patch
  14. #Prevent buffer overflow for filenames with length of 100 characters (#556664)
  15. Patch4: star-1.5.2-bufferoverflow.patch
  16. #Fix some invalid manpage references (#624612)
  17. Patch5: star-1.5.1-manpagereferences.patch
  18. # note that the H=crc format uses Sum32 algorithm, not CRC
  19. Patch7: star-1.5.1-crc.patch
  20. # fix man-page-day objections
  21. # ~> proposed upstream:
  22. # https://lists.berlios.de/pipermail/star-developers/2013-April/000027.html
  23. # ~> #948866
  24. Patch8: star-1.5.2-man-page-day.patch
  25. # Disable profiling on aarch64 as it's not currently supported upstream
  26. Patch9: star-aarch64.patch
  27. # Allow rmt to access all files.
  28. # ~> downstream
  29. # ~> #968980
  30. Patch10: star-1.5.2-rmt-rh-access.patch
  31. # Use ssh rather than rsh by default
  32. # ~> downstream
  33. # ~> related to #968980
  34. Patch11: star-1.5.2-use-ssh-by-default.patch
  35. BuildRequires: libattr-devel libacl-devel libtool
  36. BuildRequires: e2fsprogs-devel
  37. # Historically, star installed /usr/bin/spax binary also so we don't want to
  38. # break the compatibility. We don't care about scpio because scpio binary was
  39. # not installed.
  40. Requires: spax
  41. %description
  42. Star saves many files together into a single tape or disk archive,
  43. and can restore individual files from the archive. Star supports ACL.
  44. %package -n spax
  45. Summary: Portable archive exchange
  46. Group: Applications/Archiving
  47. Obsoletes: pax < 3.4-2
  48. Provides: pax
  49. %description -n spax
  50. The pax utility shall read and write archives, write lists of the members of
  51. archive files and copy directory hierarchies as is defined in IEEE Std 1003.1.
  52. %package -n scpio
  53. Summary: Copy file archives in and out (LEGACY)
  54. Group: Applications/Archiving
  55. %description -n scpio
  56. The scpio utility, depending on the options used: copies files to an archive
  57. file, extracts files from an archive file, lists files from an archive file or
  58. copies files from one directory tree to another.
  59. %package -n rmt
  60. Summary: Provides certain programs with access to remote tape devices
  61. Group: Applications/Archiving
  62. %description -n rmt
  63. The rmt utility provides remote access to tape devices for programs
  64. like dump (a filesystem backup program), restore (a program for
  65. restoring files from a backup), and tar (an archiving program).
  66. %prep
  67. %setup -q
  68. %patch1 -p1 -b .newMake
  69. %patch3 -p1 -b .changewarnSegv
  70. %patch4 -p1 -b .namesoverflow
  71. %patch5 -p1 -b .references
  72. %patch7 -p1 -b .crc
  73. %patch8 -p1 -b .man-page-day
  74. %patch9 -p1 -b .aarch64
  75. %patch10 -p1 -b .rmt-access-rules
  76. %patch11 -p1 -b .ssh-by-default
  77. cp -a star/all.mk star/Makefile
  78. star_recode()
  79. {
  80. for i in $@; do
  81. iconv -f iso_8859-1 -t utf-8 $i > .tmp_file
  82. mv .tmp_file $i
  83. done
  84. }
  85. star_recode AN-1.5 AN-1.5.2 star/star.4
  86. cp -a READMEs/README.linux .
  87. for PLAT in %{arm} %{power64} aarch64 x86_64 s390 s390x sh3 sh4 sh4a sparcv9; do
  88. for AFILE in gcc cc; do
  89. [ ! -e RULES/${PLAT}-linux-${AFILE}.rul ] \
  90. && ln -s i586-linux-${AFILE}.rul RULES/${PLAT}-linux-${AFILE}.rul
  91. done
  92. done
  93. %build
  94. export MAKEPROG=gmake
  95. # Autoconfiscate
  96. (cd autoconf; AC_MACRODIR=. AWK=gawk ./autoconf)
  97. #make %%{?_smp_mflags} PARCH=%%{_target_cpu} CPPOPTX="-DNO_FSYNC" \
  98. # ~~> enable debug by COPTX='-g3 -O0' LDOPTX='-g3 -O0'
  99. make %{?_smp_mflags} PARCH=%{_target_cpu} \
  100. COPTX="$RPM_OPT_FLAGS -DTRY_EXT2_FS" CC="%{__cc}" \
  101. K_ARCH=%{_target_cpu} \
  102. CONFFLAGS="%{_target_platform} --prefix=%{_prefix} \
  103. --exec-prefix=%{_exec_prefix} --bindir=%{_bindir} \
  104. --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} \
  105. --datadir=%{_datadir} --includedir=%{_includedir} \
  106. --libdir=%{_libdir} --libexec=%{_libexecdir} \
  107. --localstatedir=%{_localstatedir} --sharedstatedir=%{_sharedstatedir} \
  108. --mandir=%{_mandir} --infodir=%{_infodir}" < /dev/null
  109. %install
  110. export MAKEPROG=gmake
  111. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man4
  112. make install RPM_INSTALLDIR=${RPM_BUILD_ROOT} PARCH=%{_target_cpu} K_ARCH=%{_target_cpu} < /dev/null
  113. ln -s star.1.gz ${RPM_BUILD_ROOT}%{_mandir}/man1/ustar.1
  114. ln -s %{_sbindir}/rmt ${RPM_BUILD_ROOT}%{_sysconfdir}/rmt
  115. # compat links
  116. ln -sf spax %{buildroot}%{_bindir}/pax
  117. ln -sf spax.1.gz %{buildroot}%{_mandir}/man1/pax.1.gz
  118. # XXX Nuke unpackaged files.
  119. ( cd ${RPM_BUILD_ROOT}
  120. rm -f .%{_bindir}/mt
  121. rm -f .%{_bindir}/smt
  122. rm -f .%{_bindir}/tartest
  123. rm -f .%{_bindir}/tar
  124. rm -f .%{_bindir}/gnutar
  125. rm -f .%{_bindir}/star_fat
  126. rm -f .%{_bindir}/star_sym
  127. rm -f .%{_bindir}/suntar
  128. rm -rf .%{_docdir}/rmt
  129. rm -rf .%{_prefix}%{_sysconfdir}
  130. rm -rf .%{_prefix}/include
  131. rm -rf .%{_prefix}/lib # hard-wired intently
  132. rm -rf .%{_mandir}/man3
  133. rm -rf .%{_mandir}/man5/{makefiles,makerules}.5*
  134. rm -rf .%{_mandir}/man1/{tartest,gnutar,smt,mt,suntar,match}.1*
  135. )
  136. %clean
  137. %global general_docs README AN* COPYING CDDL.Schily.txt TODO README.linux
  138. %files
  139. %doc %{general_docs}
  140. %{_bindir}/star
  141. %{_bindir}/ustar
  142. %{_mandir}/man1/star.1*
  143. %{_mandir}/man1/ustar.1*
  144. %{_mandir}/man5/star.5*
  145. %files -n scpio
  146. %doc %{general_docs}
  147. %doc %{_mandir}/man1/scpio.1*
  148. %{_bindir}/scpio
  149. %files -n spax
  150. %doc %{general_docs}
  151. %doc %{_mandir}/man1/spax.1*
  152. %doc %{_mandir}/man1/pax.1*
  153. %{_bindir}/spax
  154. %{_bindir}/pax
  155. %files -n rmt
  156. %doc %{general_docs}
  157. %{_sbindir}/rmt
  158. %{_mandir}/man1/rmt.1*
  159. %config %{_sysconfdir}/default/rmt
  160. # This symlink is used by cpio, star, spax, scpio, .. thus it is needed. Even
  161. # if the cpio may be configured to use /sbin/rmt rather than /etc/rmt, star (and
  162. # thus spax, ..) has the lookup path hardcoded to '/etc/rmt' (it means that even
  163. # non rpm based systems will try to look for /etc/rmt). And - the conclusion is
  164. # - it does not make sense to fight against /etc/rmt symlink ATM (year 2013).
  165. %{_sysconfdir}/rmt
  166. %changelog
  167. * Tue Jun 17 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.5.2-1
  168. - initial build for Vine Linux
  169. - add Obsoletes/Provides pax to spax
  170. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2-11
  171. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  172. * Fri Jan 17 2014 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-10
  173. - enable build for ppc64le (#1054401)
  174. * Mon Jan 13 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.5.2-9
  175. - Temporarily disable profiling on aarch64
  176. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2-8
  177. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  178. * Thu Jun 20 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-7
  179. - we should provide /etc/rmt symlink for a while (related to #968980)
  180. - use the ssh as the default remote access method
  181. * Thu May 30 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-6
  182. - subpackage also 'rmt' (#968980)
  183. * Fri May 24 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-5
  184. - add missing ghost files (#960007)
  185. - fix the upgrade path, sorry for the noise (#959917, #960007)
  186. * Mon May 06 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-2
  187. - package spax and scpio separately (#959917)
  188. - fedora-review fixes, unapplied patch
  189. - make the spax to be pax alternative (#960007)
  190. * Wed Apr 10 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-1
  191. - rebase to most up2date upstream tarball, remove patches already upstream, fix
  192. code movements in patches (#928758)
  193. - fix man-page-day objections (private #948866)
  194. - fix the build for aarch64 (#926571)
  195. * Thu Mar 21 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.1-12
  196. - package also the 'scpio' utility (#771926)
  197. * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-11
  198. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  199. * Thu Oct 18 2012 Pavel Raiskup <praiskup@redhat.com> - 1.5.1-10
  200. - do not crash during extracting if extended attributes are not set on all
  201. archived files (#861848)
  202. - note in man page that H=crc format uses Sum32 algorithm (FIPS refuses CRC)
  203. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-9
  204. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  205. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-8
  206. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  207. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-7
  208. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  209. * Tue Jan 04 2011 Ondrej Vasik <ovasik@redhat.com> 1.5.1-6
  210. - fix segfault with multivol option due to signedness(#666015)
  211. * Wed Sep 29 2010 jkeating - 1.5.1-5
  212. - Rebuilt for gcc bug 634757
  213. * Tue Sep 14 2010 Ondrej Vasik <ovasik@redhat.com> 1.5.1-4
  214. - fix another instance of buffer overflow for files with
  215. long names(#632384)
  216. * Tue Aug 17 2010 Ondrej Vasik <ovasik@redhat.com> 1.5.1-3
  217. - Fix some invalid manpage references (#624612)
  218. - ship star.4 manpage with star format description
  219. * Wed Feb 03 2010 Ondrej Vasik <ovasik@redhat.com> 1.5.1-2
  220. - fix buffer overflow for files with names of length
  221. 100 chars(#556664)
  222. * Wed Jan 13 2010 Ondrej Vasik <ovasik@redhat.com> 1.5.1-1
  223. - new upstream release 1.5.1
  224. * Thu Aug 27 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-8
  225. - provide symlinked manpage for ustar
  226. * Thu Aug 27 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-7
  227. - Merge review (#226434) changes: convert AN-1.5 to utf-8,
  228. spec file cosmetic/policy changes, ship README.linux in doc
  229. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-6
  230. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  231. * Sun May 10 2009 Ville Skyttä <ville.skytta at iki.fi> - 1.5-5
  232. - Build with $RPM_OPT_FLAGS.
  233. - Convert specfile to UTF-8.
  234. * Wed Apr 08 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-4
  235. - fix build failure due to symbols conflicting
  236. with stdio(#494213)
  237. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-3
  238. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  239. * Wed Jan 28 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-2
  240. - remove names.c requirements from non-fat Makefiles,
  241. do not ship names.c (#255261 for details)
  242. * Tue Jan 27 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-1
  243. - use final instead of beta
  244. - ship missing names.c separately
  245. - enable optimalization again
  246. * Wed Dec 03 2008 Ondrej Vasik <ovasik@redhat.com> 1.5a89-1
  247. - update to latest upstream release
  248. * Fri Jun 06 2008 Dennis Gilmore <dennis@ausil.us> 1.5a84-6
  249. - add sparcv9 support
  250. * Mon May 12 2008 Peter Vrabec <pvrabec@redhat.com> 1.5a84-5
  251. - add super-H(sh3,4) architecture support (#442883)
  252. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.5a84-4
  253. - Autorebuild for GCC 4.3
  254. * Fri Aug 31 2007 Dan Kopecek <dkopecek@redhat.com> 1.5a84-3
  255. - added -O0 to COPTX (CFLAGS) (see #255261)
  256. * Mon Aug 27 2007 Peter Vrabec <pvrabec@redhat.com> 1.5a84-2
  257. - fix segfault of data-change-warn option (#255261),
  258. patch from dkopecek@redhat.com
  259. * Fri Aug 24 2007 Peter Vrabec <pvrabec@redhat.com> 1.5a84-1
  260. - new upstream release with CVE-2007-4134 fix
  261. * Sun Jun 24 2007 Peter Vrabec <pvrabec@redhat.com> 1.5a76-3
  262. - build star on ARM platforms (#245465)
  263. * Mon Jan 29 2007 Peter Vrabec <pvrabec@redhat.com> 1.5a76-2
  264. - fix buildreq. and rebuild
  265. * Thu Jan 18 2007 Jan Cholasta <grubber.x@gmail.com> 1.5a76-1
  266. - upgrade
  267. * Tue Aug 08 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a75-1
  268. - upgrade
  269. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.5a74-3.1
  270. - rebuild
  271. * Tue Jun 13 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a74-3
  272. - use autoconf provided by star
  273. * Fri Jun 02 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a74-2
  274. - update tarball
  275. * Mon Apr 24 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a74-1
  276. - upgrade
  277. * Wed Mar 22 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a73-1
  278. - upgrade
  279. * Wed Mar 01 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a72-1
  280. - upgrade
  281. * Wed Feb 22 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a71-1
  282. - upgrade
  283. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  284. - rebuilt
  285. * Tue Nov 08 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a69-1
  286. - upgrade
  287. * Mon Oct 10 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a68-1
  288. - upgrade
  289. * Thu Sep 22 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a67-1
  290. - upgrade
  291. * Fri Aug 26 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a65-1
  292. - upgrade 1.5a65-1 made by Horst H. von Brand <vonbrand@inf.utfsm.cl>
  293. - Source URL changed, no homepage now
  294. - License changed from GPL to CDDL 1.0
  295. - Define MAKEPROG=gmake like the Gmake.linux script does
  296. - Disable fat binary as per star/Makefile, update star-1.5-selinux.patch for
  297. the various *.mk files used in that case
  298. - Axe /usr/share/man/man1/match.1*, /usr/etc/default/rmt too
  299. - Explicit listing in %%files, allow for compressed or plain manpages
  300. * Fri Aug 26 2005 Peter Vrabec <pvrabec@redhat.com>
  301. - do not remove star_fat
  302. * Fri Aug 12 2005 Peter Vrabec <pvrabec@redhat.com>
  303. - upgrade 1.5a64-1
  304. * Thu Aug 04 2005 Karsten Hopp <karsten@redhat.de> 1.5a54-3
  305. - remove /usr/bin/tar symlink
  306. * Fri Mar 18 2005 Peter Vrabec <pvrabec@redhat.com>
  307. - rebuilt
  308. * Mon Nov 22 2004 Peter Vrabec <pvrabec@redhat.com>
  309. - upgrade 1.5a54-1 & rebuild
  310. * Mon Oct 25 2004 Peter Vrabec <pvrabec@redhat.com>
  311. - fix dependencie (#123770)
  312. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  313. - rebuilt
  314. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  315. - rebuilt
  316. * Mon Jan 26 2004 Dan Walsh <dwalsh@redhat.com> 1.5a25-4
  317. - Fix call to is_selinux_enabled
  318. * Mon Jan 19 2004 Jeff Johnson <jbj@jbj.org> 1.5.a25-3
  319. - fix: (!(x & 1)) rather than (!x & 1) patch.
  320. * Wed Sep 24 2003 Dan Walsh <dwalsh@redhat.com> 1.5a25-2
  321. - turn selinux off
  322. * Tue Sep 16 2003 Dan Walsh <dwalsh@redhat.com> 1.5a25-1.sel
  323. - turn selinux on
  324. * Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 1.5a18-5
  325. - turn selinux off
  326. * Mon Aug 25 2003 Dan Walsh <dwalsh@redhat.com> 1.5a18-3
  327. - Add SELinux modification to handle setting security context before creation.
  328. * Thu Aug 21 2003 Dan Walsh <dwalsh@redhat.com> 1.5a18-2
  329. - Fix free_xattr bug
  330. * Wed Jul 16 2003 Dan Walsh <dwalsh@redhat.com> 1.5a18-1
  331. - Add SELinux support
  332. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  333. - rebuilt
  334. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  335. - rebuilt
  336. * Tue Nov 12 2002 Elliot Lee <sopwith@redhat.com> 1.5a08-3
  337. - Build when uname -m != _target_platform
  338. - Use _smp_mflags
  339. - Build on x86_64
  340. * Mon Nov 11 2002 Jeff Johnson <jbj@redhat.com> 1.5a08-2
  341. - update to 1.5a08.
  342. - build from cvs.
  343. * Wed Jun 26 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.5a04
  344. - Initial build. Alpha version - it's needed for ACLs.