wpa_supplicant-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446
  1. %bcond_with systemd
  2. %bcond_with gui
  3. Summary: WPA/WPA2/IEEE 802.1X Supplicant
  4. Name: wpa_supplicant
  5. Version: 2.9
  6. Release: 5%{?_dist_release}%{?with_systemd:.systemd}
  7. Group: network,system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: BSD
  11. URL: https://w1.fi/wpa_supplicant/
  12. Source0: https://w1.fi/releases/%{name}-%{version}.tar.gz
  13. Source2: %{name}.conf
  14. Source3: %{name}.init.d
  15. Source4: %{name}.sysconfig
  16. Source6: %{name}.logrotate
  17. Source100: %{name}.service
  18. Source101: %{name}.sysconfig.systemd
  19. # distro specific customization and not suitable for upstream,
  20. # Fedora-specific updates to defconfig
  21. Patch0: wpa_supplicant-config.patch
  22. # works around busted drivers
  23. Patch1: wpa_supplicant-assoc-timeout.patch
  24. # ensures that debug output gets flushed immediately to help diagnose driver
  25. # bugs, not suitable for upstream
  26. Patch2: wpa_supplicant-flush-debug-output.patch
  27. # quiet an annoying and frequent syslog message
  28. Patch3: wpa_supplicant-quiet-scan-results-message.patch
  29. # distro specific customization for Qt4 build tools, not suitable for upstream
  30. Patch4: wpa_supplicant-gui-qt4.patch
  31. # fix AP mode PMF disconnection protection bypass
  32. Patch5: 0001-AP-Silently-ignore-management-frame-from-unexpected-.patch
  33. # fix some issues with P2P operation
  34. Patch6: 0001-P2P-Always-use-global-p2p_long_listen.patch
  35. Patch7: 0001-D-Bus-Fix-P2P-NULL-dereference-after-interface-remov.patch
  36. Patch8: 0001-p2p-Limit-P2P_DEVICE-name-to-appropriate-ifname-size.patch
  37. #fix for bz1915236
  38. Patch9: 0001-D-Bus-Allow-changing-an-interface-bridge-via-D-Bus.patch
  39. #expose OWE capability in D-Bus
  40. Patch10: 0001-dbus-Export-OWE-capability-and-OWE-BSS-key_mgmt.patch
  41. # CVE-2021-0326
  42. Patch11: 0001-P2P-Fix-copying-of-secondary-device-types-for-P2P-gr.patch
  43. # CVE-2021-27803
  44. Patch12: 0001-P2P-Fix-a-corner-case-in-peer-addition-based-on-PD-R.patch
  45. # CVE-2021-30004
  46. Patch13: 0001-ASN-1-Validate-DigestAlgorithmIdentifier-parameters.patch
  47. # fix for 802.11r networks, and cards that don't support it
  48. Patch14: 0001-Check-for-FT-support-when-selecting-FT-suites.patch
  49. #fix nmci failures with OpenSSL-3.0.0
  50. Patch15: 0001-OpenSSL-Allow-systemwide-secpolicy-overrides-for-TLS.patch
  51. Patch16: 0001-EAP-TTLS-PEAP-peer-Fix-failure-when-using-session-ti.patch
  52. Patch17: 0001-openssl-Disable-padding-after-initializing-the-ciphe.patch
  53. Patch18: 0001-openssl-Remove-deprecated-functions-from-des_encrypt.patch
  54. ## Vine patches
  55. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  56. %if %{with gui}
  57. BuildRequires: qt4-devel
  58. %endif
  59. BuildRequires: openssl-devel
  60. BuildRequires: readline-devel
  61. BuildRequires: dbus-devel
  62. BuildRequires: libnl3-devel
  63. BuildRequires: docbook-utils
  64. %if %{with systemd}
  65. %{?systemd_requires}
  66. %else
  67. Requires(post): /sbin/chkconfig
  68. Requires(preun): /sbin/chkconfig /sbin/service
  69. Requires(postun): /sbin/service
  70. %endif
  71. %description
  72. wpa_supplicant is a WPA Supplicant for Linux, BSD and Windows with support
  73. for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA
  74. component that is used in the client stations. It implements key negotiation
  75. with a WPA Authenticator and it controls the roaming and IEEE 802.11
  76. authentication/association of the wlan driver.
  77. %if %{with gui}
  78. %package gui
  79. Summary: Graphical User Interface for %{name}
  80. Summary(ja): %{name} のグラフィカルユーザインタフェース
  81. Group: admin-tools,network
  82. %description gui
  83. Graphical User Interface for wpa_supplicant written using QT4
  84. %description -l ja gui
  85. QT4 を用いた wpa_supplicant のグラフィカルユーザインタフェース
  86. %endif
  87. %debug_package
  88. %prep
  89. %setup -q
  90. %autopatch -p1
  91. %build
  92. pushd wpa_supplicant
  93. cp defconfig .config
  94. export CFLAGS="${CFLAGS:-%optflags} -fPIE -DPIE"
  95. export CXXFLAGS="${CXXFLAGS:-%optflags} -fPIE -DPIE"
  96. export LDFLAGS="${LDFLAGS:-%optflags} -pie -Wl,-z,now"
  97. # yes, BINDIR=_sbindir
  98. export BINDIR="%{_sbindir}"
  99. export LIBDIR="%{_libdir}"
  100. make %{_smp_mflags} V=1
  101. %if %{with gui}
  102. make wpa_gui-qt4 %{_smp_mflags} V=1 QTDIR=%{_libdir}/qt4
  103. %endif
  104. make eapol_test
  105. popd
  106. %install
  107. rm -rf %{buildroot}
  108. %if %{with systemd}
  109. # systemd unit
  110. install -D -m 0644 %{SOURCE100} %{buildroot}%{_unitdir}/%{name}.service
  111. install -D -m 0644 %{SOURCE101} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  112. %else
  113. # init scripts
  114. install -D -m 0755 %{SOURCE3} %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
  115. install -D -m 0644 %{SOURCE4} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  116. %endif
  117. # logrotate
  118. install -D -m 0644 %{SOURCE6} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  119. # config
  120. install -D -m 0600 %{SOURCE2} %{buildroot}%{_sysconfdir}/%{name}/%{name}.conf
  121. # binary
  122. install -d %{buildroot}/%{_sbindir}
  123. install -m 0755 %{name}/wpa_passphrase %{buildroot}/%{_sbindir}
  124. install -m 0755 %{name}/wpa_cli %{buildroot}/%{_sbindir}
  125. install -m 0755 %{name}/wpa_supplicant %{buildroot}/%{_sbindir}
  126. install -m 0755 wpa_supplicant/eapol_test %{buildroot}/%{_sbindir}
  127. install -D -m 0644 %{name}/dbus/dbus-wpa_supplicant.conf \
  128. %{buildroot}/%{_sysconfdir}/dbus-1/system.d/wpa_supplicant.conf
  129. install -D -m 0644 %{name}/dbus/fi.w1.wpa_supplicant1.service \
  130. %{buildroot}/%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
  131. %if %{with gui}
  132. # gui
  133. install -d %{buildroot}/%{_bindir}
  134. install -m 0755 %{name}/wpa_gui-qt4/wpa_gui %{buildroot}/%{_bindir}
  135. %endif
  136. # running
  137. mkdir -p %{buildroot}/%{_localstatedir}/run/%{name}
  138. # man pages
  139. install -d %{buildroot}%{_mandir}/man{5,8}
  140. install -m 0644 %{name}/doc/docbook/*.8 %{buildroot}%{_mandir}/man8
  141. install -m 0644 %{name}/doc/docbook/*.5 %{buildroot}%{_mandir}/man5
  142. # some cleanup in docs
  143. rm -f %{name}/doc/.cvsignore
  144. rm -rf %{name}/doc/docbook
  145. chmod -R 0644 %{name}/examples/*.py
  146. %clean
  147. rm -rf %{buildroot}
  148. %post
  149. %if %{with systemd}
  150. %systemd_post wpa_supplicant.service
  151. %else
  152. if [ $1 = 1 ]; then
  153. /sbin/chkconfig --add %{name}
  154. fi
  155. %endif
  156. %preun
  157. %if %{with systemd}
  158. %systemd_preun wpa_supplicant.service
  159. %else
  160. if [ $1 = 0 -o -x /bin/systemctl ]; then
  161. /sbin/service %{name} stop > /dev/null 2>&1 ||:
  162. killall -TERM wpa_supplicant >/dev/null 2>&1 || :
  163. /sbin/chkconfig --del %{name}
  164. fi
  165. %endif
  166. %postun
  167. %if %{with systemd}
  168. %systemd_postun_with_restart wpa_supplicant.service
  169. %else
  170. if [ $1 -ge 1 ]; then
  171. /sbin/service %{name} condrestart > /dev/null 2>&1 ||:
  172. fi
  173. %endif
  174. %files
  175. %defattr(-, root, root)
  176. %license COPYING
  177. %doc %{name}/ChangeLog README %{name}/eap_testing.txt %{name}/todo.txt %{name}/wpa_supplicant.conf %{name}/examples
  178. %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
  179. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  180. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  181. %if %{with systemd}
  182. %{_unitdir}/%{name}.service
  183. %else
  184. %{_sysconfdir}/rc.d/init.d/%{name}
  185. %endif
  186. %{_sysconfdir}/dbus-1/system.d/%{name}.conf
  187. %{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
  188. %{_sbindir}/wpa_passphrase
  189. %{_sbindir}/wpa_supplicant
  190. %{_sbindir}/wpa_cli
  191. %{_sbindir}/eapol_test
  192. %dir %{_localstatedir}/run/%{name}
  193. %dir %{_sysconfdir}/%{name}
  194. %{_mandir}/man8/*
  195. %{_mandir}/man5/*
  196. %if %{with gui}
  197. %files gui
  198. %defattr(-, root, root)
  199. %{_bindir}/wpa_gui
  200. %endif
  201. %changelog
  202. * Mon Oct 18 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.9-5
  203. - built with openssl-3.0.0.
  204. - imported Patch14-18 from rawhide.
  205. * Sat Apr 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.9-4
  206. - imported Patch13 from upstream to fox CVE-2021-30004.
  207. * Sat Mar 06 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.9-3
  208. - imported Patch11 from upstream to fix CVE-2021-0326.
  209. - imported Patch12 from upstream to fix CVE-2021-27803.
  210. * Mon Mar 01 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.9-2
  211. - diasabled gui as default.
  212. - added systemd support (disabled as default).
  213. - replaced all patches to rawhide's.
  214. * Tue Mar 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.9-1
  215. - new upstream release.
  216. - replaced all patches to rawhide's.
  217. * Tue Nov 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.6-2
  218. - rebuilt with openssl-1.1.1.
  219. - imported Patch62-64 from rawhide.
  220. * Sat Mar 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.6-1
  221. - updated to 2.6.
  222. - imported Patch9-60 from rawhide.
  223. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.5-3
  224. - rebuilt with new toolchain.
  225. * Tue Mar 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.5-2
  226. - rebuild with openssl-1.0.2g
  227. * Thu Oct 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.5-1
  228. - update to 2.5
  229. - update SOURCE1
  230. - remove Patch7 (libnl3-includes.patch)
  231. - add Patch 9,10,11 from Fedora
  232. - remove Patch 6, 700
  233. * Thu Feb 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.3-1
  234. - updated to 2.3
  235. - built with libnl3 instead of libnl
  236. - added Patch 6, 7 and 8 from Fedora
  237. - added Patch700
  238. * Mon Aug 22 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.3-3
  239. - import Patch8 from Fedora 1:0.7.3-9 to fix some crashes
  240. - Wed Jul 27 2011 Dan Williams <dcbw@redhat.com> - 1:0.7.3-9
  241. - Fix various crashes with D-Bus interface (rh #678625) (rh #725517)
  242. * Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
  243. - rebuild with openssl-1.0.0c
  244. - add BuildRequires: qt4-designer, libnl-devel
  245. * Thu Jan 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-1
  246. - new upstream release
  247. - update patches
  248. - change License to BSD due to linkage against OpsnSSL since there is no
  249. OpenSSL exception in upstream GPLv2 license text.
  250. - build with qt4
  251. - update build config
  252. * Wed Jan 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.4-1
  253. - new upstream release
  254. - remove hostap/madwifi/prism54 drivers, use 'wext' instead.
  255. - drop upstream patches
  256. - import some fedora patches
  257. - Handle encryption keys correctly when switching 802.11 modes (rh #459399)
  258. - Better scanning behavior on resume from suspend/hibernate
  259. - Better interaction with newer kernels and drivers
  260. * Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-2
  261. - start wpa_supplicant by default.
  262. * Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
  263. - new upstream release
  264. - import some fedora patches
  265. * Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
  266. - rebuild with new openssl
  267. * Mon May 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
  268. - new upstream release
  269. * Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
  270. - initial build for Vine Linux based on FC package.
  271. * Thu Apr 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-10
  272. - Add fix for madwifi and WEP (wpa_supplicant/hostap bud #140) (#rh190075#)
  273. - Fix up madwifi-ng private ioctl()s for r1331 and later
  274. - Update madwifi headers to r1475
  275. * Tue Apr 25 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-9
  276. - Enable Wired driver, PKCS12, and Smartcard options (#rh189805#)
  277. * Tue Apr 11 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-8
  278. - Fix control interface key obfuscation a bit
  279. * Sun Apr 2 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-7
  280. - Work around older & incorrect drivers that return null-terminated SSIDs
  281. * Mon Mar 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-6
  282. - Add patch to make orinoco happy with WEP keys
  283. - Enable Prism54-specific driver
  284. - Disable ipw-specific driver; ipw2x00 should be using WEXT instead
  285. * Fri Mar 3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-5
  286. - Increase association timeout, mainly for drivers that don't
  287. fully support WPA ioctls yet
  288. * Fri Mar 3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-4
  289. - Add additional BuildRequires #rh181914#
  290. - Add prereq on chkconfig #rh182905# #rh182906#
  291. - Own /var/run/wpa_supplicant and /etc/wpa_supplicant #rh183696#
  292. * Wed Mar 1 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-3
  293. - Install wpa_passphrase too #rh183480#
  294. * Mon Feb 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-2
  295. - Don't expose private data on the control interface unless requested
  296. * Fri Feb 24 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-1
  297. - Downgrade to 0.4.8 stable release rather than a dev release
  298. * Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-3
  299. - Documentation cleanup (Terje Rosten <terje.rosten@ntnu.no>)
  300. * Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-2
  301. - Move initscript to /etc/rc.d/init.d
  302. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.2
  303. - bump again for double-long bug on ppc(64)
  304. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.1
  305. - rebuilt for new gcc4.1 snapshot and glibc changes
  306. * Sun Feb 5 2006 Dan Williams <dcbw@redhat.com> 0.5.1-1
  307. - Update to 0.5.1
  308. - Add WE auth fallback to actually work with older drivers
  309. * Thu Jan 26 2006 Dan Williams <dcbw@redhat.com> 0.4.7-2
  310. - Bring package into Fedora Core
  311. - Add ap_scan control interface patch
  312. - Enable madwifi-ng driver
  313. * Sun Jan 15 2006 Douglas E. Warner <silfreed@silfreed.net> 0.4.7-1
  314. - upgrade to 0.4.7
  315. - added package w/ wpa_gui in it
  316. * Mon Nov 14 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.6-1
  317. - upgrade to 0.4.6
  318. - adding ctrl interface changes recommended
  319. by Hugo Paredes <hugo.paredes@e-know.org>
  320. * Sun Oct 9 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.5-1
  321. - upgrade to 0.4.5
  322. - updated config file wpa_supplicant is built with
  323. especially, the ipw2100 driver changed to just ipw
  324. and enabled a bunch more EAP
  325. - disabled dist tag
  326. * Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-3
  327. - fix typo in init script
  328. * Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-2
  329. - fixing init script using fedora-extras' template
  330. - removing chkconfig default startup
  331. * Tue Jun 21 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-1
  332. - upgrade to 0.4.2
  333. - new sample conf file that will use any unrestricted AP
  334. - make sysconfig config entry
  335. - new BuildRoot for Fedora Extras
  336. - adding dist tag to Release
  337. * Fri May 06 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.8-1
  338. - upgrade to 0.3.8
  339. * Thu Feb 10 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-2
  340. - compile ipw driver in
  341. * Wed Feb 09 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-1
  342. - upgrade to 0.3.6
  343. * Thu Dec 23 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-4
  344. - fixing init script
  345. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-3
  346. - fixing init script
  347. - adding post/preun items to add/remove via chkconfig
  348. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-2
  349. - adding sysV scripts
  350. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-1
  351. - Initial RPM release.