asymptote-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define texmf %{_datadir}/texmf
  4. %define build_texmf %{buildroot}%{texmf}
  5. %define exec_texhash [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
  6. %define emacspkg asy-mode
  7. Name: asymptote
  8. Version: 2.10
  9. Release: 1%{?_dist_release}
  10. Summary: Descriptive vector graphics language
  11. Summary(ja): MetaPost に触発されたスクリプトベースのベクターグラフィック言語
  12. Group: Applications/Publishing
  13. License: GPLv3+
  14. URL: http://asymptote.sourceforge.net/
  15. Source0: http://dl.sourceforge.net/sourceforge/asymptote/asymptote-%{version}.src.tgz
  16. Source1: asy.gif
  17. Source2: xasy.desktop
  18. #Source3: asymptote.sty.204
  19. Source11: %{emacspkg}-install.sh
  20. Source12: %{emacspkg}-remove.sh
  21. #Source13: %{name}-init.el
  22. #Patch0: asymptote-2.00-settings.patch
  23. Patch0: asymptote-2.00-settings-vine.patch
  24. Patch1: asymptote-1.63-gcc44.patch
  25. Patch2: asymptote-1.91-fix-implicit-DSO-linking-libGL.patch
  26. # This doesn't need to go upstream. We put the info file in the topdir, not a subdir, so we need this fix.
  27. Patch3: asymptote-2.08-info-path-fix.patch
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. BuildRequires: ncurses-devel
  30. BuildRequires: readline-devel
  31. BuildRequires: fftw3-devel >= 3.0
  32. BuildRequires: gc-devel >= 6.8
  33. BuildRequires: gsl-devel
  34. BuildRequires: texlive-common
  35. BuildRequires: texlive-collection-texinfo
  36. BuildRequires: texlive-collection-genericrecommended
  37. BuildRequires: ghostscript
  38. BuildRequires: texinfo
  39. BuildRequires: ImageMagick
  40. BuildRequires: desktop-file-utils
  41. BuildRequires: freeglut-devel
  42. BuildRequires: zlib-devel
  43. BuildRequires: libtool
  44. Requires: texlive-common
  45. Requires(post): desktop-file-utils
  46. Requires(postun): desktop-file-utils
  47. # for /usr/bin/texhash and /sbin/install-info
  48. Requires(post): texlive, info
  49. Requires(postun): texlive, info
  50. %define texpkgdir %{texmf}/tex/latex/%{name}
  51. %description
  52. Asymptote is a powerful descriptive vector graphics language for technical
  53. drawings, inspired by MetaPost but with an improved C++-like syntax.
  54. Asymptote provides for figures the same high-quality level of typesetting
  55. that LaTeX does for scientific text.
  56. This package is custmized for Japanese.
  57. - added eplatex, platex to latex engines
  58. - use pdvips as dvips command
  59. %description -l ja
  60. Asymptote は MetaPost に触発されているが,C++ のような構文に改良された,
  61. テクニカルな図面のための強力な記述ベクターグラフィックス言語です.
  62. Asymptote は科学的なテキストに対して LaTeX がしている組版のと
  63. 同じくらい高品質なレベルの図を提供します.
  64. このパッケージは日本語向けにカスタマイズされています.
  65. - latex エンジンに eplatex, platex を追加
  66. - dvips コマンドとして pdvips を使う
  67. %package gui
  68. Summary: A graphical interface for Asymptote
  69. Summary(ja): Asymptote のためのグラフィカルインターフェース
  70. Group: Applications/Graphics
  71. Requires: %{name} = %{version}-%{release}
  72. Requires: tkinter
  73. Requires: python-imaging
  74. BuildArch: noarch
  75. %description gui
  76. A graphical interface for Asymptote
  77. %package -n %{emacspkg}
  78. Summary: Emacs mode for editing Asymptote source code
  79. Summary(ja): Asymptote ソースコードを編集するための Emacs モード
  80. Group: Applications/Editors/Emacs
  81. Requires: %{name} = %{version}-%{release}
  82. BuildRequires: emacsen
  83. %prereq_ge emacsen-common
  84. BuildArch: noarch
  85. %description -n %{emacspkg}
  86. Emacs mode for editing Asymptote source code
  87. %prep
  88. %setup -q
  89. %patch0 -p1 -b .settings
  90. %patch1 -p1 -b .gcc44
  91. %patch2 -p1 -b .DSO
  92. %patch3 -p1 -b .path-fix
  93. %{__sed} -i 's/\r//' doc/CAD1.asy
  94. # convert to UTF-8
  95. iconv -f iso-8859-1 -t utf-8 -o examples/interpolate1.asy{.utf8,}
  96. %__mv examples/interpolate1.asy{.utf8,}
  97. autoreconf -i
  98. %build
  99. %configure \
  100. --enable-gc=system \
  101. --with-docdir=%{_defaultdocdir}/%{name}-%{version}/ \
  102. --with-latex=%{texmf}/tex/latex \
  103. --with-context=%{texmf}/tex/context \
  104. ;
  105. %__make %{?_smp_mflags}
  106. cd doc/
  107. %__make asy-latex.pdf
  108. %__make all
  109. %install
  110. %__rm -rf $RPM_BUILD_ROOT
  111. %__make install DESTDIR=%{buildroot} mandir=%{buildroot}%{_mandir}
  112. %__install -p -m 644 BUGS ChangeLog LICENSE README ReleaseNotes TODO \
  113. $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-%{version}/
  114. # # Vim syntax file
  115. # for vimver in 63 64 70 71 ; do
  116. # install -dm 755 $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
  117. # cd $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
  118. # ln -s ../../../%{name}/asy.vim .
  119. # done
  120. # Move info file
  121. %__mv %{buildroot}%{_infodir}/asymptote/asymptote.info %{buildroot}%{_infodir}/asymptote.info
  122. # copy icon to pixmaps dir
  123. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
  124. %__cp %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/pixmaps/
  125. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
  126. desktop-file-install --vendor "vine" \
  127. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  128. %{SOURCE2}
  129. # Clean up symlink
  130. %__rm -rf $RPM_BUILD_ROOT%{_bindir}/xasy
  131. cd $RPM_BUILD_ROOT%{_bindir}
  132. %__ln_s ../share/%{name}/GUI/xasy.py xasy
  133. ## <asy-mode>
  134. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}
  135. %__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
  136. %__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
  137. #
  138. # install el files
  139. #
  140. # install -dm 755 $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
  141. # cd $RPM_BUILD_ROOT%{emacs_sitelisp}
  142. # ln -s ../../%{name}/asy-{mode,keywords}.el .
  143. # cd $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
  144. # ln -s ../../../%{name}/asy-init.el .
  145. %__mv $RPM_BUILD_ROOT%{_datadir}/%{name}/asy-{init,mode,keywords}.el \
  146. $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}/
  147. #
  148. # install script (bytecompile el and install elc, remove)
  149. #
  150. %_installemacsenscript %{name} %{SOURCE11}
  151. %_removeemacsenscript %{name} %{SOURCE12}
  152. ## </asy-mode>
  153. %clean
  154. %__rm -rf $RPM_BUILD_ROOT
  155. %post
  156. /sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir 2>/dev/null || :
  157. /sbin/install-info %{_infodir}/asy-faq.info.gz %{_infodir}/dir 2>/dev/null || :
  158. %{exec_texhash}
  159. %post -n %{emacspkg}
  160. if [ "$1" = 2 ]; then
  161. %_emacsenPackageRemove %{name}
  162. fi
  163. %_addemacsenlist %{name}
  164. %_emacsenPackageInstall %{name}
  165. %postun
  166. if [ $1 = 0 ]; then
  167. /sbin/install-info --delete %{name} %{_infodir}/dir 2>/dev/null || :
  168. /sbin/install-info --delete asy-faq %{_infodir}/dir 2>/dev/null || :
  169. %{exec_texhash}
  170. fi
  171. %preun -n %{emacspkg}
  172. if [ "$1" = 0 ]; then
  173. %_emacsenPackageRemove %{name}
  174. %_removeemacsenlist %{name}
  175. fi
  176. %files
  177. %defattr(-,root,root,-)
  178. %doc %{_defaultdocdir}/%{name}-%{version}/
  179. %{_bindir}/asy
  180. %{_datadir}/%{name}/
  181. %exclude %{_datadir}/asymptote/GUI/
  182. %{texpkgdir}/
  183. %{texmf}/tex/context/
  184. %{_mandir}/man1/*.1*
  185. %{_infodir}/*.info*
  186. ##%{_datadir}/vim/vim*/syntax/asy.vim
  187. %files gui
  188. %{_bindir}/xasy
  189. %{_datadir}/applications/vine-xasy.desktop
  190. %{_datadir}/pixmaps/asy.gif
  191. %{_datadir}/asymptote/GUI/
  192. %{_mandir}/man*/xasy.*
  193. %files -n %{emacspkg}
  194. %defattr(-,root,root)
  195. %{_datadir}/emacs/site-lisp/%{name}
  196. %{_prefix}/lib/emacsen-common/packages/install/%{name}
  197. %{_prefix}/lib/emacsen-common/packages/remove/%{name}
  198. %changelog
  199. * Sat Jun 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 2.10-1
  200. - new upstream release
  201. * Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.70-5
  202. - TeX Live 2009
  203. * Tue Feb 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.70-4
  204. - rebuilt with new toolchain, libsigsegv-2.8
  205. - appled Patch1 again
  206. * Tue Jun 16 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.70-3
  207. - don't apply Patch1 until gcc44 comes to VineSeed
  208. * Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-2
  209. - separated Xasy to gui subpackage
  210. * Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-1
  211. - initial build based on Fedora Development (fc11) package
  212. - applied asymptote-1.70-settings-vine.patch
  213. * Mon Apr 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.70-1
  214. - update to 1.70
  215. * Tue Apr 7 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.69-1
  216. - update to 1.69
  217. * Wed Mar 25 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.68-1
  218. - update to 1.68
  219. * Thu Mar 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.67-1
  220. - update to 1.67
  221. * Fri Feb 27 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.66-1
  222. - update to 1.66
  223. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.63-5
  224. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  225. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-4
  226. - more gcc44 fixes with BIG_ENDIAN platforms
  227. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-3
  228. - fix gcc44 issue with BIG_ENDIAN platforms
  229. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-2
  230. - forgot to put in new source
  231. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-1
  232. - 1.63
  233. * Fri Jan 30 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.60-1
  234. - 1.60
  235. * Mon Jan 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.59-1
  236. - 1.59
  237. * Mon Jan 12 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.58-1
  238. - 1.58
  239. * Mon Dec 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.57-1
  240. - 1.57
  241. * Tue Dec 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.56-1
  242. - 1.56
  243. * Tue Dec 2 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.54-1
  244. - 1.54
  245. * Tue Nov 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.52-1
  246. - 1.52
  247. * Tue Nov 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.51-1
  248. - update to 1.51
  249. * Mon Nov 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.49-1
  250. - update to 1.49
  251. * Sun Oct 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.47-1
  252. - update to 1.47
  253. * Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.46-1
  254. - update to 1.46
  255. * Mon Oct 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-2
  256. - add missing BuildRequires
  257. * Mon Oct 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-1
  258. - update to 1.44
  259. * Fri Jun 13 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.43-1
  260. - update to 1.43
  261. * Fri Apr 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-3
  262. - explicitly call "make asymptote.pdf" in doc/
  263. * Fri Apr 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-2
  264. - fix build failure (use _POSIX_ARG_MAX) resolves bz 440799
  265. * Thu Feb 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-1
  266. - update to 1.42
  267. * Wed Feb 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.41-1
  268. - update to 1.41
  269. - enable desktop file for xasy
  270. * Thu Jan 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.37-1
  271. - bump to 1.37
  272. - fix gcc43 failures
  273. - drop triggers
  274. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - sh: kpsewhich: command not found
  275. - Rebuild for selinux ppc32 issue.
  276. * Sun Jul 29 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.33-1
  277. - Update 1.33.
  278. * Sat Jun 30 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.32-1
  279. - Update to 1.32.
  280. - vim-common triggers: correction and improvements (#246131).
  281. * Wed Jun 27 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.31-1
  282. - Update to 1.31.
  283. * Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.30-1
  284. - Update to 1.30.
  285. * Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-3
  286. - Using "evince" as the default PS and PDF viewers (#244151).
  287. (patch file: asymptote-1.29-settings.patch)
  288. - Use relative symbolic links in the {emacs,xemacs}-common triggers (#155750).
  289. - Use relative symbolic links in the vim-common triggers.
  290. * Sat Jun 2 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-2
  291. - Add asy-faq to install-info (#155750).
  292. - Add support for vim 7.1.
  293. * Mon May 21 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-1
  294. - Update to 1.29.
  295. * Tue May 8 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.28-1
  296. - Update to 1.28.
  297. * Sat May 5 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.27-1
  298. - Update to 1.27.
  299. * Wed Apr 25 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.26-1
  300. - Update to 1.26.
  301. * Tue Apr 10 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.25-1
  302. - Update to 1.25.
  303. * Sun Apr 1 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.24-1
  304. - Update to 1.24.
  305. * Sun Mar 11 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.23-1
  306. - Update to 1.23.
  307. * Tue Mar 6 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.22-1
  308. - Update to 1.22.
  309. * Sat Mar 3 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.21-1
  310. - Update to 1.21.
  311. * Fri Dec 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.20-1
  312. - Update to 1.20.
  313. * Sat Dec 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.19-1
  314. - Update to 1.19.
  315. * Sun Nov 5 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.18-1
  316. - Update to 1.18.
  317. * Wed Nov 1 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.17-1
  318. - Update to 1.17.
  319. * Wed Oct 25 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.16-1
  320. - Update to 1.16.
  321. * Sun Oct 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.15-1
  322. - Update to 1.15.
  323. * Wed Sep 6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.13-1
  324. - Update to 1.13.
  325. * Thu Aug 3 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-1
  326. - Update to 1.12.
  327. * Thu Jul 6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.11-1
  328. - Update to 1.11.
  329. * Wed Jun 28 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.10-1
  330. - Update to 1.10.
  331. * Fri Jun 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.09-1
  332. - Update to 1.09.
  333. * Thu Jun 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.08-1
  334. - Update to 1.08.
  335. - Also installs the info file.
  336. * Mon May 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-5
  337. - Fedora Core 6: the texinfo package has been splitted (texinfo + texinfo-tex).
  338. * Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-4
  339. - Group: Development/Tools -> Applications/Publishing (#193154).
  340. * Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-3
  341. - Emacs/Xemacs init file (#193154 comment 6).
  342. * Fri May 26 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-2
  343. - Directories ownership (#193154).
  344. * Wed May 24 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-1
  345. - Update to 1.06.
  346. - Using triggers to install the Vim syntax file and the Emacs/Xemacs mode file.
  347. * Mon May 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.05-1
  348. - Update to 1.05.
  349. * Sun May 7 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.04-1
  350. - Update to 1.04.
  351. * Fri Mar 31 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.03-1
  352. - Update to 1.03.
  353. * Thu Mar 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.02-1
  354. - First build.
  355. # vim:set ai ts=4 sw=4 sts=4 et: