texlive-collection-documentation-czechslovak-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187
  1. ## -*- coding: utf-8-unix -*-
  2. ## NOTE: This spec file is generated by tlpdb2rpmspec 2009-3:
  3. ## tlpdb2rpmspec collection-documentation-czechslovak
  4. %bcond_with firstbuild
  5. %define tex_destdir %{_datadir}
  6. %define texmf %{tex_destdir}/texmf
  7. %define texlive_src %{tex_destdir}/texlive-sources
  8. %define build_tex_destdir %{buildroot}%{tex_destdir}
  9. %define build_texmf %{buildroot}%{texmf}
  10. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  11. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  12. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
  13. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
  14. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  15. %define vartexfonts %{_var}/lib/texmf
  16. %define __find_provides %{nil}
  17. %define __find_requires %{nil}
  18. %define __perl_provides %{nil}
  19. %define __perl_requires %{nil}
  20. Autoreq: 0
  21. Summary: TeX Live: Czech/Slovak documentation
  22. Summary(ja): TeX Live: Czech/Slovak documentation
  23. Name: texlive-collection-documentation-czechslovak
  24. Version: 2009
  25. Release: 3%{?_dist_release}
  26. License: LPPL
  27. Group: Applications/Publishing
  28. URL:http://www.tug.org/texlive/
  29. Requires: texlive = %{version}
  30. Requires(post): texlive = %{version}
  31. Requires(postun): texlive = %{version}
  32. BuildRequires: texlive-sources = %{version}
  33. BuildArch: noarch
  34. Buildroot: %{_tmppath}/%{name}-%{version}-root
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. Packager: munepi
  38. %description
  39. The TeX Live software distribution offers a complete TeX system for a
  40. variety of Unix, Macintosh, Windows and other platforms. It
  41. encompasses programs for editing, typesetting, previewing and printing
  42. of TeX documents in many different languages, and a large collection
  43. of TeX macros and font libraries.
  44. The distribution includes extensive general documentation about TeX,
  45. as well as the documentation for the included software packages.
  46. This package is a collection of Czech/Slovak documentation:
  47. This package contains the following CTAN packages:
  48. lshort-slovak: Slovak introduction to LaTeX.
  49. texlive-cz: TeX Live manual (Czech/Slovak)
  50. %description -l ja
  51. TeX Live ソフトウェアディストリビューションは、
  52. さまざまな Unix, Macintosh, Windows、および
  53. 他のプラットホームに対して完全な TeX システムを提供します。
  54. 多くの異なった言語を含む TeX ドキュメントの
  55. 編集、組版、閲覧、印刷するためのプログラム、
  56. そして、TeX マクロやフォントライブラリの大きなコレクションを
  57. 同梱しています。
  58. このディストリビューションは
  59. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  60. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  61. このパッケージは以下のようなパッケージ集です。
  62. Czech/Slovak documentation:
  63. このパッケージは以下の CTAN パッケージを含んでいます:
  64. lshort-slovak: Slovak introduction to LaTeX.
  65. texlive-cz: TeX Live manual (Czech/Slovak)
  66. %prep
  67. %build
  68. %install
  69. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  70. PREF=%{buildroot}%{tex_destdir}
  71. manifest=(
  72. texmf-dist/doc/latex/lshort-slovak/slshorte.pdf
  73. texmf-dist/doc/latex/lshort-slovak/src.zip
  74. )
  75. %__mkdir_p ${PREF}/texmf-dist
  76. for i in "${manifest[@]}"; do
  77. %__install -D %{texlive_src}/$i ${PREF}/$i
  78. done
  79. ## info
  80. %__rm -f %{buildroot}%{_infodir}/dir
  81. %__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
  82. ## man
  83. ## man t1* files are provided by t1utils
  84. for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
  85. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  86. done
  87. ## man some files are provided by psutils
  88. for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
  89. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  90. done
  91. ## fix perl path
  92. for i in source/metapost/expressg/expressg.dtx \
  93. doc/metapost/expressg/n2mpsprl.prl \
  94. doc/latex/songbook/contrib/crd2sb/crd2sb; do
  95. [ -f %{build_texmf}-dist/${i} ] && \
  96. %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
  97. done
  98. ## remove asymptote directries, which provides asymptote package
  99. find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
  100. # find %{buildroot} -name "Makefile" | xargs %__rm -f
  101. # ## remove xindy
  102. # find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
  103. # ## remove tex4ht
  104. # find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
  105. ## remove arch dependent binaries
  106. %__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
  107. ## remove unpackaging files
  108. find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
  109. find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
  110. ## Files list
  111. find %{buildroot} -type f -or -type l | \
  112. %__sed -e "s|%{buildroot}||g" > filelist.full
  113. find %{buildroot}%{texmf}-dist -type d | \
  114. %__sed -e "s|^%{buildroot}|%dir |" \
  115. -e "s|$|/|" >> filelist.full
  116. %clean
  117. %__rm -rf %{buildroot}
  118. %post
  119. %{exec_texhash}
  120. exit 0
  121. %postun
  122. if [ "$1" = 0 ]; then
  123. %{exec_texhash}
  124. fi
  125. exit 0
  126. %files -f filelist.full
  127. %defattr(-,root,root)
  128. %changelog
  129. * Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  130. - generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-documentation-czechslovak
  131. - improved %%post
  132. * Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  133. - generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-documentation-czechslovak
  134. - removed arch dependent binaries (texlive-collection-latexextra)
  135. - fixed perl path
  136. - improved updmap process in %%post and %%postun
  137. * Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  138. - generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-czechslovak