libopenraw.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236
  1. Summary: Decode camera RAW files
  2. Name: libopenraw
  3. Version: 0.0.8
  4. Release: 5%{?dist}
  5. License: LGPLv3+
  6. Group: System Environment/Libraries
  7. URL: http://libopenraw.freedesktop.org/wiki
  8. Source0: http://libopenraw.freedesktop.org/download/%{name}-%{version}.tar.gz
  9. # upstream patch 1b15acdcfdc4664bc6c0be473cb6e096071a4e62 adds support
  10. # for certain PEF files and fixes a crash when opening such files
  11. Patch0: 0001-Support-partially-PEF-from-Pentax-K20D.patch
  12. # upstream patch 22287584fbfa4657098ee997957a6c4fc972a53b to
  13. # properly decompress CFA from certain cameras (patch slightly modified
  14. # to omit patching README)
  15. Patch1: 0001-Properly-decompress-CFA-from-Canon-7D-5DMkII-500D-1D.patch
  16. # https://bugs.freedesktop.org/show_bug.cgi?id=31088
  17. Patch2: libopenraw-0.0.8-pixbufloaderdir.patch
  18. BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
  19. BuildRequires: libtool autoconf automake
  20. BuildRequires: boost-devel
  21. BuildRequires: exempi-devel >= 1.99.5
  22. BuildRequires: gtk2-devel
  23. BuildRequires: libcurl-devel
  24. BuildRequires: libjpeg-devel
  25. BuildRequires: libxml2-devel
  26. %description
  27. libopenraw is an ongoing project to provide a free software
  28. implementation for camera RAW files decoding. One of the main reason is
  29. that dcraw is not suited for easy integration into applications, and
  30. there is a need for an easy to use API to build free software digital
  31. image processing application.
  32. %package gnome
  33. Summary: GUI components of %{name}
  34. Group: System Environment/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. %description gnome
  37. The %{name}-gnome package contains gui components of %{name}.
  38. %package devel
  39. Summary: Development files for %{name}
  40. Group: Development/Libraries
  41. Requires: %{name} = %{version}-%{release}
  42. Requires: pkgconfig
  43. %description devel
  44. The %{name}-devel package contains libraries and header files for
  45. developing applications that use %{name}.
  46. %package gnome-devel
  47. Summary: Development files for %{name}-gnome
  48. Group: Development/Libraries
  49. Requires: %{name}-gnome = %{version}-%{release}
  50. Requires: %{name}-devel = %{version}-%{release}
  51. Requires: pkgconfig
  52. %description gnome-devel
  53. The %{name}-gnome-devel package contains libraries and header files for
  54. developing applications that use %{name}-gnome.
  55. %package pixbuf-loader
  56. Summary: RAW image loader for GTK+ applications
  57. Group: System Environment/Libraries
  58. Requires: gtk2
  59. Requires: %{name} = %{version}-%{release}
  60. Requires(post): gdk-pixbuf2
  61. Requires(postun): gdk-pixbuf2
  62. %description pixbuf-loader
  63. %{name}-pixbuf-loader contains a plugin to load RAW images, as created by
  64. digital cameras, in GTK+ applications.
  65. %prep
  66. %setup -q
  67. %patch1 -p1 -b CFA-decrompress-fix
  68. %patch0 -p1 -b pef-crash-fix
  69. %patch2 -p1 -b pixbufloaderdir
  70. %build
  71. autoreconf -i -f
  72. %configure --disable-static --enable-gnome
  73. # Omit unused direct shared library dependencies.
  74. sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' libtool
  75. make %{?_smp_mflags}
  76. %check
  77. make check
  78. %install
  79. rm -rf $RPM_BUILD_ROOT
  80. make install DESTDIR=$RPM_BUILD_ROOT
  81. find $RPM_BUILD_ROOT -type f -name "*.la" -delete
  82. %clean
  83. rm -rf $RPM_BUILD_ROOT
  84. %post -p /sbin/ldconfig
  85. %postun -p /sbin/ldconfig
  86. %post gnome -p /sbin/ldconfig
  87. %postun gnome -p /sbin/ldconfig
  88. %post pixbuf-loader
  89. gdk-pixbuf-query-loaders-%{__isa_bits} --update-cache || :
  90. %postun pixbuf-loader
  91. gdk-pixbuf-query-loaders-%{__isa_bits} --update-cache || :
  92. %files
  93. %defattr(-,root,root,-)
  94. %doc AUTHORS
  95. %doc ChangeLog
  96. %doc COPYING
  97. %doc NEWS
  98. %doc README
  99. %doc TODO
  100. %{_libdir}/%{name}.so.*
  101. %files gnome
  102. %defattr(-,root,root,-)
  103. %{_libdir}/%{name}gnome.so.*
  104. %files devel
  105. %defattr(-,root,root,-)
  106. %{_libdir}/%{name}.so
  107. %{_libdir}/pkgconfig/%{name}-1.0.pc
  108. %dir %{_includedir}/%{name}-1.0
  109. %{_includedir}/%{name}-1.0/%{name}/*.h
  110. %files gnome-devel
  111. %defattr(-,root,root,-)
  112. %{_libdir}/%{name}gnome.so
  113. %{_libdir}/pkgconfig/%{name}-gnome-1.0.pc
  114. %dir %{_includedir}/%{name}-1.0/%{name}-gnome
  115. %{_includedir}/%{name}-1.0/%{name}-gnome/gdkpixbuf.h
  116. %files pixbuf-loader
  117. %defattr(-,root,root,-)
  118. %{_libdir}/gdk-pixbuf-2.0/*/loaders/*.so
  119. %changelog
  120. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.8-5
  121. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  122. * Sun Oct 24 2010 Christian Krause <chkr@fedoraproject.org> - 0.0.8-4
  123. - fix %%post and %%postun scripts and install directory for
  124. pixbuf-loader
  125. * Sun Oct 24 2010 Christian Krause <chkr@fedoraproject.org> - 0.0.8-3
  126. - add upstream patch 22287584fbfa4657098ee997957a6c4fc972a53b to
  127. properly decompress CFA from certain cameras (BZ 624283)
  128. * Wed Sep 08 2010 Christian Krause <chkr@fedoraproject.org> - 0.0.8-2
  129. - add upstream patch 1b15acdcfdc4664bc6c0be473cb6e096071a4e62
  130. to support certain PEF files and to fix a crash when opening
  131. such files (BZ 606898)
  132. * Sat Dec 05 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.0.8-1
  133. - Version bump to 0.0.8.
  134. * Fixed a huge memory leak. (FreeDesktop Bugzilla #21435)
  135. * cfa output should write the data in PGM as big endian.
  136. * Better handling of Canon CR2 "slices" to fix crasher with Canon
  137. 450D/Digital Rebel XSi files (and possibly others).
  138. * Added new API or_rawfile_new_from_memory() to load a Raw file from a
  139. memory buffer.
  140. * Added new API or_rawfile_get_typeid() and the associated consts.
  141. * Added new API or_rawdata_get_minmax().
  142. * Added new API or_get_file_extensions().
  143. * Added new API or_rawfile_get_rendered_image() to get a rendered image.
  144. * Added new API or_bitmapdata_*().
  145. * New GdkPixbuf loader.
  146. * Decompress NEF files.
  147. - License changed to LGPLv3 or later.
  148. - Missing includes fixed by upstream.
  149. - Replaced 'BuildRequires: chrpath glib2-devel' with 'BuildRequires:
  150. exempi-devel libcurl-devel'.
  151. - Added 'Requires: gtk2' to pixbuf-loader for directory ownership.
  152. - Added a %%check stanza.
  153. * Fri Jul 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 0.0.5-4
  154. - Autorebuild for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  155. * Wed Feb 25 2009 Caolán McNamara <caolanm@redhat.com> - 0.0.5-3
  156. - add stdio.h for fopen and friends
  157. * Wed Feb 25 2009 Release Engineering <rel-eng@fedoraproject.org> - 0.0.5-2
  158. - Autorebuild for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  159. * Tue Mar 04 2008 Trond Danielsen <trond.danielsen@gmail.com> - 0.0.5-1
  160. - New upstream version.
  161. * Wed Feb 20 2008 Release Engineering <rel-eng@fedoraproject.org> - 0.0.4-3
  162. - Autorebuild for GCC 4.3
  163. * Wed Jan 30 2008 Trond Danielsen <trond.danielsen@gmail.com> - 0.0.4-2
  164. - Added missing dependency on libxml
  165. * Wed Jan 30 2008 Trond Danielsen <trond.danielsen@gmail.com> - 0.0.4-1
  166. - New upstream version.
  167. * Fri Dec 28 2007 Trond Danielsen <trond.danielsen@gmail.com> - 0.0.3-1
  168. - New upstream version.
  169. - Updated license tag.
  170. - Fixed rpath error.
  171. * Thu May 03 2007 Trond Danielsen <trond.danielsen@gmail.com> - 0.0.2-5
  172. - Added unowned directory to list of files.
  173. - Changed license from GPL to LGPL.
  174. * Wed May 02 2007 Trond Danielsen <trond.danielsen@gmail.com> - 0.0.2-4
  175. - Moved gui components to a separate package.
  176. * Tue May 01 2007 Trond Danielsen <trond.danielsen@gmail.com> - 0.0.2-3
  177. - Added missing BuildRequirement.
  178. * Mon Apr 30 2007 Trond Danielsen <trond.danielsen@gmail.com> - 0.0.2-2
  179. - Added missing BuildRequirement.
  180. * Sun Apr 29 2007 Trond Danielsen <trond.danielsen@gmail.com> - 0.0.2-1
  181. - Inital version.