swig-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235
  1. %define tcl 1
  2. %define guile 0
  3. Summary: Connects C/C++/Objective C to some high-level programming languages
  4. Summary(ja): C/C++/Objective C を高級プログラミング言語に接続するためのツール
  5. Name: swig
  6. Version: 4.0.2
  7. Release: 1%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPLv3+ and BSD
  12. URL: http://www.swig.org/
  13. Source: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: lua-devel
  16. BuildRequires: pcre-devel
  17. BuildRequires: perl
  18. BuildRequires: python-devel
  19. BuildRequires: python3-devel
  20. BuildRequires: ruby-devel
  21. %if %{tcl}
  22. BuildRequires: tcl-devel
  23. %endif
  24. %if %{guile}
  25. BuildRequires: guile-devel
  26. %endif
  27. BuildRequires: autoconf, automake, gawk, nkf
  28. Obsoletes: swig-runtime
  29. %description
  30. Simplified Wrapper and Interface Generator (SWIG) is a software
  31. development tool for connecting C, C++ and Objective C programs with a
  32. variety of high-level programming languages. SWIG is primarily used
  33. with Perl, Python and Tcl/TK, but it has also been extended to Java,
  34. Eiffel and Guile. SWIG is normally used to create high-level
  35. interpreted programming environments, systems integration, and as a
  36. tool for building user interfaces
  37. %package doc
  38. Summary: Documentation files for SWIG
  39. Summary(ja): SWIG のドキュメント
  40. License: BSD
  41. Group: documentation
  42. BuildArch: noarch
  43. %description doc
  44. This package contains documentation for SWIG and useful examples
  45. %debug_package
  46. %prep
  47. %setup -q -n swig-%{version}
  48. # as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
  49. # (specific req/prov filtering). Before you remove this hack make sure you don't
  50. # reintroduce https://bugzilla.redhat.com/show_bug.cgi?id=489421
  51. cat << \EOF > %{name}-prov
  52. #!/bin/sh
  53. %{__perl_provides} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
  54. EOF
  55. %global __perl_provides %{_builddir}/%{name}-%{version}/%{name}-prov
  56. chmod +x %{__perl_provides}
  57. cat << \EOF > %{name}-req
  58. #!/bin/sh
  59. %{__perl_requires} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
  60. EOF
  61. %global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
  62. chmod +x %{__perl_requires}
  63. for all in CHANGES README; do
  64. iconv -f ISO88591 -t UTF8 < $all > $all.new
  65. touch -r $all $all.new
  66. mv -f $all.new $all
  67. done
  68. %build
  69. ./autogen.sh
  70. %configure \
  71. --with-python3=python3 \
  72. --with-2to3=2to3-3.8 \
  73. %{nil}
  74. make %{?_smp_mflags}
  75. # Test suite is currently broken
  76. #make check
  77. %install
  78. rm -rf %{buildroot}
  79. make clean-examples
  80. pushd Examples/
  81. # Remove all arch dependent files in Examples/
  82. find -type f -name 'Makefile.in' | xargs rm -f --
  83. # We don't want to ship files below.
  84. rm -rf test-suite
  85. find -type f -name '*.dsp' | xargs rm -f --
  86. find -type f -name '*.dsw' | xargs rm -f --
  87. # Convert files to UNIX format
  88. for all in `find -type f`; do
  89. nkf --unix $all
  90. chmod -x $all
  91. done
  92. popd
  93. make DESTDIR=%{buildroot} install
  94. %files
  95. %defattr(-,root,root,-)
  96. %{_bindir}/*
  97. %{_datadir}/swig
  98. %doc ANNOUNCE CHANGES CHANGES.current INSTALL
  99. %doc README TODO
  100. %license LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
  101. %files doc
  102. %defattr(-,root,root,-)
  103. %doc Doc Examples
  104. %license LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
  105. %changelog
  106. * Fri Mar 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.2-1
  107. - new upstream release.
  108. * Wed Oct 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.1-1
  109. - new upstream release.
  110. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.12-1
  111. - new upstream release.
  112. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.10-1
  113. - new upstream release.
  114. * Wed Feb 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.0.5-1
  115. - new upstream release
  116. - moved doc subpackage to Documentation Group
  117. * Mon Jun 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.2-1
  118. - update to 3.0.2
  119. * Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
  120. - update to 3.0.0
  121. - add BR: ruby-devel, lua-devel
  122. * Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
  123. - update to 2.0.8
  124. - build with pcre-8.31
  125. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-2
  126. - rebuild with python-2.7.2
  127. * Sat Oct 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.4-1
  128. - update to 2.0.4
  129. * Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.40-2
  130. - add missing man file(s) to the filelist
  131. * Mon Mar 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.40-1
  132. - new upstream release
  133. - rebuild with new toolchain
  134. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.35-1
  135. - new upstream release
  136. * Wed Mar 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.31-0vl1
  137. - new upstream release
  138. - removed php-devel and ruby-devel from BuildPreReq:.
  139. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.29-0vl1
  140. - new upstream release
  141. - use %%configure
  142. - remove runtime subpackage
  143. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
  144. - 1.3.21-0vl2
  145. - un-libtoolize (tarball have already been libtoolized).
  146. - fix %%clean.
  147. - add guile-devel, php-devel, python-devel and ruby-devel to BuildPreReq:.
  148. * Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  149. - 1.3.21-0vl1
  150. - update version
  151. * Sat Dec 27 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  152. - 1.3.20-0vl1
  153. - update version
  154. * Tue Jun 03 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  155. - update version
  156. * Sun Mar 03 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
  157. - update version
  158. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  159. - import to Vine Linux
  160. * Wed Jul 19 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.3a3-1mdk
  161. - BM.
  162. - Clean up specs.
  163. - 1.3a3.
  164. * Tue Jun 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.1p5-5mdk
  165. - Use makeinstall macros.
  166. * Mon Apr 10 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-4mdk
  167. - Provides: swig
  168. * Mon Apr 3 2000 Pixel <pixel@mandrakesoft.com> 1.1p5-3mdk
  169. - rebuild with new perl
  170. - cleanup
  171. * Wed Mar 22 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-2mdk
  172. - Rebuilt on kenobi
  173. - Don't use prefix
  174. * Fri Mar 10 2000 Francis Galiegue <francis@mandrakesoft.com> 1.1p5-1mdk
  175. - First RPM for Mandrake