glib2-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A library of handy utility functions.
  3. Name: glib2
  4. Version: 2.29.92
  5. Release: 1%{?_dist_release}
  6. License: LGPLv2+
  7. Group: System Environment/Libraries
  8. Source: http://ftp.gnome.org/pub/GNOME/sources/glib/2.29/glib-%{version}.tar.xz
  9. Source2: glib2.sh
  10. Source3: glib2.csh
  11. BuildRoot: %{_tmppath}/glib-%{version}-root
  12. BuildRequires: pkgconfig >= 0.14
  13. BuildRequires: dbus-devel
  14. BuildRequires: gamin-devel
  15. BuildRequires: libffi-devel
  16. BuildRequires: zlib-devel
  17. BuildRequires: gtk-doc
  18. Obsoletes: glib-gtkbeta
  19. URL: http://www.gtk.org
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>, Takemikaduchi
  23. %description
  24. GLib is the low-level core library that forms the basis
  25. for projects such as GTK+ and GNOME. It provides data structure
  26. handling for C, portability wrappers, and interfaces for such runtime
  27. functionality as an event loop, threads, dynamic loading, and an
  28. object system.
  29. This package provides version 2.29 of GLib.
  30. %package devel
  31. Summary: Development files for the GLib library
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}
  34. Requires: pkgconfig >= 0.14
  35. Obsoletes: glib-gtkbeta-devel
  36. Conflicts: glib-devel <= 1.2.8
  37. %description devel
  38. The glib-devel package includes the header files for
  39. version 2.29 of the GLib library.
  40. ## to build compat32 for x86_64 architecture support
  41. %package -n compat32-%{name}
  42. Summary: A library of handy utility functions.
  43. Group: System Environment/Libraries
  44. %description -n compat32-%{name}
  45. GLib is the low-level core library that forms the basis
  46. for projects such as GTK+ and GNOME. It provides data structure
  47. handling for C, portability wrappers, and interfaces for such runtime
  48. functionality as an event loop, threads, dynamic loading, and an
  49. object system.
  50. This package provides version 2.29 of GLib.
  51. %package -n compat32-%{name}-devel
  52. Summary: Development files for the GLib library
  53. Group: Development/Libraries
  54. Requires: pkgconfig >= 0.14
  55. Requires: compat32-%{name} = %{version}
  56. Conflicts: glib-devel <= 1.2.8
  57. %description -n compat32-%{name}-devel
  58. The glib-devel package includes the header files for
  59. version 2.29 of the GLib library.
  60. %prep
  61. %setup -q -n glib-%{version}
  62. %build
  63. %configure --disable-selinux --enable-static
  64. make %{?_smp_mflags}
  65. %install
  66. rm -rf $RPM_BUILD_ROOT
  67. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  68. %makeinstall
  69. ## glib2.sh and glib2.csh
  70. ./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  71. install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  72. install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  73. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  74. rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
  75. rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
  76. %find_lang glib20
  77. %clean
  78. rm -rf $RPM_BUILD_ROOT
  79. %post -p /sbin/ldconfig
  80. %postun -p /sbin/ldconfig
  81. %post -n compat32-%{name} -p /sbin/ldconfig
  82. %postun -n compat32-%{name} -p /sbin/ldconfig
  83. %files -f glib20.lang
  84. %defattr(-, root, root)
  85. %doc AUTHORS COPYING ChangeLog NEWS README
  86. %{_bindir}/gdbus
  87. %{_bindir}/gio-querymodules
  88. %{_bindir}/glib-compile-schemas
  89. %{_bindir}/gsettings
  90. %{_libdir}/libglib-2.0.so.*
  91. %{_libdir}/libgthread-2.0.so.*
  92. %{_libdir}/libgmodule-2.0.so.*
  93. %{_libdir}/libgobject-2.0.so.*
  94. %{_libdir}/libgio-2.0.so.*
  95. %{_libdir}/gdbus-2.0/codegen/*
  96. %{_libdir}/gio/modules/lib*.so
  97. %{_sysconfdir}/profile.d/*
  98. %{_sysconfdir}/bash_completion.d/*
  99. %files devel
  100. %defattr(-, root, root)
  101. %{_bindir}/gdbus-codegen
  102. %{_bindir}/glib-genmarshal
  103. %{_bindir}/glib-gettextize
  104. %{_bindir}/glib-mkenums
  105. %{_bindir}/gobject-query
  106. %{_bindir}/gtester
  107. %{_bindir}/gtester-report
  108. %{_libdir}/lib*.so
  109. %{_libdir}/lib*.a
  110. %{_libdir}/glib-2.0
  111. %{_includedir}/*
  112. %{_datadir}/aclocal/*
  113. %{_libdir}/pkgconfig/*
  114. %{_datadir}/glib-2.0
  115. %doc %{_datadir}/gtk-doc/html/*
  116. %doc %{_mandir}/man1/*
  117. %{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
  118. %{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
  119. %if %{build_compat32}
  120. %files -n compat32-%{name}
  121. %defattr(-, root, root)
  122. %{_libdir}/libglib-2.0.so.*
  123. %{_libdir}/libgthread-2.0.so.*
  124. %{_libdir}/libgmodule-2.0.so.*
  125. %{_libdir}/libgobject-2.0.so.*
  126. %{_libdir}/libgio-2.0.so.*
  127. %{_libdir}/gio/modules/lib*.so
  128. %files -n compat32-%{name}-devel
  129. %defattr(-, root, root)
  130. %{_libdir}/lib*.so
  131. %{_libdir}/lib*.a
  132. %{_libdir}/glib-2.0
  133. %{_libdir}/pkgconfig/*
  134. %endif
  135. %changelog
  136. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
  137. - new upstream release
  138. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
  139. - new upstream release
  140. - remove Patch0,1
  141. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
  142. - new upstream release
  143. - Patch0: glib-2.29.16-fixes-bug-656387.patch
  144. - Patch1: glib-2.29.16-fixes-bug-656675.patch
  145. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
  146. - new upstream release
  147. - add BuildRequires: libffi-devel, dbus-devel
  148. * Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
  149. - new upstream release
  150. * Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
  151. - new upstream release
  152. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
  153. - new upstream release
  154. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
  155. - new upstream release
  156. * Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
  157. - new upstream release
  158. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  159. - new upstream release
  160. * Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
  161. - new upstream release
  162. * Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  163. - new upstream release
  164. * Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
  165. - move the following files from glib2-devel to glib2 package
  166. (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
  167. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
  168. - new upstream release
  169. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
  170. - new upstream release
  171. - fix Source (add URL)
  172. - fix %files to add /etc/bash_completion.d files
  173. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
  174. - build with rpm-4.8.1-1 for pkg-config file
  175. * Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
  176. - new upstream release
  177. * Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
  178. - new upstream release
  179. * Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
  180. - new upstream release
  181. - add BuildRequires: zlib-devel
  182. * Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
  183. - new upstream release
  184. * Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
  185. - new upstream release
  186. * Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
  187. - new upstream release
  188. * Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  189. - new upstream release
  190. * Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
  191. - new upstream release
  192. * Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
  193. - new upstream release
  194. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
  195. - new upstream release
  196. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
  197. - new upstream release
  198. * Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
  199. - new upstream release
  200. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
  201. - new upstream release
  202. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
  203. - new upstream release
  204. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
  205. - new upstream release
  206. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
  207. - new upstream release
  208. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
  209. - new upstream release
  210. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
  211. - new upstream release
  212. * Mon Jul 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
  213. - new upstream release
  214. * Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
  215. - updated %%if %%{build_compat32} case related statements
  216. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
  217. - new upstream release
  218. - removed lib*.la files from devel package
  219. * Sun Apr 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
  220. - new upstream release
  221. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
  222. - added %%{?_dist_release}
  223. - BuildRequires: gamin-devel
  224. * Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
  225. - new upstream release
  226. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
  227. - new upstream release
  228. * Wed Jan 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
  229. - new upstream release
  230. * Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
  231. - new upstream release
  232. * Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
  233. - new upstream release
  234. - removed BuildRequires: automake17
  235. * Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
  236. - new upstream release
  237. * Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
  238. - new upstream release
  239. * Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
  240. - new upstream release
  241. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
  242. - rebuild with new environment
  243. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
  244. - new upstream release
  245. * Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
  246. - new upstream release
  247. * Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
  248. - new upstream release
  249. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
  250. - new upstream release
  251. * Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
  252. - new upstream release
  253. * Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
  254. - new upstream release
  255. * Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
  256. - new upstream release
  257. * Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
  258. - rebuild
  259. * Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
  260. - update glib2.{sh,csh}
  261. - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
  262. * Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
  263. - new upstream release
  264. * Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
  265. - new upstream release
  266. * Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
  267. - new upstream release
  268. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  269. - new upstream release
  270. * Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
  271. - added compat32-* packages for x86_64 architecture support
  272. - chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
  273. * Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
  274. - new upstream release
  275. * Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
  276. - new upstream release
  277. * Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
  278. - new upstream release
  279. * Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
  280. - new upstream release
  281. * Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
  282. - fixed typo in glib2.csh
  283. * Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
  284. - update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
  285. G_BROKEN_FILENAMES.
  286. * Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
  287. - new upstream release
  288. * Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
  289. - new upstream release
  290. * Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
  291. - new upstream release
  292. * Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
  293. - new upstream release
  294. * Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
  295. - new upstream release
  296. * Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
  297. - new upstream release
  298. - add *.la to build arts (should be fixed in arts?)
  299. * Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
  300. - new upstream release
  301. * Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
  302. - new upstream release
  303. * Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
  304. - new upstream release
  305. * Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
  306. - new upstream release
  307. * Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
  308. - new upstream release
  309. * Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
  310. - rebuilt
  311. * Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
  312. - new upstream release
  313. * Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
  314. - new upstream release
  315. * Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
  316. - new upstream release
  317. * Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
  318. - new upstream release
  319. * Sat Jun 5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
  320. - new upstream release
  321. * Sat May 1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  322. - new upstream release
  323. * Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  324. - new upstream release
  325. * Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
  326. - rebuild with new toolchain
  327. * Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
  328. - new upstream release
  329. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
  330. - new upstream release
  331. * Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  332. - new upstream release
  333. * Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  334. - new upstream release
  335. * Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
  336. - new upstream release
  337. - build for Vine Linux
  338. * Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
  339. - install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
  340. - blow away unpackaged files in install
  341. * Thu Aug 8 2002 Owen Taylor <otaylor@redhat.com>
  342. - Version 2.0.6
  343. - Remove fixed-ltmain.sh; shouldn't be needed any more.
  344. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  345. - automated rebuild
  346. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  347. - 2.0.4
  348. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  349. - automated rebuild
  350. * Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
  351. - rebuild in different environment
  352. * Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
  353. - Fix missing .po files (#63336)
  354. * Wed Apr 3 2002 Alex Larsson <alexl@redhat.com>
  355. - Update to version 2.0.1
  356. * Fri Mar 8 2002 Owen Taylor <otaylor@redhat.com>
  357. - Version 2.0.0
  358. * Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
  359. - Update to 1.3.15
  360. * Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
  361. - Bump for rebuild
  362. * Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
  363. - Update to 1.3.14
  364. * Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
  365. - add horrible buildrequires hack
  366. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  367. - 1.3.13.91 cvs snap
  368. * Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
  369. - rebuild from CVS snapshot
  370. - use setup -q
  371. * Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
  372. - rebuild
  373. * Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
  374. - 1.3.13
  375. * Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
  376. - attempting rebuild in rawhide
  377. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  378. - remove 64-bit patch now upstream, 1.3.12.90
  379. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  380. - add some missing files to file list, langify
  381. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  382. - add temporary patch to fix GTypeFundamentals on 64-bit
  383. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  384. - Version 1.3.11
  385. * Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
  386. - Version 1.3.10
  387. * Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
  388. - Version 1.3.9
  389. * Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
  390. - Version 1.3.8
  391. * Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
  392. - Make -devel package require main package (#45388)
  393. - Fix description and summary
  394. - Configure with --disable-gtk-doc
  395. * Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  396. - add some portability fixes needed at least on s390
  397. - copy config.{guess,sub} instead of calling libtoolize
  398. * Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
  399. - try a new glib tarball with Makefile changes to work around
  400. libtool linking to installed .la files
  401. - make -devel require pkgconfig
  402. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  403. - either libtool or the bad libtool hacks caused link
  404. against glib-gobject 1.3.2, rebuild
  405. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  406. - 1.3.6
  407. - bad libtool workarounds
  408. * Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
  409. - 1.3.5, rename to glib2
  410. * Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
  411. - Final 1.3.2
  412. * Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
  413. - Version 1.3.2pre1
  414. - Remove pkgconfig
  415. * Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
  416. - Call 1.3.1b instead of snap... the snap* naming doesn't
  417. order correctly.
  418. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  419. - new snapshot with fixed .pc files
  420. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  421. - include .pc files in file list
  422. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  423. - Include pkg-config
  424. - Upgrade to a glib CVS snapshot
  425. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  426. - rebuild to cope with glibc locale binary incompatibility
  427. * Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
  428. - Remove glib-config.1 manpage from build since
  429. it conflicts with glib-devel. When we go to
  430. glib glib1.2 setup, we should add it back
  431. * Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
  432. - Version 1.3.1
  433. - Move back to standard %{prefix}
  434. * Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
  435. - Rebuild in /opt/gtk-beta
  436. * Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
  437. - New version (adds gobject)
  438. * Wed Apr 25 2000 Owen Taylor <otaylor@redhat.com>
  439. - Don't blow away /etc/ld.so.conf (sorry!)
  440. * Tue Apr 24 2000 Owen Taylor <otaylor@redhat.com>
  441. - Snapshot RPM for Pango testing
  442. * Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
  443. - Added fixes from stable branch of CVS
  444. * Thu Oct 7 1999 Owen Taylor <otaylor@redhat.com>
  445. - version 1.2.6
  446. * Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
  447. - version 1.2.5
  448. * Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
  449. - version 1.2.4
  450. * Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
  451. - version 1.2.3
  452. * Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
  453. - version 1.2.1
  454. * Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
  455. - Version 1.2
  456. * Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
  457. - version 1.2.0pre1
  458. * Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
  459. - new description tags
  460. * Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
  461. - removed libtoolize from %build
  462. * Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
  463. - added libgthread to file list
  464. * Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
  465. - version 1.1.15
  466. * Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
  467. - version 1.1.14
  468. * Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
  469. - version 1.1.13
  470. * Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
  471. - version 1.1.12
  472. * Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
  473. - updated in preparation for the GNOME freeze
  474. * Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
  475. - Split out glib package