rply-vl.spec 2.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102
  1. Name: rply
  2. Version: 1.01
  3. Release: 1%{?_dist_release}
  4. Summary: A library to read and write PLY files
  5. Group: Development/Libraries
  6. License: MIT
  7. URL: http://www.tecgraf.puc-rio.br/~diego/professional/rply/
  8. Source0: http://www.tecgraf.puc-rio.br/~diego/professional/rply/rply-1.01.tar.gz
  9. Source1: rply_CMakeLists.txt
  10. Source2: RPLYConfig.cmake.in
  11. Source3: rply_cmake_export_cmakelists.txt
  12. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  13. BuildRequires: cmake >= 2.6.0
  14. %description
  15. RPly is a library that lets applications read and write PLY files.
  16. The PLY file format is widely used to store geometric information, such as 3D
  17. models, but is general enough to be useful for other purposes.
  18. RPly is easy to use, well documented, small, free, open-source, ANSI C,
  19. efficient, and well tested. The highlights are:
  20. * A callback mechanism that makes PLY file input straightforward;
  21. * Support for the full range of numeric formats;
  22. * Binary (big and little endian) and text modes are fully supported;
  23. * Input and output are buffered for efficiency;
  24. * Available under the MIT license for added freedom.
  25. %package devel
  26. Summary: Libraries and headers for rply
  27. Group: Development/Libraries
  28. Requires: %{name} = %{version}-%{release}
  29. %description devel
  30. Rply Library Header Files and Link Libraries
  31. %prep
  32. %setup -q
  33. # Add CMakeLists.txt file
  34. cp %{SOURCE1} CMakeLists.txt
  35. # Add CMake detection modules
  36. mkdir -p CMake/export
  37. mkdir -p CMake/Modules
  38. cp %{SOURCE2} CMake/Modules/
  39. cp %{SOURCE3} CMake/export/CMakeLists.txt
  40. %build
  41. %cmake -DCMAKE_BUILD_TYPE:STRING="Release"\
  42. -DCMAKE_VERBOSE_MAKEFILE=ON .
  43. make %{?_smp_mflags}
  44. %install
  45. rm -rf $RPM_BUILD_ROOT
  46. make install DESTDIR=$RPM_BUILD_ROOT
  47. %clean
  48. rm -rf $RPM_BUILD_ROOT
  49. %post -p /sbin/ldconfig
  50. %postun -p /sbin/ldconfig
  51. %files
  52. %defattr(-,root,root,-)
  53. %doc LICENSE
  54. %doc manual/*
  55. %{_libdir}/*.so.*
  56. %{_bindir}/*
  57. %files devel
  58. %defattr(-,root,root)
  59. %dir %{_includedir}/%{name}/
  60. %{_includedir}/%{name}/*
  61. %{_libdir}/*.so
  62. %dir %{_datadir}/%{name}/
  63. %{_datadir}/%{name}/rplyConfig.cmake
  64. %changelog
  65. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.01-1
  66. - initial build for Vine Linux
  67. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
  68. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  69. * Sun Mar 21 2010 Mario Ceresa mrceresa@gmail.com
  70. - Added CMake modules to detect the package
  71. * Thu Mar 04 2010 Mario Ceresa mrceresa@gmail.com
  72. - Fixed problems detected in https://bugzilla.redhat.com/show_bug.cgi?id=570258#c2
  73. * Wed Mar 03 2010 Mario Ceresa mrceresa@gmail.com
  74. - Initial RPM Release