shotwell-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226
  1. Name: shotwell
  2. Version: 0.11.2
  3. Release: 1%{?_dist_release}
  4. Summary: A photo manager for the GNOME desktop
  5. Summary(ja): GNOME デスクトップ向けの写真管理ツール
  6. Group: Applications/Graphics
  7. # LGPLv2+ for the code
  8. # CC-BY-SA for some of the icons
  9. License: LGPLv2+ and CC-BY-SA
  10. URL: http://www.yorba.org/shotwell/
  11. Source0: http://www.yorba.org/download/shotwell/0.10/shotwell-%{version}.tar.bz2
  12. # http://trac.yorba.org/ticket/3379
  13. Source1: shotwell-icons.tar.bz2
  14. Source2: shotwell-0.8.1-vine2-ja.po
  15. Patch0: shotwell-0.11.1-vala-0.14.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: GConf2-devel
  18. BuildRequires: LibRaw-devel
  19. BuildRequires: LibRaw-static
  20. BuildRequires: WebKit-gtk-devel
  21. BuildRequires: dbus-glib-devel
  22. BuildRequires: desktop-file-utils
  23. BuildRequires: gettext
  24. BuildRequires: gtk2-devel
  25. BuildRequires: gstreamer-devel
  26. BuildRequires: gstreamer-plugins-base-devel
  27. BuildRequires: hal-devel
  28. BuildRequires: json-glib-devel
  29. BuildRequires: libexif-devel
  30. BuildRequires: libgee-devel
  31. BuildRequires: libgphoto2-devel
  32. BuildRequires: libgudev1-devel
  33. BuildRequires: libgexiv2-devel >= 0.2.0
  34. BuildRequires: libsoup-devel
  35. BuildRequires: libxml2-devel
  36. BuildRequires: sqlite3-devel
  37. BuildRequires: unique-devel
  38. BuildRequires: vala-devel >= 0.9.5
  39. Vendor: Project Vine
  40. Distribution: Vine Linux
  41. Packager: kudoh
  42. %description
  43. Shotwell is a new open source photo manager designed for the GNOME desktop
  44. environment. It allows you to import photos from your camera, view and edit
  45. them, and share them with others.
  46. %description -l ja
  47. Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
  48. 画像管理ツールです。
  49. あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
  50. 他の人々と共有するなどができます。
  51. %prep
  52. %setup -q -n %{name}-%{version}
  53. %patch0 -p1 -b .vala014
  54. pushd po
  55. %__rm -f ja.po
  56. %__cp %{SOURCE2} ja.po
  57. popd
  58. %build
  59. # We can't use the configure macro: it's not a standard autotools configure script
  60. export CFLAGS="%{optflags}"
  61. export LIB=%{_lib}
  62. # HACK: Remove fatal-warnings to succeed build with vala 0.13.
  63. sed -i "s:--fatal-warnings ::g" Makefile plugins/Makefile.plugin.mk
  64. ./configure --prefix=%{_prefix} --lib=%{_lib} --disable-schemas-install
  65. #sed -i -e 's/\\n/\n/g' configure.mk
  66. #sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
  67. #sed -i -e 's|LIB_DIRS=.*$|LIB_DIRS=%{_libdir}|' libraw-config
  68. make %{?_smp_mflags}
  69. %install
  70. rm -rf $RPM_BUILD_ROOT
  71. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  72. export XDG_DISABLE_MAKEFILE_UPDATES=1
  73. # otherwise gettext always returns English text regardless of LANGUAGE asked
  74. export LANG=en_US.utf8
  75. make install DESTDIR=$RPM_BUILD_ROOT
  76. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
  77. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
  78. # put hi-res icons in place
  79. (
  80. cd $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
  81. rm -rf 16x16 24x24 scalable
  82. tar xf %{SOURCE1}
  83. )
  84. %find_lang %{name} --all-name
  85. %clean
  86. rm -rf $RPM_BUILD_ROOT
  87. %post
  88. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  89. update-desktop-database &> /dev/null || :
  90. %postun
  91. if [ $1 -eq 0 ] ; then
  92. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  93. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  94. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  95. fi
  96. update-desktop-database &> /dev/null || :
  97. %posttrans
  98. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  99. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  100. %files -f %{name}.lang
  101. %defattr(-,root,root,-)
  102. %doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
  103. %{_bindir}/shotwell
  104. %{_bindir}/shotwell-video-thumbnailer
  105. %{_libdir}/shotwell/plugins/builtin
  106. %{_datadir}/GConf/gsettings/shotwell.convert
  107. %{_datadir}/glib-2.0/schemas/org.yorba.shotwell-extras.gschema.xml
  108. %{_datadir}/glib-2.0/schemas/org.yorba.shotwell.gschema.xml
  109. %{_datadir}/gnome/help/
  110. %{_datadir}/shotwell
  111. %{_datadir}/applications/shotwell.desktop
  112. %{_datadir}/applications/shotwell-viewer.desktop
  113. %{_datadir}/icons/hicolor/*
  114. %exclude %{_datadir}/icons/hicolor/icon-theme.cache
  115. %exclude %{_datadir}/glib-2.0/schemas/gschemas.compiled
  116. %changelog
  117. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.11.2-1
  118. - new upstream release
  119. - add Patch0 (shotwell-0.11.1-vala-0.14.patch)
  120. - add BuildRequires: gstreamer-plugins-base-devel
  121. * Sat Aug 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.1-2
  122. - rebuilt with libgexiv2-0.2.2-2
  123. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
  124. - new upstream release
  125. * Sat Jun 18 2011 IWAI, Masaharu <iwai@alib.jp> 0.8.1-5
  126. - add ja.po (Source2): fix <BTS:VineLinux:1142>
  127. - update Summary and description
  128. * Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-4
  129. - add hi-res icons (SOURCE1)
  130. - add LANG=en_US.utf8 to get gettext to actually generate translated strings
  131. * Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
  132. - dropt Patch0
  133. - added BuildRequires: LibRaw-static
  134. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
  135. - add Patch1 (shotwell-0.8.1-vala.patch)
  136. * Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
  137. - new upstream release
  138. - added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
  139. * Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
  140. - rebuilt with rpm-4.8.1 for pkg-config
  141. - fixed %%changelog in Tue Sep 14 2010
  142. * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
  143. - new upstream release
  144. - changed source URL
  145. - added Patch0 to work around desktop file incorrect comment
  146. - changed BuildRequires: vala-devel >= 0.9.5
  147. * Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
  148. - new upstream release
  149. * Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
  150. - new upstream release
  151. - changed BuildRequires: libgexiv2-devel >= 0.2.0
  152. * Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
  153. - fixed LIB_DIRS in libraw-config (for lib64)
  154. * Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
  155. - new upstream release
  156. - added BuildRequires: LibRaw-devel, libgexiv2-devel
  157. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
  158. - new upstream release
  159. * Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
  160. - new upstream release
  161. - added BuildRequires: libgudev1-devel
  162. - applied new naming policy to spec
  163. * Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
  164. - new upstream release
  165. - proved Japanese description
  166. * Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
  167. - new upstrema release
  168. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
  169. - intial build for VineSeed
  170. * Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
  171. * Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  172. - Update to 0.3.2
  173. * Tue Nov 3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
  174. - Version 0.3.0
  175. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
  176. - Rebuild against new libgee
  177. * Sun Aug 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
  178. - Bring icon cache handling in sync with current guidelines
  179. * Sun Aug 9 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
  180. - Initial packaging