arts-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460
  1. %define beta 0
  2. %define alsa 1
  3. %define run_test 0
  4. %define make_cvs 1
  5. Name: arts
  6. Summary: aRts (analog realtime synthesizer) - the KDE sound system
  7. Epoch: 1
  8. Version: 1.5.10
  9. %if %{beta}
  10. Release: 0.%{beta}%{?_dist_release}
  11. %else
  12. Release: 2%{?_dist_release}
  13. %endif
  14. License: LGPLv2
  15. Group: System Environment/Daemons
  16. %if %{beta}
  17. Source: ftp://ftp.kde.org/pub/kde/unstable/%{version}-%{beta}/src/%{name}-%{version}-%{beta}.tar.bz2
  18. %else
  19. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
  20. %endif
  21. Patch1: arts-1.1.4-debug.patch
  22. Patch2: arts-1.3.92-glib2.patch
  23. Patch5: arts-1.3.1-alsa.patch
  24. Patch6: arts-1.5.8-glibc.patch
  25. Patch7: arts-1.5.0-check_tmp_dir.patch
  26. Patch8: arts-1.5.2-multilib.patch
  27. # kde#93359
  28. Patch50: arts-1.5.4-dlopenext.patch
  29. Patch51: kde-3.5-libtool-shlibext.patch
  30. # upstream patches
  31. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  32. #PreReq: ldconfig
  33. BuildRequires: gcc-c++ libjpeg-devel
  34. BuildRequires: mesa-libGL-devel mesa-libGLU-devel
  35. BuildRequires: libmng-devel zlib-devel audiofile-devel
  36. BuildRequires: qt-devel >= 3.3.2, libpng-devel >= 1.2.5
  37. BuildRequires: libogg-devel libvorbis-devel glib2-devel
  38. BuildRequires: esound-devel jack-audio-connection-kit-devel
  39. BuildRequires: pkgconfig
  40. #libmad-devel
  41. %if %{alsa}
  42. BuildRequires: alsa-lib-devel
  43. %endif
  44. %if %{run_test}
  45. BuildRequires: kdelibs
  46. %endif
  47. # We don't want to require X11, Qt or glib2, arts is perfectly usable without
  48. # them, they're just used by addons the qtmcop, gmcop and x11globalcomm addons
  49. AutoReq: off
  50. #Requires: XFree86-gl XFree86-libs freetype2 libjpeg libmng libpng zlib
  51. #Requires: audiofile glibc
  52. Obsoletes: kdelibs-sound
  53. Provides: kdelibs-sound
  54. %description
  55. arts (analog real-time synthesizer) is the sound system of KDE 3.
  56. The principle of arts is to create/process sound using small modules which do
  57. certain tasks. These may be create a waveform (oscillators), play samples,
  58. filter data, add signals, perform effects like delay/flanger/chorus, or
  59. output the data to the soundcard.
  60. By connecting all those small modules together, you can perform complex
  61. tasks like simulating a mixer, generating an instrument or things like
  62. playing a wave file with some effects.
  63. %package devel
  64. Summary: Development files for the aRts sound server
  65. Group: Development/Libraries
  66. Requires: %{name} = %{epoch}:%{version}-%{release}
  67. Requires: glib2-devel
  68. Obsoletes: kdelibs-sound-devel
  69. Provides: kdelibs-sound-devel
  70. %description devel
  71. arts (analog real-time synthesizer) is the sound system of KDE 3.
  72. The principle of arts is to create/process sound using small modules which do
  73. certain tasks. These may be create a waveform (oscillators), play samples,
  74. filter data, add signals, perform effects like delay/flanger/chorus, or
  75. output the data to the soundcard.
  76. By connecting all those small modules together, you can perform complex
  77. tasks like simulating a mixer, generating an instrument or things like
  78. playing a wave file with some effects.
  79. Install arts-devel if you intend to write applications using arts (such as
  80. KDE applications using sound).
  81. %prep
  82. %setup -q
  83. %patch1 -p1 -b .debug
  84. %patch2 -p1 -b .glib
  85. %patch5 -p1 -b .alsa
  86. %patch6 -p1 -b .glibc
  87. %patch7 -p1 -b .check_tmp_dir
  88. %patch8 -p1 -b .multilib
  89. %patch50 -p1 -b .dlopenext
  90. %patch51 -p1 -b .libtool-shlibext
  91. %if %{make_cvs}
  92. make -f admin/Makefile.common cvs
  93. %endif
  94. %build
  95. unset QTDIR || : ; . /etc/profile.d/qt.sh
  96. %configure \
  97. --includedir=%{_includedir}/kde \
  98. --with-qt-libraries=$QTDIR/lib \
  99. --disable-rpath --disable-warnings \
  100. --disable-dependency-tracking \
  101. --enable-new-ldflags \
  102. --disable-libmad \
  103. %if %{alsa}
  104. --with-alsa \
  105. %endif
  106. --enable-final
  107. make %{?_smp_mflags}
  108. %if %{run_test}
  109. make check
  110. %endif
  111. %install
  112. rm -rf $RPM_BUILD_ROOT
  113. export PATH=`pwd`:$PATH
  114. make DESTDIR=$RPM_BUILD_ROOT install
  115. ## remove references to optional external libraries in .la files (#178733)
  116. find $RPM_BUILD_ROOT%{_libdir} -name "*.la" | xargs \
  117. sed -i \
  118. -e "s|-lmad||g" \
  119. -e "s|%{_libdir}/libmad.la||g" \
  120. -e "s|-lvorbisfile||g" \
  121. -e "s|-lvorbisenc||g" \
  122. -e "s|-lvorbis||g" \
  123. -e "s|-logg||g" \
  124. -e "s|-lasound||g" \
  125. -e "s|-laudiofile||g" \
  126. -e "s|-lesd||g" \
  127. -e "s|%{_libdir}/libesd.la||g" \
  128. -e "s|-lgmodule-2.0||g" \
  129. -e "s|-lgthread-2.0||g" \
  130. -e "s|-lglib-2.0||g" \
  131. -e "s|-laudio ||g" \
  132. -e "s|-lpng -lz ||g" \
  133. -e "s|%{_libdir}/libartsc.la||g" \
  134. -e "s@-lboost_filesystem@@g" \
  135. -e "s@-lboost_regex@@g" \
  136. -e "s@-ljack@@g"
  137. #rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.la
  138. #chmod a+x $RPM_BUILD_ROOT%{_libdir}/*
  139. %clean
  140. rm -rf $RPM_BUILD_ROOT
  141. %post -p /sbin/ldconfig
  142. %postun -p /sbin/ldconfig
  143. %files
  144. %defattr(-,root,root)
  145. %doc COPYING.LIB
  146. %dir %{_libdir}/mcop
  147. %dir %{_libdir}/mcop/Arts
  148. %{_bindir}/arts*
  149. %exclude %{_bindir}/artsc-config
  150. %{_libdir}/mcop/Arts/*
  151. %{_libdir}/mcop/*.mcopclass
  152. %{_libdir}/mcop/*.mcoptype
  153. %{_libdir}/lib*.so.*
  154. %{_libdir}/lib*.la
  155. %files devel
  156. %defattr(-,root,root)
  157. %{_bindir}/artsc-config
  158. %{_bindir}/mcopidl
  159. %{_includedir}/kde/arts
  160. %{_includedir}/kde/artsc
  161. %{_libdir}/lib*.so
  162. %{_libdir}/pkgconfig/artsc.pc
  163. %changelog
  164. * Sat May 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-2
  165. - updated to 1.5.10
  166. - added Patch1,2,5,8,50 and 51 from Fedora
  167. - added lib*.la files again...
  168. * Wed Apr 15 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.10-1
  169. - updated to 1.5.10
  170. - added BuildRequires: jack-audio-connection-kit-devel
  171. - removed static library
  172. * Sun Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.8-1vl5
  173. - applied new versioning policy
  174. - updated build dependancies
  175. * Wed Oct 10 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.8-0vl2
  176. - rebuild for VineSeed
  177. * Wed Oct 10 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.8-0vl1
  178. - new upstream release
  179. * Mon Jun 18 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.7-0vl2
  180. - rebuild for VineSeed
  181. * Sun May 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.7-0vl1
  182. - new upstream release
  183. * Wed Jan 17 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.6-0vl1
  184. - new upstream release
  185. * Tue Nov 14 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl5
  186. - rebuild for VineSeed
  187. * Tue Nov 14 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl4
  188. - add Patch0 [VineLinux:0369]
  189. * Sat Oct 14 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.5.5-0vl3
  190. - added --with-qt-libraries option
  191. - removed --libdir=%%{_libdir} option
  192. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl2
  193. - rebuild for VineSeed
  194. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl1
  195. - new upstream release
  196. * Mon Aug 7 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.4-0vl2
  197. - rebuild for VineSeed
  198. * Mon Aug 7 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.4-0vl1
  199. - new upstream release
  200. - drop Patch0
  201. * Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.5.3-0vl5
  202. - added --libdir=%%{_libdir} to ./configure option
  203. * Mon Jun 12 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl4
  204. - rebuild for VineSeed
  205. * Mon Jun 12 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl3
  206. - add Patch0 (CVE-2006-2916)
  207. * Wed May 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl2
  208. - rebuild for VineSeed
  209. * Wed May 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.3-0vl1
  210. - new upstream release
  211. * Mon Mar 20 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl2
  212. - rebuild for VineSeed
  213. * Mon Mar 20 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl1
  214. - new upstream release
  215. * Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl2
  216. - rebuild for VineSeed
  217. * Tue Jan 24 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.1-0vl1
  218. - new upstream release
  219. * Mon Dec 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0-0vl3
  220. - add "%%{epoch}:" to Requires in arts-devel
  221. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl2
  222. - rebuild for VineSeed
  223. * Mon Nov 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl1
  224. - new upstream release
  225. * Fri Nov 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.0-0vl0.rc1
  226. - new upstream release
  227. * Thu Oct 13 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.92-0vl1
  228. - new upstream release
  229. * Mon Sep 12 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.91-0vl1
  230. - new upstream release
  231. * Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl2
  232. - rebuild for VineSeed
  233. * Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.2-0vl1
  234. - new upstream release
  235. * Mon Jun 27 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl2
  236. - add alsa support for VineSeed
  237. - add --disable-rpath to configure option
  238. * Mon Jun 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl1
  239. - new upstream release
  240. - use %%{?_smp_mflags} for make option
  241. - add BuildPrereq: esound-devel libmad-devel
  242. * Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0-0vl2
  243. - rebuild for VineSeed
  244. * Thu Mar 10 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0-0vl1
  245. - new upstream release
  246. * Tue Mar 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.0-0vl0.rc1
  247. - new upstream release (1.4.0-rc1)
  248. * Mon Feb 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.92-0vl1
  249. - new upstream release
  250. * Tue Jan 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.91-0vl1
  251. - new upstream release
  252. * Sun Dec 12 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.2-0vl2
  253. - rebuild for VineSeed
  254. * Wed Dec 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.2-0vl1
  255. - source upgrade
  256. * Tue Oct 5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.1-0vl1
  257. - source upgrade
  258. - refine %%files
  259. * Sun Sep 5 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.0-0vl1
  260. - source upgrade
  261. * Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-0vl2
  262. - rebuild with qt32
  263. * Fri Jun 4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-0vl1
  264. - source upgrade
  265. - remove lines about vine26
  266. - BuildPrereq: XOrg-devel XOrg-gl-devel
  267. * Fri Apr 30 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.2-0vl1
  268. - source upgrade
  269. * Thu Mar 4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.1-0vl1
  270. - source upgrade
  271. * Sun Feb 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.0-0vl1
  272. - source upgrade
  273. - add Requires: glib2 to arts-devel package
  274. * Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.5-0vl2
  275. - rebuild for VineSeedPlus
  276. * Sat Jan 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.5-0vl1
  277. - source upgrade
  278. - build for VinePlus/2.6
  279. - (VinePlus/2.6) BuildPrereq: autoconf258
  280. * Sun Dec 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0vl3
  281. - build for VineSeed with new toolchain and qt-3.2.3
  282. - add BuildPrereq: gcc-c++ gcc-g77 glib2-devel pkgconfig
  283. * Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0.26vl2
  284. - rebuild with qt-3.2.1-0.26vl3
  285. * Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0vl2
  286. - rebuild with qt-3.2.1-0vl3
  287. * Tue Sep 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.4-0vl1
  288. - source upgrade
  289. - build with gcc-3.2.3
  290. * Thu Jul 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.3-0vl1
  291. - source upgrade
  292. * Sun Jun 29 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl3
  293. - change spec to build with gcc295
  294. - change make option for SMP and add script
  295. * Wed Jun 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl2
  296. - build with gcc295
  297. - add KDEDIR and QTDIR
  298. * Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl1
  299. - source upgrade
  300. * Mon Apr 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.1-0vl3
  301. - rebuilt with libpng >= 1.2.5 when %{vine26} is set to 0 (ie VineSeedPlus)
  302. * Mon Apr 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.1-0vl2
  303. - rebuild with qt-3.1.2-0vl2
  304. * Sat Mar 22 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.1-0vl1
  305. - source upgrade
  306. * Mon Feb 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl4
  307. - rebuild with qt-3.1.1-0vl3
  308. * Tue Feb 11 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl3
  309. - change spec to build both VineSeed and Vine2.5/2.6
  310. * Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl2
  311. - OOPS! rebuild with spec that changed 1.1-0vl0.2
  312. * Fri Jan 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl1
  313. - source upgrade to kde-3.1-stable
  314. * Wed Jan 22 2003 Tomoya TAKA <taka@vinelinux.org> 1.1-0vl0.2
  315. - add '-fPIC' to FLAGS on alpha
  316. * Wed Jan 8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1-0vl0.1
  317. - source upgrade to kde-3.1-rc6
  318. - stop using objprelink2, it does not work with gcc3
  319. * Tue Oct 16 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.4-0vl2
  320. - objprelink2 support only i386 (add %ifarch i386 ... again)
  321. -
  322. * Thu Oct 10 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.4-0vl1
  323. - source upgrade
  324. * Tue Oct 8 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl4
  325. - rebuild with qt-3.0.5-0vl1
  326. - BuildPrereq: qt-devel >= 3.0.5 autoconf253 objprelink2
  327. * Thu Aug 20 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl3
  328. - add BuildPrereq: libogg-devel libvorbis-devel
  329. * Wed Jul 10 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl2
  330. - rebuild
  331. * Mon Jul 8 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.3-0vl1
  332. - source upgrade
  333. * Thu Jul 4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.2-0vl1
  334. - source upgrade
  335. * Fri Jun 7 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.1-0vl1
  336. - source upgrade to 1.0.1
  337. - add BuildPrereq: objprelink for i386
  338. * Wed Apr 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.0-0vl2
  339. - add configure option `--with-xinerama'
  340. - add `Requires: %%{name} = %%{version}-%%{release}' for arts-devel
  341. * Thu Apr 4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.0-0vl1
  342. - source upgrade to 1.0.0
  343. * Sat Mar 30 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 0.9.9-1vl1
  344. - source update to cvs-20020329
  345. - build for VineSeed
  346. - merged with 3.0-0.cvs20020313.1
  347. - Epoch: 1
  348. - add BuildPrereq: autoconf252 automake15
  349. * Wed Mar 13 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0-0.cvs20020313.1
  350. - Build with autoconf 2.53, automake 1.5
  351. * Thu Feb 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0-0.cvs20020114.1
  352. - initial package