wpa_supplicant-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346
  1. %define build_gui 1
  2. Summary: WPA/WPA2/IEEE 802.1X Supplicant
  3. Name: wpa_supplicant
  4. Version: 2.3
  5. Release: 1%{?_dist_release}
  6. License: BSD
  7. Group: System Environment/Base
  8. URL: http://w1.fi/wpa_supplicant/
  9. Source0: http://hostap.epitest.fi/releases/%{name}-%{version}.tar.gz
  10. Source1: %{name}.build-config
  11. Source2: %{name}.conf
  12. Source3: %{name}.init.d
  13. Source4: %{name}.sysconfig
  14. Source6: %{name}.logrotate
  15. # distro specific customization and not suitable for upstream,
  16. # works around busted drivers
  17. Patch0: wpa_supplicant-assoc-timeout.patch
  18. # ensures that debug output gets flushed immediately to help diagnose driver
  19. # bugs, not suitable for upstream
  20. Patch1: wpa_supplicant-flush-debug-output.patch
  21. # disto specific customization for log paths, not suitable for upstream
  22. Patch2: wpa_supplicant-dbus-service-file-args.patch
  23. # quiet an annoying and frequent syslog message
  24. Patch3: wpa_supplicant-quiet-scan-results-message.patch
  25. # allow more private key encryption algorithms
  26. Patch5: wpa_supplicant-openssl-more-algs.patch
  27. # distro specific customization for Qt4 build tools, not suitable for upstream
  28. Patch6: wpa_supplicant-gui-qt4.patch
  29. # Fix libnl3 includes path
  30. Patch7: libnl3-includes.patch
  31. # Less aggressive roaming; signal strength is wildly variable
  32. Patch8: rh837402-less-aggressive-roaming.patch
  33. ## Vine patches
  34. Patch700: wpa_supplicant-2.3-vineqt4.patch
  35. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  36. %if %{build_gui}
  37. BuildRequires: qt4-devel
  38. %endif
  39. BuildRequires: openssl-devel
  40. BuildRequires: readline-devel
  41. BuildRequires: dbus-devel
  42. BuildRequires: libnl3-devel
  43. BuildRequires: docbook-utils
  44. Requires(post): /sbin/chkconfig
  45. Requires(preun): /sbin/chkconfig /sbin/service
  46. Requires(postun): /sbin/service
  47. %description
  48. wpa_supplicant is a WPA Supplicant for Linux, BSD and Windows with support
  49. for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA
  50. component that is used in the client stations. It implements key negotiation
  51. with a WPA Authenticator and it controls the roaming and IEEE 802.11
  52. authentication/association of the wlan driver.
  53. %if %{build_gui}
  54. %package gui
  55. Summary: Graphical User Interface for %{name}
  56. Summary(ja): %{name} のグラフィカルユーザインタフェース
  57. Group: Applications/System
  58. %description gui
  59. Graphical User Interface for wpa_supplicant written using QT4
  60. %description -l ja gui
  61. QT4 を用いた wpa_supplicant のグラフィカルユーザインタフェース
  62. %endif
  63. %prep
  64. %setup -q
  65. %patch0 -p1 -b .assoc-timeout
  66. %patch1 -p1 -b .flush-debug-output
  67. %patch2 -p1 -b .dbus-service-file
  68. %patch3 -p1 -b .quiet-scan-results-msg
  69. %patch5 -p1 -b .more-openssl-algs
  70. %patch6 -p1 -b .qt4
  71. %patch7 -p1 -b .libnl3
  72. %patch8 -p1 -b .rh837402-less-aggressive-roaming
  73. %patch700 -p1 -b .qt4
  74. %build
  75. pushd wpa_supplicant
  76. cp %{SOURCE1} .config
  77. echo "CONFIG_LIBNL32=y" >> .config
  78. CFLAGS="${CFLAGS:-%optflags} -fPIE -DPIE" ; export CFLAGS ;
  79. CXXFLAGS="${CXXFLAGS:-%optflags} -fPIE -DPIE" ; export CXXFLAGS ;
  80. LDFLAGS="${LDFLAGS:-%optflags} -pie -Wl,-z,now" ; export LDFLAGS ;
  81. # yes, BINDIR=_sbindir
  82. BINDIR="%{_sbindir}" ; export BINDIR ;
  83. LIBDIR="%{_libdir}" ; export LIBDIR ;
  84. make %{?_smp_mflags}
  85. %if %{build_gui}
  86. QTDIR=%{_libdir}/qt4 make wpa_gui-qt4 %{?_smp_mflags}
  87. %endif
  88. make eapol_test
  89. popd
  90. %install
  91. rm -rf %{buildroot}
  92. # init scripts
  93. install -D -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/rc.d/init.d/%{name}
  94. install -D -m 0644 %{SOURCE4} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
  95. install -D -m 0644 %{SOURCE6} %{buildroot}/%{_sysconfdir}/logrotate.d/%{name}
  96. # config
  97. install -D -m 0600 %{SOURCE2} %{buildroot}/%{_sysconfdir}/%{name}/%{name}.conf
  98. # binary
  99. install -d %{buildroot}/%{_sbindir}
  100. install -m 0755 %{name}/wpa_passphrase %{buildroot}/%{_sbindir}
  101. install -m 0755 %{name}/wpa_cli %{buildroot}/%{_sbindir}
  102. install -m 0755 %{name}/wpa_supplicant %{buildroot}/%{_sbindir}
  103. install -D -m 0644 %{name}/dbus/dbus-wpa_supplicant.conf %{buildroot}/%{_sysconfdir}/dbus-1/system.d/wpa_supplicant.conf
  104. install -D -m 0644 %{name}/dbus/fi.w1.wpa_supplicant1.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
  105. install -D -m 0644 %{name}/dbus/fi.epitest.hostap.WPASupplicant.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
  106. %if %{build_gui}
  107. # gui
  108. install -d %{buildroot}/%{_bindir}
  109. install -m 0755 %{name}/wpa_gui-qt4/wpa_gui %{buildroot}/%{_bindir}
  110. %endif
  111. # running
  112. mkdir -p %{buildroot}/%{_localstatedir}/run/%{name}
  113. # man pages
  114. install -d %{buildroot}%{_mandir}/man{5,8}
  115. install -m 0644 %{name}/doc/docbook/*.8 %{buildroot}%{_mandir}/man8
  116. install -m 0644 %{name}/doc/docbook/*.5 %{buildroot}%{_mandir}/man5
  117. # some cleanup in docs
  118. rm -f %{name}/doc/.cvsignore
  119. rm -rf %{name}/doc/docbook
  120. chmod -R 0644 %{name}/examples/*.py
  121. %clean
  122. rm -rf %{buildroot}
  123. %post
  124. if [ $1 = 1 ]; then
  125. /sbin/chkconfig --add %{name}
  126. fi
  127. %preun
  128. if [ $1 = 0 ]; then
  129. /sbin/service %{name} stop > /dev/null 2>&1
  130. killall -TERM wpa_supplicant >/dev/null 2>&1
  131. /sbin/chkconfig --del %{name}
  132. fi
  133. %postun
  134. if [ $1 -ge 1 ]; then
  135. /sbin/service %{name} condrestart > /dev/null 2>&1
  136. fi
  137. %files
  138. %defattr(-, root, root)
  139. %doc COPYING %{name}/ChangeLog README %{name}/eap_testing.txt %{name}/todo.txt %{name}/wpa_supplicant.conf %{name}/examples
  140. %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
  141. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  142. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  143. %{_sysconfdir}/rc.d/init.d/%{name}
  144. %{_sysconfdir}/dbus-1/system.d/%{name}.conf
  145. %{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
  146. %{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
  147. %{_sbindir}/wpa_passphrase
  148. %{_sbindir}/wpa_supplicant
  149. %{_sbindir}/wpa_cli
  150. %dir %{_localstatedir}/run/%{name}
  151. %dir %{_sysconfdir}/%{name}
  152. %{_mandir}/man8/*
  153. %{_mandir}/man5/*
  154. %if %{build_gui}
  155. %files gui
  156. %defattr(-, root, root)
  157. %{_bindir}/wpa_gui
  158. %endif
  159. %changelog
  160. * Thu Feb 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.3-1
  161. - updated to 2.3
  162. - built with libnl3 instead of libnl
  163. - added Patch 6, 7 and 8 from Fedora
  164. - added Patch700
  165. * Mon Aug 22 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.3-3
  166. - import Patch8 from Fedora 1:0.7.3-9 to fix some crashes
  167. - Wed Jul 27 2011 Dan Williams <dcbw@redhat.com> - 1:0.7.3-9
  168. - Fix various crashes with D-Bus interface (rh #678625) (rh #725517)
  169. * Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
  170. - rebuild with openssl-1.0.0c
  171. - add BuildRequires: qt4-designer, libnl-devel
  172. * Thu Jan 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-1
  173. - new upstream release
  174. - update patches
  175. - change License to BSD due to linkage against OpsnSSL since there is no
  176. OpenSSL exception in upstream GPLv2 license text.
  177. - build with qt4
  178. - update build config
  179. * Wed Jan 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.4-1
  180. - new upstream release
  181. - remove hostap/madwifi/prism54 drivers, use 'wext' instead.
  182. - drop upstream patches
  183. - import some fedora patches
  184. - Handle encryption keys correctly when switching 802.11 modes (rh #459399)
  185. - Better scanning behavior on resume from suspend/hibernate
  186. - Better interaction with newer kernels and drivers
  187. * Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-2
  188. - start wpa_supplicant by default.
  189. * Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
  190. - new upstream release
  191. - import some fedora patches
  192. * Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
  193. - rebuild with new openssl
  194. * Mon May 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
  195. - new upstream release
  196. * Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
  197. - initial build for Vine Linux based on FC package.
  198. * Thu Apr 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-10
  199. - Add fix for madwifi and WEP (wpa_supplicant/hostap bud #140) (#rh190075#)
  200. - Fix up madwifi-ng private ioctl()s for r1331 and later
  201. - Update madwifi headers to r1475
  202. * Tue Apr 25 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-9
  203. - Enable Wired driver, PKCS12, and Smartcard options (#rh189805#)
  204. * Tue Apr 11 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-8
  205. - Fix control interface key obfuscation a bit
  206. * Sun Apr 2 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-7
  207. - Work around older & incorrect drivers that return null-terminated SSIDs
  208. * Mon Mar 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-6
  209. - Add patch to make orinoco happy with WEP keys
  210. - Enable Prism54-specific driver
  211. - Disable ipw-specific driver; ipw2x00 should be using WEXT instead
  212. * Fri Mar 3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-5
  213. - Increase association timeout, mainly for drivers that don't
  214. fully support WPA ioctls yet
  215. * Fri Mar 3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-4
  216. - Add additional BuildRequires #rh181914#
  217. - Add prereq on chkconfig #rh182905# #rh182906#
  218. - Own /var/run/wpa_supplicant and /etc/wpa_supplicant #rh183696#
  219. * Wed Mar 1 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-3
  220. - Install wpa_passphrase too #rh183480#
  221. * Mon Feb 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-2
  222. - Don't expose private data on the control interface unless requested
  223. * Fri Feb 24 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-1
  224. - Downgrade to 0.4.8 stable release rather than a dev release
  225. * Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-3
  226. - Documentation cleanup (Terje Rosten <terje.rosten@ntnu.no>)
  227. * Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-2
  228. - Move initscript to /etc/rc.d/init.d
  229. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.2
  230. - bump again for double-long bug on ppc(64)
  231. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.1
  232. - rebuilt for new gcc4.1 snapshot and glibc changes
  233. * Sun Feb 5 2006 Dan Williams <dcbw@redhat.com> 0.5.1-1
  234. - Update to 0.5.1
  235. - Add WE auth fallback to actually work with older drivers
  236. * Thu Jan 26 2006 Dan Williams <dcbw@redhat.com> 0.4.7-2
  237. - Bring package into Fedora Core
  238. - Add ap_scan control interface patch
  239. - Enable madwifi-ng driver
  240. * Sun Jan 15 2006 Douglas E. Warner <silfreed@silfreed.net> 0.4.7-1
  241. - upgrade to 0.4.7
  242. - added package w/ wpa_gui in it
  243. * Mon Nov 14 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.6-1
  244. - upgrade to 0.4.6
  245. - adding ctrl interface changes recommended
  246. by Hugo Paredes <hugo.paredes@e-know.org>
  247. * Sun Oct 9 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.5-1
  248. - upgrade to 0.4.5
  249. - updated config file wpa_supplicant is built with
  250. especially, the ipw2100 driver changed to just ipw
  251. and enabled a bunch more EAP
  252. - disabled dist tag
  253. * Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-3
  254. - fix typo in init script
  255. * Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-2
  256. - fixing init script using fedora-extras' template
  257. - removing chkconfig default startup
  258. * Tue Jun 21 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-1
  259. - upgrade to 0.4.2
  260. - new sample conf file that will use any unrestricted AP
  261. - make sysconfig config entry
  262. - new BuildRoot for Fedora Extras
  263. - adding dist tag to Release
  264. * Fri May 06 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.8-1
  265. - upgrade to 0.3.8
  266. * Thu Feb 10 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-2
  267. - compile ipw driver in
  268. * Wed Feb 09 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-1
  269. - upgrade to 0.3.6
  270. * Thu Dec 23 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-4
  271. - fixing init script
  272. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-3
  273. - fixing init script
  274. - adding post/preun items to add/remove via chkconfig
  275. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-2
  276. - adding sysV scripts
  277. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-1
  278. - Initial RPM release.