foomatic-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666
  1. %define dbver_rel 4.0
  2. %define dbver_snap 20140607
  3. %define enginever 4.0.11
  4. %define filtersver 4.0.17
  5. Summary: Foomatic printer database.
  6. Name: foomatic
  7. Version: %{enginever}
  8. Release: 2%{?_dist_release}
  9. License: GPL
  10. Group: System Environment/Libraries
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Packager: tomop, daisuke, machino
  14. Source0: http://www.linuxprinting.org/download/foomatic/foomatic-db-engine-%{enginever}.tar.gz
  15. Source1: http://www.linuxprinting.org/download/foomatic/foomatic-filters-%{filtersver}.tar.gz
  16. Source2: http://www.linuxprinting.org/download/foomatic/foomatic-db-%{dbver_rel}-%{dbver_snap}.tar.gz
  17. # Use libdir.
  18. Patch1: foomatic-filters-libdir.patch
  19. Patch2: foomatic-db-engine-libdir.patch
  20. # Handle non-UTF-8 encodings in imported PPD files.
  21. Patch15: foomatic-bad-utf8.patch
  22. Url: http://www.linuxprinting.org
  23. Requires: perl >= 5.12.3
  24. Requires: %(eval `perl -V:version`; echo "perl(:MODULE_COMPAT_$version)")
  25. Requires: hplip
  26. BuildRequires: perl >= 5.12.3
  27. BuildRequires: libxml2-devel
  28. BuildRequires: ghostscript-devel
  29. BuildRequires: autoconf, automake
  30. BuildRequires: mpage
  31. BuildRequires: dbus-devel
  32. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  33. Provides: perl(Foomatic::GrovePath)
  34. # For 'rm' and '/sbin/service' in post
  35. Requires(pre): coreutils initscripts
  36. Obsoletes: foomatic-db < 4.0.0
  37. Obsoletes: foomatic-ppd < 4.0.0
  38. Obsoletes: foomatic-ppd-gimp-print < 4.0.0
  39. Obsoletes: foomatic-ppd-gimp-print-ijs < 4.0.0
  40. Obsoletes: foomatic-ppd-omni < 4.0.0
  41. # We need ghostscript to have the gimp-print-4.2.0 driver, and hpijs 1.1.
  42. Conflicts: ghostscript < 7.05
  43. %description
  44. Foomatic is a comprehensive, spooler-independent database of printers,
  45. printer drivers, and driver descriptions. It contains utilities to
  46. generate driver description files and printer queues for CUPS, LPD,
  47. LPRng, and PDQ using the database. There is also the possibility to
  48. read the PJL options out of PJL-capable laser printers and take them
  49. into account at the driver description file generation.
  50. There are spooler-independent command line interfaces to manipulate
  51. queues (foomatic-configure) and to print files/manipulate jobs
  52. (foomatic printjob).
  53. The site http://www.linuxprinting.org/ is based on this database.
  54. %prep
  55. %setup -q -c -a 1 -a 2
  56. #pushd foomatic-filters-%{filtersver}
  57. #%patch1 -p1 -b .libdir
  58. #popd
  59. pushd foomatic-db-engine-%{enginever}
  60. chmod a+x mkinstalldirs
  61. #%patch2 -p1 -b .libdir
  62. #%patch15 -p1
  63. popd
  64. pushd foomatic-db-%{dbver_snap}
  65. cd db/source
  66. # For gutenprint printers, use gutenprint-ijs-simplified.5.2.
  67. perl -pi -e 's,>gutenprint<,>gutenprint-ijs-simplified.5.2<,' printer/*.xml
  68. # Remove references to foo2zjs, foo2oak, foo2hp and foo2qpdl (bug #208851).
  69. # Also foo2lava, foo2kyo, foo2xqx (bug #438319).
  70. for x in zjs oak hp qpdl lava kyo xqx
  71. do
  72. find printer -name '*.xml' |xargs grep -l "<driver>foo2${x}"|xargs rm -vf
  73. rm -f driver/foo2${x}.xml opt/foo2${x}-*
  74. done
  75. # Same for m2300w/m2400w
  76. find printer -name '*.xml' |xargs grep -l '<driver>m2[34]00w<'|xargs rm -vf
  77. rm -f driver/m2300w.xml driver/m2400w.xml opt/m2300w-*
  78. # Same for all these.
  79. for x in drv_x125 ml85p pbm2lwxl pbmtozjs bjc800j
  80. do
  81. find printer -name '*.xml' |xargs grep -l "<driver>${x}</driver>"|xargs rm -vf
  82. rm -vf driver/${x}.xml opt/${x}-*
  83. done
  84. popd
  85. %build
  86. export LIB_CUPS=%{_libdir}/cups
  87. export CUPS_BACKENDS=%{_libdir}/cups/backend
  88. export CUPS_FILTERS=%{_libdir}/cups/filter
  89. export CUPS_PPDS=%{_datadir}/cups/model
  90. pushd foomatic-filters-%{filtersver}
  91. %configure
  92. make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
  93. INSTALLDIRS=vendor
  94. popd
  95. pushd foomatic-db-engine-%{enginever}
  96. %configure --disable-xmltest
  97. make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
  98. INSTALLDIRS=vendor defaults
  99. make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
  100. INSTALLDIRS=vendor
  101. popd
  102. pushd foomatic-db-%{dbver_snap}
  103. %configure
  104. make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
  105. INSTALLDIRS=vendor
  106. popd
  107. %install
  108. rm -rf %{buildroot}
  109. pushd foomatic-filters-%{filtersver}
  110. eval `perl '-V:installvendorlib' '-V:installvendorarch'`
  111. mkdir -p %{buildroot}/$installvendorlib
  112. echo %{buildroot}
  113. make DESTDIR=%{buildroot} PREFIX=%{_prefix} \
  114. INSTALLDIRS=vendor \
  115. INSTALLVENDORLIB=$installvendorlib \
  116. INSTALLVENDORARCH=$installvendorarch \
  117. install-main install-cups
  118. popd
  119. pushd foomatic-db-engine-%{enginever}
  120. make DESTDIR=%buildroot PREFIX=%{_prefix} \
  121. INSTALLDIRS=vendor \
  122. INSTALLVENDORLIB=$installvendorlib \
  123. INSTALLVENDORARCH=$installvendorarch \
  124. install
  125. popd
  126. pushd foomatic-db-%{dbver_snap}
  127. make DESTDIR=%buildroot PREFIX=%{_prefix} \
  128. INSTALLDIRS=vendor \
  129. INSTALLVENDORLIB=$installvendorlib \
  130. INSTALLVENDORARCH=$installvendorarch \
  131. install
  132. popd
  133. # Remove ghostscript UPP drivers that are gone in 7.07
  134. rm -f %buildroot%{_datadir}/foomatic/db/source/driver/{bjc6000a1,PM760p,PM820p,s400a1,sharp,Stc670pl,Stc670p,Stc680p,Stc760p,Stc777p,Stp720p,Stp870p}.upp.xml
  135. # Remove drivers with no command line.
  136. pushd foomatic-db-engine-%{enginever}
  137. perl -Ilib ./foomatic-cleanupdrivers %buildroot%{_datadir}/foomatic
  138. popd
  139. # Update any old-style printer IDs still left around.
  140. echo '#!/usr/bin/perl -pi' > convert-printerids.pl
  141. sed -e 's|^\(.*\) \(.*\)$|s,printer/\1,printer/\2,g;|' \
  142. %{buildroot}%{_datadir}/foomatic/db/oldprinterids \
  143. >> convert-printerids.pl
  144. chmod a+x convert-printerids.pl
  145. ./convert-printerids.pl %{buildroot}%{_datadir}/foomatic/db/source/{opt,driver}/*.xml
  146. find %{buildroot}%{_datadir}/foomatic/db/source/ -type f | xargs chmod 0644
  147. # Use relative, not absolute, symlink for CUPS filter.
  148. ln -sf ../../../bin/foomatic-rip %{buildroot}%{_libdir}/cups/filter/foomatic-rip
  149. mkdir %{buildroot}%{_datadir}/foomatic/db/source/PPD/Custom
  150. mkdir -p %{buildroot}%{_var}/cache/foomatic
  151. echo cups > %{buildroot}%{_sysconfdir}/foomatic/defaultspooler
  152. # Remove things we don't ship.
  153. rm -rf %{buildroot}%{_libdir}/perl5/site_perl \
  154. %{buildroot}%{_libdir}/ppr \
  155. %{buildroot}%{_sysconfdir}/foomatic/filter.conf.sample
  156. find %{buildroot} -name .packlist -o -name '*.xml.*' | xargs rm -f
  157. %post
  158. /bin/rm -f /var/cache/foomatic/*
  159. # restart the print server if it is running now
  160. /sbin/service lpd condrestart >/dev/null 2>&1
  161. /sbin/service cups condrestart >/dev/null 2>&1
  162. exit 0
  163. %clean
  164. rm -fr %buildroot $RPM_BUILD_DIR/%{name}
  165. %files
  166. %defattr(-,root,root)
  167. %doc --parents */README */USAGE */ChangeLog
  168. %dir %{_sysconfdir}/foomatic
  169. %config(noreplace) %{_sysconfdir}/foomatic/filter.conf
  170. %config(noreplace) %{_sysconfdir}/foomatic/defaultspooler
  171. %{_bindir}/*
  172. %{_sbindir}/*
  173. %{perl_vendorlib}/Foomatic
  174. %{_libdir}/cups/backend/*
  175. %{_libdir}/cups/driver/*
  176. %{_libdir}/cups/filter/*
  177. %{_datadir}/foomatic
  178. %{_datadir}/cups/model/foomatic-db-ppds
  179. %{_mandir}/*/*
  180. %{_var}/cache/foomatic
  181. %changelog
  182. * Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 4.0.11-2
  183. - rebuild with perl-5.16
  184. - add BR: dbus-devel
  185. * Sun Jun 8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.11-1
  186. - new upstream release.
  187. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.9-1
  188. - new upstream release.
  189. * Mon Jun 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
  190. - added hplip and coreutils to "Requires:".
  191. - removed hpijs and fileutils from "Requires:".
  192. * Wed Apr 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
  193. - new upstream release.
  194. - dropped Source3 (no longer provided by upstream).
  195. - updated Patch2.
  196. * Thu Mar 24 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.1-3
  197. - rebuild with perl 5.12.3
  198. * Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.0.1-2
  199. - add Requires: hpijs
  200. * Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
  201. - new upstream release
  202. * Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.0-1
  203. - new upstream release.
  204. - applied some patches from Fedora development.
  205. - remove subpackages.
  206. * Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
  207. - applied new versioning policy
  208. - used rpm macros: %%perl_sitelib %%perl_sitearch
  209. - added foomatic-db-engine-3.1-20050411-combo-xml.patch
  210. - added foomatic-db-engine-3.1-20050411-perl-data.patch
  211. - fixed permission of %%{_datadir}/foomatic/db
  212. * Sat Dec 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.0.2-0vl5
  213. - add BuildRequires: libxml2-devel, mpage, Omni
  214. - use %%{_prefix}/lib/{cups,ppr} instead of %%{_libdir}/{cups,ppr}
  215. - run foomatic-cleanupdrivers, foomatic-compiledb with 'perl -Ilib'
  216. - not create ppd-omni package if omni support is disabled
  217. * Mon Apr 11 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl4
  218. - updated foomatic-db to 20050411
  219. - updated foomatic-db-engine to 3.1-20050411
  220. - updated foomatic-db-hpijs to 1.5-20050411
  221. - updated foomatic-filters to 3.1-20050411
  222. * Wed Jan 12 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl3
  223. - updated foomatic-db to 20050112
  224. - updated foomatic-db-engine to 3.1-20050112
  225. - updated foomatic-db-hpijs to 1.5-20050112
  226. * Tue Dec 21 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl2
  227. - updated foomatic-db to 20041220
  228. - updated foomatic-db-hpijs to 1.5-20041220
  229. * Sun Sep 19 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl1
  230. - updated foomatic-db to 20040919
  231. - updated foomatic-db-engine to 3.0.2
  232. - updated foomatic-db-hpijs to 1.5-20040919
  233. - updated foomatic-filters to 3.0.2
  234. * Wed May 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl4
  235. - update foomatic-db to 20040526
  236. - update foomatic-db-hpijs to 1.5-20040526
  237. * Tue May 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl3
  238. - sprit foomatic-ppd to ppd,ppd-hpijs,ppd-omni,ppd-gimp-print,
  239. ppd-gimp-print-ijs
  240. - add Requires: to ppd-* subpackages.
  241. * Thu Apr 15 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.1-0vl2
  242. - new upstream version
  243. -- Omni-printers-0.9.1
  244. -- gimp-print-foomatic-db-4.2.6
  245. - foomatic.spec -> foomatic-vl.spec
  246. * Fri Feb 20 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.1-0vl1
  247. - new upstream version
  248. -- foomatic-filters-3.0.1
  249. -- foomatic-db-engine-3.0.1
  250. -- foomatic-db-20040219
  251. -- foomatic-db-hpijs-1.5-20040219
  252. * Mon Jan 26 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl11
  253. - new upstream version
  254. -- foomatic-filters-3.0.1rc3(bug fix. in configure script)
  255. -- defined filterver
  256. - dropped patch101
  257. * Sun Jan 25 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl10
  258. - new upstream cvs version(foomatic-3.0.1rc2)
  259. -- foomatic-db-20040125
  260. -- foomatic-db-engine-3.0.1rc2
  261. -- foomatic-db-hpijs-1.5-20040125
  262. -- foomatic-filters-3.0.1rc2
  263. - added patch101
  264. -- tests diris null in foomatic-filters-3.0.1rc2
  265. * Fri Jan 23 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl9
  266. - new upstream cvs version
  267. -- foomatic-db-20040123
  268. -- foomatic-db-engine-3.0-20040123
  269. -- foomatic-db-hpijs-1.5-20040123
  270. -- foomatic-filters-3.0-20040123
  271. - dropped old patches
  272. * Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl8
  273. - built on perl-5.8.2
  274. * Tue Nov 11 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl7
  275. - separated foomatic-db package included xml files
  276. * Mon Nov 10 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl6
  277. - added description of ppd sub package
  278. * Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl5
  279. - separated foomatic-ppd package included PPD files
  280. * Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl4
  281. - new upstream version
  282. -- foomatic-db-20031109, foomatic-db-engine-3.0-20031109
  283. -- foomatic-filters-3.0-20031109, foomatic-db-hpijs-1.4-1
  284. - dropped patches
  285. -- foomatic-filters-path.patch(patch0)
  286. -- foomatic-2.0.2-fontpath.patch(patch3)
  287. - updated patches
  288. -- foomatic-filters-3.0-20031109-libdir.patch (patch1)
  289. -- foomatic-db-engine-3.0-20031109-libdir.patch (patch2)
  290. -- foomatic-filters-3.0-20031109-vine.patch (patch100)
  291. * Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl3
  292. - built on perl-5.8.1
  293. - fixed install section in spec file
  294. * Sat Aug 30 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 3.0.0-0vl2
  295. - fix some bugs of foomatic-filters.
  296. A
  297. * Sat Jun 07 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl1
  298. - new upstream version
  299. -- rewrote spec file
  300. -- added some patches from rawhide(foomatic-3.0.0-5)
  301. - enable cups support
  302. * Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl2
  303. - imported some patches from foomatic-2.0.2-18
  304. -- added foomatic-2.0.2-psc2210.patch
  305. -- added foomatic-2.0.2-duplex184.patch
  306. * Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl1
  307. - imported foomatic-2.0.2-15
  308. * Tue Feb 4 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-15
  309. - Update data-generators to CVS.
  310. * Thu Jan 30 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-14
  311. - Use hpijs, not hpijs-rss (we don't ship the RSS patch now).
  312. * Thu Jan 23 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-13
  313. - Pacify printers that don't understand duplex (bug #82385).
  314. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.2-12
  315. - rebuilt
  316. * Tue Jan 21 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-11
  317. - Add autodetect info for HP DeskJet 656C. It doesn't really do
  318. IEEE 1284 IDs, but since it's a USB device we can figure out it's
  319. manufacturer and model anyway.
  320. * Thu Jan 9 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-10
  321. - Set GS_FONTPATH in gs wrapper (bug #81410).
  322. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.2-9
  323. - use internal dep generator.
  324. * Sun Dec 15 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-8
  325. - Add several device IDs.
  326. * Sat Dec 14 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-7
  327. - Update Omni printers to 0.7.2.
  328. - No longer need Omni badxml patch.
  329. * Sat Dec 14 2002 Tim Powers <timp@redhat.com> 2.0.2-6
  330. - don't use rpms internal dep generator
  331. * Fri Dec 6 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-5
  332. - Omni XML wasn't well-formed.
  333. * Wed Nov 20 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-4
  334. - Update gimp-print data.
  335. - Add 'generic postscript' model.
  336. * Mon Nov 11 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-3
  337. - Update Omni printers to 0.7.1.
  338. * Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-2
  339. - Fix file manifest for perl modules.
  340. - Add autodetect information for HP DeskJet 990C.
  341. * Mon Oct 21 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-1
  342. - 2.0.2.
  343. - No longer need 67973, 970c patches.
  344. - Remove cups-drivers-* packages (no longer needed).
  345. - Remove files not shipped. Ship filter.conf.
  346. - Conditionally restart cups.
  347. - Use libdir.
  348. - Don't put things in site_perl; use vendor_perl instead (bug #73528).
  349. * Fri Aug 9 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.6
  350. - Fix autodetect information for HPDJ970C.
  351. * Thu Aug 8 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.5
  352. - For gimp-print, use the Ghostscript stp driver in preference to the
  353. IJS interface.
  354. * Thu Jul 25 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.4
  355. - Quieten scriptlets.
  356. * Fri Jul 5 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.3
  357. - Fix autodetect information for HPLJ2100/2100M.
  358. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.9-1.20020617.2
  359. - automated rebuild
  360. * Wed Jun 19 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.2
  361. - Omni 0.7.0 printers.
  362. * Mon Jun 17 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.1
  363. - Update to CVS.
  364. - Remove some more explicit perl dependencies that are picked up
  365. automatically.
  366. * Wed May 29 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.3
  367. - Remove explicit perl-Storable dependency; it should be perl(Storable),
  368. and that is picked up automatically.
  369. * Tue May 28 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.2
  370. - Fix release number.
  371. - Drop gen-ppds from the file manifest---use foomatic-compiledb instead
  372. (bug #63622).
  373. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  374. - automated rebuild
  375. * Thu May 23 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.1
  376. - Remove ghostscript UPP drivers that are gone in 7.05.
  377. * Sat May 18 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.0.1
  378. - Update to CVS.
  379. - Updated requirements.
  380. - Updated path and libdir patches.
  381. - Drop hpijs 1.0.2 patch.
  382. - foomatic-datafile has moved to %%{_bindir}.
  383. - Update gimp-print data to 4.2.1.
  384. - Update Omni printer data to 0.6.1.
  385. * Thu Apr 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.3
  386. - Fix the hpijs option data too (bug #62587).
  387. * Wed Apr 3 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.2
  388. - Back off to 1.0.2 for hpijs driver data (bug #62587).
  389. * Thu Mar 14 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.1
  390. - Update to CVS.
  391. * Wed Mar 6 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020306.1
  392. - Update to CVS.
  393. - Patches no longer needed: conffile, sys, cachedir, fd0.
  394. - Adapted path patch.
  395. * Tue Mar 5 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.10
  396. - Fix bug #58319.
  397. - Drop dbg patch.
  398. * Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.9
  399. - Fix file lists.
  400. * Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.8
  401. - Fix %post scriplet bug (bug #59942).
  402. * Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.7
  403. - Rebuild in new environment.
  404. * Wed Feb 13 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.6
  405. - Merge cups-drivers. No epoch needed.
  406. - Require perl-URI.
  407. * Wed Feb 06 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.5
  408. - Cache fix.
  409. * Mon Feb 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.4
  410. - Don't ship backup files.
  411. * Mon Feb 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.3
  412. - Rebuild to pick up new perl installsitelib.
  413. * Thu Jan 31 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.2
  414. - Fix a thinko in DB.pl.
  415. * Wed Jan 30 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.1
  416. - Update to CVS.
  417. - No longer need the cachedir patch.
  418. - Fix config file path.
  419. - Look in /usr/local/bin last, not first, in lpdomatic (bug #57915).
  420. * Tue Jan 29 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020129.1
  421. - Update to CVS.
  422. - Patches no longer needed: prepend, fd3.
  423. - Use RPM_OPT_FLAGS.
  424. - Allow non-root users to use foomatic-datafile (bug #58956).
  425. * Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com> 1.1-0.20020124.2
  426. - added Provides: perl(Foomatic::GrovePath)
  427. * Thu Jan 24 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020124.1
  428. - Update to CVS.
  429. - Updated Omni printers to those in Omni 0.5.1.
  430. - Updated patches: prepend, fd3.
  431. - Patches no longer needed: utf8, lpdomatic.
  432. - Added gimp-print (formerly stp) foomatic db info, and removed the old
  433. stp.xml file.
  434. - Conflict with ghostscript if it doesn't have gimp-print-4.2.0 yet.
  435. * Fri Jan 18 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20011218.2
  436. - REALLY fix PCL fixup code (bug #55909, others).
  437. - PreReq fileutils, initscripts (bug #56984).
  438. - Fix prepends in lpdomatic (bug #57371).
  439. - Run foomatic-cleanupdrivers during install, to remove driver entries
  440. with no command line.
  441. - Put lpdomatic in /usr/sbin again.
  442. - Fix foomatic-gswrapper's file descriptor manipulations (bug #56871).
  443. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011218.1
  444. - re-imported from upstream to fix some perl fixup code on pcl printers.
  445. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.2
  446. - fix the rest of the quoting issues with foomatic-combo-xml with the patch
  447. - foomatic-1.1-20011217-quotes.patch. This has been sent upstream.
  448. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.1
  449. - respin to pull in latest foomatic database, fixes:
  450. - properly use the cache in relation to foomatic-combo-xml's output
  451. - fix _some_ of the quoting issues with calling foomatic-combo-xml
  452. * Wed Dec 5 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011205.1
  453. - respin to pull in latest foomatic database, fixes:
  454. - droping half of a large job
  455. - -Mutf8 added to the upstream filters
  456. - miscelaneous printer db updates
  457. * Thu Nov 29 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.8
  458. - added Requires: fileutils for the 'rm' in post
  459. * Mon Nov 26 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.7
  460. - /var/chache => /var/cache, doh!
  461. * Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 1.1-0.20011018.6
  462. - fix %%post scriptlet
  463. * Tue Nov 13 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.5
  464. - changed the patch to use the -Mutf8 command line option,
  465. - and to restart the printserver, after rebuilding the settings.
  466. * Fri Nov 9 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.4
  467. - grumble. Some drivers use inline perl scripts, and need the 'use utf8;'
  468. - pragma. Without it, they break on _some_ of their options.
  469. * Wed Oct 31 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.3
  470. - patched lpdomatic to prepend PostScript options in the _right_ place.
  471. * Thu Oct 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.2
  472. - zap the foomatic cache on install
  473. * Thu Oct 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.1
  474. - rolled to pull in latest information.
  475. - added Omni printers to the printer list.
  476. * Fri Oct 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011005.1
  477. - rolled to pull in an ia64 fix to foomatic-combo-xml.c
  478. * Mon Oct 01 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011001.1
  479. - rolled to pull in foomatic fixes to foomatic-combo-xml.c
  480. * Wed Sep 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010905.1
  481. - upgraded to latest foomatic, we now have fast overview generation!
  482. - this means that there is no prebuilt overview file.
  483. * Tue Aug 28 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010828.1
  484. - WOW! The latest foomatic uses Till Kamppeter's C based combo compiler.
  485. - It is now fast enough that there is no real benifit to precompiling.
  486. - NOTE: this forces the package to stop being noarched.
  487. * Mon Aug 27 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010827.1
  488. - fresh pull, maybe it fixes the build errors.
  489. * Sat Aug 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010825.1
  490. - did a fresh database pull, which contains the old japanese printers as well.
  491. - removed japanese hack.
  492. * Tue Aug 14 2001 Akira TAGOH <tagoh@redhat.com> 1.1-0.20010717.5
  493. - Add Japanese printer entry.
  494. * Mon Aug 6 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.4
  495. - move the cache back to /var, sigh.
  496. * Mon Jul 23 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.2
  497. - made foomatic pre-compute its db
  498. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.1
  499. - imported from mandrake.
  500. * Tue Jul 17 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010717mdk
  501. - Added job listing/removal/manipulation and queue control to
  502. foomatic-printjob
  503. - Support for printing multiple copies with PDQ
  504. * Sat Jul 14 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010714mdk
  505. - Included the cupsomatic filter script
  506. - When a queue is set up, default options can be set now
  507. - Help messages of foomatic-configure and foomatic-printjob cleaned up.
  508. * Fri Jul 13 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010713mdk
  509. - Many bugfixes in "foomatic-printjob".
  510. - "foomatic-configure" adds the Foomatic config file directory automatically
  511. to the search paths of PDQ.
  512. - Printing a help page under PDQ was broken.
  513. * Thu Jul 12 2001 Stefan van der Eijk <stefan@eijk.nu> 1.1-0.20010712mdk
  514. - BuildRequires: perl-devel
  515. * Wed Jul 11 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010711mdk
  516. - initial release.
  517. - Deleted the obsolete drivers "stp", "cZ11", and "hpdj".
  518. - Patch applied which flushes the memory cache regularly, otherwise
  519. foomatic-configure would hang when the Foomatic data of GIMP-Print is
  520. installed.