libjpeg-turbo-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A MMX/SSE2/SIMD accelerated library for manipulating JPEG image files
  3. Summary(ja): MMX/SSE2/SIMD でアクセラレーションされた libjpeg ライブラリ
  4. Name: libjpeg-turbo
  5. Version: 2.1.3
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: IJG
  11. URL: http://sourceforge.net/projects/libjpeg-turbo
  12. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  13. Patch0: libjpeg-turbo-cmake.patch
  14. Patch1: libjpeg-turbo-CET.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: cmake
  17. %ifarch %{ix86} x86_64
  18. BuildRequires: nasm
  19. %endif
  20. Obsoletes: libjpeg < 6b-50vl6
  21. Provides: libjpeg = 6b-50vl6
  22. %description
  23. The libjpeg-turbo package contains a library of functions for manipulating
  24. JPEG images
  25. %package devel
  26. Summary: Headers for the libjpeg-turbo library
  27. Summary(ja): libjpeg-turbo ライブラリのヘッダファイル
  28. Group: programming
  29. Obsoletes: libjpeg-devel < 6b-50vl6
  30. Obsoletes: libjpeg-static < 6b-50vl6
  31. Provides: libjpeg-devel = 6b-50vl6
  32. Requires: libjpeg-turbo = %{version}-%{release}
  33. %description devel
  34. This package contains header files necessary for developing programs which
  35. will manipulate JPEG files using the libjpeg-turbo library
  36. %package utils
  37. Summary: Utilities for manipulating JPEG images
  38. Summary(ja): JPEG イメージを操作するためのユーティリティ
  39. Group: graphics
  40. Requires: libjpeg-turbo = %{version}-%{release}
  41. %description utils
  42. The libjpeg-turbo-utils package contains simple client programs for
  43. accessing the libjpeg functions. It contains cjpeg, djpeg, jpegtran,
  44. rdjpgcom and wrjpgcom. Cjpeg compresses an image file into JPEG format.
  45. Djpeg decompresses a JPEG file into a regular image file. Jpegtran
  46. can perform various useful transformations on JPEG files. Rdjpgcom
  47. displays any text comments included in a JPEG file. Wrjpgcom inserts
  48. text comments into a JPEG file.
  49. ## to build compat32 for x86_64 architecture support
  50. %package -n compat32-%{name}
  51. Summary: A MMX/SSE2 accelerated library for manipulating JPEG image files
  52. Summary(ja): MMX/SSE2 でアクセラレーションされた libjpeg ライブラリ
  53. Group: system,legacy
  54. Obsoletes: compat32-libjpeg < 6b-50vl6
  55. Provides: compat32-libjpeg = 6b-50vl6
  56. %description -n compat32-%{name}
  57. The libjpeg-turbo package contains a library of functions for manipulating
  58. JPEG images
  59. %package -n compat32-%{name}-devel
  60. Summary: Headers for the libjpeg-turbo library
  61. Summary(ja): libjpeg-turbo ライブラリのヘッダファイル
  62. Group: programming,legacy
  63. Obsoletes: compat32-libjpeg-devel < 6b-50vl6
  64. Provides: compat32-libjpeg-devel = 6b-50vl6
  65. Requires: libjpeg-turbo = %{version}-%{release}
  66. %description -n compat32-%{name}-devel
  67. This package contains header files necessary for developing programs which
  68. will manipulate JPEG files using the libjpeg-turbo library
  69. %debug_package
  70. %prep
  71. %setup -q
  72. %patch0 -p1
  73. %patch1 -p1
  74. %build
  75. %ifarch %{ix86} x86_64
  76. export LDFLAGS="$RPM_LD_FLAGS -Wl,-z,ibt -Wl,-z,shstk"
  77. %endif
  78. mkdir jpeg6
  79. pushd jpeg6
  80. %{cmake} \
  81. -DCMAKE_SKIP_RPATH:BOOL=YES \
  82. -DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES \
  83. -DENABLE_STATIC:BOOL=NO \
  84. ..
  85. %cmake_build
  86. popd
  87. mkdir jpeg8
  88. pushd jpeg8
  89. %{cmake} \
  90. -DWITH_JPEG8=YES \
  91. -DCMAKE_SKIP_RPATH:BOOL=YES \
  92. -DCMAKE_SKIP_INSTALL_RPATH:BOOL=YES \
  93. -DENABLE_STATIC:BOOL=NO \
  94. ..
  95. %cmake_build
  96. popd
  97. # Fix perms
  98. chmod -x README.md
  99. %install
  100. rm -rf %{buildroot}
  101. pushd jpeg6
  102. %cmake_install
  103. popd
  104. rm -rf %{buildroot}%{_mandir}/*
  105. rm -f %{buildroot}%{_includedir}/*
  106. rm -f %{buildroot}%{_bindir}/*
  107. rm -f %{buildroot}%{_libdir}/pkgconfig/*
  108. rm -f %{buildroot}%{_libdir}/lib*.so
  109. pushd jpeg8
  110. %cmake_install
  111. popd
  112. # Remove unwanted files
  113. rm -f %{buildroot}/%{_libdir}/lib{,turbo}jpeg.la
  114. %check
  115. export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
  116. pushd jpeg6
  117. %ctest
  118. popd
  119. pushd jpeg8
  120. %ctest
  121. popd
  122. %clean
  123. rm -rf %{buildroot}
  124. %files
  125. %defattr(-,root,root,-)
  126. %license LICENSE.md
  127. %doc README.md README.ijg ChangeLog.md
  128. %{_libdir}/libjpeg.so.*
  129. %{_libdir}/libturbojpeg.so.*
  130. %files devel
  131. %defattr(-,root,root,-)
  132. %doc coderules.txt jconfig.txt libjpeg.txt structure.txt
  133. %{_includedir}/jconfig.h
  134. %{_includedir}/jerror.h
  135. %{_includedir}/jmorecfg.h
  136. %{_includedir}/jpegint.h
  137. %{_includedir}/jpeglib.h
  138. %{_includedir}/turbojpeg.h
  139. %{_libdir}/libjpeg.so
  140. %{_libdir}/libturbojpeg.so
  141. %{_libdir}/pkgconfig/libjpeg.pc
  142. %{_libdir}/pkgconfig/libturbojpeg.pc
  143. %{_libdir}/cmake/libjpeg-turbo
  144. %files utils
  145. %defattr(-,root,root,-)
  146. %doc usage.txt wizard.txt
  147. %{_bindir}/cjpeg
  148. %{_bindir}/djpeg
  149. %{_bindir}/jpegtran
  150. %{_bindir}/rdjpgcom
  151. %{_bindir}/wrjpgcom
  152. %{_mandir}/man1/cjpeg.1*
  153. %{_mandir}/man1/djpeg.1*
  154. %{_mandir}/man1/jpegtran.1*
  155. %{_mandir}/man1/rdjpgcom.1*
  156. %{_mandir}/man1/wrjpgcom.1*
  157. ## to build compat32 for x86_64 architecture support
  158. %if %{build_compat32}
  159. %files -n compat32-%{name}
  160. %defattr(-,root,root)
  161. %{_libdir}/libjpeg.so.*
  162. %{_libdir}/libturbojpeg.so.*
  163. %files -n compat32-%{name}-devel
  164. %defattr(-,root,root)
  165. %{_libdir}/*.so
  166. %endif
  167. %changelog
  168. * Sat Feb 26 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.3-1
  169. - new upstream release.
  170. * Sat Nov 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.2-1
  171. - new upstream release.
  172. * Fri Oct 15 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
  173. - new upstream release.
  174. * Fri Jun 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
  175. - new upstream release.
  176. - dropped ldconfig scriptlets.
  177. - updated Patch0 and 1.
  178. * Tue Dec 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.6-1
  179. - new upstream release.
  180. * Wed Sep 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.5-1
  181. - new upstream release.
  182. - dropped Patch1000: fixed in upstream.
  183. * Mon Jun 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-2
  184. - added Patch1000 to fix CVE-2020-13790.
  185. * Mon Feb 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-1
  186. - new upstream release.
  187. * Sat Oct 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.3-2
  188. - built both of libjpeg.so.62 and libjpeg.so.8.
  189. * Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.3-1
  190. - new upstream release.
  191. - dropped all patches.
  192. - imported Patch0 and 1 from rawhide.
  193. * Tue Dec 19 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.5.3-1
  194. - update to 1.5.3
  195. - update Patch0,doc
  196. * Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  197. - update to 1.4.2
  198. - update Patch0
  199. * Sun Sep 07 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.3.1-1
  200. - update to 1.3.1
  201. - ship turbojpeg library and headers
  202. * Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-2
  203. - rebuild with VineSeed environment
  204. * Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  205. - new upstream release
  206. * Tue Mar 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
  207. - new upstream release
  208. * Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  209. - initial build for Vine Linux
  210. * Wed Aug 04 2010 Adam Tkac <atkac redhat com> 1.0.0-3
  211. - fix huffman decoder to handle broken JPEGs well (#617469)
  212. * Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-2
  213. - add libjpeg-devel%%{_isa} provides to -devel subpkg to satisfy imlib-devel
  214. deps
  215. * Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-1
  216. - update to 1.0.0
  217. - patches merged
  218. - libjpeg-turbo-programs.patch
  219. - libjpeg-turbo-nosimd.patch
  220. - add libjpeg provides to the main package to workaround problems with broken
  221. java-1.6.0-openjdk package
  222. * Fri Jul 02 2010 Adam Tkac <atkac redhat com> 0.0.93-13
  223. - remove libjpeg provides from -utils subpkg
  224. * Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-12
  225. - move Obsoletes: libjpeg to main pkg
  226. * Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-11
  227. - -utils: Requires: %%name ...
  228. * Wed Jun 30 2010 Adam Tkac <atkac redhat com> 0.0.93-10
  229. - add Provides = libjpeg to -utils subpackage
  230. * Mon Jun 28 2010 Adam Tkac <atkac redhat com> 0.0.93-9
  231. - merge review related fixes (#600243)
  232. * Wed Jun 16 2010 Adam Tkac <atkac redhat com> 0.0.93-8
  233. - merge review related fixes (#600243)
  234. * Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-7
  235. - obsolete -static libjpeg subpackage (#600243)
  236. * Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-6
  237. - improve package description a little (#600243)
  238. - include example.c as %%doc in the -devel subpackage
  239. * Fri Jun 11 2010 Adam Tkac <atkac redhat com> 0.0.93-5
  240. - don't use "fc12" disttag in obsoletes/provides (#600243)
  241. * Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-4
  242. - fix compilation on platforms without MMX/SSE (#600243)
  243. * Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-3
  244. - package review related fixes (#600243)
  245. * Wed Jun 09 2010 Adam Tkac <atkac redhat com> 0.0.93-2
  246. - package review related fixes (#600243)
  247. * Fri Jun 04 2010 Adam Tkac <atkac redhat com> 0.0.93-1
  248. - initial package