imake-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214
  1. Summary: imake source code configuration and build system
  2. Name: imake
  3. Version: 1.0.4
  4. Release: 1%{?_dist_release}
  5. License: MIT/X11
  6. Group: User Interface/X
  7. URL: http://www.x.org
  8. Source0: ftp://ftp.x.org/pub/individual/util/imake-1.0.4.tar.bz2
  9. Source1: ftp://ftp.x.org/pub/individual/util/makedepend-1.0.3.tar.bz2
  10. Source2: ftp://ftp.x.org/pub/individual/util/gccmakedep-1.0.2.tar.bz2
  11. Source3: ftp://ftp.x.org/pub/individual/util/xorg-cf-files-1.0.3.tar.bz2
  12. Source4: ftp://ftp.x.org/pub/individual/util/lndir-1.0.2.tar.bz2
  13. Patch0: xorg-cf-files-1.0.0-misc.patch
  14. Patch1: xorg-cf-files-1.0.0-ProjectRoot.patch
  15. Patch2: xorg-cf-files-1.0.3-redhat.patch
  16. Patch3: xorg-cf-files-1.0.3-xprint.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. BuildRequires: pkgconfig
  19. BuildRequires: xorg-x11-util-macros
  20. BuildRequires: xorg-x11-proto-devel
  21. Provides: ccmakedep cleanlinks gccmakedep imake lndir makedepend makeg
  22. Provides: mergelib mkdirhier mkhtmlindex revpath xmkmf
  23. %description
  24. Imake is a deprecated source code configuration and build system which
  25. has traditionally been supplied by and used to build the X Window System
  26. in X11R6 and previous releases. As of the X Window System X11R7 release,
  27. the X Window system has switched to using GNU autotools as the primary
  28. build system, and the Imake system is now deprecated, and should not be
  29. used by new software projects. Software developers are encouraged to
  30. migrate software to the GNU autotools system.
  31. %prep
  32. %setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
  33. #%patch0 -p0 -b .imake
  34. #%patch1 -p0 -b .ProjectRoot
  35. %patch2 -p0 -b .redhat
  36. %patch3 -p0 -b .xprint
  37. %build
  38. # Build everything
  39. {
  40. for pkg in imake makedepend gccmakedep lndir xorg-cf-files ; do
  41. pushd $pkg-*
  42. case $pkg in
  43. imake|xorg-cf-files)
  44. %configure --with-config-dir=%{_datadir}/X11/config
  45. ;;
  46. *)
  47. %configure
  48. ;;
  49. esac
  50. make
  51. popd
  52. done
  53. }
  54. %install
  55. rm -rf $RPM_BUILD_ROOT
  56. # Install everything
  57. {
  58. for pkg in imake makedepend gccmakedep lndir xorg-cf-files ; do
  59. pushd $pkg-*
  60. case $pkg in
  61. # xorg-cf-files)
  62. # make install DESTDIR=$RPM_BUILD_ROOT libdir=%{_datadir}
  63. # ;;
  64. *)
  65. make install DESTDIR=$RPM_BUILD_ROOT
  66. ;;
  67. esac
  68. popd
  69. done
  70. }
  71. %clean
  72. rm -rf $RPM_BUILD_ROOT
  73. %files
  74. %defattr(-,root,root,-)
  75. %doc
  76. %{_bindir}/ccmakedep
  77. %{_bindir}/cleanlinks
  78. %{_bindir}/gccmakedep
  79. %{_bindir}/imake
  80. %{_bindir}/lndir
  81. %{_bindir}/makedepend
  82. %{_bindir}/makeg
  83. %{_bindir}/mergelib
  84. %{_bindir}/mkdirhier
  85. %{_bindir}/mkhtmlindex
  86. %{_bindir}/revpath
  87. %{_bindir}/xmkmf
  88. %dir %{_datadir}/X11
  89. %dir %{_datadir}/X11/config
  90. %{_datadir}/X11/config/*.cf
  91. %{_datadir}/X11/config/*.def
  92. %{_datadir}/X11/config/*.rules
  93. %{_datadir}/X11/config/*.tmpl
  94. #%dir %{_mandir}/man1x
  95. %{_mandir}/man1/ccmakedep.1.*
  96. %{_mandir}/man1/cleanlinks.1.*
  97. %{_mandir}/man1/gccmakedep.1x.*
  98. %{_mandir}/man1/imake.1.*
  99. %{_mandir}/man1/lndir.1.*
  100. %{_mandir}/man1/makedepend.1.*
  101. %{_mandir}/man1/makeg.1.*
  102. %{_mandir}/man1/mergelib.1.*
  103. %{_mandir}/man1/mkdirhier.1.*
  104. %{_mandir}/man1/mkhtmlindex.1.*
  105. %{_mandir}/man1/revpath.1.*
  106. %{_mandir}/man1/xmkmf.1.*
  107. %changelog
  108. * Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
  109. - imake-1.0.4
  110. - lndir-1.0.2
  111. - makedepend-1.0.3
  112. - xorg-cf-files-1.0.3
  113. - update Patch2 (xorg-cf-files-1.0.3-redhat.patch)
  114. - update Patch3 (xorg-cf-files-1.0.3-xprint.patch)
  115. - fix %%files
  116. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.2-2
  117. - rebuilt with new toolchain
  118. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  119. - new versioning policy
  120. * Fri Jan 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
  121. - initial build for Vine Linux
  122. * Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-5
  123. - Rebuild for build id
  124. * Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 1.0.2-4
  125. - makedepend 1.0.1
  126. * Tue Jul 18 2006 Than Ngo <than@redhat.com> 1.0.2-3
  127. - cleanup patch files
  128. - update source files
  129. * Fri Jul 14 2006 Jesse Keating <jkeating@redhat.com> - 1.0.2-2
  130. - rebuild
  131. * Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-1
  132. - Update to imake-1.0.2, gccmakedep-1.0.2, xorg-cf-files-1.0.2
  133. * Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-4
  134. - Fix ExtraXawReqs to reflect reality (libXp is unneeded)
  135. * Mon Mar 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-3
  136. - Updated xorg-cf-files-1.0.1-redhat.patch with fix for (#178177)
  137. * Wed Mar 01 2006 Karsten Hopp <karsten@redhat.de> 1.0.1-2
  138. - Buildrequires: xorg-x11-proto-devel
  139. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
  140. - bump again for double-long bug on ppc(64)
  141. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
  142. - rebuilt for new gcc4.1 snapshot and glibc changes
  143. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
  144. - Updated all packages to version 1.0.1 from X11R7.0
  145. * Wed Dec 21 2005 Than Ngo <than@redhat.com> 1.0.0-4
  146. - final fix for #173593
  147. * Tue Dec 20 2005 Than Ngo <than@redhat.com> 1.0.0-3
  148. - add correct XAppLoadDir #173593
  149. - add more macros for fedora
  150. * Mon Dec 19 2005 Than Ngo <than@redhat.com> 1.0.0-2
  151. - add some macros to fix problem in building of manpages
  152. * Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
  153. - Updated all packages to version 1.0.0 from X11R7 RC4
  154. - Added new lndir, gccmakedep tarballs. (#173478)
  155. - Changed manpage dirs from man1x to man1 to match upstream RC4 default.
  156. - Removed all previous 'misc' patch, as we now pass --with-config-dir to
  157. configure to specify the location of the Imake config files.
  158. - Renamed imake patch to xorg-cf-files-1.0.0-ProjectRoot.patch as it did not
  159. patch imake at all. This should probably be changed to be a custom Red Hat
  160. host.def file that is added as a source line instead of randomly patching
  161. various files.
  162. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> 0.99.2-5.1
  163. - rebuilt
  164. * Mon Nov 28 2005 Than Ngo <than@redhat.com> 0.99.2-5
  165. - add correct ProjectRoot for modular X
  166. * Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-4
  167. - add missing host.conf
  168. * Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-3
  169. - fix typo
  170. * Wed Nov 16 2005 Than Ngo <than@redhat.com> 0.99.2-2
  171. - fix xmkmf to look config files in /usr/share/X11/config
  172. instead /usr/%%{_lib}/X11/config/
  173. - add host.conf
  174. * Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
  175. - Updated to imake-0.99.2, xorg-cf-files-0.99.2, makedepend-0.99.2 from
  176. X11R7 RC2.
  177. * Thu Nov 10 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-1
  178. - Initial build.