xorg-x11-apps-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337
  1. %define pkgname apps
  2. Summary: X.Org X11 applications
  3. Summary(ja): X.Org X11 アプリケーション
  4. Name: xorg-x11-%{pkgname}
  5. # NOTE: The package version should be set to the X11 major release from which
  6. # the OS release is based upon.
  7. Version: 7.5
  8. Release: 4%{?_dist_release}
  9. License: MIT/X11
  10. Group: User Interface/X
  11. URL: http://www.x.org
  12. # Clock apps
  13. Source0: ftp://ftp.x.org/pub/individual/app/oclock-1.0.2.tar.bz2
  14. Source1: ftp://ftp.x.org/pub/individual/app/xclock-1.0.5.tar.bz2
  15. # X Window Dump (xwd) utilities
  16. Source2: ftp://ftp.x.org/pub/individual/app/xwd-1.0.4.tar.bz2
  17. Source3: ftp://ftp.x.org/pub/individual/app/xwud-1.0.3.tar.bz2
  18. Source4: ftp://ftp.x.org/pub/individual/app/xpr-1.0.3.tar.bz2
  19. # Miscellaneous other applications
  20. Source5: ftp://ftp.x.org/pub/individual/app/luit-1.1.0.tar.bz2
  21. Source6: ftp://ftp.x.org/pub/individual/app/x11perf-1.5.2.tar.bz2
  22. Source7: ftp://ftp.x.org/pub/individual/app/xbiff-1.0.2.tar.bz2
  23. Source8: ftp://ftp.x.org/pub/individual/app/xclipboard-1.1.1.tar.bz2
  24. Source9: ftp://ftp.x.org/pub/individual/app/xconsole-1.0.4.tar.bz2
  25. Source10: ftp://ftp.x.org/pub/individual/app/xcursorgen-1.0.4.tar.bz2
  26. Source11: ftp://ftp.x.org/pub/individual/app/xeyes-1.1.1.tar.bz2
  27. Source12: ftp://ftp.x.org/pub/individual/app/xkill-1.0.3.tar.bz2
  28. Source13: ftp://ftp.x.org/pub/individual/app/xload-1.1.0.tar.bz2
  29. Source14: ftp://ftp.x.org/pub/individual/app/xlogo-1.0.3.tar.bz2
  30. Source15: ftp://ftp.x.org/pub/individual/app/xmag-1.0.4.tar.bz2
  31. Source16: ftp://ftp.x.org/pub/individual/app/xmessage-1.0.3.tar.bz2
  32. Source17: ftp://ftp.x.org/pub/individual/app/xinput-1.5.3.tar.bz2
  33. Source18: ftp://ftp.x.org/pub/individual/app/xcalc-1.0.4.tar.bz2
  34. Patch2: xconsole-1.0.3-streams-me-softer.patch
  35. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  36. BuildRequires: autoconf, automake
  37. BuildRequires: pkgconfig
  38. BuildRequires: xorg-x11-util-macros
  39. BuildRequires: xorg-x11-xbitmaps
  40. BuildRequires: zlib-devel
  41. BuildRequires: libfontenc-devel
  42. BuildRequires: libX11-devel
  43. BuildRequires: libXmu-devel
  44. BuildRequires: libXext-devel
  45. BuildRequires: libXt-devel
  46. BuildRequires: libXaw-devel
  47. BuildRequires: libXpm-devel
  48. BuildRequires: libXft-devel
  49. BuildRequires: libXrender-devel
  50. BuildRequires: libxkbfile-devel
  51. BuildRequires: libXcursor-devel
  52. BuildRequires: libpng-devel
  53. BuildRequires: libXfixes-devel
  54. BuildRequires: libXi-devel
  55. Requires(pre): xorg-x11-filesystem
  56. Provides: luit oclock x11perf xbiff xclipboard xclock xconsole xcursorgen
  57. Provides: xeyes xkill xload xlogo xmag xmessage xpr xwd xwud xinput xcalc
  58. # NOTE: xwd, xwud, luit used to be in these.
  59. Obsoletes: XFree86, XOrg
  60. # NOTE: x11perf, xclipboard used to be in these.
  61. Obsoletes: XFree86-tools, XOrg-tools
  62. %description
  63. A collection of common X Window System applications.
  64. %prep
  65. %setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a11 -a12 -a13 -a14 -a15 -a16 -a17 -a18
  66. ## %patch2 -p0 -b .streams-me-softer
  67. %build
  68. # Build all apps
  69. {
  70. for app in * ; do
  71. pushd $app
  72. case $app in
  73. x11perf*)
  74. aclocal ; automake ; autoconf
  75. ;;
  76. luit*)
  77. autoconf
  78. ;;
  79. esac
  80. %configure --disable-xprint
  81. make
  82. popd
  83. done
  84. }
  85. %install
  86. rm -rf $RPM_BUILD_ROOT
  87. # Install all apps
  88. {
  89. for app in * ; do
  90. pushd $app
  91. make install DESTDIR=$RPM_BUILD_ROOT
  92. popd
  93. done
  94. }
  95. %clean
  96. rm -rf $RPM_BUILD_ROOT
  97. %files
  98. %defattr(-,root,root,-)
  99. #%doc
  100. %{_bindir}/luit
  101. %{_bindir}/oclock
  102. %{_bindir}/x11perf
  103. %{_bindir}/x11perfcomp
  104. %{_bindir}/xbiff
  105. %{_bindir}/xcalc
  106. %{_bindir}/xclipboard
  107. %{_bindir}/xclock
  108. %{_bindir}/xconsole
  109. %{_bindir}/xcursorgen
  110. %{_bindir}/xcutsel
  111. %{_bindir}/xdpr
  112. %{_bindir}/xeyes
  113. %{_bindir}/xinput
  114. %{_bindir}/xkill
  115. %{_bindir}/xload
  116. %{_bindir}/xlogo
  117. %{_bindir}/xmag
  118. %{_bindir}/xmessage
  119. %{_bindir}/xpr
  120. %{_bindir}/xwd
  121. %{_bindir}/xwud
  122. %dir %{_datadir}/X11
  123. %{_datadir}/X11/app-defaults/Clock-color
  124. %{_datadir}/X11/app-defaults/XCalc
  125. %{_datadir}/X11/app-defaults/XCalc-color
  126. %{_datadir}/X11/app-defaults/XClipboard
  127. %{_datadir}/X11/app-defaults/XClock
  128. %{_datadir}/X11/app-defaults/XClock-color
  129. %{_datadir}/X11/app-defaults/XConsole
  130. %{_datadir}/X11/app-defaults/XLoad
  131. %{_datadir}/X11/app-defaults/XLogo
  132. %{_datadir}/X11/app-defaults/XLogo-color
  133. %{_datadir}/X11/app-defaults/Xmag
  134. %{_datadir}/X11/app-defaults/Xmessage
  135. %{_datadir}/X11/app-defaults/Xmessage-color
  136. %dir %{_libdir}/X11/x11perfcomp
  137. %{_libdir}/X11/x11perfcomp/Xmark
  138. %{_libdir}/X11/x11perfcomp/fillblnk
  139. %{_libdir}/X11/x11perfcomp/perfboth
  140. %{_libdir}/X11/x11perfcomp/perfratio
  141. #%dir %{_mandir}/man1x
  142. %{_mandir}/man1/xcursorgen.1*
  143. %{_mandir}/man1/Xmark.1*
  144. %{_mandir}/man1/luit.1*
  145. %{_mandir}/man1/oclock.1*
  146. %{_mandir}/man1/x11perf.1*
  147. %{_mandir}/man1/x11perfcomp.1*
  148. %{_mandir}/man1/xbiff.1*
  149. %{_mandir}/man1/xcalc.1*
  150. %{_mandir}/man1/xclipboard.1*
  151. %{_mandir}/man1/xclock.1*
  152. %{_mandir}/man1/xconsole.1*
  153. %{_mandir}/man1/xcutsel.1*
  154. %{_mandir}/man1/xdpr.1*
  155. %{_mandir}/man1/xeyes.1*
  156. %{_mandir}/man1/xinput.1*
  157. %{_mandir}/man1/xkill.1*
  158. %{_mandir}/man1/xload.1*
  159. %{_mandir}/man1/xlogo.1*
  160. %{_mandir}/man1/xmag.1*
  161. %{_mandir}/man1/xmessage.1*
  162. %{_mandir}/man1/xpr.1*
  163. %{_mandir}/man1/xwd.1*
  164. %{_mandir}/man1/xwud.1*
  165. %changelog
  166. * Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
  167. - xwd-1.0.4
  168. - wud-1.0.3
  169. - xclipboard-1.1.1
  170. - xcursorgen-1.0.4
  171. - xeyes-1.1.1
  172. - xkill-1.0.3
  173. - xinput-1.5.3
  174. - xcalc-1.0.4
  175. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
  176. - oclock-1.0.2
  177. - xlock-1.0.5
  178. - xconsole-1.0.4
  179. - luit-1.1.0
  180. - x11perf-1.5.2
  181. - xbiff-1.0.2
  182. - xlogo-1.0.3
  183. - xload-1.1.0
  184. - xmag-1.0.4
  185. - xinput-1.5.2
  186. - drop Patch2
  187. - add BuildRequires: libXi-devel
  188. * Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.5-2
  189. - luit-1.0.5
  190. - xeyes-1.1.0
  191. - xlogo-1.0.2
  192. - xmessage-1.0.3
  193. - xinput-1.5.1
  194. - added xcalc-1.0.3 <wishes:161>
  195. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
  196. - xclock-1.0.4
  197. - xwd-1.0.3
  198. - xwud-1.0.2
  199. - xpr-1.0.3
  200. - luit-1.0.4
  201. - x11perf-1.5.1
  202. - xclipboard-1.1.0
  203. - xcursorgen-1.0.3
  204. - xeyes-1.0.991
  205. - xkill-1.0.2
  206. - xmag-1.0.3
  207. - xinput-1.5.0
  208. * Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-3
  209. - xinput-1.4.2
  210. * Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-2
  211. - xinput-1.4.1
  212. * Mon Nov 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
  213. - bump to 7.4 version
  214. - add xinput-1.3.0
  215. * Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
  216. - xwd 1.0.2
  217. - luit 1.0.3
  218. - x11perf 1.5
  219. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
  220. - new versioning policy
  221. * Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
  222. - initial build for Vine Linux
  223. * Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
  224. - xconsole 1.0.3
  225. - xmessage 1.0.2
  226. - Bump to 7.3-1
  227. * Tue Aug 21 2007 Dave Airlie <airlied@redhat.com> 7.2-1
  228. - luit-1.0.2 xclock 1.0.3 xmag 1.0.2 xpr 1.0.2 xload 1.0.2 xcursorgen 1.0.2
  229. - bump to 7.2 version
  230. * Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-4
  231. - Fix man page globs and rebuild for FC7.
  232. * Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> 7.1-3.fc6
  233. - Fix race condition in luit (Bug 197165).
  234. * Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-2.fc6
  235. - Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
  236. - Add 'dist' tag to package release string.
  237. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-1.1
  238. - rebuild
  239. * Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
  240. - Added xload-1.0.1-setuid.diff to fix potential security issue (#196094)
  241. - Artificially inflate package version-release to 7.1 to match the X11R7.1
  242. release that all of the tarballs are taken from.
  243. - Update to xconsole-1.0.2, xcursorgen-1.0.1 from X11R7.1
  244. - Add temporary dependency on autoconf, automake for brew builds.
  245. * Fri May 26 2006 Adam Jackson <ajackson@redhat.com> 1.0.3-2
  246. - Add more BuildRequires to fix mock builds. (#191896)
  247. * Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.3-1
  248. - Updated xclock and xconsole
  249. * Thu Mar 02 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
  250. - Bump x11perf to 1.4.1 from upstream.
  251. * Fri Feb 24 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
  252. - Added luit-1.0.1-locale.alias-datadir.patch to fix bug (#181785)
  253. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
  254. - bump again for double-long bug on ppc(64)
  255. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
  256. - rebuilt for new gcc4.1 snapshot and glibc changes
  257. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
  258. - Upgraded all apps to version 1.0.1 from X11R7.0
  259. * Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
  260. - Upgraded all apps to version 1.0.0 from X11R7 RC4.
  261. - Changed manpage dir from man1x to man1 to match upstream default now.
  262. - Dropped all of the datadir-cleanups patches added in the previous build.
  263. - Added x11perf-1.0.0-x11perf-datadir-cleanups.patch as it is still needed
  264. to put the helper scripts in datadir.
  265. - Added --disable-xprint to configure, as a great symbolic jesture.
  266. * Wed Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
  267. - Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3" to workaround
  268. (#173384)
  269. - Added the following patches, and invoke aclocal/automake/autoconf on them
  270. to force app-defaults and other datafiles into _datadir instead of _libdir:
  271. - oclock-0.99.1-oclock-datadir-cleanups.patch
  272. - x11perf-0.99.1-x11perf-datadir-cleanups.patch
  273. - xclipboard-0.99.1-xclipboard-datadir-cleanups.patch
  274. - xclock-0.99.1-xclock-datadir-cleanups.patch
  275. - xconsole-0.99.2-xconsole-datadir-cleanups.patch
  276. - xload-0.99.1-xload-datadir-cleanups.patch
  277. - xlogo-0.99.1-xlogo-datadir-cleanups.patch
  278. - xmag-0.99.1-xmag-datadir-cleanups.patch
  279. - xmessage-0.99.1-xmessage-datadir-cleanups.patch
  280. - Added luit-0.99.1-luit-locale-dir-fix.patch to fix bug (#173702)
  281. * Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
  282. - add Requires(pre) on newer filesystem package (#172610)
  283. * Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
  284. - Add "Obsoletes: XFree86, XFree86-tools, xorg-x11, xorg-x11-tools", as
  285. various utils have moved here from there in monolithic X packaging.
  286. - Add "BuildRequires: xbitmaps-devel" for xbiff.
  287. - Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
  288. * Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
  289. - Initial build, with all apps taken from X11R7 RC2.
  290. - Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
  291. some packages.
  292. - Temporary hack to move xcursorgen manpage to 'man1' dir.