xnoise-vl.spec 6.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232
  1. %define XNOISE_BIN %{_libexecdir}/%{name}
  2. Name: xnoise
  3. Version: 0.2.17
  4. Release: 1%{?_dist_release}
  5. Summary: Tracklist-centric Media Player
  6. Summary(ja): トラックリストを中心とするメディアプレーヤー
  7. Group: Applications/Multimedia
  8. License: GPLv2+ with exceptions
  9. URL: http://www.xnoise-media-player.com/
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. Source0: http://xnoise.googlecode.com/files/xnoise-%{version}.tar.gz
  12. Source1: xnoise_ja.po
  13. Source10: xnoise.sh
  14. BuildRequires: pkgconfig
  15. BuildRequires: gettext
  16. BuildRequires: glib2-devel >= 2.30.0
  17. BuildRequires: gtk3-devel
  18. BuildRequires: gstreamer1-plugins-base-devel >= 1.0.1
  19. BuildRequires: intltool
  20. BuildRequires: libxml2-devel >= 2.6.32
  21. BuildRequires: libsoup-devel >= 2.26.0
  22. BuildRequires: libtaginfo-devel
  23. BuildRequires: perl-XML-Parser
  24. BuildRequires: sqlite3-devel >= 3.6
  25. BuildRequires: taglib-devel >= 1.6.0
  26. BuildRequires: unique-devel
  27. BuildRequires: vala-devel >= 0.16.0
  28. BuildRequires: desktop-file-utils gettext intltool
  29. Requires: hicolor-icon-theme
  30. Requires: libtaginfo
  31. # xnoise >= 0.1.14 bundles the plug-ins
  32. Provides: xnoise-plugins-core = %{version}-%{release}
  33. %description
  34. Xnoise is a Gtk+ media player with a tracklist-centric design. The
  35. tracklist is a list of video or music tracks that are played one by
  36. one without being removed (right side of window). This gives you the
  37. possibility to enqueue any track in any order, regardless if they are
  38. on the same album or not. The tracks can be reordered at any time by
  39. using drag and drop.
  40. %package devel
  41. Summary: Development files for %{name}
  42. Summary(ja): %{name} の開発ファイル
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. %description devel
  46. The %{name}-devel package contains libraries and header files for
  47. developing applications that use %{name}.
  48. %prep
  49. %setup -q
  50. %{__cp} -f %{SOURCE1} po/ja.po
  51. #sed -i s/hu/hu\\nja/g po/LINGUAS
  52. %build
  53. %configure --enable-soundmenu2=no --disable-ubuntuone
  54. make %{?_smp_mflags}
  55. %install
  56. rm -rf $RPM_BUILD_ROOT
  57. make install DESTDIR=$RPM_BUILD_ROOT
  58. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  59. # remove invalid locale file
  60. rm -rf $RPM_BUILD_ROOT%{_share}/locale/default
  61. ## wrapper install
  62. %__mkdir_p $RPM_BUILD_ROOT%{_libexecdir}
  63. %__mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{XNOISE_BIN}
  64. %{__install} -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
  65. %find_lang %{name}
  66. %check
  67. make check
  68. desktop-file-validate $RPM_BUILD_ROOT/%{_datadir}/applications/xnoise.desktop
  69. %post
  70. /sbin/ldconfig
  71. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  72. update-desktop-database &> /dev/null || :
  73. %postun
  74. /sbin/ldconfig
  75. if [ $1 -eq 0 ] ; then
  76. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  77. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  78. fi
  79. update-desktop-database &> /dev/null || :
  80. %posttrans
  81. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  82. %files -f %{name}.lang
  83. %defattr(-,root,root,-)
  84. %doc AUTHORS COPYING README
  85. %{XNOISE_BIN}
  86. %{_bindir}/xnoise
  87. %{_bindir}/xnoise_image_extractor_service
  88. # libxnoise.so *needs* to be in main package
  89. # otherwise plugins currently don't work
  90. %exclude %{_libdir}/xnoise/libxnoisetest.so
  91. %{_libdir}/xnoise
  92. %{_libdir}/libxnoise.so*
  93. %{_mandir}/man1/xnoise.1*
  94. %{_datadir}/xnoise
  95. %{_datadir}/applications/xnoise.desktop
  96. %{_datadir}//dbus-1/services/org.gtk.xnoise.ImageExtractor.service
  97. %{_datadir}//dbus-1/services/org.gtk.xnoise.PlayerEngine.service
  98. %{_datadir}/icons/hicolor/*
  99. %{_datadir}/icons/ubuntu-mono-*/*
  100. %files devel
  101. %defattr(-,root,root,-)
  102. %{_includedir}/xnoise
  103. %{_libdir}/xnoise/libxnoise*.so*
  104. %{_libdir}/pkgconfig/xnoise-1.0.pc
  105. # make package own the vala API dir:
  106. # xnoise plugins don't have to be written in vala
  107. %dir %{_datadir}/vala
  108. %dir %{_datadir}/vala/vapi
  109. %{_datadir}/vala/vapi/xnoise-1.0.*
  110. %changelog
  111. * Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.17-1
  112. - new upstream release
  113. - updated Source1
  114. - changed BuildRequires: gstreamer-plugins-base-devel >= 0.10.23 to
  115. gstreamer1-plugins-base-devel >= 1.0.1
  116. - added BuildRequires: libtaginfo-devel
  117. - added Requires: libtaginfo
  118. - fixed Source10
  119. * Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.15-1
  120. - new upstream release
  121. - updated Source1
  122. * Fri Jan 11 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.14-1
  123. - new upstream release
  124. - updated Source1
  125. * Sat Nov 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.13-1
  126. - new upstream release
  127. - updated Source1
  128. * Thu Oct 04 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.12-1
  129. - new upstream release
  130. - updated Source1
  131. - deleted BuildRequires: libnotify-devel >= 0.7.0
  132. - changed BuildRequires: vala-devel >= 0.15.0 to 0.16.0
  133. * Sat Sep 22 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.11-1
  134. - new upstream release
  135. - updated Source1
  136. - deleted %%configure option: --disable-magnatune
  137. * Sat Sep 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.9-1
  138. - new upstream release
  139. - updated Source1
  140. * Sat Aug 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.8-1
  141. - new upstream release
  142. - updated Source1
  143. - added %%configure option: --disable-magnatune
  144. * Fri Aug 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.5-1
  145. - new upstream release
  146. - updated Source1
  147. - added %%configure option: --disable-ubuntuone
  148. * Thu Aug 02 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.4-1
  149. - initial build for VineSeed
  150. * Wed Oct 5 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.29-1
  151. - Update to 0.1.29
  152. * Wed Sep 21 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.28-1
  153. - Update to 0.1.28
  154. * Sat Sep 10 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.27-1
  155. - Update to 0.1.27
  156. * Thu Jul 28 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.26-1
  157. - Update to 0.1.26
  158. - Enable tests
  159. * Mon Apr 4 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.18-1
  160. - Update to 0.1.18
  161. * Sun Mar 13 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.16-1
  162. - Update to 0.1.16
  163. - Now bundles the plugins, obsoleting xnoise-plugins-core
  164. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.12-4
  165. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  166. * Sat Nov 6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-3
  167. - Own %%{_libdir}/xnoise for plugins
  168. * Sat Nov 6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-2
  169. - invoke ldconfig on (un)install
  170. - remove %%clean section; only targeting F-14+
  171. - re-enable deletion of invalid locale dir
  172. * Sat Nov 6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-1
  173. - Update to 0.1.12
  174. - Specify the correct location for Vala API files in *.pc
  175. * Fri Jun 25 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.6-2
  176. - Make xnoise-devel co-own Vala's VAPI dir
  177. - Remove invalid locale file
  178. * Wed Jun 23 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
  179. - Update to final 0.1.6 release
  180. * Sat Apr 3 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.2-0.1.331hg
  181. - Initial package