clang-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. %define _unpackaged_files_terminate_build 1
  5. # Documentation install path
  6. %global llvmdocdir() %{_docdir}/%1-%{version}
  7. %define _unpackaged_files_terminate_build 1
  8. Summary: A C language family front-end for LLVM
  9. Summary(ja): LLVM の C 言語フロントエンド
  10. Name: clang
  11. Version: 12.0.1
  12. Release: 1%{?_dist_release}
  13. Group: programming
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. License: NCSA
  17. URL: https://llvm.org/
  18. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-%{version}.src.tar.xz
  19. Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-tools-extra-%{version}.src.tar.xz
  20. # multilib fixes
  21. Source11: clang-config.h
  22. # Patches for clang
  23. Patch0: 0001-PATCH-clang-Reorganize-gtest-integration.patch
  24. Patch1: 0002-PATCH-clang-Make-funwind-tables-the-default-on-all-a.patch
  25. Patch2: 0003-PATCH-clang-Don-t-install-static-libraries.patch
  26. Patch3: 0004-PATCH-clang-Prefer-gcc-toolchains-with-libgcc_s.so-w.patch
  27. Patch5: 0006-PATCH-clang-Allow-__ieee128-as-an-alias-to-__float12.patch
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  29. BuildRequires: cmake
  30. BuildRequires: ninja
  31. BuildRequires: llvm-devel = %{version}
  32. BuildRequires: llvm-static = %{version}
  33. BuildRequires: libatomic
  34. BuildRequires: libxml2-devel
  35. BuildRequires: perl
  36. BuildRequires: ncurses-devel
  37. BuildRequires: python3
  38. BuildRequires: python3-devel
  39. Requires: llvm = %{version}-%{release}
  40. # clang requires gcc, clang++ requires libstdc++-devel
  41. Requires: libstdc++-devel
  42. # LLVM is not supported on PPC64
  43. # http://llvm.org/bugs/show_bug.cgi?id=3729
  44. ExcludeArch: ppc64
  45. %description
  46. clang: noun
  47. 1. A loud, resonant, metallic sound.
  48. 2. The strident call of a crane or goose.
  49. 3. C-language family front-end toolkit.
  50. The goal of the Clang project is to create a new C, C++, Objective C
  51. and Objective C++ front-end for the LLVM compiler. Its tools are built
  52. as libraries and designed to be loosely-coupled and extensible.
  53. %Package libs
  54. Summary: Runtime library for clang
  55. Summary(ja): Clang のランタイムライブラリ
  56. Group: system
  57. %description libs
  58. Runtime library for clang.
  59. %description libs -l ja
  60. Clang のランタイムライブラリです.
  61. %package devel
  62. Summary: Header files for clang
  63. Summary(ja): Clang のヘッダファイル
  64. Group: programming
  65. Requires: clang = %{version}-%{release}
  66. %description devel
  67. This package contains header files for the Clang compiler.
  68. %description devel -l ja
  69. Clang コンパイラのヘッダファイル集です.
  70. %package analyzer
  71. Summary: A source code analysis framework
  72. Summary(ja): ソースコード分析フレームワーク
  73. License: NCSA
  74. Group: programming
  75. Requires: clang = %{version}-%{release}
  76. # not picked up automatically since files are currently not instaled
  77. # in standard Python hierarchies yet
  78. Requires: python3
  79. %description analyzer
  80. The Clang Static Analyzer consists of both a source code analysis
  81. framework and a standalone tool that finds bugs in C and Objective-C
  82. programs. The standalone tool is invoked from the command-line, and is
  83. intended to run in tandem with a build of a project or code base.
  84. %package -n python3-clang
  85. Summary: Python3 bindings for clang
  86. Group: programming
  87. Requires: %{name}-libs%{?_isa} = %{version}-%{release}
  88. Requires: python3
  89. %description -n python3-clang
  90. Python3 bindings for clang
  91. %package tools-extra
  92. Summary: Extra tools for clang
  93. Group: programming
  94. Requires: %{name}-libs%{?_isa} = %{version}-%{release}
  95. %description tools-extra
  96. A set of extra tools built using Clang's tooling API.
  97. %debug_package
  98. %prep
  99. %setup -T -q -b 1 -n clang-tools-extra-%{version}.src
  100. %autopatch -m200 -p2
  101. # failing test case
  102. rm test/clang-tidy/checkers/altera-struct-pack-align.cpp
  103. pathfix%{python3_version}.py -i %{__python3} -pn \
  104. clang-tidy/tool/*.py \
  105. clang-include-fixer/find-all-symbols/tool/run-find-all-symbols.py
  106. %setup -q -n clang-%{version}.src
  107. %autopatch -M200 -p2
  108. # failing test case
  109. rm test/CodeGen/profile-filter.c
  110. pathfix%{python3_version}.py -i %{__python3} -pn \
  111. tools/clang-format/*.py \
  112. tools/clang-format/git-clang-format \
  113. utils/hmaptool/hmaptool \
  114. tools/scan-view/bin/scan-view
  115. sed -i -e 's/"i686-linux-gnu",/"i686-linux-gnu","i686-vine-linux","i686-vine-linux-gnu",/' lib/Driver/ToolChains/Gnu.cpp
  116. sed -i -e 's/"x86_64-linux-gnu",/"x86_64-linux-gnu","x86_64-vine-linux","x86_64-vine-linux-gnu",/' lib/Driver/ToolChains/Gnu.cpp
  117. sed -i -e 's/"ld"/"ld.gold"/' include/clang/Driver/ToolChain.h
  118. %build
  119. # lto builds with gcc 11 fail while running the lit tests.
  120. %define _lto_cflags %{nil}
  121. %ifarch s390 s390x %{arm} %ix86
  122. # Decrease debuginfo verbosity to reduce memory consumption during final library linking
  123. %global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
  124. %endif
  125. %cmake \
  126. -GNinja \
  127. -DLLVM_PARALLEL_LINK_JOBS=1 \
  128. -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
  129. -DCMAKE_BUILD_TYPE=Release \
  130. -DPYTHON_EXECUTABLE=%{__python3} \
  131. -DCMAKE_INSTALL_RPATH:BOOL=";" \
  132. -DLLVM_EXTERNAL_CLANG_TOOLS_EXTRA_SOURCE_DIR=../clang-tools-extra-%{version}.src \
  133. %if 0%{?__isa_bits} == 64
  134. -DLLVM_LIBDIR_SUFFIX=64 \
  135. %else
  136. -DLLVM_LIBDIR_SUFFIX= \
  137. %endif
  138. \
  139. -DLLVM_TABLEGEN_EXE:FILEPATH=%{_bindir}/llvm-tblgen \
  140. -DCLANG_ENABLE_ARCMT:BOOL=ON \
  141. -DCLANG_ENABLE_STATIC_ANALYZER:BOOL=ON \
  142. -DCLANG_ENABLE_ARCMT:BOOL=ON \
  143. -DCLANG_ENABLE_STATIC_ANALYZER:BOOL=ON \
  144. -DCLANG_INCLUDE_DOCS:BOOL=ON \
  145. -DCLANG_INCLUDE_TESTS:BOOL=ON \
  146. -DCLANG_PLUGIN_SUPPORT:BOOL=ON \
  147. \
  148. -DCLANG_INCLUDE_DOCS:BOOL=ON \
  149. -DCLANG_PLUGIN_SUPPORT:BOOL=ON \
  150. -DENABLE_LINKER_BUILD_ID:BOOL=ON \
  151. -DLLVM_ENABLE_EH=ON \
  152. -DLLVM_ENABLE_RTTI=ON \
  153. -DLLVM_BUILD_DOCS=ON \
  154. -DLLVM_ENABLE_SPHINX=OFF \
  155. -DCLANG_LINK_CLANG_DYLIB=ON \
  156. \
  157. -DCLANG_LINK_CLANG_DYLIB=ON \
  158. -DCLANG_BUILD_EXAMPLES:BOOL=OFF \
  159. -DBUILD_SHARED_LIBS=OFF \
  160. -DCLANG_REPOSITORY_STRING="Vine Linux %{version}-%{release}" \
  161. -DCLANG_DEFAULT_UNWINDLIB=libgcc
  162. %cmake_build
  163. %install
  164. rm -rf %{buildroot}
  165. %cmake_install
  166. # remove static libraries
  167. rm -fv %{buildroot}%{_libdir}/libclang*.a
  168. # install clang python bindings
  169. mkdir -p %{buildroot}%{python3_sitelib}/clang/
  170. install -p -m644 bindings/python/clang/* %{buildroot}%{python3_sitelib}/clang/
  171. mv -v %{buildroot}%{_includedir}/clang/Config/config{,-%{__isa_bits}}.h
  172. install -m 0644 %{SOURCE11} %{buildroot}%{_includedir}/clang/Config/config.h
  173. # TODO: Package html docs
  174. rm -Rvf %{buildroot}%{_docdir}/clang/html
  175. rm -Rvf %{buildroot}%{_datadir}/clang/clang-doc-default-stylesheet.css
  176. rm -Rvf %{buildroot}%{_datadir}/clang/index.js
  177. # remove git integration
  178. rm -vf %{buildroot}%{_bindir}/git-clang-format
  179. # remove editor integrations (bbedit, sublime, emacs, vim)
  180. rm -vf %{buildroot}%{_datadir}/clang/clang-format-bbedit.applescript
  181. rm -vf %{buildroot}%{_datadir}/clang/clang-format-sublime.py*
  182. rm -vf %{buildroot}%{_datadir}/clang/clang-format.el
  183. rm -vf %{buildroot}%{_datadir}/clang/clang-format.py*
  184. # remove diff reformatter
  185. rm -vf %{buildroot}%{_datadir}/clang/clang-format-diff.py*
  186. rm -f %{buildroot}%{_datadir}/clang/bash-autocomplete.sh
  187. rm -f %{buildroot}%{_datadir}/clang/clang-rename.el
  188. rm -f %{buildroot}%{_datadir}/clang/clang-rename.py
  189. rm -f %{buildroot}%{_datadir}/clang/clang-include-fixer.el
  190. rm -f %{buildroot}%{_datadir}/clang/clang-include-fixer.py
  191. # Remove clang-tidy headers. We don't ship the libraries for these.
  192. rm -Rvf %{buildroot}%{_includedir}/clang-tidy/
  193. %if %{with test}
  194. %check
  195. %ctest check-clang
  196. %endif
  197. %clean
  198. rm -rf %{buildroot}
  199. %files
  200. %defattr(-,root,root,-)
  201. #doc %{llvmdocdir clang}/
  202. %{_bindir}/clang
  203. %{_bindir}/clang++
  204. %{_bindir}/clang-%{ver_suffix}
  205. %{_bindir}/clang-cl
  206. %{_bindir}/clang-cpp
  207. %files libs
  208. %defattr(-,root,root,-)
  209. %{_libdir}/clang
  210. %{_libdir}/libclang.so.*
  211. %{_libdir}/libclang-cpp.so.*
  212. %files devel
  213. %defattr(-,root,root,-)
  214. #doc %{llvmdocdir clang-devel}/
  215. %{_libdir}/libclang.so
  216. %{_libdir}/libclang-cpp.so
  217. %{_includedir}/clang
  218. %{_includedir}/clang-c
  219. %dir %{_datadir}/clang/
  220. %{_libdir}/cmake/*
  221. %files analyzer
  222. %defattr(-,root,root,-)
  223. %{_bindir}/scan-build
  224. %{_bindir}/scan-view
  225. #%{_libdir}/CheckerDependencyHandlingAnalyzerPlugin.so
  226. #%{_libdir}/CheckerOptionHandlingAnalyzerPlugin.so
  227. #%{_libdir}/SampleAnalyzerPlugin.so
  228. %{_libexecdir}/ccc-analyzer
  229. %{_libexecdir}/c++-analyzer
  230. %{_datadir}/scan-view
  231. %{_datadir}/scan-build
  232. %{_mandir}/man1/scan-build.1.*
  233. %files -n python3-clang
  234. %{python3_sitelib}/clang/
  235. %files tools-extra
  236. %{_bindir}/c-index-test
  237. %{_bindir}/clang*
  238. %exclude %{_bindir}/clang
  239. %exclude %{_bindir}/clang++
  240. %exclude %{_bindir}/clang-%{ver_suffix}
  241. %exclude %{_bindir}/clang-cl
  242. %exclude %{_bindir}/clang-cpp
  243. %{_bindir}/diagtool
  244. %{_bindir}/find-all-symbols
  245. %{_bindir}/hmaptool
  246. %{_bindir}/modularize
  247. %{_bindir}/pp-trace
  248. %{_datadir}/clang/clang-tidy-diff.py*
  249. %{_datadir}/clang/run-clang-tidy.py*
  250. %{_datadir}/clang/run-find-all-symbols.py*
  251. %changelog
  252. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  253. - new upstream release.
  254. - refreshed patches.
  255. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  256. - devided clang from llvm.
  257. - new upstream release.
  258. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  259. - enabled to build utils.
  260. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  261. - new upstream release.
  262. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  263. - new upstream release.
  264. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  265. - rebuilt with libffi-3.3.
  266. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  267. - new upstream release.
  268. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  269. - new upstream release.
  270. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  271. - dropped all patches.
  272. - switched build-system to ninja.
  273. - switched python to python3.
  274. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  275. - new upstream release.
  276. - added OpenMP.
  277. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  278. - fixed %%files.
  279. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  280. - new upstream release.
  281. - dropped Patch0, 4, 5, 100 and 200.
  282. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  283. - renamed a subpackage "llvm-libs".
  284. - added a subpackage "lld".
  285. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  286. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  287. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  288. - new upstream release.
  289. - dropped Patch1 and 2: fixed in upstream.
  290. - imported Patch0, 3-5, 100 and 200 from rawhide.
  291. - disabled Patch1002: no longer needed?
  292. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  293. - new upstream release.
  294. - switched to cmake.
  295. - disable ocaml binding as default.
  296. - updated Patch1000 and 1002.
  297. - disabled Patch1000 as default.
  298. - cleanup patches.
  299. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  300. - rebuild with gcc-5.4.0
  301. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  302. - new upstream release
  303. - added BR: ocaml-ctypes
  304. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  305. - new upstream release
  306. - dropt Patch 1, 201 and 1001
  307. - updated Patch 1000
  308. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  309. - updated to 3.5.1
  310. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  311. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  312. - obsoleted clang-doc
  313. - built with ocaml 4.02.1
  314. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  315. - fix <BTS:2832>
  316. - fix configure option "--with-c-include-dirs"
  317. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  318. - update Patch1001: clang-3.5.0-driver-lib64.patch
  319. - update Patch1002: clang-3.5.0-driver-vine.patch
  320. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  321. - update to 3.5.0
  322. - remove Patch11 (clang-hardfloat-hack.patch)
  323. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  324. - rebuild with libffi-3.0.13
  325. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  326. - update to 3.3
  327. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  328. - ld.gold (patch1000,1001)
  329. - add /%{_lib} to ld search path
  330. - add support *-vine-linux gcc (patch1002)
  331. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  332. - update to 3.1
  333. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  334. - updated to 3.0 release
  335. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  336. - added patch 2-4 to support -O4 link-time optimization
  337. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  338. - disable -fno-var-tracking-assignments on ppc
  339. (seems like gcc-4.4.5 still doesn't support this)
  340. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  341. - new upstream release
  342. - add BR: libffi-devel
  343. - add R: libffi-devel to -devel
  344. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  345. - initial build for Vine Linux
  346. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  347. - Update to final 2.7 release
  348. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  349. - Update to first 2.7 pre-release
  350. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  351. - Update to 2.6 pre-release2
  352. - -devel subpackage now virtually provides -static
  353. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  354. - Disable var tracking assignments on PPC
  355. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  356. - Don't adjust clang include dir; files there are noarch (bz#521893)
  357. - Enable clang unit tests
  358. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  359. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  360. - Package Clang's static analyzer tools
  361. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  362. - PIC is now enabled by default; explicitly disable on %%{ix86}
  363. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  364. - First 2.6 prerelease
  365. - Enable Clang front-end
  366. - Enable debuginfo generation
  367. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  368. - Disable assertions (needed by OpenGTL, bz#521261)
  369. - Align spec file with upstream build instructions
  370. - Enable unit tests
  371. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  372. - Only disable PIC on %%ix86; ppc actually needs it
  373. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  374. - Disable use of position-independent code on 32-bit platforms
  375. (buggy in LLVM <= 2.5)
  376. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  377. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  378. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  379. - Remove build scripts; they require the build directory to work
  380. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  381. - Update to 2.5
  382. - Package build scripts (bug #457881)
  383. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  384. - Patched build process for the OCaml binding
  385. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  386. - Update to 2.4
  387. - Package Ocaml binding
  388. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  389. - Add dependency on groff
  390. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  391. - LLVM 2.3
  392. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  393. - fix license tags
  394. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  395. - Fix compilation problems with gcc 4.3
  396. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  397. - Autorebuild for GCC 4.3
  398. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  399. - Fix review comments
  400. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  401. - Initial version