tcl-vl.spec 9.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288
  1. %define majorver 8.4
  2. %define minorver 19
  3. %define version %{majorver}.%{minorver}
  4. %define htmlver %{majorver}.18
  5. Summary: A Tcl/Tk development environment: tcl
  6. Summary(ja): Tcl/Tk 開発環境: tcl
  7. Name: tcl
  8. Version: %{version}
  9. Release: 3%{?_dist_release}
  10. Group: Development/Languages
  11. License: BSD
  12. URL: http://tcl.sourceforge.net/
  13. Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
  14. Source1: http://prdownloads.sourceforge.net/tcl/%{name}%{htmlver}-html.tar.gz
  15. Patch1: tcl-8.3.5-tclm4-soname.patch
  16. Patch2: tcl-8.4.5-lib-perm.patch
  17. #Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
  18. Patch3: tcl8.4.16-configure.patch
  19. Patch4: tcl-8.4.12-no_rpath.patch
  20. Patch10: tcl-8.4.15-init.lib64.patch
  21. Buildroot: %{_tmppath}/%{name}-%{version}-root
  22. BuildRequires: libtool, util-linux, perl, gdbm, autoconf
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. %description
  26. Tcl is a simple scripting language designed to be embedded into
  27. other applications. Tcl is designed to be used with Tk, a widget
  28. set, which is provided in the tk package. This package also includes
  29. tclsh, a simple example of a Tcl application.
  30. %description -l ja
  31. Tcl は様々なアプリケーションの実行を行うための、簡単なスクリプ
  32. ト言語です。Tclはウィジッド・セットであるTkとともに用いるように
  33. デザインしています。このパッケージにはTclの簡単な例として、tclsh
  34. も含んでいます。
  35. %prep
  36. #%setup -n %{name}%{version} -q -b1
  37. %setup -n %{name}%{version} -q -a 1
  38. mv tcl%{htmlver}/html .
  39. # define DT SONAME in shared lib
  40. # %patch1 -p1 -b .soname
  41. %patch2 -p1 -b .ro-lib
  42. %patch3 -p1 -b .pkgpath
  43. %patch4 -p1 -b .no_rpath
  44. # patch1 touches tcl.m4, and patch3 touches configure.in
  45. %ifarch x86_64
  46. %patch10 -p1 -b .init.lib64
  47. %endif
  48. cd unix
  49. #autoconf-2.13
  50. autoconf
  51. %build
  52. cd unix
  53. %configure \
  54. --enable-shared --disable-threads --enable-langinfo --enable-64bit
  55. make %{?_smp_mflags} TCL_LIBRARY=%{_datadir}/tcl%{majorver}
  56. %install
  57. rm -rf $RPM_BUILD_ROOT
  58. make install -C unix INSTALL_ROOT=%{buildroot} TCL_LIBRARY=%{_datadir}/tcl%{majorver}
  59. ln -s tclsh%{majorver} %{buildroot}%{_bindir}/tclsh
  60. # for linking with -ltcl
  61. ln -s libtcl%{majorver}.so %{buildroot}%{_libdir}/libtcl.so
  62. mkdirhier %buildroot/%{_includedir}/tcl-private/{generic,unix}
  63. cp -p generic/tcl{Int,IntDecls,IntPlatDecls,Math,Port}.h %buildroot/%{_includedir}/tcl-private/generic
  64. cp -p unix/tclUnixPort.h %buildroot/%{_includedir}/tcl-private/unix
  65. # Fix up the include files.
  66. install -m 644 generic/tclRegexp.h $RPM_BUILD_ROOT%{_includedir}
  67. cp generic/*.h $RPM_BUILD_ROOT%{_includedir}/tcl-private/generic
  68. cp unix/*.h $RPM_BUILD_ROOT%{_includedir}/tcl-private/unix
  69. # remove buildroot traces
  70. perl -pi -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/tcl-private|" %buildroot/%{_libdir}/tclConfig.sh
  71. %clean
  72. rm -rf $RPM_BUILD_ROOT
  73. %post -p /sbin/ldconfig
  74. %postun -p /sbin/ldconfig
  75. %files
  76. %defattr(-,root,root,-)
  77. %doc html/*
  78. %{_bindir}/tclsh*
  79. %{_datadir}/tcl%{majorver}
  80. %{_libdir}/libtcl%{majorver}.so
  81. %{_libdir}/tclConfig.sh
  82. %{_mandir}/man1/*
  83. %{_includedir}/*
  84. %{_libdir}/libtclstub%{majorver}.a
  85. %{_libdir}/libtcl.so
  86. %{_mandir}/man3/*
  87. %{_mandir}/mann/*
  88. %changelog
  89. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
  90. - rebuilt with rpm-4.8.1-3
  91. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
  92. - rebuilt with new environment
  93. - updated Patch3: tcl8.4.16-configure.patch
  94. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
  95. - new upstream release
  96. * Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.4.18-2
  97. - spec in UTF-8
  98. - configure with disabled threads. See:
  99. https://bugzilla.redhat.com/show_bug.cgi?id=443246
  100. http://groups.google.com/group/comp.lang.tcl/msg/ce6a1324bada8db0
  101. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
  102. - rebuild with new environment
  103. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
  104. - updated tcl to 8.4.18
  105. - updated tcl-html to 8.4.18
  106. * Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
  107. - updated tcl to 8.4.16
  108. - updated tcl-html to 8.4.16
  109. - dropt Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
  110. - added Patch3: tcl8.4.16-configure.patch
  111. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
  112. - updated tcl to 8.4.15
  113. - updated tcl-html to 8.4.15
  114. - dropt Patch1: tcl-8.3.5-tclm4-soname.patch
  115. - added Patch10: tcl-8.4.15-init.lib64.patch
  116. - rebuilt with new toolchain
  117. * Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
  118. - updated tcl to 8.4.13
  119. - updated tcl-html to 8.4.13
  120. * Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
  121. - updated tcl to 8.4.12
  122. - updated patch4
  123. * Sat Aug 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.4.11-0vl1
  124. - updated tcl to 8.4.11
  125. - updated Patch4
  126. * Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
  127. - updated tcl to 8.4.6
  128. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
  129. - merged with fedora
  130. * Mon Dec 1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-3
  131. - removed rpath (patch 4)
  132. * Fri Nov 28 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-2
  133. - put private header files under generic and unix subdirs
  134. - include real generic/tclPort.h not just a symlink to tclUnixPort.h
  135. - add tclMath.h to %{_includedir}/tcl-private/generic for building tk
  136. * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
  137. - new package split out from tcltk
  138. - update to tcl 8.4.5 (#88429)
  139. - drop tcl-8.3.3-heiierarchy.patch, tcl-8.3.3-dlopen.patch
  140. and tcl8.3.5-koi8-u.enc-88806.patch
  141. - include private include headers under %{_includedir}/tcl-private
  142. - filtered changelog for tcl
  143. - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
  144. * Sat Mar 29 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
  145. - update based on BitWalk's tcltk-8.4.2-83bw
  146. * Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
  147. - split source package.
  148. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  149. - expand some macros.. (FIXME)
  150. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  151. - use %configure macros
  152. - add Patch 47,50
  153. * Thu May 31 2001 <sagami@vinelinux.org>
  154. - 8.0.5_jp-10
  155. - unexpand old %%{configure}, new one causes build failure
  156. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  157. - install manpages into %%{_mandir} and mode 644
  158. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  159. - 8.0.5_jp-9
  160. - modified %install section to handle compressed man pages
  161. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  162. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  163. - changed default fonts
  164. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  165. - added defattr
  166. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  167. - added some symlinks, such as libtcl8.0.so.
  168. - obsoletes version number using _jp, now 8.0.5-31vl1
  169. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  170. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  171. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  172. - fix tclX symlinks.
  173. - compile on systems where SIGPWR == SIGLOST.
  174. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  175. - update tcl/tk to 8.0.5.
  176. - avoid "containing" in Tix (#2332).
  177. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  178. - use /usr/bin/write in kibitz (#1320).
  179. - use cirrus.sprl.umich.edu in weather (#1926).
  180. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  181. - auto rebuild in the new build environment (release 28)
  182. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  183. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  184. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  185. - expect does unaligned access on alpha (#989)
  186. - upgrade tcl/tk/tclX to 8.0.4
  187. - upgrade expect to 5.28.
  188. - add itcl 3.0.1
  189. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  190. - call libtoolize to allow building on the arm
  191. - build for glibc 2.1
  192. - strip binaries
  193. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  194. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  195. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  196. - expect: mkpasswd needs delay before sending password (problem #576)
  197. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  198. - translations modified for de, fr, tr
  199. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  200. - fixed expect binaries exec permissions
  201. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  202. - updated to Tix 4.1.0.006
  203. - updated version numbers of tcl/tk to relflect includsion of p2
  204. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  205. - updated tcl/tk to patch level 2
  206. - updated tclX to 8.0.2
  207. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  208. - fixed filelist for tix... replacing path to the expect binary in scripts
  209. was leaving junk files around.
  210. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  211. - added patch to remove libieee test in configure.in for tcl and tk.
  212. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  213. solution for all systems
  214. - fixed src urls
  215. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  216. - removed version numbers from descriptions
  217. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  218. - updated to tcl/tk 8.0 and related versions of packages
  219. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  220. - built against glibc
  221. - fixed dangling tclx/tkx symlinks