perl-EV-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169
  1. Name: perl-EV
  2. Version: 4.25
  3. Release: 1%{?_dist_release}
  4. Summary: Wrapper for the libev high-performance event loop library
  5. Summary(ja): 高性能イベントループライブラリ libev の Perl ラッパー
  6. Group: Development/Libraries
  7. # Note: The source archive includes a libev/ folder which contents are licensed
  8. # as "BSD or GPLv2+". However, those are removed at build-time and
  9. # perl-EV is instead built against the system-provided libev.
  10. License: GPL+ or Artistic
  11. URL: http://search.cpan.org/dist/EV/
  12. Source0: http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/EV-%{version}.tar.gz
  13. Patch0: perl-EV-4.03-Don-t-ask-questions-at-build-time.patch
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. BuildRequires: perl(ExtUtils::MakeMaker)
  17. BuildRequires: perl(common::sense)
  18. BuildRequires: gdbm-devel
  19. BuildRequires: libev-source >= %{version}
  20. BuildRequires: perl(AnyEvent) => 2.6
  21. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  22. # As per review, a perl-EV-devel subpackage had at first been pushed to the
  23. # repositories. It now has broken deps if it's not properly obsoleted/provided.
  24. # TODO: Remove those two lines during the Fedora 17 development cycle.
  25. Provides: %{name}-devel = %{version}-%{release}
  26. Obsoletes: %{name}-devel < 4.03-5
  27. %{?perl_default_filter}
  28. %description
  29. This module provides an interface to libev
  30. (<http://software.schmorp.de/pkg/libev.html>). While the included documentation
  31. is comprehensive, one might also consult the documentation of libev itself
  32. (<http://cvs.schmorp.de/libev/ev.html>) for more subtle details on watcher
  33. semantics or some discussion on the available backends, or how to force a
  34. specific backend with "LIBEV_FLAGS", or just about in any case because it has
  35. much more detailed information.
  36. %prep
  37. %setup -q -n EV-%{version}
  38. # no questins during build
  39. %patch0 -p1
  40. # remove all traces of the bundled libev
  41. rm -fr libev/*
  42. # use the sources from the system libev
  43. mkdir -p ./libev
  44. cp -r /usr/share/libev-source/* ./libev/
  45. %build
  46. %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
  47. make %{?_smp_mflags}
  48. %install
  49. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  50. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  51. find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  52. find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
  53. chmod -R u+w %{buildroot}/*
  54. %check
  55. make test
  56. %clean
  57. rm -rf %{buildroot}
  58. %files
  59. %defattr(-,root,root,-)
  60. %license COPYING
  61. %doc Changes README
  62. %{perl_vendorarch}/auto/*
  63. %{perl_vendorarch}/EV.pm
  64. %{perl_vendorarch}/EV
  65. %{perl_vendorarch}/EV/*.h
  66. %{_mandir}/man3/*.3*
  67. %changelog
  68. * Thu May 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.25-1
  69. - new upstream release.
  70. - rebuilt with perl-5.26.
  71. * Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 4.03-2
  72. - build with Perl 5.16
  73. * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.03-1
  74. - initial build for Vine Linux
  75. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.03-8
  76. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  77. * Thu Dec 01 2011 Petr Pisar <ppisar@redhat.com> - 4.03-7
  78. - Build-require exact or higher version of libev-source (bug #759021)
  79. * Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 4.03-6
  80. - Perl mass rebuild
  81. * Tue Apr 12 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-5
  82. - Add the correct Obsoletes/Provides to avoid broken deps from the -devel
  83. subpackage removal.
  84. * Thu Apr 07 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-4
  85. - Readded the header file to the main package, as per guidelines:
  86. -> http://fedoraproject.org/wiki/Packaging/Perl#.h_files_in_module_packages
  87. * Tue Mar 08 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-3
  88. - Some more fixes as part of the review process:
  89. - Fix the license tag to be only the license of perl-EV, and add a note about
  90. the included libev sources.
  91. - Removed manual cleaning of the buildroot since it has been useless since
  92. Fedora 10 and even EPEL (>=6) doesn't need it now.
  93. * Wed Feb 23 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-2
  94. - Fixes asked during the review process:
  95. - Filter the private shared EV.so out of the automatic Provides
  96. - Put the header files in a -devel package
  97. - Removed the Buildroot line since it's useless for newer versions of Fedora
  98. and this package can only go in Fedora >= 15 due to its libev dependency)
  99. * Mon Jan 24 2011 Mathieu Bridon <bochecha@fedoraproject.org> - 4.03-1
  100. - Update to 4.03.
  101. - Use the system libev instead of the bundled one.
  102. * Sun Nov 8 2009 kwizart < kwizart at gmail.com > - 3.8-1
  103. - Update to 3.8
  104. * Tue Apr 28 2009 kwizart < kwizart at gmail.com > - 3.6-1
  105. - Update to 3.6
  106. * Mon Mar 2 2009 kwizart < kwizart at gmail.com > - 3.53-1
  107. - Update to 3.53
  108. * Tue Feb 3 2009 kwizart < kwizart at gmail.com > - 3.52-1
  109. - Update to 3.52
  110. * Tue Oct 14 2008 kwizart < kwizart at gmail.com > - 3.44-1
  111. - Update to 3.44
  112. - WIP conditional --with systemlibev
  113. * Tue Jul 15 2008 kwizart < kwizart at gmail.com > - 3.431-1
  114. - Update to 3.431
  115. - Update License to (GPL+ or Artistic) and (BSD or GPLv2+)
  116. - Add libev README and LICENSE
  117. * Tue Jul 8 2008 kwizart < kwizart at gmail.com > - 3.43-1
  118. - Update to 3.43
  119. * Mon Jun 9 2008 kwizart < kwizart at gmail.com > - 3.42-2
  120. - Disable filter AnyEvent
  121. * Tue May 27 2008 kwizart < kwizart at gmail.com > - 3.42-1
  122. - Update to 3.42
  123. * Wed Apr 30 2008 kwizart < kwizart at gmail.com > - 3.31-1
  124. - Initial package for Fedora