gnash-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. # ghelp/omf/scrollkeeper support
  3. # not working as of version 0.8.7
  4. %define scrollkeeper 0
  5. # kde and klash support
  6. %define kde_support 0
  7. Name: gnash
  8. Version: 0.8.10
  9. Release: 1%{?_dist_release}
  10. Summary: GNU flash movie player
  11. Group: Applications/Multimedia
  12. License: GPLv3+
  13. URL: http://www.gnu.org/software/gnash/
  14. Source0: http://ftp.gnu.org/gnu/gnash/%{version}/%{name}-%{version}.tar.bz2
  15. Patch0: %{name}-%{version}-add-unistd-header.patch
  16. Patch1: %{name}-%{version}-integer-overflow.patch
  17. # register KComponentData properly in KDE 4 KPart
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: libxml2-devel libpng-devel libjpeg-devel libogg-devel
  20. BuildRequires: libboost-devel curl-devel freetype-devel fontconfig-devel
  21. BuildRequires: libboost-date-time libboost-serialization libboost-thread
  22. BuildRequires: SDL-devel
  23. BuildRequires: agg-devel
  24. BuildRequires: python-devel
  25. BuildRequires: libXv-devel
  26. %if %{kde_support}
  27. #BuildRequires: kde-filesystem
  28. BuildRequires: kdelibs-devel
  29. %endif
  30. BuildRequires: gtkglext-devel
  31. BuildRequires: docbook2X
  32. #BuildRequires: %{_bindir}/docbook2pdf
  33. BuildRequires: gstreamer-devel >= 0.10%
  34. BuildRequires: gstreamer-plugins-base-devel >= 0.10
  35. %if %{scrollkeeper}
  36. BuildRequires: scrollkeeper
  37. %endif
  38. BuildRequires: giflib-devel
  39. BuildRequires: gettext
  40. BuildRequires: desktop-file-utils
  41. BuildRequires: speex-devel
  42. BuildRequires: gstreamer-plugins-base-devel
  43. BuildRequires: pygtk2-devel
  44. BuildRequires: libtool-ltdl-devel
  45. BuildRequires: dejagnu
  46. BuildRequires: GConf2-devel
  47. BuildRequires: xulrunner-devel
  48. BuildRequires: autoconf automake libtool
  49. BuildRequires: libboost-devel
  50. BuildRequires: libboost-program-options
  51. BuildRequires: libboost-iostreams
  52. BuildRequires: mesa-libGLU-devel
  53. BuildRequires: libXmu-devel
  54. %if %{scrollkeeper}
  55. Requires(post): scrollkeeper
  56. Requires(postun): scrollkeeper
  57. %endif
  58. Requires(post): /sbin/ldconfig
  59. Requires(postun): /sbin/ldconfig
  60. Requires(post): /sbin/install-info
  61. Requires(preun): /sbin/install-info
  62. %description
  63. Gnash is capable of reading up to SWF v9 files and opcodes, but primarily
  64. supports SWF v7, with better SWF v8 and v9 support under heavy development.
  65. Gnash includes initial parser support for SWF v8 and v9. Not all
  66. ActionScript 2 classes are implemented yet, but all of the most heavily
  67. used ones are. Many ActionScript 2 classes are partially implemented;
  68. there is support for all of the commonly used methods of each
  69. class.
  70. %package plugin
  71. Summary: Web-client flash movie player plugin
  72. Requires: %{name} = %{version}-%{release}
  73. # this doesn't prevent wrong dependencies, in case a package
  74. # provides %%{_libdir}/mozilla/plugins (like kdebase for konqueror)
  75. # and another unrelated webbrowser is installed, like w3m-el.
  76. # Moreover konqueror could provide webclient some day
  77. #Requires: %{_libdir}/mozilla/plugins webclient
  78. Requires: webclient
  79. Group: Applications/Internet
  80. %description plugin
  81. The gnash flash movie player plugin for firefox or mozilla.
  82. %if %{kde_support}
  83. %package klash
  84. Summary: Konqueror flash movie player plugin
  85. Requires: %{name} = %{version}-%{release}
  86. Group: Applications/Multimedia
  87. %description klash
  88. The gnash flash movie player plugin for Konqueror.
  89. %endif
  90. %package cygnal
  91. Summary: Streaming media server
  92. Requires: %{name} = %{version}-%{release}
  93. Group: Applications/Multimedia
  94. %description cygnal
  95. Cygnal is a streaming media server that's Flash aware.
  96. %package devel
  97. Summary: Gnash header files
  98. Requires: %{name} = %{version}-%{release}
  99. Group: Development/Libraries
  100. %description devel
  101. Gnash header files can be used to write external Gnash extensions or to embed
  102. the Gnash GTK+ widget into a C/C++ application.
  103. %package -n python-gnash
  104. Summary: Gnash Python bindings
  105. Requires: %{name} = %{version}-%{release}
  106. Group: Applications/Multimedia
  107. %description -n python-gnash
  108. Python bindings for the Gnash widget. Can be used to embed Gnash into any PyGTK
  109. application.
  110. %prep
  111. %setup -q
  112. %patch0 -p1 -b .unistd-header
  113. %patch1 -p1 -b .integer-overflow
  114. autoreconf -if
  115. %build
  116. %configure --disable-static \
  117. --with-npapi-plugindir=%{_libdir}/mozilla/plugins \
  118. --enable-docbook --enable-ghelp --enable-media=GST \
  119. --disable-dependency-tracking --disable-rpath \
  120. --disable-testsuite \
  121. --without-swfdec-testsuite \
  122. --without-ming \
  123. --enable-cygnal \
  124. --enable-sdkinstall \
  125. --enable-python \
  126. %if %{kde_support}
  127. --enable-gui=gtk,kde4,sdl,fb \
  128. --with-kde4-prefix=%{_kde4_prefix} \
  129. --with-kde4-lib=%{_kde4_libdir}/kde4/devel \
  130. --with-kde4-incl=%{_kde4_includedir} \
  131. %else
  132. --enable-gui=gtk,sdl,fb \
  133. %endif
  134. --enable-renderer=all \
  135. --with-plugins-install=system \
  136. --disable-jemalloc \
  137. --enable-doublebuf \
  138. --htmldir=%{_datadir}/gnash/html
  139. %if %{kde_support}
  140. # make sure the Qt 4 moc etc. tools are found
  141. export PATH=%{_qt4_prefix}/bin:$PATH
  142. #doesn't work currently: %%{?_smp_mflags}
  143. # override KDE4_LIBS because configure doesn't detect it properly
  144. make KDE4_LIBS='-L%{_kde4_libdir}/kde4/devel -lkparts -lkdeui -lkdecore'
  145. %else
  146. #doesn't work currently: %%{?_smp_mflags}
  147. make
  148. %endif
  149. %install
  150. rm -rf $RPM_BUILD_ROOT
  151. make install install-plugins \
  152. DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p' \
  153. %if %{kde_support}
  154. KDE4_PLUGINDIR=%{_kde4_libdir}/kde4 \
  155. KDE4_SERVICESDIR=%{_kde4_datadir}/kde4/services \
  156. KDE4_CONFIGDIR=%{_kde4_configdir} \
  157. KDE4_APPSDATADIR=%{_kde4_appsdir}/klash
  158. %endif
  159. rm $RPM_BUILD_ROOT%{_libdir}/gnash/*.la
  160. %if %{kde_support}
  161. # KDE 4 doesn't need the .la file anymore, thankfully
  162. rm $RPM_BUILD_ROOT%{_kde4_libdir}/kde4/libklashpart.la
  163. %endif
  164. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  165. %find_lang %{name}
  166. %clean
  167. rm -rf $RPM_BUILD_ROOT
  168. %post
  169. /sbin/ldconfig
  170. %if %{scrollkeeper}
  171. scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
  172. %endif
  173. /sbin/install-info %{_infodir}/gnash_ref.info %{_infodir}/dir || :
  174. /sbin/install-info %{_infodir}/gnash_user.info %{_infodir}/dir || :
  175. update-desktop-database &> /dev/null || :
  176. touch --no-create %{_datadir}/icons/hicolor
  177. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  178. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  179. fi
  180. %preun
  181. if [ $1 = 0 ]; then
  182. /sbin/install-info --delete %{_infodir}/gnash_ref.info %{_infodir}/dir || :
  183. /sbin/install-info --delete %{_infodir}/gnash_user.info %{_infodir}/dir || :
  184. fi
  185. %postun
  186. /sbin/ldconfig
  187. %if %{scrollkeeper}
  188. scrollkeeper-update -q || :
  189. %endif
  190. update-desktop-database &> /dev/null || :
  191. touch --no-create %{_datadir}/icons/hicolor
  192. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  193. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  194. fi
  195. %files -f %{name}.lang
  196. %defattr(-,root,root,-)
  197. %doc README AUTHORS COPYING NEWS
  198. %config(noreplace) %{_sysconfdir}/gnashpluginrc
  199. %config(noreplace) %{_sysconfdir}/gnashrc
  200. %{_bindir}/fb-gnash
  201. %{_bindir}/gtk-gnash
  202. %{_bindir}/gnash-gtk-launcher
  203. %{_bindir}/rtmpget
  204. %{_bindir}/sdl-gnash
  205. %{_bindir}/gnash
  206. %{_bindir}/gprocessor
  207. %{_bindir}/findmicrophones
  208. %{_bindir}/findwebcams
  209. %dir %{_libdir}/gnash
  210. %{_libdir}/gnash/*.so*
  211. %{_mandir}/man1/gnash.1*
  212. %{_mandir}/man1/gprocessor.1*
  213. %{_mandir}/man1/findmicrophones.1*
  214. %{_mandir}/man1/findwebcams.1*
  215. %{_mandir}/man1/gtk-gnash.1*
  216. %{_mandir}/man1/gnash-gtk-launcher.1*
  217. %{_mandir}/man1/fb-gnash.1*
  218. %{_mandir}/man1/sdl-gnash.1*
  219. %{_mandir}/man1/rtmpget.1*
  220. %{_infodir}/gnash*
  221. %{_datadir}/gnash/
  222. %{_datadir}/icons/hicolor/32x32/apps/*.xpm
  223. %{_datadir}/applications/*.desktop
  224. %files plugin
  225. %defattr(-,root,root,-)
  226. %{_libdir}/mozilla/plugins/libgnashplugin.so
  227. %if %{kde_support}
  228. %files klash
  229. %defattr(-,root,root,-)
  230. %{_kde4_bindir}/kde4-gnash
  231. %{_kde4_libdir}/kde4/libklashpart.so
  232. %{_kde4_appsdir}/klash/
  233. %{_kde4_datadir}/kde4/services/klash_part.desktop
  234. %{_mandir}/man1/kde4-gnash.1*
  235. %endif
  236. %files cygnal
  237. %defattr(-,root,root,-)
  238. %config(noreplace) %{_sysconfdir}/cygnalrc
  239. %{_bindir}/cygnal
  240. %{_bindir}/flvdumper
  241. %{_bindir}/soldumper
  242. %{_mandir}/man1/cygnal.1*
  243. %{_mandir}/man1/flvdumper.1*
  244. %{_mandir}/man1/soldumper.1*
  245. %dir %{_libdir}/cygnal
  246. %{_libdir}/cygnal/plugins/*.so*
  247. %files devel
  248. %defattr(-,root,root,-)
  249. %{_includedir}/gnash/
  250. %{_libdir}/pkgconfig/gnash.pc
  251. %files -n python-gnash
  252. %defattr(-,root,root,-)
  253. %{python_sitearch}/gtk-2.0/*
  254. %changelog
  255. * Mon Apr 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.10-1
  256. - update to 0.8.10
  257. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.7-5
  258. - rebuild with python-2.7.2
  259. * Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.7-4
  260. - add BuildRequires: python-devel, libXv-devel
  261. * Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> 0.8.7-3
  262. - rebuilt with libboost-1.45.0
  263. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.7-2
  264. - rebuilt with rpm-4.8.1 for pkg-config
  265. * Wed Mar 17 2010 IWAI, Masaharu <iwai@alib.jp> 0.8.7-1
  266. - initial build for Vine Linux: based Fedora 0.8.7-1.fc14
  267. * Sat Feb 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.7-1
  268. - update to 0.8.7
  269. - make scrollkeeper a conditional (still disabled as it's not working)
  270. - drop gnash-0.8.3-manual.patch, should no longer be needed
  271. - drop gnash-0.8.6-python-install-dir.patch, fixed upstream
  272. * Fri Feb 12 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-13
  273. - delete bundled libltdl stuff to make sure it's not used
  274. * Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-12
  275. - don't build libltdlc.a
  276. * Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-11
  277. - --without-included-ltdl (CVE-2009-3736)
  278. * Fri Jan 22 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-10
  279. - Rebuild for new Boost (1.41.0)
  280. * Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-9
  281. - Add missing Epoch to Requires
  282. * Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-8
  283. - Install icon to the correct place (#551621)
  284. * Wed Dec 30 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-7
  285. - One more try at using the correct dir
  286. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-6
  287. - Patch was reversed
  288. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-5
  289. - Patch Makefile.in, not Makefile.am
  290. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-4
  291. - Pick up python modules from the right dir
  292. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-3
  293. - Install python modules in the right dir
  294. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-2
  295. - Add cygnal plugins
  296. * Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-1
  297. - Update to 0.8.6, increase epoch.
  298. * Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.8.20090910bzr11506
  299. - update to HEAD
  300. * Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.7.20090910bzr11505
  301. - update to HEAD
  302. * Mon Aug 10 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.6.20090809bzr11401
  303. - don't package headers in -widget, only in -devel (no duplicate files)
  304. - own %%{_includedir}/gnash/ in -devel
  305. - add missing %%defattr for -devel and -widget
  306. - make -devel and -widget require the main package (with exact VR)
  307. - fix -devel group and description
  308. - rename gnash-widget to python-gnash as per the naming guidelines
  309. * Sun Aug 09 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.5.20090809bzr11401
  310. - use %%{_includedir}, not %%{_prefix}/include
  311. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.4.20090809bzr11401
  312. - Install the python module in the sitearch dir
  313. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11401
  314. - One more 64bit fix
  315. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11400
  316. - Fix the packaging in 64bits
  317. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.2.20090809bzr11400
  318. - upload the .swf file
  319. * Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.1.20090809bzr11400
  320. - merge upstream changes into the spec
  321. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.5-5
  322. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  323. * Fri May 22 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-4
  324. - rebuild for new Boost
  325. * Fri Mar 06 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-3
  326. - explicitly link the KlashPart against the libraries it uses
  327. * Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-2
  328. - add missing speex-devel and gstreamer-plugins-base-devel BR
  329. * Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-1
  330. - update to 0.8.5
  331. - remove use_kde3_executable_hack
  332. - remove autoreconf
  333. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 0.8.4-7
  334. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  335. * Thu Dec 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-6
  336. - rebuild for new boost
  337. * Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-5
  338. - add missing portions of KDE 4 port from upstream kde4 branch
  339. * Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-4
  340. - add 3 more patches from bero to fix the KDE 4 viewer executable
  341. - disable use_kde3_executable hack
  342. * Sun Oct 19 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-3
  343. - add a desktop file
  344. * Sat Oct 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-2
  345. - update KDE 4 patch (undo the backporting and use original patch)
  346. - patch to make autoreconf work
  347. - add missing BR giflib-devel, gettext
  348. - omit unrecognized --with-qtdir
  349. * Sat Oct 18 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-1
  350. - update to 0.8.4
  351. * Sat Oct 4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-6
  352. - use the KDE 3 executable with the KDE 4 KPart for now (making this conditional
  353. so it can easily be disabled or removed once the KDE 4 executable is fixed)
  354. * Sat Oct 4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-5
  355. - register KComponentData properly in KDE 4 KPart
  356. * Fri Oct 3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-4
  357. - KDE 4 port of klash by Benjamin Wolsey and Bernhard Rosenkränzer
  358. * Fri Aug 29 2008 Michael Schwendt <mschwendt@fedoraproject.org> 0.8.3-3
  359. - include %%_libdir/gnash directory
  360. * Wed Jun 25 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-2
  361. - add glib in the link, thanks Daniel Drake (#452767)
  362. * Sun Jun 22 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-1
  363. - update to 0.8.3
  364. * Wed Apr 9 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-3
  365. - ship libklashpart (#441601)
  366. * Mon Mar 10 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-2
  367. - don't ship libltdl.so.3 (#436725)
  368. * Fri Mar 7 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-1
  369. - update to 0.8.2
  370. * Sat Oct 27 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-6
  371. - add patch from Martin Stransky to fix wrapped plugin #281061
  372. * Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-5
  373. - info files are empty, don't install them
  374. * Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-4
  375. - omf/scrollkeeper doc is broken, remove it
  376. * Fri Sep 7 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-3
  377. - better documentation generation
  378. * Wed Sep 5 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-2
  379. - update to 0.8.1
  380. - agg is now the default renderer
  381. * Fri Aug 3 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-2
  382. - rebuild for boost soname change
  383. * Sun Jun 17 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-1
  384. - update to 0.8.0
  385. * Wed May 9 2007 Patrice Dumas <pertusus@free.fr> 0.7.2-2
  386. - fix CVE-2007-2500 (fix 239213)
  387. * Mon Nov 6 2006 Patrice Dumas <pertusus@free.fr> 0.7.2-1
  388. - update for 0.7.2 release.
  389. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.7.1-9
  390. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  391. * Sun Sep 24 2006 Patrice Dumas <pertusus@free.fr> 0.7.1-8
  392. - plugin requires %%{_libdir}/mozilla/plugins. Fix (incompletly and
  393. temporarily, but there is no better solution yet) #207613
  394. * Sun Aug 27 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-7
  395. - add defattr for klash
  396. - add warnings in the description about stability
  397. * Mon Aug 21 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-6
  398. - remove superfluous buildrequires autoconf
  399. - rename last patch to gnash-plugin-tempfile-dir.patch
  400. - add README.fedora to plugin to explain tmpdirs
  401. * Wed Aug 16 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-5
  402. - source qt.sh and configure --with-qtdir (Dominik Mierzejewski)
  403. - add plugin-tempfile-dir.patch for plugin to use a safe tempdir
  404. * Fri Jul 28 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-4
  405. - buildrequire autotools (Michael Knox)
  406. * Fri Jun 2 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-3
  407. - add gnash-continue_on_info_install_error.patch to avoid
  408. - buildrequire libXmu-devel
  409. * Wed May 17 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-2
  410. - configure with --disable-rpath
  411. - buildrequire docbook2X
  412. - remove devel files
  413. * Sun May 7 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-1
  414. - update to 0.7.1 alpha release
  415. * Sat Apr 22 2006 Rob Savoye <rob@welcomehome.org> - 0.7-1
  416. - install the info file. Various tweaks for my system based on
  417. Patrice's latest patch,
  418. * Fri Feb 3 2006 Patrice Dumas <dumas@centre-cired.fr> - 0.7-1
  419. - initial packaging