libidn-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: libidn
  3. Summary: Internationalized Domain Name support library
  4. Summary(ja): 国際化ドメイン名をサポートするためのライブラリ
  5. Version: 1.35
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Libraries
  8. Distribution: Vine Linux
  9. Vendor: Project Vine
  10. License: GPLv3+ and LGPLv3+
  11. URL: https://www.gnu.org/software/libidn/
  12. Source0: https://ftp.gnu.org/gnu/libidn/libidn-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: gettext
  15. BuildRequires: pkgconfig
  16. Requires(post): /sbin/install-info
  17. Requires(preun): /sbin/install-info
  18. %global __provides_exclude_from ^%{_libdir}/pkgconfig/.*$
  19. %description
  20. GNU Libidn is an implementation of the Stringprep, Punycode and
  21. IDNA specifications defined by the IETF Internationalized Domain
  22. Names (IDN) working group, used for internationalized domain
  23. names.
  24. %package devel
  25. Summary: Development files for the libidn library
  26. Summary(ja): libidn ライブラリの開発用ファイル
  27. Group: Development/Libraries
  28. License: GPLv3+, LGPLv3+ and GFDLv1.3+
  29. Requires: %{name} = %{version}-%{release}
  30. Provides: pkgconfig(libidn) = %{version}
  31. %description devel
  32. This package includes header files and libraries necessary for
  33. developing programs which use the GNU libidn library.
  34. # compat32
  35. %package -n compat32-%{name}
  36. Summary: Internationalized Domain Name support library
  37. Summary(ja): 国際化ドメイン名をサポートするためのライブラリ
  38. Group: System Environment/Libraries
  39. Requires: %{name} = %{version}-%{release}
  40. %description -n compat32-%{name}
  41. GNU Libidn is an implementation of the Stringprep, Punycode and
  42. IDNA specifications defined by the IETF Internationalized Domain
  43. Names (IDN) working group, used for internationalized domain
  44. names.
  45. %package -n compat32-%{name}-devel
  46. Summary: Development files for the libidn library
  47. Summary(ja): libidn ライブラリの開発用ファイル
  48. Group: Development/Libraries
  49. License: GPLv3+, LGPLv3+ and GFDLv1.3+
  50. Requires: compat32-%{name} = %{version}-%{release}
  51. Requires: %{name}-devel = %{version}-%{release}
  52. %description -n compat32-%{name}-devel
  53. This package includes header files and libraries necessary for
  54. developing programs which use the GNU libidn library.
  55. %prep
  56. %setup -q
  57. # Disable static library creation by default.
  58. %define with_static 0
  59. %build
  60. %configure --disable-csharp --disable-java \
  61. %if ! %{with_static}
  62. --disable-static
  63. %endif
  64. make %{?_smp_mflags}
  65. make %{?_smp_mflags} -C tests check
  66. %install
  67. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  68. %makeinstall
  69. rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.la
  70. # provide more examples
  71. make %{?_smp_mflags} -C examples distclean
  72. # clean up docs
  73. find doc -name "Makefile*" | xargs rm
  74. rm -rf $RPM_BUILD_ROOT%{_datadir}/info/dir
  75. %find_lang %{name}
  76. %post
  77. /sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir
  78. /sbin/ldconfig
  79. %preun
  80. if [ $1 = 0 ]; then
  81. /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir
  82. fi
  83. %postun -p /sbin/ldconfig
  84. %if %{build_compat32}
  85. %post -n compat32-%{name} -p /sbin/ldconfig
  86. %postun -n compat32-%{name} -p /sbin/ldconfig
  87. %endif
  88. %clean
  89. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  90. %files -f %{name}.lang
  91. %defattr(-,root,root)
  92. %license COPYING*
  93. %doc AUTHORS ChangeLog NEWS FAQ README THANKS
  94. %{_bindir}/idn
  95. %{_mandir}/man1/idn.1*
  96. %{_datadir}/emacs/site-lisp
  97. %{_libdir}/libidn.so.*
  98. #{_libdir}/libidn.la
  99. %{_infodir}/*
  100. %files devel
  101. %defattr(0644,root,root,755)
  102. %doc doc/libidn.html doc/libidn-components.png examples contrib
  103. %{_libdir}/libidn.so
  104. %if %{with_static}
  105. %{_libdir}/libidn.a
  106. %endif
  107. %{_includedir}/*.h
  108. %{_libdir}/pkgconfig/*.pc
  109. %{_mandir}/man3/*
  110. # compat32
  111. %if %{build_compat32}
  112. %files -n compat32-%{name}
  113. %defattr(-,root,root)
  114. %{_libdir}/libidn.so.*
  115. #{_libdir}/libidn.la
  116. %files -n compat32-%{name}-devel
  117. %defattr(0644,root,root,755)
  118. %{_libdir}/libidn.so
  119. %if %{with_static}
  120. %{_libdir}/libidn.a
  121. %endif
  122. %{_libdir}/pkgconfig/*.pc
  123. %endif
  124. %changelog
  125. * Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.35-1
  126. - new upstream release.
  127. * Wed Feb 18 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.29-1
  128. - new upstream release
  129. - added Japanese summary
  130. * Sat Oct 1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.22-1
  131. - new upstream release
  132. * Sat Sep 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.19-1
  133. - new upstream release
  134. - built with rpm-4.8.1
  135. * Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.11-2
  136. - added compat32 package for x86_64 arch support.
  137. - disabled static library creation by default.
  138. * Mon Nov 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.11-1
  139. - new upstream release
  140. * Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8-1
  141. - new upstream release
  142. - applied new versioning policy
  143. - added --disable-csharp and --disable-java options to %%configure
  144. * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.14-0vl1
  145. - new upstream release
  146. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.9-0vl1
  147. - new upstream release
  148. * Wed Aug 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.18-0vl2
  149. - rebuild for VineSeed
  150. * Wed Aug 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.18-0vl1
  151. - new upstream release
  152. * Thu Dec 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.12-0vl2
  153. - rebuild for VineSeed
  154. * Wed Dec 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.12-0vl1
  155. - new upstream release
  156. - build for Vine Linux 3.1
  157. * Thu Oct 7 2004 Joe Orton <jorton@redhat.com> 0.5.6-1
  158. - update to 0.5.6 (#134343)
  159. * Thu Sep 30 2004 Miloslav Trmac <mitr@redhat.com> - 0.5.4-3
  160. - Fix Group: (#134068)
  161. * Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.5.4-2
  162. - move ldconfig from preun to postun (#131280)
  163. * Sun Aug 8 2004 Joe Orton <jorton@redhat.com> 0.5.4-1
  164. - update to 0.5.4 (#129341)
  165. * Thu Jul 15 2004 Robert Scheck <redhat@linuxnetz.de> 0.5.2-1
  166. - upgrade to 0.5.2, enabled i18n support and info files (#127906)
  167. * Fri Jul 9 2004 Joe Orton <jorton@redhat.com> 0.5.1-1
  168. - update to 0.5.1 (#127496)
  169. * Mon Jun 28 2004 Joe Orton <jorton@redhat.com> 0.5.0-1
  170. - update to 0.5.0 (#126836)
  171. * Tue Jun 22 2004 Than Ngo <than@redhat.com> 0.4.9-2
  172. - add prereq: /sbin/ldconfig
  173. - move la file in main package
  174. * Tue Jun 15 2004 Robert Scheck <redhat@linuxnetz.de> 0.4.9-1
  175. - upgrade to 0.4.9 (#126353)
  176. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  177. - rebuilt
  178. * Thu Apr 29 2004 Joe Orton <jorton@redhat.com> 0.4.4-1
  179. - update to 0.4.4; remove contrib from -devel docs
  180. * Thu Apr 29 2004 Joe Orton <jorton@redhat.com> 0.4.3-1
  181. - update to 0.4.3, remove -rpath patch
  182. * Tue Jan 27 2004 Joe Orton <jorton@redhat.com> 0.3.7-1
  183. - update to 0.3.7, simplify
  184. * Wed Jan 07 2004 Lenny Cartier <lenny@mandrakesoft.com> 0.3.6-1mdk
  185. - 0.3.6
  186. * Mon Dec 15 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.5-1mdk
  187. - 0.3.5
  188. * Sun Oct 19 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.3-2mdk
  189. - drop the "soname fix" and use the correct way...
  190. * Sat Oct 18 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.3-1mdk
  191. - 0.3.3
  192. * Mon Oct 13 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 0.3.2-1mdk
  193. - initial cooker contrib
  194. - used the package from PLD as a start point