pinentry-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376
  1. Name: pinentry
  2. Version: 0.9.7
  3. Release: 4%{?_dist_release}
  4. Summary: Collection of simple PIN or passphrase entry dialogs
  5. Vendor: Project Vine
  6. Distribution: Vine Linux
  7. # qt & qt4 subpackage have different license, see subpackage definitions
  8. License: GPLv2+
  9. URL: http://www.gnupg.org/aegypten/
  10. Source0: ftp://ftp.gnupg.org/gcrypt/pinentry/%{name}-%{version}.tar.bz2
  11. Source1: ftp://ftp.gnupg.org/gcrypt/pinentry/%{name}-%{version}.tar.bz2.sig
  12. # borrowed from opensuse
  13. Source10: pinentry-wrapper
  14. BuildRequires: gcr-devel
  15. BuildRequires: gtk2-devel
  16. BuildRequires: libcap-devel
  17. BuildRequires: ncurses-devel
  18. BuildRequires: qt4-devel
  19. BuildRequires: libgpg-error-devel
  20. BuildRequires: libassuan-devel
  21. BuildRequires: libsecret-devel
  22. Requires(pre): %{_sbindir}/update-alternatives
  23. Requires(post): /sbin/install-info
  24. Requires(preun): /sbin/install-info
  25. Provides: %{name}-curses = %{version}-%{release}
  26. %description
  27. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  28. utilize the Assuan protocol as described by the aegypten project; see
  29. http://www.gnupg.org/aegypten/ for details.
  30. This package contains the curses (text) based version of the PIN entry dialog.
  31. %package gnome3
  32. Summary: Passphrase/PIN entry dialog for GNOME 3
  33. Requires: %{name} = %{version}-%{release}
  34. Provides: %{name}-gui = %{version}-%{release}
  35. %description gnome3
  36. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  37. utilize the Assuan protocol as described by the aegypten project; see
  38. http://www.gnupg.org/aegypten/ for details.
  39. This package contains the GNOME 3 version of the PIN entry dialog.
  40. %package gtk
  41. Summary: Passphrase/PIN entry dialog based on GTK+
  42. Requires: %{name} = %{version}-%{release}
  43. Provides: %{name}-gui = %{version}-%{release}
  44. Provides: pinentry-gtk2 = %{version}-%{release}
  45. %description gtk
  46. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  47. utilize the Assuan protocol as described by the aegypten project; see
  48. http://www.gnupg.org/aegypten/ for details.
  49. This package contains the GTK GUI based version of the PIN entry dialog.
  50. %package qt
  51. Summary: Passphrase/PIN entry dialog based on Qt4
  52. # original code for secstring.cpp doesn't allow GPL versions higher than 3 to be
  53. # used
  54. License: GPLv2 or GPLv3
  55. Requires: %{name} = %{version}-%{release}
  56. Provides: %{name}-gui = %{version}-%{release}
  57. Obsoletes: pinentry-qt4 < 0.8.0-2
  58. Provides: pinentry-qt4 = %{version}-%{release}
  59. %description qt
  60. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  61. utilize the Assuan protocol as described by the aegypten project; see
  62. http://www.gnupg.org/aegypten/ for details.
  63. This package contains the Qt4 GUI based version of the PIN entry dialog.
  64. %package emacs
  65. Summary: Passphrase/PIN entry dialog based on emacs
  66. Requires: %{name} = %{version}-%{release}
  67. %description emacs
  68. Pinentry is a collection of simple PIN or passphrase entry dialogs which
  69. utilize the Assuan protocol as described by the aegypten project; see
  70. http://www.gnupg.org/aegypten/ for details.
  71. This package contains the emacs based version of the PIN entry dialog.
  72. %prep
  73. %setup -q
  74. %build
  75. %if 0%{?fedora} > 22
  76. # FTBFS on f23/gcc5 without this
  77. CXXFLAGS="%{optflags} -std=c++11"
  78. %endif
  79. %configure \
  80. --disable-rpath \
  81. --disable-dependency-tracking \
  82. --without-libcap \
  83. --enable-pinentry-gnome3 \
  84. --enable-pinentry-gtk2 \
  85. --enable-pinentry-qt \
  86. --enable-pinentry-emacs \
  87. --enable-libsecret
  88. make %{?_smp_mflags}
  89. %install
  90. make install DESTDIR=$RPM_BUILD_ROOT
  91. # Backwards compatibility
  92. ln -s pinentry-gtk-2 $RPM_BUILD_ROOT%{_bindir}/pinentry-gtk
  93. # This changed in 0.9.6
  94. ln -s pinentry-qt $RPM_BUILD_ROOT%{_bindir}/pinentry-qt4
  95. install -p -m755 -D %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/pinentry
  96. # unpackaged files
  97. rm -fv $RPM_BUILD_ROOT%{_infodir}/dir
  98. %post
  99. if [ -f %{_infodir}/pinentry.info* ]; then
  100. /sbin/install-info %{_infodir}/pinentry.info %{_infodir}/dir ||:
  101. fi
  102. %preun
  103. if [ $1 -eq 0 -a -f %{_infodir}/pinentry.info* ] ; then
  104. /sbin/install-info --delete %{_infodir}/pinentry.info %{_infodir}/dir ||:
  105. fi
  106. %files
  107. %{!?_licensedir:%global license %%doc}
  108. %license COPYING
  109. %doc AUTHORS ChangeLog NEWS README THANKS TODO
  110. %{_bindir}/pinentry-curses
  111. %{_bindir}/pinentry
  112. %{_infodir}/pinentry.info*
  113. %files gnome3
  114. %{_bindir}/pinentry-gnome3
  115. %files gtk
  116. %{_bindir}/pinentry-gtk
  117. %{_bindir}/pinentry-gtk-2
  118. %files qt
  119. %{_bindir}/pinentry-qt
  120. %{_bindir}/pinentry-qt4
  121. %files emacs
  122. %{_bindir}/pinentry-emacs
  123. %changelog
  124. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> - 0.9.7-4
  125. - rebuild with gcc-5.4.0
  126. * Sun May 22 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.9.7-3
  127. - initial build for Vine Linux.
  128. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.7-2
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  130. * Mon Dec 07 2015 Boris Ranto <branto@redhat.com> - 0.9.7-1
  131. - Rebase to latest upstream version
  132. * Tue Oct 27 2015 Stef Walter <stefw@redhat.com> - 0.9.6-4
  133. - Enable libsecret, which enables password caching in pinentry-gnome3
  134. - Resolves rhbz#1275567
  135. * Thu Oct 15 2015 Kalev Lember <klember@redhat.com> - 0.9.6-3
  136. - Add pinentry-gnome3 support to pinentry wrapper
  137. * Mon Sep 21 2015 Kalev Lember <klember@redhat.com> - 0.9.6-2
  138. - Build pinentry-gnome3
  139. * Fri Sep 11 2015 Boris Ranto <branto@redhat.com> - 0.9.6-1
  140. - Rebase to latest upstream version
  141. - Modify backwards compatible symlink for qt(4)
  142. - Enable pinentry-emacs since it was enabled by default in 0.9.5
  143. * Thu Jul 02 2015 Boris Ranto <branto@redhat.com> - 0.9.5-1
  144. - Rebase to latest upstream version
  145. - Removing qt4 pinentry patch -- got merged upstream
  146. - New package pinentry-emacs that hosts pinentry-emacs
  147. - New dependencies on libassuan and libgpg-error (de-bundling)
  148. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.2-2
  149. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  150. * Thu May 14 2015 Boris Ranto <branto@redhat.com> - 0.9.2-1
  151. - Rebase to latest upstream version
  152. * Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 0.9.1-2
  153. - Rebuilt for GCC 5 C++11 ABI change
  154. * Wed Mar 25 2015 Boris Ranto <branto@redhat.com> - 0.9.1-1
  155. - Rebase to latest upstream version
  156. - There are no longer any moc files so there is no need to patch them
  157. * Fri Mar 13 2015 Rex Dieter <rdieter@fedoraproject.org> - 0.9.0-3
  158. - fix FTBFS on f23/gcc5
  159. - drop deprecated configure flags
  160. * Sat Feb 21 2015 Till Maas <opensource@till.name> - 0.9.0-2
  161. - Rebuilt for Fedora 23 Change
  162. https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
  163. * Wed Nov 12 2014 Boris Ranto <branto@redhat.com> - 0.9.0-1
  164. - Rebase to latest upstream version
  165. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-7
  166. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  167. * Tue Aug 12 2014 Boris Ranto <branto@redhat.com> - 0.8.3-6
  168. - fix bogus dates
  169. - upgrade pinentry-wrapper to handle corner cases better
  170. * Wed Jul 30 2014 Tom Callaway <spot@fedoraproject.org> - 0.8.3-5
  171. - fix license handling
  172. * Sat Jul 19 2014 Rex Dieter <rdieter@fedoraproject.org> 0.8.3-4
  173. - /usr/bin/pinentry should not check if stderr is opened (#787775)
  174. * Sat Jul 19 2014 Rex Dieter <rdieter@fedoraproject.org> - 0.8.3-3
  175. - .spec cleanup (drop support for old releases)
  176. - -gtk: Provides: pinentry-gtk2
  177. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-2
  178. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  179. * Thu Jan 30 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.3-1
  180. - Update to latest upstream version (0.8.3)
  181. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-11
  182. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  183. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-10
  184. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  185. * Wed Nov 14 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-9
  186. - Fix macros expansions so that conditionals work
  187. * Mon Nov 12 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-8
  188. - Fix up licenses for qt and qt4 subpackages (#875875)
  189. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-7
  190. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  191. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-6
  192. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  193. * Mon Nov 14 2011 Adam Jackson <ajax@redhat.com> 0.8.1-5
  194. - Rebuild for new libpng
  195. * Tue Jul 26 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-4
  196. - Improve wrapper to fallback to curses even with DISPLAY set (#622077)
  197. * Fri Feb 18 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-3
  198. - Fix pinentry-curses running as root by disabling capabilities (#677670)
  199. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-2
  200. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  201. * Tue Feb 1 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-1
  202. - Updated to latest upstream version (0.8.1)
  203. * Fri May 7 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.0-3
  204. - Fix X11 even race with gtk (#589998)
  205. - Fix qt4 problems with creating window in the background (#589532)
  206. * Thu Apr 29 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.8.0-2
  207. - -qt: build as qt4 version, and drop qt3 support (f13+ only)
  208. * Tue Apr 27 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.0-1
  209. - pinentry-0.8.0
  210. - pinentry-gtk keyboard grab fail results in SIGABRT (#585422)
  211. * Sun Apr 18 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-5
  212. - pinentry-gtk -g segfaults on focus change (#520236)
  213. * Sun Sep 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-4
  214. - Errors installing with --excludedocs (#515925)
  215. * Sun Sep 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-3
  216. - drop alternatives, use app-wrapper instead (borrowed from opensuse)
  217. - -qt4 experimental subpkg, -qt includes qt3 version again (#523488)
  218. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.6-2
  219. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  220. * Mon Jun 22 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-1
  221. - pinentry-0.7.6
  222. - -qt switched qt4 version, where applicable (f9+, rhel6+)
  223. - fixup scriptlets
  224. * Sat Apr 25 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.5-1
  225. - pinentry-0.7.5
  226. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-6
  227. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  228. * Tue Mar 25 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.7.4-5
  229. - pinentry failed massrebuild attempt for GCC 4.3 (#434400)
  230. * Tue Mar 25 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.7.4-4
  231. - s/qt-devel/qt3-devel/ (f9+)
  232. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.7.4-3
  233. - Autorebuild for GCC 4.3
  234. * Sun Feb 17 2008 Adam Tkac <atkac redhat com> - 0.7.4-2
  235. - rebuild against new libcap
  236. * Sun Dec 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.4-1
  237. - pinentry-0.7.4
  238. - BR: libcap-devel
  239. * Sat Aug 25 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.3-2
  240. - respin (BuildID)
  241. * Sat Aug 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.3-1
  242. - pinentry-0.7.3
  243. - License: GPLv2+
  244. * Thu May 10 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.2-15
  245. - respin (for ppc64)
  246. * Mon Dec 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-14
  247. - -14 respin (to help retire ATrpms pinentry pkg)
  248. * Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-3
  249. - fc6 respin
  250. * Wed Aug 09 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-2
  251. - fc6 respin
  252. * Wed Mar 01 2006 Rex Dieter <rexdieter[AT]users.sf.net>
  253. - fc5: gcc/glibc respin
  254. * Tue Oct 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.7.2-1
  255. - 0.7.2, docs patch applied upstream.
  256. - Switch to GTK2 in -gtk.
  257. - Fine tune dependencies.
  258. - Build with dependency tracking disabled.
  259. - Clean up obsolete pre-FC2 support.
  260. * Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.7.1-4
  261. - rebuilt
  262. * Wed Jun 30 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.3
  263. - BuildRequires qt-devel >= 3.2.
  264. * Sat May 22 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.2
  265. - Spec cleanups.
  266. * Sat Apr 24 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.1
  267. - Update to 0.7.1.
  268. * Fri Dec 26 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.0-0.fdr.1
  269. - Update to 0.7.0.
  270. - Split GTK+ and QT dialogs into subpackages.
  271. * Thu Jul 10 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.9-0.fdr.1
  272. - Update to 0.6.9.
  273. - Smoother experience with --excludedocs.
  274. - Don't change alternative priorities on upgrade.
  275. * Sat Mar 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.8-0.fdr.1
  276. - Update to current Fedora guidelines.
  277. * Wed Feb 12 2003 Warren Togami <warren@togami.com> 0.6.8-1.fedora.3
  278. - info/dir temporary workaround
  279. * Sat Feb 8 2003 Ville Skyttä <ville.skytta at iki.fi> - 0.6.8-1.fedora.1
  280. - First Fedora release.