123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410 |
- %{!?ruby_vendorarch: %global ruby_vendorarch %(ruby -r rbconfig -e "puts RbConfig::CONFIG['vendorarchdir'].nil? ? RbConfig::CONFIG['sitearchdir'] : RbConfig::CONFIG['vendorarchdir']")}
- %define _unpackaged_files_terminate_build 1
- %define filter_provides_in(P) %{expand: \
- %global __filter_prov_cmd %{?__filter_prov_cmd} %{__grep} -v %{-P} '%*' | \
- }
- %define filter_setup %{expand: \
- %global _use_internal_dependency_generator 0 \
- %global __deploop() while read FILE; do /usr/lib/rpm/rpmdeps -%{1} ${FILE}; done | /bin/sort -u \
- %global __find_provides /bin/sh -c "%{?__filter_prov_cmd} %{__deploop P} %{?__filter_from_prov}" \
- %global __find_requires /bin/sh -c "%{?__filter_req_cmd} %{__deploop R} %{?__filter_from_req}" \
- }
- %filter_provides_in %{perl_vendorarch}/.*\.so$
- %filter_provides_in %{python3_sitearch}/.*\.so$
- %global _cmake_opts \\\
- -DFEDORA=1 \\\
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \\\
- -DENABLE_PERL=1 \\\
- -DENABLE_PYTHON=1 \\\
- -DENABLE_RUBY=1 \\\
- -DUSE_VENDORDIRS=1 \\\
- -DENABLE_DEBIAN=1 \\\
- -DENABLE_ARCHREPO=1 \\\
- -DENABLE_SUSEREPO=1 \\\
- -DENABLE_HELIXREPO=1 \\\
- -DENABLE_LZMA_COMPRESSION=1 \\\
- -DMULTI_SEMANTICS=1 \\\
- -DENABLE_COMPLEX_DEPS=1 \\\
- %{nil}
- %filter_provides_in %{ruby_vendorarch}/.*\.so$
- %filter_setup
- Name: libsolv
- Summary: Package dependency solver
- Version: 0.7.20
- Release: 1%{?_dist_release}
- Group: system
- Vendor: Project Vine
- Distribution: Vine Linux
- License: BSD
- URL: https://github.com/openSUSE/libsolv
- Source: https://github.com/openSUSE/libsolv/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
- #Patch0: 0001-ruby-make-compatible-with-ruby-2.2.patch
- BuildRequires: git git-devel
- BuildRequires: cmake libdb-devel expat-devel rpm-devel zlib-devel
- BuildRequires: swig
- BuildRequires: perl ruby ruby-devel
- BuildRequires: python3-devel
- BuildRequires: python3-setuptools
- BuildRequires: python3-rpm-macros
- BuildRequires: xz-devel
- %description
- A free package dependency solver using a satisfiability algorithm. The
- library is based on two major, but independent, blocks:
- - Using a dictionary approach to store and retrieve package
- and dependency information.
- - Using satisfiability, a well known and researched topic, for
- resolving package dependencies.
- %package devel
- Summary: A new approach to package dependency solving
- Group: programming
- Requires: libsolv-tools%{?_isa} = %{version}-%{release}
- Requires: libsolv%{?_isa} = %{version}-%{release}
- Requires: rpm-devel%{?_isa}
- Requires: cmake
- %description devel
- Development files for libsolv,
- %package tools
- Summary: A new approach to package dependency solving
- Group: programming
- Requires: gzip bzip2 coreutils
- Requires: libsolv%{?_isa} = %{version}-%{release}
- %description tools
- Package dependency solver tools.
- %package demo
- Summary: Applications demoing the libsolv library
- Group: programming
- Requires: curl gnupg
- %description demo
- Applications demoing the libsolv library.
- %package -n ruby-solv
- Summary: Ruby bindings for the libsolv library
- Group: programming
- Requires: libsolv%{?_isa} = %{version}-%{release}
- %description -n ruby-solv
- Ruby bindings for sat solver.
- %package -n python3-solv
- Summary: Python 3 bindings for the libsolv library
- Group: programming
- Requires: python3
- Requires: libsolv%{?_isa} = %{version}-%{release}
- %{?python_provide:%python_provide python3-solv}
- %description -n python3-solv
- Python 3 bindings for sat solver.
- %package -n perl-solv
- Summary: Perl bindings for the libsolv library
- Group: programming
- Requires: perl
- Requires: libsolv%{?_isa} = %{version}-%{release}
- %description -n perl-solv
- Perl bindings for sat solver.
- %debug_package
- %prep
- %autosetup -S git
- %build
- %cmake %_cmake_opts \
- -DPythonLibs_FIND_VERSION=3 -DPythonLibs_FIND_VERSION_MAJOR=3
- %cmake_build
- %install
- %cmake_install
- %check
- export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
- %ctest
- %files
- %license LICENSE*
- %doc README BUGS
- %_libdir/libsolv.so.*
- %_libdir/libsolvext.so.*
- %files tools
- %_bindir/archpkgs2solv
- %_bindir/archrepo2solv
- %_bindir/deb2solv
- %_bindir/deltainfoxml2solv
- %_bindir/dumpsolv
- %_bindir/helix2solv
- %_bindir/installcheck
- %_bindir/mergesolv
- %_bindir/repo2solv
- %_bindir/repomdxml2solv
- %_bindir/rpmdb2solv
- %_bindir/rpmmd2solv
- %_bindir/rpms2solv
- %_bindir/susetags2solv
- %_bindir/testsolv
- %_bindir/updateinfoxml2solv
- %files devel
- %doc examples/solv/
- %_libdir/libsolv.so
- %_libdir/libsolvext.so
- %_includedir/solv
- %_datadir/cmake/Modules/FindLibSolv.cmake
- %{_mandir}/man?/*
- %{_libdir}/pkgconfig/%{name}.pc
- %{_libdir}/pkgconfig/%{name}ext.pc
- %files demo
- %_bindir/solv
- %files -n perl-solv
- %doc examples/p5solv
- %{perl_vendorarch}/*
- %files -n ruby-solv
- %doc examples/rbsolv
- %{ruby_vendorarch}/*
- %files -n python3-solv
- %doc examples/pysolv
- %{python3_sitearch}/*
- %changelog
- * Tue Oct 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.20-1
- - new upstream release.
- * Thu Sep 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.19-1
- - new upstream release.
- - dropped ldconfig scriptlets.
- * Mon Feb 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.17-2
- - rebuilt with rpm-4.16.
- * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.17-1
- - new upstream release.
- - dropped python2 support.
- * Wed Mar 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.11-1
- - new upstream release.
- * Tue Sep 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.6-1
- - new upstream release.
- * Mon Nov 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.35-1
- - new upstream release.
- * Wed Jan 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.30-1
- - new upstream release.
- * Sun Jul 17 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.22-1
- - new upstream release.
- * Sun May 8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.20-1
- - new upstream release.
- * Sun Nov 22 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.14-4
- - initial build for Vine Linux.
- * Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.14-3
- - Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
- * Wed Oct 14 2015 Michal Luscon <mluscon@redhat.com> - 0.6.14-2
- - Backport patches from upstream
- * Mon Oct 12 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.6.14-1
- - Update to 0.6.14
- - Backport patches from upstream
- * Thu Sep 10 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.6.12-1
- - Update to 0.6.12
- * Wed Aug 05 2015 Jan Silhan <jsilhan@redhat.com> - 0.6.11-3
- - added compile flag to support rich dependencies
- - new version adding MIPS support
- - Distribute testsolv in -tools subpackage (Igor Gnatenko)
- - Enable python3 bindings for fedora (Igor Gnatenko)
- * Tue Aug 04 2015 Adam Williamson <awilliam@redhat.com> - 0.6.11-2
- - make bindings require the exact matching version of the lib (#1243737)
- * Mon Jun 22 2015 Jan Silhan <jsilhan@redhat.com> - 0.6.11-1
- - new version fixing segfault
- - RbConfig fixed in the upstream (1928f1a), libsolv-ruby22-rbconfig.patch erased
- * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
- * Wed Mar 25 2015 Jan Silhan <jsilhan@redhat.com> - 0.6.10-1
- - new version fixing segfault
- * Fri Mar 6 2015 Jan Silhan <jsilhan@redhat.com> - 0.6.8-3
- - Rebuilt with new provides selection feature
- * Mon Jan 19 2015 Vít Ondruch <vondruch@redhat.com> - 0.6.8-2
- - Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.2
- * Fri Jan 16 2015 Richard Hughes <richard@hughsie.com> - 0.6.8-2
- - Update to latest upstream release to fix a crash in PackageKit.
- * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.4-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
- * Mon Aug 11 2014 Jan Silhan <jsilhan@redhat.com> - 0.6.4-2
- - Rebase to upstream 12af31a
- * Mon Jul 28 2014 Aleš Kozumplík <akozumpl@redhat.com> - 0.6.4-1
- - Rebase to upstream 5bd9589
- * Mon Jul 14 2014 Jan Silhan <jsilhan@redhat.com> - 0.6.4-0.git2a5c1c4
- - Rebase to upstream 2a5c1c4
- - Filename selector can start with a star
- * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-2.git6d968f1
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
- * Tue May 27 2014 Aleš Kozumplík <ales@redhat.com> - 0.6.1-1.git6d968f1
- - Rebase to upstream 6d968f1
- - Fix RhBug:1049209
- * Fri Apr 25 2014 Jan Silhan <jsilhan@redhat.com> - 0.6.1-0.gitf78f5de
- - Rebase to 0.6.0, upstream commit f78f5de.
- * Thu Apr 24 2014 Vít Ondruch <vondruch@redhat.com> - 0.6.0-0.git05baf54.1
- - Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.1
- * Wed Apr 9 2014 Jan Silhan <jsilhan@redhat.com> - 0.6.0-0.git05baf54
- - Rebase to 0.6.0, upstream commit 05baf54.
- * Mon Dec 16 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.4.1-1.gitbcedc98
- - Rebase upstream bcedc98
- - Fix RhBug:1051917.
- * Mon Dec 16 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.4.1-0.gita8e47f1
- - Rebase to 0.4.1, upstream commit a8e47f1.
- * Fri Nov 22 2013 Zdenek Pavlas <zpavlas@redhat.com> - 0.4.0-2.git4442b7f
- - Rebase to 0.4.0, upstream commit 4442b7f.
- - support DELTA_LOCATION_BASE for completeness
- * Tue Oct 29 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.4.0-1.gitd49d319
- - Rebase to 0.4.0, upstream commit d49d319.
- * Sat Aug 03 2013 Petr Pisar <ppisar@redhat.com> - 0.3.0-9.gita59d11d
- - Perl 5.18 rebuild
- * Wed Jul 31 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-8.gita59d11d
- - Rebase to upstream a59d11d.
- * Fri Jul 19 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-7.git228d412
- - Add build flags, including Deb, Arch, LZMA and MULTI_SEMANTICS. (RhBug:985905)
- * Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 0.3.0-6.git228d412
- - Perl 5.18 rebuild
- * Mon Jun 24 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-5.git228d412
- - Rebase to upstream 228d412.
- - Fixes hawkey github issue https://github.com/akozumpl/hawkey/issues/13
- * Thu Jun 20 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-4.git209e9cb
- - Rebase to upstream 209e9cb.
- - Package the new man pages.
- * Thu May 16 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-3.git7399ad1
- - Run 'make test' with libsolv build.
- * Mon Apr 8 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-2.git7399ad1
- - Rebase to upstream 7399ad1.
- - Fixes RhBug:905209
- * Mon Apr 8 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-1.gite372b78
- - Rebase to upstream e372b78.
- - Fixes RhBug:e372b78
- * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-2.gitf663ca2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
- * Thu Aug 23 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-17.git6c9d3eb
- - Rebase to upstream 6c9d3eb.
- - Drop the solv.i stdbool.h fix integrated upstream.
- - Dropped the job reasons fix.
- * Mon Jul 23 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-16.git1617994
- - Fix build problems with Perl bindings.
- * Mon Jul 23 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-15.git1617994
- - Rebuilt after a failed mass rebuild.
- * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.0-14.git1617994
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
- * Mon Jul 16 2012 Aleš Kozumplik <akozumpl@redhat.com> - 0.0.0-13.git1617994%{?dist}
- - preliminary fix for JOB resons in solver_describe_decision().
- * Sun Jul 1 2012 Aleš Kozumplik <akozumpl@redhat.com> - 0.0.0-12.git1617994%{?dist}
- - Rebase to upstream 1617994.
- - Support for RPM_ADD_WITH_HDRID.
- * Thu Jun 7 2012 Aleš Kozumplik <akozumpl@redhat.com> - 0.0.0-11.gitd39a42b%{?dist}
- - Rebase to upstream d39a42b.
- - Fix the epochs.
- - Move the ruby modules into vendorarch dir, where they are expected.
- * Thu May 17 2012 Aleš Kozumplik <akozumpl@redhat.com> - 0.0.0-9.git8cf7650%{?dist}
- - Rebase to upstream 8cf7650.
- - ruby bindings: fix USE_VENDORDIRS for Fedora.
- * Thu Apr 12 2012 Aleš Kozumplik <akozumpl@redhat.com> - 0.0.0-7.gitaf1465a2%{?dist}
- - Rebase to the upstream.
- - Make repo_add_solv() work without stub repodata.
- * Thu Apr 5 2012 Karel Klíč <kklic@redhat.com> - 0.0.0-6.git80afaf7%{?dist}
- - Rebuild for the new libdb package.
- * Mon Apr 2 2012 Karel Klíč <kklic@redhat.com> - 0.0.0-5.git80afaf7%{?dist}
- - Rebuild for the new rpm package.
- * Wed Mar 21 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-4.git80afaf7%{?dist}
- - New upstream version, fix the .rpm release number.
- * Wed Mar 21 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-3.git80afaf7%{?dist}
- - New upstream version.
- * Tue Feb 7 2012 Karel Klíč <kklic@redhat.com> - 0.0.0-2.git857fe28%{?dist}
- - Adapted to Ruby 1.9.3 (workaround for broken CMake in Fedora and
- ruby template correction in bindings)
- * Thu Feb 2 2012 Karel Klíč <kklic@redhat.com> - 0.0.0-1.git857fe28
- - Initial packaging
- - Based on Jindra Novy's spec file
- - Based on upstream spec file
|