thunderbird-vl.spec 28 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845
  1. # do not include minor version number in MOZILLA_FIVE_HOME
  2. %define tbmajor 10.0.1
  3. #%define tbversion %{tbmajor}.10
  4. %define tbversion %{tbmajor}
  5. %define tbrelease 1%{?_dist_release}
  6. # The tarball is pretty inconsistent with directory structure.
  7. # Sometimes there is a top level directory. That goes here.
  8. #
  9. # IMPORTANT: If there is no top level directory, this should be
  10. # set to the cwd, ie: '.'
  11. #%define tarballdir .
  12. %define tarballdir comm-release
  13. %define mozappdir %{_libdir}/%{name}-%{version_internal}
  14. %define moz_objdir objdir-tb
  15. %define version_internal %{tbmajor}
  16. %define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
  17. %define desktop_file_utils_version 0.6
  18. %define nspr_version 4.8
  19. %define nss_version 3.13.1
  20. %define cairo_version 1.6.0
  21. %define freetype_version 2.1.9
  22. %define sqlite_version 3.6.14
  23. %define libnotify_version 0.4
  24. %define build_vine7 0
  25. %define build_vine6 0
  26. %define build_vine5 0
  27. %if "%{?_dist_release}" >= "vl7"
  28. %define build_vine7 1
  29. %endif
  30. %if "%{?_dist_release}" == "vl6"
  31. %define build_vine6 1
  32. %endif
  33. %if "%{?_dist_release}" == "vl5"
  34. %define build_vine5 1
  35. %endif
  36. Summary: Thunderbird Community Edition, Mail/newsgroup client
  37. Summary(ja): Thunderbirdコミュニティエディション, メール・ニュースクライアント
  38. Name: thunderbird
  39. Version: %{tbversion}
  40. Release: %{tbrelease}
  41. URL: http://www.mozilla.org/projects/thunderbird/
  42. License: MPL
  43. Group: Applications/Internet
  44. Source0: ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
  45. Source1: ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
  46. Source1010: mozconfig-thunderbird-vine5
  47. Source1020: mozconfig-thunderbird-vine6
  48. Source1030: mozconfig-thunderbird-vine7
  49. Source12: thunderbird-vine-default-prefs.js
  50. Source20: thunderbird.desktop
  51. Source21: thunderbird.vine.sh.in
  52. Source30: thunderbird-open-browser.sh
  53. Source40: thunderbird-unofficial-brandig-tb-brand.properties
  54. Source41: thunderbird-unofficial-brandig-tb-brand.dtd
  55. Source42: thunderbird-unofficial-brandig-tb-ja-brand.properties
  56. Source43: thunderbird-unofficial-brandig-tb-ja-brand.dtd
  57. Source100: find-external-requires
  58. # locale sources
  59. #%define MOZ_BUILD_LOCALES "ja"
  60. # get from mercurial repository with command,
  61. # mkdir l10n
  62. # hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
  63. #Source1000: thunderbird-%{tbversion}-ja.tar.bz2
  64. # upstream patch
  65. # Fix for version issues
  66. Patch0: thunderbird-version.patch
  67. # customization patches
  68. Patch1: firefox-1.5-default-a4-paper.patch
  69. # Linux specific
  70. Patch100: thunderbird-9.0-enable-addons.patch
  71. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  72. BuildRequires: pango-devel
  73. BuildRequires: cairo-devel >= %{cairo_version}
  74. %if %{build_vine7}
  75. BuildRequires: nspr-devel >= %{nspr_version}
  76. BuildRequires: nss-devel >= %{nss_version}
  77. BuildRequires: hunspell-devel
  78. %endif
  79. %if %{build_vine6}
  80. BuildRequires: nspr-devel >= %{nspr_version}
  81. BuildRequires: hunspell-devel
  82. %endif
  83. BuildRequires: pixman-devel
  84. BuildRequires: libpng-devel
  85. %if %{build_vine5}
  86. BuildRequires: libjpeg-devel
  87. %else
  88. BuildRequires: libjpeg-turbo-devel
  89. %endif
  90. BuildRequires: gtk2-devel
  91. BuildRequires: zlib-devel, gzip, zip, unzip
  92. BuildRequires: libIDL-devel
  93. BuildRequires: freetype2-devel >= %{freetype_version}
  94. ## disabled libnotify support
  95. ## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
  96. BuildRequires: libnotify-devel >= %{libnotify_version}
  97. BuildRequires: bzip2-devel
  98. BuildRequires: gnome-vfs2-devel
  99. BuildRequires: libgnome-devel
  100. BuildRequires: libgnomeui-devel
  101. BuildRequires: krb5-devel
  102. BuildRequires: pango-devel
  103. BuildRequires: libXt-devel
  104. BuildRequires: libXrender-devel
  105. # hunspell is in plus category for vine
  106. #BuildRequires: hunspell-devel
  107. BuildRequires: sqlite3-devel >= %{sqlite_version}
  108. BuildRequires: startup-notification-devel
  109. BuildRequires: desktop-file-utils
  110. BuildRequires: alsa-lib-devel
  111. BuildRequires: yasm
  112. Requires: sqlite3 >= %{sqlite_version}
  113. Requires(post): desktop-file-utils >= %{desktop_file_utils_version}
  114. Requires(postun): desktop-file-utils >= %{desktop_file_utils_version}
  115. Obsoletes: MozillaThunderbird
  116. Provides: MozillaThunderbird = %{version}
  117. Vendor: Project Vine
  118. Distribution: Vine Linux
  119. Packager: daisuke, ryoichi, kazutaka
  120. AutoProv: 0
  121. %define _use_internal_dependency_generator 0
  122. %define __find_requires %{SOURCE100}
  123. %description
  124. Thunderbird is a standalone mail and newsgroup client.
  125. %description -l ja
  126. Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
  127. #===============================================================================
  128. %prep
  129. %setup -q %{name}-%{version} -c
  130. cd %{tarballdir}
  131. # Fix for version issue
  132. sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
  133. > version.patch
  134. %{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
  135. cd mozilla
  136. %patch1 -p1 -b .default-a4
  137. cd -
  138. %{__rm} -f .mozconfig
  139. %if %{build_vine5}
  140. %{__cp} %{SOURCE1010} .mozconfig
  141. %endif
  142. %if %{build_vine6}
  143. %{__cp} %{SOURCE1020} .mozconfig
  144. %endif
  145. %if %{build_vine7}
  146. %{__cp} %{SOURCE1030} .mozconfig
  147. %endif
  148. # setup unofficial branding name
  149. %{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
  150. %{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
  151. %patch100 -p1 -b .addons
  152. #===============================================================================
  153. %build
  154. cd %{tarballdir}
  155. INTERNAL_GECKO=%{version_internal}
  156. MOZ_APP_DIR=%{mozappdir}
  157. #MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
  158. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
  159. export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
  160. export CFLAGS="$RPM_OPT_FLAGS"
  161. export CXXFLAGS="$CFLAGS"
  162. export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
  163. %ifarch ppc ppc64 s390 s390x
  164. %define moz_make_flags -j1
  165. %else
  166. %define moz_make_flags %{?_smp_mflags}
  167. %endif
  168. export PREFIX='%{_prefix}'
  169. export LIBDIR='%{_libdir}'
  170. export LDFLAGS="-Wl,-rpath,%{mozappdir}"
  171. export MAKE="gmake %{moz_make_flags}"
  172. %{__make} -f client.mk build
  173. ## build locales
  174. #LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
  175. # sed -e 's|\./\(.*\)/locales/.*|\1|g'`
  176. #for dir in $LOCALEDIRS
  177. #do
  178. # for lang in %{MOZ_BUILD_LOCALES} ; do
  179. # make -C $dir/locales AB_CD=$lang
  180. # done
  181. #done
  182. #===============================================================================
  183. %install
  184. %{__rm} -rf $RPM_BUILD_ROOT
  185. cd %{tarballdir}
  186. INTERNAL_GECKO=%{version_internal}
  187. INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
  188. MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
  189. cd %{moz_objdir}
  190. DESTDIR=$RPM_BUILD_ROOT make install
  191. # install unofficial icons
  192. cd -
  193. %{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
  194. %{__cp} mail/branding/aurora/mailicon16.png \
  195. $RPM_BUILD_ROOT/%{mozappdir}/icons/
  196. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
  197. %{__cp} mail/branding/aurora/mailicon16.png \
  198. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
  199. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
  200. %{__cp} mail/branding/aurora/mailicon22.png \
  201. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
  202. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
  203. %{__cp} mail/branding/aurora/mailicon24.png \
  204. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
  205. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
  206. %{__cp} mail/branding/aurora/mailicon32.png \
  207. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
  208. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
  209. %{__cp} mail/branding/aurora/mailicon48.png \
  210. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
  211. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
  212. %{__cp} mail/branding/aurora/mailicon256.png \
  213. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
  214. desktop-file-install --vendor vine \
  215. --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
  216. # set up the thunderbird start script
  217. rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
  218. %{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
  219. $RPM_BUILD_ROOT%{_bindir}/thunderbird
  220. %{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
  221. install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
  222. %{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
  223. %{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
  224. -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
  225. $RPM_BUILD_ROOT/vine-default-prefs
  226. %{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
  227. %{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
  228. %{__rm} $RPM_BUILD_ROOT/vine-default-prefs
  229. %{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
  230. # own mozilla plugin dir (#135050)
  231. %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
  232. # own extension directories
  233. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
  234. %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
  235. # install locales
  236. #for lang in %{MOZ_BUILD_LOCALES} ; do
  237. # %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
  238. #done
  239. # install ja.xpi to langpacks directory
  240. #%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
  241. #unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
  242. # also setup unofficial branding name
  243. #%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
  244. #%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
  245. # install ja.xpi to langpack file
  246. %{__mkdir_p} lang_tmp
  247. unzip %{SOURCE1} -d lang_tmp
  248. # also setup unofficial branding name
  249. %{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
  250. %{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
  251. %{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
  252. cd lang_tmp; \
  253. zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
  254. %clean
  255. %{__rm} -rf $RPM_BUILD_ROOT
  256. #===============================================================================
  257. %post
  258. update-desktop-database &> /dev/null || :
  259. touch --no-create %{_datadir}/icons/hicolor
  260. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  261. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  262. fi
  263. %postun
  264. update-desktop-database &> /dev/null || :
  265. touch --no-create %{_datadir}/icons/hicolor
  266. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  267. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  268. fi
  269. %files
  270. %defattr(-,root,root,-)
  271. %attr(755,root,root) %{_bindir}/thunderbird
  272. %attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
  273. %{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
  274. %{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
  275. %{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
  276. %{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
  277. %{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
  278. %{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
  279. %{mozappdir}
  280. #%{_libdir}/mozilla
  281. %exclude %{_libdir}/%{name}-%{version_internal}/removed-files
  282. %exclude %{_datadir}/idl/%{name}-%{version_internal}
  283. %exclude %{_includedir}/%{name}-%{version_internal}
  284. %exclude %{_libdir}/%{name}-devel-%{version_internal}
  285. #===============================================================================
  286. %changelog
  287. * Mon Feb 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.1-1
  288. - new upstream release
  289. * Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
  290. - new upstream release
  291. * Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
  292. - new upstream release
  293. - update Source1
  294. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
  295. - new upstream release
  296. - update Source1
  297. - add Source1030 (mozconfig-thunderbird-vine7)
  298. - add Patch100 (thunderbird-9.0-enable-addons.patch)
  299. * Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
  300. - fix %%version_internal
  301. * Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
  302. - new upstream release
  303. - update Source1
  304. * Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
  305. - new upstream release
  306. - update Source1,21,1010,1020
  307. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
  308. - rebuild with libnotify-0.7
  309. * Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
  310. - enable-install-strip
  311. * Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
  312. - new upstream release
  313. - drop obsolete patch and renumber patch26 to patch1
  314. - add BuildRequires: yasm
  315. - enable libnotify support
  316. - add --disable-updater and --disable-installer to mozconfig
  317. - use ja.xpi instead of l10n source
  318. - update Source21: add step to setup langpack plugin
  319. - update Source20: add japanese translation
  320. - add Source42 & Source43 for localized branding
  321. - add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
  322. for mozconfig-thunderbird-vine5
  323. * Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
  324. - new upstream release with security fix
  325. * Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
  326. - new upstream release with security fix
  327. * Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
  328. - new upstream release with security fix
  329. * Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
  330. - new upstream release with security fix
  331. - add patch5 to fix build failure
  332. * Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
  333. - new upstream release
  334. * Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
  335. - new upstream release with security fix
  336. - add Patch1030 to fix compilation error
  337. * Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
  338. - change mozconfig (Source1030 & 1040): add --enable-jsd
  339. * Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
  340. - new upstream release
  341. * Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
  342. - new upstream release with security fix
  343. - add Patch0 from fedora development: fix version issue
  344. - remove BuildRequires: hunspell-devel
  345. - update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
  346. * Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
  347. - add BuildRequires: alsa-lib-devel
  348. - remove BuildRequires: libnotify-devel
  349. (workaround for known bug)
  350. - update mozconfig to add --disable-libnotify option
  351. * Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
  352. - new upstream release
  353. - update spec entirely
  354. - import patches from fedora (Patch1, 2 & 4)
  355. - drop outdated patches (Patch22, 24)
  356. - update Sources:
  357. - mozconfig (Source1030 & Source1040)
  358. - default prefs.js (Source12)
  359. - unofficial branding (Source40 & Source41)
  360. - japanese translation (Source1000)
  361. - update Patch1000 (sjis-alias)
  362. * Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
  363. - new upstream release
  364. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
  365. - new upstream release
  366. * Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
  367. - don't install official branding logos
  368. * Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
  369. - add necessary icons in %%{tbdir}/chrome/icons/default
  370. - add Packager tag
  371. * Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
  372. - new upstream release
  373. * Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
  374. - new upstream release
  375. * Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
  376. - new upstream release
  377. * Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
  378. - new upstream release
  379. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
  380. - rebuilt for VineSeed
  381. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
  382. - new upstream release
  383. * Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
  384. - new upstream release
  385. - built for Vine Linux 4.x
  386. - dropped Patch1020 (merged into upstream)
  387. * Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
  388. - added Patch1020 for workaround gcc visibility hidden bugs
  389. * Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
  390. - build with new environment/toolchain
  391. - add build options to build with external nss/nspr libraries
  392. ac_add_options --with-system-nspr
  393. ac_add_options --with-system-nss
  394. * Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
  395. - new upstream release
  396. * Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
  397. - new upstream release
  398. * Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
  399. - new upstream release
  400. * Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
  401. - new upstream release
  402. * Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
  403. - new upstream release
  404. - merge changes from firefox
  405. - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
  406. * Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
  407. - new upstream release
  408. - build en-US locale
  409. - merge changes from firefox
  410. - add upstream patches
  411. - disable pango rendering by default
  412. (workaround fix slow rendering in some page)
  413. * Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
  414. - initial build for Vine Linux based on FC package
  415. - update to 1.5RC2
  416. * Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
  417. - Fix issue with popup dialogs and other actions causing lockups
  418. * Sat Nov 5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
  419. - Update to 1.5 rc1
  420. * Sat Oct 8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
  421. - Update to 1.5 beta2
  422. * Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
  423. - Update to 1.5 beta1
  424. - Bring the install phase of the spec file up to speed
  425. * Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
  426. - Rebuild
  427. * Sat Aug 6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
  428. - Add patch to make file chooser dialog modal
  429. * Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
  430. - Update to 1.0.6
  431. * Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
  432. - 1.0.6 Release Candidate
  433. * Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
  434. - Use system NSPR
  435. - Fix crash on 64bit platforms (#160330)
  436. * Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com> 1.0.2-7
  437. - Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
  438. references, fixing the "no fonts" problem.
  439. * Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
  440. - Change the Exec line in the desktop file to `thunderbird`
  441. * Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
  442. - Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
  443. * Mon May 9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
  444. - Add temporary workaround to not create files in the user's $HOME (#149664)
  445. * Wed May 4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
  446. - Don't have downloads "disappear" when downloading to desktop (#139015)
  447. - Fix for some more cursor issues in textareas (149991, 150002, 152089)
  448. - Add upstream patch to fix bidi justification of pango
  449. - Add patch to fix launching of helper applications
  450. - Add patch to properly link against libgfxshared_s.a
  451. - Fix multilib conflicts
  452. * Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
  453. - correct confusing PANGO vars in startup script
  454. * Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
  455. - Thunderbird 1.0.2
  456. * Tue Mar 8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
  457. - Add patch to compile against new fortified glibc macros
  458. * Sat Mar 5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
  459. - Rebuild against GCC 4.0
  460. - Add execshield patches
  461. - Minor specfile cleanup
  462. * Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
  463. - Rebuild
  464. * Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
  465. - Add RPM version to useragent
  466. * Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
  467. - Port over pango patches from firefox
  468. * Wed Dec 8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
  469. - Thunderbird 1.0
  470. * Mon Dec 6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
  471. - Fix advanced prefs
  472. * Fri Dec 3 2004 Christopher Aillon <caillon@redhat.com>
  473. - Make this run on s390(x) now for real
  474. * Wed Dec 1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
  475. - Update to 1.0 rc1
  476. * Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
  477. - Add patches to build and run on s390(x)
  478. * Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
  479. - Rebuild to fix file chooser
  480. * Fri Nov 5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
  481. - Update to 0.9
  482. * Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
  483. - Prevent inlining of stack direction detection (#135255)
  484. * Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
  485. - More file chooser fixes (same as in firefox)
  486. - Fix for upstream 28327.
  487. * Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
  488. - Update the pango patch
  489. * Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
  490. - Pull over patches from firefox build:
  491. - disable default application dialog
  492. - don't include software update since it doesn't work
  493. - make external app support work
  494. * Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
  495. - Use pango for rendering
  496. * Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
  497. - Fix for 64 bit crash at startup (b.m.o #256603)
  498. * Sat Oct 9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
  499. - Add patches to fix xremote (#135036)
  500. * Fri Oct 8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
  501. - Add patch to fix button focus issues (#133507)
  502. - Add patch for fix IMAP race issues (bmo #246439)
  503. * Fri Oct 1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
  504. - filter out library Provides: and internal Requires:
  505. * Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
  506. - Backport the GTK+ File Chooser.
  507. - Add fix for JS math on x86_64 systems
  508. - Add pkgconfig patch
  509. * Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
  510. - Update to 0.8.0
  511. - Remove enigmail
  512. - Update BuildRequires
  513. - Remove gcc34 and extension manager patches -- they are upstreamed.
  514. - Fix for gnome-vfs2 error at component registration
  515. * Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
  516. - Build with --disable-xprint
  517. * Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
  518. - remove all Xvfb-related hacks
  519. * Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
  520. - actually apply psfonts
  521. - add mozilla gnome-uriloader patch to prevent build failure
  522. * Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
  523. - rawhide import
  524. - apply NetBSD's freetype 2.1.8 patch
  525. - apply psfonts patch
  526. - remove BR on /usr/bin/ex, breaks beehive
  527. * Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
  528. - oops, fix %%install
  529. * Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
  530. - update to Thunderbird 0.7.3 and Enigmail 0.85.0
  531. - remove XUL.mfasl on startup, add Debian enigmail patches
  532. - add Xvfb hack for -install-global-extension
  533. * Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
  534. - update to 0.7.2, just because it's there
  535. - update gcc-3.4 patch (Kaj Niemi)
  536. - add EM registration patch and remove instdir hack
  537. * Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
  538. - re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
  539. * Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
  540. - update to 0.7.1
  541. - remove Enigmail
  542. * Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
  543. - re-enable Enigmail 0.84.1
  544. - add gcc-3.4 patch (Kaj Niemi)
  545. - use official branding (with permission)
  546. * Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
  547. - update to 0.7
  548. - temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
  549. - specify libdir, change BR for apt (V. Skytt辰, #1617)
  550. * Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
  551. - temporary workaround for enigmail skin "modern" bug
  552. * Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
  553. - update to Enigmail 0.84.0
  554. - update launch script
  555. * Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
  556. - installation directory now versioned
  557. - allow root to run the program (for installing extensions)
  558. - remove unnecessary %%pre and %%post
  559. - remove separators, update mozconfig and launch script (M. Schwendt, #1460)
  560. * Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
  561. - include Enigmail, re-add release notes
  562. - delete %{_libdir}/thunderbird in %%pre
  563. * Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
  564. - update to Thunderbird 0.6
  565. * Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
  566. - update to Thunderbird 0.6 RC1
  567. - add new icon, remove release notes
  568. * Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
  569. - update to latest CVS, update mozconfig and %%build accordingly
  570. - update to Enigmail 0.83.6
  571. - remove x-remote and x86_64 patches
  572. - build with -Os
  573. * Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
  574. - update x-remote patch
  575. - more startup script fixes
  576. * Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
  577. - startup script fixes, and a minor cleanup
  578. * Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
  579. - Minor cleanups
  580. * Sun Apr 04 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.8
  581. - minor improvements to open-browser.sh and startup script
  582. - update to latest version of Blizzard's x-remote patch
  583. * Thu Mar 25 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.7
  584. - update open-browser.sh, startup script, and BuildRequires
  585. * Sun Mar 14 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.6
  586. - update open-browser script, modify BuildRequires (Warren)
  587. - add Blizzard's x-remote patch
  588. - initial attempt at x-remote-enabled startup script
  589. * Sun Mar 07 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.5
  590. - refuse to run with excessive privileges
  591. * Fri Feb 27 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.4
  592. - add Mozilla x86_64 patch (Oliver Sontag)
  593. - Enigmail source filenames now include the version
  594. - modify BuildRoot
  595. * Thu Feb 26 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.3
  596. - use the updated official tarball
  597. * Wed Feb 18 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.2
  598. - fix %%prep script
  599. * Mon Feb 16 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.1
  600. - update Enigmail to 0.83.3
  601. - use official source tarball (after removing the CRLFs)
  602. - package renamed to thunderbird
  603. * Mon Feb 09 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.0
  604. - update to 0.5
  605. - check for lockfile before launching
  606. * Fri Feb 06 2004 David Hill <djh[at]ii.net>
  607. - update to latest cvs
  608. - update to Enigmail 0.83.2
  609. * Thu Jan 29 2004 David Hill <djh[at]ii.net> 0:0.4-0.fdr.5
  610. - update to Enigmail 0.83.1
  611. - removed Mozilla/Firebird script patching
  612. * Sat Jan 03 2004 David Hill <djh[at]ii.net> 0:0.4-0.fdr.4
  613. - add startup notification to .desktop file
  614. * Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
  615. - open-browser.sh release 3
  616. - patch broken /usr/bin/mozilla script during install
  617. - dir ownership
  618. - XXX: Source fails build on x86_64... fix later
  619. * Tue Dec 23 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.2
  620. - update to Enigmail 0.82.5
  621. - add Warren's open-browser.sh (#1113)
  622. * Tue Dec 09 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.1
  623. - use Thunderbird's mozilla-xremote-client to launch browser
  624. * Sun Dec 07 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.0
  625. - update to 0.4
  626. - make hyperlinks work (with recent versions of Firebird/Mozilla)
  627. * Thu Dec 04 2003 David Hill <djh[at]ii.net>
  628. - update to 0.4rc2
  629. * Wed Dec 03 2003 David Hill <djh[at]ii.net>
  630. - update to 0.4rc1 and Enigmail 0.82.4
  631. * Thu Nov 27 2003 David Hill <djh[at]ii.net>
  632. - update to latest CVS and Enigmail 0.82.3
  633. * Sun Nov 16 2003 David Hill <djh[at]ii.net>
  634. - update to latest CVS (0.4a)
  635. - update Enigmail to 0.82.2
  636. - alter mozconfig for new build requirements
  637. - add missing BuildReq (#987)
  638. * Thu Oct 16 2003 David Hill <djh[at]ii.net> 0:0.3-0.fdr.0
  639. - update to 0.3
  640. * Sun Oct 12 2003 David Hill <djh[at]ii.net> 0:0.3rc3-0.fdr.0
  641. - update to 0.3rc3
  642. - update Enigmail to 0.81.7
  643. * Thu Oct 02 2003 David Hill <djh[at]ii.net> 0:0.3rc2-0.fdr.0
  644. - update to 0.3rc2
  645. * Wed Sep 17 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.2
  646. - simplify startup script
  647. * Wed Sep 10 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.1
  648. - add GPG support (Enigmail 0.81.6)
  649. - specfile fixes (#679)
  650. * Thu Sep 04 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.0
  651. - update to 0.2
  652. * Mon Sep 01 2003 David Hill <djh[at]ii.net>
  653. - initial RPM
  654. (based on the fedora MozillaFirebird-0.6.1 specfile)