shotwell-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267
  1. Name: shotwell
  2. Version: 0.13.1
  3. Release: 2%{?_dist_release}
  4. Summary: A photo manager for the GNOME desktop
  5. Summary(ja): GNOME デスクトップ向けの写真管理ツール
  6. Group: Applications/Graphics
  7. # LGPLv2+ for the code
  8. # CC-BY-SA for some of the icons
  9. License: LGPLv2+ and CC-BY-SA
  10. URL: http://www.yorba.org/shotwell/
  11. Source0: http://www.yorba.org/download/shotwell/stable/shotwell-%{version}.tar.xz
  12. # http://trac.yorba.org/ticket/3379
  13. Source1: shotwell-icons.tar.bz2
  14. # http://redmine.yorba.org/issues/5181
  15. Patch0: shotwell-usrmove.patch
  16. # http://redmine.yorba.org/issues/5548
  17. Patch1: 0001-Port-to-GStreamer-1.0.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: GConf2-devel
  20. BuildRequires: LibRaw-devel
  21. BuildRequires: LibRaw-static
  22. BuildRequires: WebKit3-gtk-devel
  23. BuildRequires: dbus-glib-devel
  24. BuildRequires: desktop-file-utils
  25. BuildRequires: gettext
  26. BuildRequires: gtk3-devel
  27. #BuildRequires: gstreamer-devel
  28. #BuildRequires: gstreamer-plugins-base-devel
  29. BuildRequires: gstreamer1-devel
  30. BuildRequires: gstreamer1-plugins-base-devel
  31. BuildRequires: json-glib-devel
  32. BuildRequires: libexif-devel
  33. BuildRequires: libgee06-devel
  34. BuildRequires: libgphoto2-devel
  35. BuildRequires: libgudev1-devel
  36. BuildRequires: libgexiv2-devel >= 0.2.0
  37. BuildRequires: libsoup-devel
  38. BuildRequires: libxml2-devel
  39. BuildRequires: lcms2-devel
  40. BuildRequires: sqlite3-devel
  41. BuildRequires: unique3-devel
  42. BuildRequires: vala-devel >= 0.9.5
  43. BuildRequires: rest-devel
  44. # used by shotwell-settings-migrator
  45. Requires: dconf
  46. Vendor: Project Vine
  47. Distribution: Vine Linux
  48. Packager: kudoh
  49. %description
  50. Shotwell is a new open source photo manager designed for the GNOME desktop
  51. environment. It allows you to import photos from your camera, view and edit
  52. them, and share them with others.
  53. %description -l ja
  54. Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
  55. 画像管理ツールです。
  56. あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
  57. 他の人々と共有するなどができます。
  58. %prep
  59. %setup -q -n %{name}-%{version}
  60. %patch0 -p1 -b .usrmove
  61. %patch1 -p1
  62. %build
  63. # We can't use the configure macro: it's not a standard autotools configure script
  64. export CFLAGS="%{optflags}"
  65. export LIB=%{_lib}
  66. # HACK: Remove fatal-warnings to succeed build with vala 0.13.
  67. #sed -i "s:--fatal-warnings ::g" Makefile plugins/Makefile.plugin.mk
  68. ./configure --prefix=%{_prefix} --lib=%{_lib} --disable-schemas-install
  69. #sed -i -e 's/\\n/\n/g' configure.mk
  70. make %{?_smp_mflags}
  71. %install
  72. rm -rf $RPM_BUILD_ROOT
  73. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  74. export XDG_DISABLE_MAKEFILE_UPDATES=1
  75. # otherwise gettext always returns English text regardless of LANGUAGE asked
  76. export LANG=en_US.utf8
  77. make install DESTDIR=$RPM_BUILD_ROOT
  78. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
  79. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
  80. # put hi-res icons in place
  81. (
  82. cd $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
  83. rm -rf 16x16 24x24 scalable
  84. tar xf %{SOURCE1}
  85. )
  86. %find_lang %{name} --all-name
  87. %clean
  88. rm -rf $RPM_BUILD_ROOT
  89. %post
  90. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  91. update-desktop-database &> /dev/null || :
  92. %postun
  93. if [ $1 -eq 0 ] ; then
  94. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  95. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  96. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  97. fi
  98. update-desktop-database &> /dev/null || :
  99. %posttrans
  100. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  101. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  102. %files -f %{name}.lang
  103. %defattr(-,root,root,-)
  104. %doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
  105. %{_bindir}/shotwell
  106. %{_bindir}/shotwell-video-thumbnailer
  107. %{_libexecdir}/shotwell/shotwell-settings-migrator
  108. %{_libdir}/shotwell/plugins/builtin
  109. %{_datadir}/GConf/gsettings/shotwell.convert
  110. %{_datadir}/glib-2.0/schemas/org.yorba.shotwell-extras.gschema.xml
  111. %{_datadir}/glib-2.0/schemas/org.yorba.shotwell.gschema.xml
  112. %{_datadir}/gnome/help/
  113. %{_datadir}/shotwell
  114. %{_datadir}/applications/shotwell.desktop
  115. %{_datadir}/applications/shotwell-viewer.desktop
  116. %{_datadir}/icons/hicolor/*
  117. %exclude %{_datadir}/icons/hicolor/icon-theme.cache
  118. %exclude %{_datadir}/glib-2.0/schemas/gschemas.compiled
  119. %changelog
  120. * Fri Jan 11 2013 IWAI, Masaharu <iwai@alib.jp> - 0.13.1-2
  121. - build with libgphoto2 2.5.0-1
  122. * Sat Oct 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.13.1-1
  123. - new upstream release
  124. - changed archive typr to xz
  125. - changed BuildRequires: libgee-devel to libgee06-devel
  126. - changed BuildRequires: gstreamer-devel and gstreamer-plugins-base-devel to
  127. gstreamer1-devel and gstreamer1-plugins-base-devel
  128. - added Requires: dconf
  129. - added Patch0,1 from Fedora
  130. * Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.3-2
  131. - rebuild with exiv2-0.23
  132. * Thu May 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.12.3-1
  133. - new upstream release
  134. - dropt Source2
  135. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.2-1
  136. - new upstream release
  137. - remove Patch0
  138. - change BuildRequires: gtk3-devel instead of gtk2-devel
  139. - change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
  140. - change BuildRequires: unique3-devel instead of unique-devel
  141. - remove BuildRequires: hal-devel
  142. - add BuildRequires: rest-devel, lcms2-devel
  143. * Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.6-1
  144. - new upstream release
  145. * Thu Oct 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.5-1
  146. - new upstream release
  147. * Fri Oct 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.4-1
  148. - new upstream release
  149. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.11.2-1
  150. - new upstream release
  151. - add Patch0 (shotwell-0.11.1-vala-0.14.patch)
  152. - add BuildRequires: gstreamer-plugins-base-devel
  153. * Sat Aug 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.1-2
  154. - rebuilt with libgexiv2-0.2.2-2
  155. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
  156. - new upstream release
  157. * Sat Jun 18 2011 IWAI, Masaharu <iwai@alib.jp> 0.8.1-5
  158. - add ja.po (Source2): fix <BTS:VineLinux:1142>
  159. - update Summary and description
  160. * Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-4
  161. - add hi-res icons (SOURCE1)
  162. - add LANG=en_US.utf8 to get gettext to actually generate translated strings
  163. * Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
  164. - dropt Patch0
  165. - added BuildRequires: LibRaw-static
  166. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
  167. - add Patch1 (shotwell-0.8.1-vala.patch)
  168. * Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
  169. - new upstream release
  170. - added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
  171. * Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
  172. - rebuilt with rpm-4.8.1 for pkg-config
  173. - fixed %%changelog in Tue Sep 14 2010
  174. * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
  175. - new upstream release
  176. - changed source URL
  177. - added Patch0 to work around desktop file incorrect comment
  178. - changed BuildRequires: vala-devel >= 0.9.5
  179. * Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
  180. - new upstream release
  181. * Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
  182. - new upstream release
  183. - changed BuildRequires: libgexiv2-devel >= 0.2.0
  184. * Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
  185. - fixed LIB_DIRS in libraw-config (for lib64)
  186. * Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
  187. - new upstream release
  188. - added BuildRequires: LibRaw-devel, libgexiv2-devel
  189. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
  190. - new upstream release
  191. * Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
  192. - new upstream release
  193. - added BuildRequires: libgudev1-devel
  194. - applied new naming policy to spec
  195. * Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
  196. - new upstream release
  197. - proved Japanese description
  198. * Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
  199. - new upstrema release
  200. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
  201. - intial build for VineSeed
  202. * Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
  203. * Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  204. - Update to 0.3.2
  205. * Tue Nov 3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
  206. - Version 0.3.0
  207. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
  208. - Rebuild against new libgee
  209. * Sun Aug 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
  210. - Bring icon cache handling in sync with current guidelines
  211. * Sun Aug 9 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
  212. - Initial packaging