nodejs-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439
  1. %bcond_without clang
  2. %global system_zlib 1
  3. %global system_v8 0
  4. %global system_openssl 1
  5. %global system_http_parser 0
  6. %global system_cares 1
  7. %global system_libuv 0
  8. %if "%{_dist_release}" < "vl7"
  9. %global system_openssl 0
  10. %endif
  11. %define _unpackaged_files_terminate_build 1
  12. Name: nodejs
  13. Version: 14.16.0
  14. Release: 1%{?_dist_release}
  15. Summary: JavaScript runtime
  16. Summary(ja): JavaScript ランタイム
  17. Group: programming,servers
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. License: MIT and ASL 2.0 and ISC and BSD
  21. URL: https://nodejs.org/
  22. Source0: https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
  23. Source1: macros.nodejs
  24. Source2: nodejs.attr
  25. Source3: nodejs.prov
  26. Source4: nodejs.req
  27. Source5: nodejs-symlink-deps
  28. Source6: nodejs-fixdep
  29. # Exclusive archs must match v8
  30. ExclusiveArch: %{ix86} x86_64 %{arm}
  31. # V8 presently breaks ABI at least every x.y release while never bumping SONAME,
  32. # so we need to be more explicit until spot fixes that
  33. %global v8_ge 6.1.534.48
  34. %global v8_lt 6.2
  35. BuildRequires: libatomic
  36. %if %{with clang}
  37. BuildRequires: clang
  38. BuildRequires: lld
  39. %endif
  40. %if %{system_v8}
  41. BuildRequires: v8-devel >= %{v8_ge}
  42. %endif
  43. %if %{system_http_parser}
  44. BuildRequires: http-parser-devel >= 2.0
  45. %endif
  46. %if %{system_libuv}
  47. BuildRequires: libuv-devel
  48. %endif
  49. %if %{system_cares}
  50. BuildRequires: c-ares-devel
  51. %endif
  52. %if %{system_zlib}
  53. BuildRequires: zlib-devel
  54. %endif
  55. %if %{system_openssl}
  56. # Node.js requires some features from openssl 1.0.1 for SPDY support
  57. BuildRequires: openssl-devel >= 1.0.1
  58. %endif
  59. %if %{system_v8}
  60. Requires: v8%{?isa} >= %{v8_ge}
  61. Requires: v8%{?isa} < %{v8_lt}
  62. %endif
  63. #virtual provides for automatic depedency generation
  64. Provides: nodejs(engine) = %{version}
  65. #npm
  66. Provides: npm = %{version}-%{release}
  67. # Node.js currently has a conflict with the 'node' package in Fedora
  68. # The ham-radio group has agreed to rename their binary for us, but
  69. # in the meantime, we're setting an explicit Conflicts: here
  70. Conflicts: node <= 0.3.2-11
  71. %description
  72. Node.js is a platform built on Chrome's JavaScript runtime
  73. for easily building fast, scalable network applications.
  74. Node.js uses an event-driven, non-blocking I/O model that
  75. makes it lightweight and efficient, perfect for data-intensive
  76. real-time applications that run across distributed devices.
  77. #'
  78. %package devel
  79. Summary: JavaScript runtime - development headers
  80. Summary(ja): JavaScript runtime - development headers
  81. Group: programming
  82. Requires: %{name} == %{version}-%{release}
  83. %if %{system_libuv}
  84. Requires: libuv-devel
  85. %endif
  86. %if %{system_http_parser}
  87. Requires: http-parser-devel
  88. %endif
  89. %if %{system_cares}
  90. Requires: c-ares-devel
  91. %endif
  92. %if %{system_zlib}
  93. Requires: zlib-devel
  94. %endif
  95. %if %{system_openssl}
  96. Requires: openssl-devel
  97. %endif
  98. %description devel
  99. Development headers for the Node.js JavaScript runtime.
  100. %package docs
  101. Summary: Node.js API documentation
  102. Summary(ja): Node.js API documentation
  103. Group: documentation
  104. %description docs
  105. The API documentation for the Node.js JavaScript runtime.
  106. %debug_package
  107. %prep
  108. %setup -q -n node-v%{version}
  109. # Make sure nothing gets included from bundled deps:
  110. # We only delete the source and header files, because
  111. # the remaining build scripts are still used.
  112. %if %{system_cares}
  113. find deps/cares -name "*.c" -exec rm -f {} \;
  114. find deps/cares -name "*.h" -exec rm -f {} \;
  115. %endif
  116. %if %{system_zlib}
  117. find deps/zlib -name "*.c" -exec rm -f {} \;
  118. find deps/zlib -name "*.h" -exec rm -f {} \;
  119. %endif
  120. %if %{system_v8}
  121. find deps/v8 -name "*.c" -exec rm -f {} \;
  122. find deps/v8 -name "*.h" -exec rm -f {} \;
  123. %endif
  124. %if %{system_http_parser}
  125. find deps/http_parser -name "*.c" -exec rm -f {} \;
  126. find deps/http_parser -name "*.h" -exec rm -f {} \;
  127. %endif
  128. %if %{system_openssl}
  129. find deps/openssl -name "*.c" -exec rm -f {} \;
  130. find deps/openssl -name "*.h" -exec rm -f {} \;
  131. %endif
  132. %if %{system_libuv}
  133. find deps/uv -name "*.c" -exec rm -f {} \;
  134. find deps/uv -name "*.h" -exec rm -f {} \;
  135. %endif
  136. %build
  137. # build with debugging symbols and add defines from libuv (#892601)
  138. %ifarch x86_64
  139. %global debug_flag -g
  140. %global libatomic_flag ""
  141. %else
  142. %global debug_flag -g1
  143. %global libatomic_flag -latomic
  144. %endif
  145. export CFLAGS='%{optflags} %{debug_flag} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64'
  146. export CXXFLAGS='%{optflags} %{debug_flag} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64'
  147. export LDFLAGS="-Wl,-z,relro,-z,now"
  148. %if %{with clang}
  149. export CC=clang
  150. export CXX=clang++
  151. export LD=clang
  152. export CFLAGS="$CFLAGS -Wno-ignored-optimization-argument"
  153. export CXXFLAGS="$CXXFLAGS -Wno-ignored-optimization-argument"
  154. export LDFLAGS="$LDFLAGS %{libatomic_flag} -fuse-ld=lld"
  155. %endif
  156. ./configure \
  157. --prefix=%{_prefix} \
  158. %if %{system_v8}
  159. --shared-v8 \
  160. %endif
  161. %if %{system_openssl}
  162. --shared-openssl \
  163. %endif
  164. %if %{system_zlib}
  165. --shared-zlib \
  166. %endif
  167. %if %{system_cares}
  168. --shared-cares \
  169. %endif
  170. %if %{system_libuv}
  171. --shared-libuv \
  172. %endif
  173. %if %{system_http_parser}
  174. --shared-http-parser \
  175. %endif
  176. --without-dtrace \
  177. --openssl-use-def-ca-store
  178. # Setting BUILDTYPE=Debug builds both release and debug binaries
  179. make BUILDTYPE=Release %{?_smp_mflags}
  180. %install
  181. rm -rf %{buildroot}
  182. ./tools/install.py install %{buildroot} %{_prefix}
  183. # and remove dtrace file again
  184. rm -rf %{buildroot}/%{_prefix}/lib/dtrace
  185. # remove systemtap files
  186. rm -rf %{buildroot}/%{_datadir}/systemtap
  187. # Set the binary permissions properly
  188. chmod 0755 %{buildroot}/%{_bindir}/node
  189. # Install the debug binary and set its permissions
  190. #install -Dpm0755 out/Debug/node %{buildroot}/%{_bindir}/node_g
  191. # own the sitelib directory
  192. mkdir -p %{buildroot}%{_prefix}/lib/node_modules
  193. # install rpm magic
  194. install -Dpm0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/rpm/macros.nodejs
  195. install -Dpm0644 %{SOURCE2} %{buildroot}%{_rpmconfigdir}/fileattrs/nodejs.attr
  196. install -pm0755 %{SOURCE3} %{buildroot}%{_rpmconfigdir}/nodejs.prov
  197. install -pm0755 %{SOURCE4} %{buildroot}%{_rpmconfigdir}/nodejs.req
  198. install -pm0755 %{SOURCE5} %{buildroot}%{_rpmconfigdir}/nodejs-symlink-deps
  199. install -pm0755 %{SOURCE6} %{buildroot}%{_rpmconfigdir}/nodejs-fixdep
  200. #install documentation
  201. mkdir -p %{buildroot}%{_defaultdocdir}/%{name}-docs-%{version}/html
  202. cp -pr doc/* %{buildroot}%{_defaultdocdir}/%{name}-docs-%{version}/html
  203. rm -f %{_defaultdocdir}/%{name}-docs-%{version}/html/nodejs.1
  204. # move files for debug
  205. mkdir -p debug
  206. cp -pr %{buildroot}%{_docdir}/node/* debug/
  207. rm -rf %{buildroot}%{_docdir}/node
  208. #install development headers
  209. #FIXME: we probably don't really need *.h but node-gyp downloads the whole
  210. #freaking source tree so I can't be sure ATM
  211. mkdir -p %{buildroot}%{_includedir}/node
  212. cp -p src/*.h %{buildroot}%{_includedir}/node
  213. #node-gyp needs common.gypi too
  214. mkdir -p %{buildroot}%{_datadir}/node
  215. cp -p common.gypi %{buildroot}%{_datadir}/node
  216. %files
  217. %license LICENSE
  218. %doc CHANGELOG.md README.md AUTHORS
  219. %{_bindir}/node
  220. %{_bindir}/npm
  221. %{_bindir}/npx
  222. %{_mandir}/man1/node.*
  223. %dir %{_prefix}/lib/node_modules
  224. %{_prefix}/lib/node_modules/npm
  225. %files devel
  226. %doc debug
  227. #%{_bindir}/node_g
  228. %{_includedir}/node
  229. %{_datadir}/node
  230. %{_sysconfdir}/rpm/macros.nodejs
  231. %{_rpmconfigdir}/fileattrs/nodejs.attr
  232. %{_rpmconfigdir}/nodejs*
  233. %files docs
  234. %doc %{_docdir}/%{name}-docs-%{version}
  235. %license LICENSE
  236. %changelog
  237. * Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.16.0-1
  238. - updated to 14.16.0.
  239. * Wed Jan 13 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.15.4-1
  240. - updated to 14.15.4.
  241. * Mon Dec 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.15.1-1
  242. - updated to 14.15.1.
  243. * Thu Oct 01 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.18.4-1
  244. - updated to 12.18.4.
  245. * Fri Jul 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.18.2-1
  246. - updated to 12.18.2.
  247. * Fri Jun 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.18.0-1
  248. - updated to 12.18.0.
  249. * Thu Feb 13 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.16.0-1
  250. - updated to 12.16.0.
  251. * Mon Dec 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.14.0-1
  252. - updated to 12.14.0.
  253. * Sat Sep 28 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.16.3-1
  254. - updated to 10.16.3.
  255. - dropped Patch0 and 1: fixed in upstream.
  256. - built with clang / lld.
  257. * Tue Dec 26 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.9.3-1
  258. - updated to 8.9.3.
  259. - built with bundled v8.
  260. - built with system c-ares.
  261. - added Patch0 and 1.
  262. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 0.10.26-2
  263. - rebuild with gcc-5.4.0
  264. * Mon Mar 24 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.26-1
  265. - update to 0.10.26
  266. * Thu May 02 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.5-1
  267. - update to 0.10.5
  268. - fix deps
  269. * Fri Mar 15 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-2
  270. - build with internal openssl on Vine Linux 6
  271. * Wed Mar 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-1
  272. - update to 0.10.0
  273. * Mon Mar 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.5-1
  274. - initial build for Vine Linux
  275. - include npm
  276. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.5-11
  277. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  278. * Tue Jan 22 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-10
  279. - minor bugfixes to RPM magic
  280. - nodejs-symlink-deps: don't create an empty node_modules dir when a module
  281. has no dependencies
  282. - nodes-fixdep: support adding deps when none exist
  283. - Add the full set of headers usually bundled with node as deps to nodejs-devel.
  284. This way `npm install` for native modules that assume the stuff bundled with
  285. node exists will usually "just work".
  286. -move RPM magic to nodejs-devel as requested by FPC
  287. * Sat Jan 12 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-9
  288. - fix brown paper bag bug in requires generation script
  289. * Thu Jan 10 2013 Stephen Gallagher <sgallagh@redhat.com> - 0.9.5-8
  290. - Build debug binary and install it in the nodejs-devel subpackage
  291. * Thu Jan 10 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-7
  292. - don't use make install since it rebuilds everything
  293. * Thu Jan 10 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-6
  294. - add %%{?isa}, epoch to v8 deps
  295. * Wed Jan 09 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-5
  296. - add defines to match libuv (#892601)
  297. - make v8 dependency explicit (and thus more accurate)
  298. - add -g to $C(XX)FLAGS instead of patching configure to add it
  299. - don't write pointless 'npm(foo) > 0' deps
  300. * Sat Jan 05 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-4
  301. - install development headers
  302. - add nodejs_sitearch macro
  303. * Wed Jan 02 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-3
  304. - make nodejs-symlink-deps actually work
  305. * Tue Jan 01 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-2
  306. - provide nodejs-devel so modules can BuildRequire it (and be consistent
  307. with other interpreted languages in the distro)
  308. * Tue Jan 01 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-1
  309. - new upstream release 0.9.5
  310. - provide nodejs-devel for the moment
  311. - fix minor bugs in RPM magic
  312. - add nodejs_fixdep macro so packagers can easily adjust dependencies in
  313. package.json files
  314. * Wed Dec 26 2012 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.4-1
  315. - new upstream release 0.9.4
  316. - system library patches are now upstream
  317. - respect optflags
  318. - include documentation in subpackage
  319. - add RPM dependency generation and related magic
  320. - guard libuv depedency so it always gets bumped when nodejs does
  321. - add -devel subpackage with enough to make node-gyp happy
  322. * Wed Dec 19 2012 Dan Horák <dan[at]danny.cz> - 0.9.3-8
  323. - set exclusive arch list to match v8
  324. * Tue Dec 18 2012 Stephen Gallagher <sgallagh@redhat.com> - 0.9.3-7
  325. - Add remaining changes from code review
  326. - Remove unnecessary BuildRequires on findutils
  327. - Remove %%clean section
  328. * Fri Dec 14 2012 Stephen Gallagher <sgallagh@redhat.com> - 0.9.3-6
  329. - Fixes from code review
  330. - Fix executable permissions
  331. - Correct the License field
  332. - Build debuginfo properly
  333. * Thu Dec 13 2012 Stephen Gallagher <sgallagh@redhat.com> - 0.9.3-5
  334. - Return back to using the standard binary name
  335. - Temporarily adding a conflict against the ham radio node package until they
  336. complete an agreed rename of their binary.
  337. * Wed Nov 28 2012 Stephen Gallagher <sgallagh@redhat.com> - 0.9.3-4
  338. - Rename binary and manpage to nodejs
  339. * Mon Nov 19 2012 Stephen Gallagher <sgallagh@redhat.com> - 0.9.3-3
  340. - Update to latest upstream development release 0.9.3
  341. - Include upstreamed patches to unbundle dependent libraries
  342. * Tue Oct 23 2012 Adrian Alves <alvesadrian@fedoraproject.org> 0.8.12-1
  343. - Fixes and Patches suggested by Matthias Runge
  344. * Mon Apr 09 2012 Adrian Alves <alvesadrian@fedoraproject.org> 0.6.5
  345. - First build.