python-rdflib-vl.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124
  1. # The upstream test suite does not pass on recent versions of Fedora
  2. # See package review (bug 378841)
  3. # For now, we disable running the test suite:
  4. %define run_tests 0
  5. Name: python-rdflib
  6. Summary: Python library for working with RDF
  7. Version: 3.1.0
  8. Release: 3%{?_dist_release}
  9. Group: Development/Languages
  10. License: BSD
  11. URL: http://rdflib.net
  12. Source0: http://rdflib.googlecode.com/files/rdflib-%{version}.tar.gz
  13. BuildArch: noarch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: python-devel
  16. BuildRequires: python-setuptools
  17. %if %{run_tests}
  18. BuildRequires: python-nose >= 0.9.2
  19. %endif
  20. %description
  21. RDFLib is a Python library for working with RDF, a simple yet powerful
  22. language for representing information.
  23. The library contains parsers and serializers for RDF/XML, N3, NTriples,
  24. Turtle, TriX and RDFa. The library presents a Graph interface which can
  25. be backed by any one of a number of store implementations, including
  26. memory, MySQL, Redland, SQLite, Sleepycat, ZODB and SQLObject.
  27. %prep
  28. %setup -q -n rdflib-%{version}
  29. %build
  30. %{__python} setup.py build
  31. %install
  32. rm -rf $RPM_BUILD_ROOT
  33. %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
  34. cp LICENSE $RPM_BUILD_ROOT/%{python_sitelib}/rdflib/LICENSE
  35. # Various .py files within site-packages have a shebang line but aren't
  36. # flagged as executable.
  37. # I've gone through them and either removed the shebang or made them
  38. # executable as appropriate:
  39. # __main__ parses URI as N-Triples:
  40. chmod +x $RPM_BUILD_ROOT/%{python_sitelib}/rdflib/plugins/parsers/ntriples.py
  41. # __main__ parses the file given on the command line:
  42. chmod +x $RPM_BUILD_ROOT/%{python_sitelib}/rdflib/plugins/parsers/notation3.py
  43. %check
  44. %if %{run_tests}
  45. %{__python} run_tests.py
  46. %endif
  47. %clean
  48. rm -rf $RPM_BUILD_ROOT
  49. %files
  50. %defattr(-,root,root,-)
  51. %doc LICENSE
  52. %{python_sitelib}/*
  53. %changelog
  54. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 3.1.0-3
  55. - rebuild with python-2.7.2
  56. * Sun Nov 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.1.0-2
  57. - Initial build for Vine Linux
  58. * Wed Sep 28 2011 David Malcolm <dmalcolm@redhat.com> - 3.1.0-1
  59. - 3.1.0; converting from arch-specific to noarch (sitearch -> sitelib);
  60. removing rdfpipe and various other extensions
  61. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.2-3
  62. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  63. * Thu Jul 22 2010 Thomas Spura <tomspur@fedoraproject.org> - 2.4.2-2
  64. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  65. * Wed Jan 6 2010 David Malcolm <dmalcolm@redhat.com> - 2.4.2-1
  66. - bump to 2.4.2 (#552909)
  67. - fix source URL to use version macro
  68. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-10
  69. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  70. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-9
  71. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  72. * Wed Dec 10 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.4.0-8
  73. - Rebuild for Python 2.6
  74. * Wed Oct 1 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-7
  75. - fix tab/space issue in specfile
  76. * Tue Sep 30 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-6
  77. - override autogeneration of provides info to eliminate unwanted provision
  78. of SPARQLParserc.so
  79. * Mon Sep 29 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-5
  80. - make various scripts executable, or remove shebang, as appropriate
  81. * Tue Feb 19 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-4
  82. - delete test subdir
  83. * Thu Jan 24 2008 David Malcolm <dmalcolm@redhat.com> - 2.4.0-3
  84. - introduce macro to disable running the test suite, in the hope of eventually
  85. patching it so it passes
  86. * Mon Nov 19 2007 David Malcolm <dmalcolm@redhat.com> - 2.4.0-2
  87. - add python-setuptools(-devel) build requirement; move testing to correct stanza
  88. * Wed Aug 1 2007 David Malcolm <dmalcolm@redhat.com> - 2.4.0-1
  89. - initial version