docbook-style-xsl-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297
  1. Name: docbook-style-xsl
  2. Version: 1.76.1
  3. Release: 1%{?_dist_release}
  4. Group: Applications/Text
  5. Summary: Norman Walsh's XSL stylesheets for DocBook XML.
  6. Summary(ja): DocBook XML用 XSLスタイルシート
  7. License: Copyright only
  8. URL: http://docbook.sourceforge.net/projects/xsl/
  9. Source0: http://downloads.sourceforge.net/docbook/docbook-xsl-%{version}.tar.bz2
  10. Source1: %{name}.Makefile
  11. Source2: http://downloads.sourceforge.net/docbook/docbook-xsl-doc-%{version}.tar.bz2
  12. # Avoid proportional-column-width for passivetex (bug #176766).
  13. Patch1: docbook-xsl-pagesetup.patch
  14. # Hard-code the margin-left work around to expect passivetex (bug #113456).
  15. Patch2: docbook-xsl-marginleft.patch
  16. # fix of #161619 - adjustColumnWidths now available
  17. Patch3: docbook-xsl-newmethods.patch
  18. # change a few non-constant expressions to constant - needed for passivetex(#366441)
  19. Patch4: docbook-xsl-non-constant-expressions.patch
  20. # added fixes for passivetex extension and list-item-body(#161371)
  21. Patch5: docbook-xsl-list-item-body.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildArch: noarch
  24. Provides: docbook-xsl = %{version}
  25. Requires: docbook-dtd-xml
  26. # xml-common was using /usr/share/xml until 0.6.3-8.
  27. Requires: xml-common >= 0.6.3-8
  28. # required because of usage of /usr/bin/xmlcatalog
  29. Requires(post): libxml2 >= 2.4.8
  30. Requires(postun): libxml2 >= 2.4.8
  31. # PassiveTeX before 1.21 can't handle the newer stylesheets.
  32. Conflicts: passivetex < 1.21
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. %description
  36. These XSL stylesheets allow you to transform any DocBook XML document to
  37. other formats, such as HTML, FO, and XHMTL. They are highly customizable.
  38. %description -l ja
  39. この XSL スタイルシートを使って, さまざまな DocBook XML 形式のドキュメント
  40. を HTML や FO や XHTML などの他のフォーマットに変換することができます.
  41. %prep
  42. %setup -q -n docbook-xsl-%{version}
  43. pushd ..
  44. tar jxf %{SOURCE2}
  45. popd
  46. %patch1 -p1 -b .pagesetup
  47. %patch2 -p1 -b .marginleft
  48. %patch3 -p1 -b .newmethods
  49. %patch4 -p1 -b .nonconstant
  50. %patch5 -p1 -b .listitembody
  51. cp %{SOURCE1} Makefile
  52. # fix of non UTF-8 files rpmlint warnings
  53. for fhtml in $(find ./doc -name '*.html' -type f)
  54. do
  55. iconv -f ISO-8859-1 -t UTF-8 "$fhtml" -o "$fhtml".tmp
  56. mv -f "$fhtml".tmp "$fhtml"
  57. sed -i 's/charset=ISO-8859-1/charset=UTF-8/' "$fhtml"
  58. done
  59. for f in $(find -name "*'*")
  60. do
  61. mv -v "$f" $(echo "$f" | tr -d "'")
  62. done
  63. %build
  64. %install
  65. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  66. DESTDIR=$RPM_BUILD_ROOT
  67. make install BINDIR=$DESTDIR%{_bindir} DESTDIR=$DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}
  68. ln -s xsl-stylesheets-%{version} \
  69. $DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets
  70. # Don't ship the extensions (bug #177256).
  71. rm -rf $DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets/extensions/*
  72. %clean
  73. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  74. %post
  75. CATALOG=%{_sysconfdir}/xml/catalog
  76. %{_bindir}/xmlcatalog --noout --add "rewriteSystem" \
  77. "http://docbook.sourceforge.net/release/xsl/%{version}" \
  78. "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
  79. %{_bindir}/xmlcatalog --noout --add "rewriteURI" \
  80. "http://docbook.sourceforge.net/release/xsl/%{version}" \
  81. "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
  82. %{_bindir}/xmlcatalog --noout --add "rewriteSystem" \
  83. "http://docbook.sourceforge.net/release/xsl/current" \
  84. "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
  85. %{_bindir}/xmlcatalog --noout --add "rewriteURI" \
  86. "http://docbook.sourceforge.net/release/xsl/current" \
  87. "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
  88. %postun
  89. # remove entries only on removal of package
  90. if [ "$1" = 0 ]; then
  91. CATALOG=%{_sysconfdir}/xml/catalog
  92. %{_bindir}/xmlcatalog --noout --del \
  93. "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
  94. fi
  95. %files
  96. %defattr (-,root,root)
  97. %doc BUGS README TODO doc
  98. %{_datadir}/sgml/docbook/xsl-stylesheets-%{version}
  99. %{_datadir}/sgml/docbook/xsl-stylesheets
  100. %changelog
  101. * Fri Apr 22 2011 IWAI, Masaharu <iwai@alib.jp> 1.76.1-1
  102. - new upstream release
  103. - add Vendor and Distribution tags
  104. * Sun Mar 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.75.3-6
  105. - updated based on FC 1.75.3-5
  106. * Fri Dec 18 2009 Ondrej Vasik <ovasik@redhat.com> 1.75.3-5
  107. - comment patches purpose
  108. - License Copyright only
  109. * Mon May 11 2009 Ondrej Vasik <ovasik@redhat.com> 1.75.0-1
  110. - New upstream release 1.75.0
  111. - update marginleft patch
  112. * Mon Feb 23 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.2-2
  113. - updated Makefile: do ship .svg images(#486849), xsl
  114. stylesheets for website, xhtml-1_1, docbook -> epub
  115. convertor
  116. * Wed Feb 11 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-7
  117. - fix broken varlistentry (#479683)
  118. * Mon Feb 02 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-6
  119. - fix improper localization for rtl languages, thanks
  120. Muayyad Alsadi(#475077)
  121. * Wed Jan 28 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-5
  122. - fix xsl stylesheets for rtl languages(#475077)
  123. * Fri Dec 12 2008 Ondrej Vasik <ovasik@redhat.com> 1.74.0-4
  124. - Author_Group "<orgname>" merged between "<surname>"
  125. and "<surname>" (#473019)
  126. * Wed Aug 06 2008 Kamil Dudka <kdudka@redhat.com> 1.74.0-3
  127. - Rediffed all patches to work with patch --fuzz=0
  128. * Wed Aug 06 2008 Kamil Dudka <kdudka@redhat.com> 1.74.0-2
  129. - Tiny changes in docbook-xsl-newmethods.patch to work with xalan
  130. (#452867)
  131. * Fri Dec 14 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-9
  132. - added fixes for passivetex extension and list-item-body
  133. (#161371)
  134. * Mon Dec 03 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-6
  135. - fixed docbook-xsl-pagesetup.patch to follow Norman Walsh's
  136. documentation for nonpassivetex processing(#307001)
  137. * Tue Nov 27 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-5
  138. - convert all html files in doc to UTF-8 in prep
  139. (latest rpmlint gives warnings)
  140. - no longer using release in style-xsl dir(#389231)
  141. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.73.2-5vl5
  142. - applied new versioning policy, spec in utf-8
  143. * Fri Jan 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73.2-5vl1
  144. - updated to 1.73.2 based on Fedora development
  145. * Tue Dec 11 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-4
  146. - remove entries from xmlcatalog only on removal of package
  147. (required because of the last change with droping release
  148. -caused drop of catalog entries during update)
  149. * Wed Dec 05 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-3
  150. - change a few non-constant expressions to constant that
  151. could now be handled by passivetex(#366441)
  152. - fixed docbook-xsl-pagesetup.patch to follow Norman Walsh's
  153. documentation for nonpassivetex processing(#307001)
  154. (use passivetex.extensions = 1 option in param.xsl for
  155. processing with passivetex)
  156. * Fri Sep 7 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-2
  157. - Added PreReq of libxml2(#253962)
  158. * Sun Jul 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72.0-3vl1
  159. - updated to 1.72.0 based on Fedora development
  160. * Mon Jun 18 2007 Ondrej Vasik <ovasik@redhat.com> 1.72.0-3
  161. - patch fixing #161619 taken from upstream
  162. * Tue Jan 23 2007 Tim Waugh <twaugh@redhat.com> 1.72.0-1
  163. - 1.72.0.
  164. * Fri Jan 19 2007 Tomas Mraz <tmraz@redhat.com> 1.71.1-2
  165. - Add new wordml and especially highlighting (which is referenced
  166. from html) subdirs to Makefile.
  167. * Tue Jan 24 2006 Tim Waugh <twaugh@redhat.com> 1.69.1-5
  168. - Don't ship docsrc/* (bug #177256).
  169. - Don't ship the extensions (bug #177256).
  170. * Sun Oct 8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.69.1-1vl1
  171. - updated to 1.69.1 based on Fedora development
  172. * Sun Dec 19 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.67.2-2vl1
  173. - updated to 1.67.2 based on Fedora development
  174. * Wed Dec 8 2004 Tim Waugh <twaugh@redhat.com> 1.67.2-2
  175. - Prevent expressions in passivetex output from index.xsl (bug #142229).
  176. * Thu Dec 2 2004 Tim Waugh <twaugh@redhat.com> 1.67.2-1
  177. - No longer need nbsp or listblock patches.
  178. * Tue Jan 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.64.1-2vl2
  179. - patch from Fedora 1.64.1-6
  180. * Tue Jan 20 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-6
  181. - Fix last margin-left fix (bug #113456).
  182. - Reduce instances of itemized/ordered lists having misalignments.
  183. * Sun Jan 18 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-5
  184. - And another (bug #113456).
  185. * Thu Jan 15 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-4
  186. - Fixed another instance of bug #113456 in lists layout.
  187. * Wed Jan 14 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-3
  188. - Hard-code the margin-left work around to expect passivetex (bug #113456).
  189. * Mon Jan 5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.64.1-2vl1
  190. - based on Fedora 1.64.1-2
  191. - fixed Japanese summary
  192. * Sat May 24 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.61.1-1vl1
  193. - based on Redhat Rawhide 1.61.1-1
  194. - add Japanese summary and description
  195. * Tue Feb 4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.60.1-0vl1
  196. - upstream release
  197. * Tue Nov 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.57.0-2vl1
  198. - based on Redhat Rawhide 1.57.0-2
  199. * Sat Oct 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.57.0-0vl1
  200. - 1.57.0
  201. * Tue Sep 24 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.55.0-0vl3
  202. - Rebuilded for Vine Linux (add PreReq: docbook-dtd412-xml)
  203. - based on rawhide 1.50.0 and source updated 1.55.0
  204. - use better macros
  205. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  206. - automated rebuild
  207. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  208. - automated rebuild
  209. * Wed May 1 2002 Tim Waugh <twaugh@redhat.com> 1.50.0-1
  210. - 1.50.0.
  211. * Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.49-1
  212. - 1.49.
  213. - Rebuild in new environment.
  214. * Fri Feb 1 2002 Tim Waugh <twaugh@redhat.com> 1.48-4
  215. - Put URIs instead of pathnames in the XML catalog.
  216. * Thu Jan 17 2002 Tim Waugh <twaugh@redhat.com> 1.48-3
  217. - Back to /usr/share/sgml.
  218. * Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.48-2
  219. - automated rebuild
  220. * Mon Jan 7 2002 Tim Waugh <twaugh@redhat.com> 1.48-1
  221. - 1.48.
  222. * Sat Dec 8 2001 Tim Waugh <twaugh@redhat.com> 1.47-2
  223. - Conflict with PassiveTeX before 1.11.
  224. * Tue Oct 16 2001 Tim Waugh <twaugh@redhat.com> 1.47-1
  225. - 1.47-experimental.
  226. * Tue Oct 9 2001 Tim Waugh <twaugh@redhat.com> 1.45-2
  227. - Fix unversioned symlink.
  228. * Mon Oct 8 2001 Tim Waugh <twaugh@redhat.com> 1.45-1
  229. - XML Catalog entries.
  230. - Move files to /usr/share/xml.
  231. * Mon Oct 1 2001 Tim Waugh <twaugh@redhat.com> 1.45-0.1
  232. - 1.45.
  233. - Built for Red Hat Linux.
  234. * Tue Jun 26 2001 Chris Runge <crunge@pobox.com>
  235. - 1.40
  236. * Fri Jun 09 2001 Chris Runge <crunge@pobox.com>
  237. - added extensions and additional doc
  238. - bin added to doc; the Perl files are for Win32 Perl and so need some
  239. conversion first
  240. * Fri Jun 08 2001 Chris Runge <crunge@pobox.com>
  241. - Initial RPM (based on docbook-style-dsssl RPM)
  242. - note: no catalog right now (I don't know how to do it; and not sure why
  243. it is necessary)