librep-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167
  1. %define __libtoolize :
  2. Name: librep
  3. Version: 0.16.1
  4. Release: 1%{?_dist_release}
  5. Summary: An embeddable LISP environment
  6. Summary(ja): 組込み LISP 環境
  7. License: GPL
  8. Group: Development/Languages
  9. Source: http://download.sourceforge.net/librep/librep-%{version}.tar.gz
  10. Patch10: librep-0.14-mipsel.patch
  11. URL: http://librep.sourceforge.net/
  12. Buildroot: %{_tmppath}/%{name}-%{version}-root
  13. BuildPrereq: gmp-devel >= 4.1
  14. BuildPrereq: gdbm-devel readline-devel texinfo
  15. PreReq: /sbin/install-info
  16. Requires: gdbm >= 1.8
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: Ryoichi INAGAKI <ryo1@bc.wakwak.com>
  20. %description
  21. This is a lightweight Lisp environment for UNIX. It contains a Lisp
  22. interpreter, byte-code compiler and virtual machine. Applications may
  23. use the Lisp interpreter as an extension language, or it may be used
  24. for standalone scripts.
  25. Originally inspired by Emacs Lisp, the language dialect combines many
  26. of the elisp features while trying to remove some of the main
  27. deficiencies, with features from Common Lisp and Scheme.
  28. %description -l ja
  29. librep は UNIX 向け軽量 Lisp 環境です.Lisp インタプリタ,バイトコード
  30. コンパイラ,仮想マシンが収められています.アプリケーションから Lisp
  31. インタプリタを機能拡張言語として使うことも出来ますし,単純にスタンドアロンの
  32. スクリプト環境として使うことも出来ます.
  33. 元々は Emacs Lisp に影響を受けつつ,elisp に欠けている機能を補う為に
  34. Common Lisp や Scheme 等の機能を取り入れています.
  35. %package devel
  36. Summary: librep include files and link libraries
  37. Summary(ja): librep 用インクルードファイルとライブラリ
  38. Group: Development/Languages
  39. Requires: %{name} = %{version}
  40. %description devel
  41. Link libraries and C header files for librep development.
  42. %description devel -l ja
  43. librep 開発用ライブラリと C ヘッダファイル
  44. %prep
  45. %setup -q
  46. #%patch10 -p1 -b .mipsel
  47. %build
  48. LC_ALL=""
  49. LINGUAS=""
  50. LANG=""
  51. export LC_ALL LINGUAS LANG
  52. %ifarch ppc
  53. %configure --with-readline --with-stack-direction=1
  54. %else
  55. %configure --with-readline --with-extra-cflags=-fstrength-reduce
  56. %endif
  57. make host_type=%{_target_platform}
  58. %install
  59. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  60. make install \
  61. host_type=%{_target_platform} \
  62. DESTDIR=$RPM_BUILD_ROOT \
  63. aclocaldir=%{_datadir}/aclocal \
  64. infodir=%{_infodir}
  65. gzip -9nf $RPM_BUILD_ROOT%{_infodir}/librep*
  66. %post
  67. /sbin/ldconfig
  68. /sbin/install-info %{_infodir}/librep.info.gz %{_infodir}/dir
  69. %preun
  70. if [ "$1" = 0 ]; then
  71. /sbin/install-info --delete %{_infodir}/librep.info.gz %{_infodir}/dir
  72. fi
  73. %postun -p /sbin/ldconfig
  74. %clean
  75. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  76. %files
  77. %defattr(-,root,root)
  78. %doc NEWS README THANKS TODO BUGS
  79. %{_bindir}/rep
  80. %{_bindir}/rep-remote
  81. %{_libdir}/librep.so.*
  82. %{_datadir}/rep/%{version}
  83. %{_libexecdir}/rep/%{version}/%{_target_platform}
  84. %{_infodir}/librep*
  85. %files devel
  86. %defattr(-,root,root)
  87. %{_bindir}/rep-config
  88. %{_bindir}/rep-xgettext
  89. %{_bindir}/repdoc
  90. %{_libdir}/librep.so
  91. %{_includedir}/rep.h
  92. %{_includedir}/rep_*.h
  93. %{_libexecdir}/rep/%{_target_platform}/libtool
  94. %{_libexecdir}/rep/%{_target_platform}/rules.mk
  95. %{_libexecdir}/rep/%{_target_platform}/install-aliases
  96. %{_libexecdir}/rep/%{_target_platform}/rep_config.h
  97. %{_datadir}/aclocal/rep.m4
  98. %changelog
  99. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.1-1vl5
  100. - applied new versioning policy, spec in utf-8
  101. * Tue Aug 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.16.1-0vl6
  102. - small fix for configure script
  103. * Sat Aug 25 2007 Shu KONNO <owa@bg.wakwak.com> 0.16.1-0vl5
  104. - s/Copyright/License/
  105. * Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.16.1-0vl4
  106. - rebuilt with readline-4.3
  107. * Mon Jan 20 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.16.1-0vl3
  108. - rebuilt against gmp-4.1
  109. * Sat Nov 9 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.1-0vl2
  110. - update to 0.16.1
  111. - remove Patch10
  112. - add %define __libtoolize (If it isn't, sawfish can't compile...)
  113. * Mon Jul 16 2001 Daisuke SUZUKi <daisuke@linux.or.jp> 0.14-0vl1
  114. - update to 0.14
  115. - add Patch10 for mipsel
  116. * Sun May 20 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  117. - 0.13.6-1vl1
  118. - built for Vine Linux
  119. * Tue Jun 13 2000 John Harper <john@dcs.warwick.ac.uk>
  120. - use better macros
  121. * Wed Nov 10 1999 Michael K. Johnson <johnsonm@redhat.com>
  122. - post{,un} use -p
  123. * Mon Sep 13 1999 Aron Griffis <agriffis@bigfoot.com>
  124. - 0.5 spec file update: added buildroot