librsvg2-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414
  1. %define __libtoolize :
  2. %define libxml2_version 2.7.8
  3. %define gdk_pixbuf2 2.26.1
  4. %define gtk3_version 3.4.1
  5. %define freetype_version 2.4.2
  6. %define popt_version 1.14
  7. %define libart_version 2.3.21
  8. %define cairo_version 1.12.0
  9. %define dbus_version 1.4.0
  10. %define dbus_glib_version 0.88
  11. %define avahi_glib_version 0.6.23
  12. %define libcroco_version 0.6.2
  13. %define libgsf_version 1.14.19
  14. Name: librsvg2
  15. Summary: An SVG library based on libart.
  16. Summary(ja): libart ベースの SVG ライブラリ
  17. Version: 2.40.10
  18. Release: 1%{?_dist_release}
  19. License: LGPL
  20. Group: System Environment/Libraries
  21. Source: librsvg-%{version}.tar.xz
  22. Patch0: librsvg-2.40.10-git20150811.patch
  23. Requires(post,postun): gtk3 >= %{gtk3_version}
  24. Requires(post): dbus-glib >= %{dbus_glib_version}
  25. Requires(post): avahi-glib >= %{avahi_glib_version}
  26. Requires(post): libgsf, libcroco
  27. Requires: gtk3 >= %{gtk3_version}
  28. Requires: libxml2 >= %{libxml2_version}
  29. Requires: popt >= %{popt_version}
  30. Requires: freetype2 >= %{freetype_version}
  31. Requires: libpng
  32. BuildRequires: libpng-devel
  33. BuildRequires: gtk3-devel >= %{gtk3_version}
  34. BuildRequires: gobject-introspection-devel
  35. BuildRequires: libxml2-devel >= %{libxml2_version}
  36. BuildRequires: freetype2-devel >= %{freetype_version}
  37. BuildRequires: cairo-devel >= %{cairo_version}
  38. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  39. BuildRequires: avahi-glib-devel >= %{avahi_glib_version}
  40. BuildRequires: libcroco-devel >= %{libcroco_version}
  41. BuildRequires: libgsf-devel >= %{libgsf_version}
  42. BuildRequires: autoconf
  43. BuildRequires: gtk-doc
  44. BuildRequires: vala-devel
  45. BuildRequires: vala-tools
  46. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  47. Vendor: Project Vine
  48. Distribution: Vine Linux
  49. %description
  50. An SVG library based on libart.
  51. %description -l ja
  52. libart ベースの SVG ライブラリです
  53. %package devel
  54. Summary: Libraries and include files for developing with librsvg.
  55. Summary(ja): librsvg の開発用ライブラリおよびヘッダファイル
  56. Group: Development/Libraries
  57. Requires: %{name} = %{version}
  58. Requires: gdk-pixbuf2-devel >= %{gdk_pixbug2_version}
  59. Requires: cairo-devel >= %{cairo_version}
  60. %description devel
  61. This package provides the necessary development libraries and include
  62. files to allow you to develop with librsvg.
  63. %package docs
  64. Summary: Documentation for %{name}
  65. Summary(ja): %{name} 用のドキュメント
  66. Group: Documentation
  67. Requires: %{name} = %{version}-%{release}
  68. BuildArch: noarch
  69. %description docs
  70. This package contains documentation for %{name}.
  71. %package vala
  72. Summary: Vala bindings for %{name}
  73. Summary(ja): %{name} の Vala バインディング
  74. Group: Development/Libraries
  75. Requires: %{name} = %{version}-%{release}
  76. Requires: vala
  77. %description vala
  78. Vala bindings for %{name}.
  79. %prep
  80. %setup -q -n librsvg-%{version}
  81. %patch0 -p1
  82. %build
  83. %configure --enable-gtk-doc \
  84. --enable-introspection=yes \
  85. --enable-vala=yes \
  86. --with-svgz \
  87. --enable-gtk-theme \
  88. --with-croco \
  89. --disable-static
  90. %__make %{?_smp_mflags}
  91. %install
  92. rm -rf $RPM_BUILD_ROOT
  93. make install DESTDIR=$RPM_BUILD_ROOT
  94. rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
  95. rm -f $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/*/loaders/libpixbuf*.*a
  96. rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
  97. %clean
  98. rm -rf $RPM_BUILD_ROOT
  99. %post
  100. /sbin/ldconfig
  101. if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
  102. /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
  103. fi ||:
  104. %postun
  105. /sbin/ldconfig
  106. if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
  107. /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
  108. fi ||:
  109. %files
  110. %defattr(-,root,root,-)
  111. %doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
  112. %{_bindir}/rsvg-convert
  113. %{_bindir}/rsvg-view-3
  114. %{_libdir}/librsvg-2.so.*
  115. %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so
  116. %{_libdir}/girepository-1.0/Rsvg-2.0.typelib
  117. %{_mandir}/man1/rsvg-convert.1.gz
  118. %files devel
  119. %defattr(-,root,root,-)
  120. %{_libdir}/librsvg-2.so
  121. %{_includedir}/librsvg-2.0/librsvg
  122. %{_libdir}/pkgconfig/librsvg-2.0.pc
  123. %{_datadir}/gir-1.0/Rsvg-2.0.gir
  124. %files docs
  125. %defattr(-,root,root,-)
  126. %{_datadir}/gtk-doc/html/rsvg-2.0
  127. %files vala
  128. %defattr(-,root,root,-)
  129. %{_datadir}/vala/vapi/librsvg-2.0.vapi
  130. %changelog
  131. * Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.10-1
  132. - new upstream release
  133. - add Patch0 (librsvg-2.40.10-git20150811.patch)
  134. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.9-1
  135. - new upstream release
  136. * Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.8-1
  137. - new upstream release
  138. * Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.7-1
  139. - new upstream release
  140. * Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.6-1
  141. - new upstream release
  142. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.5-1
  143. - new upstream release
  144. * Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.3-1
  145. - new upstream release
  146. * Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-2
  147. - rebuild with libpng-1.6.12
  148. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-1
  149. - new upstream release
  150. * Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-2
  151. - fix typo
  152. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-1
  153. - new upstream release
  154. - remove BuildRequires: gtk2-devel
  155. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-2
  156. - add BuildRequires: autoconf, gtk-doc, vala-devel, vala-tools
  157. - create %%{name}-docs and %%{name}-vala subpackages
  158. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
  159. - new upstream release
  160. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
  161. - new upstream release
  162. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
  163. - new upstream release
  164. * Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
  165. - new upstream release
  166. - add BuildRequires: gobject-introspection-devel
  167. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
  168. - new upstream release
  169. - remove Patch0
  170. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
  171. - new upstream release
  172. - add Patch0 (librsvg2-2.34.0-git20110728.patch)
  173. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
  174. - new upstream release
  175. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  176. - new upstream release
  177. - remove BuildRequires: popt, libart_lgpl, libgnomeui-devel, gnome-vfs2-devel
  178. - remove Requires: libart_lgpl
  179. - add configure option (--disable-static)
  180. - remove unrecognized configure option (--enable-gnome-vfs, --disable-mozilla-plugins)
  181. - fix %install, %files, %post and %postun
  182. * Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.26.3-1
  183. - build with rpm-4.8.1-1 for pkg-config file
  184. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.3-1
  185. - new upstream release
  186. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  187. - new upstream release
  188. - remove static libs
  189. * Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1vl5
  190. - new upstream release
  191. - spec in UTF-8
  192. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
  193. - new upstream release
  194. * Sat Mar 8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl2
  195. - rebuilt with libgsf-1.14.8
  196. * Sat Sep 8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
  197. - new upstream release
  198. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-0vl1
  199. - new upstream release
  200. - add BuildRequires: dbus-glib-devel, avahi-glib-devel
  201. - add BuildRequires: libgsf-devel, libcroco-devel
  202. - add Requires(post): dbus-glib, avahi-glib, libgsf, libcroco
  203. - add Requires(post,postun): glib2
  204. * Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl5
  205. - rebuild with gtk+-2.10
  206. * Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl4
  207. - rebuilt without libgsf-devel
  208. * Tue Jun 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl3
  209. - update %%post scripts to use %%{_sysconfdir}/gtk-2.0/%%{_arch}/gd-pixbuf.loaders
  210. for biarch support. (TODO: add compat32)
  211. * Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl2
  212. - rebuild
  213. * Mon May 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.4-0vl1
  214. - new upstream release
  215. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
  216. - new upstream release
  217. * Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  218. - new upstream release
  219. * Wed Oct 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.7-0vl1
  220. - new upstream release
  221. - added --disable-gtk-doc option
  222. * Sat Oct 8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
  223. - new upstream release
  224. - added gtk-doc to devel package
  225. * Sun Oct 2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
  226. - new upstream release
  227. - added Japanese description
  228. - added --without-svgz option (because it requires libgsf)
  229. * Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
  230. - new upstream release
  231. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
  232. - new upstream release
  233. * Fri Jun 18 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl4
  234. - rebuilt to avoid unwanted dependency (libgsf)
  235. * Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
  236. - add gdk-pixbuf-query-loaders to post/postun script.
  237. * Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
  238. - rebuild with gtk+-2.4.0
  239. * Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  240. - new upstream release
  241. * Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl2
  242. - fix kanji code of spec file
  243. - fix file entry, add missing files
  244. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
  245. - new upstream release
  246. * Sat Jul 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl2
  247. - added --without-svgz and --without-gimp to %configure
  248. * Thu Jul 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl1
  249. - new upstream release
  250. - added %{_bindir}/rsvg and %{_mandir}/man1/* to main package
  251. - added %{_libdir}/gtk-2.0/* to devel package
  252. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  253. - new upstream release
  254. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
  255. - new upstream release
  256. * Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
  257. - new upstream release
  258. * Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.2-0vl1
  259. - build for Vine Linux
  260. - new upstream release from gnome-2.1.4
  261. * Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
  262. - 2.0.1
  263. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  264. - automated rebuild
  265. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  266. - automated rebuild
  267. * Tue May 21 2002 Havoc Pennington <hp@redhat.com>
  268. - rebuild in different environment
  269. * Thu May 02 2002 Havoc Pennington <hp@redhat.com>
  270. - rebuild in different environment
  271. * Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
  272. - 1.1.6
  273. * Mon Feb 11 2002 Alex Larsson <alexl@redhat.com> 1.1.3-1
  274. - Update to 1.1.3
  275. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  276. - automated rebuild
  277. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  278. - new CVS snap 1.1.0.91
  279. - remove automake/autoconf calls
  280. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  281. - convert to librsvg2 RPM
  282. * Tue Oct 23 2001 Havoc Pennington <hp@redhat.com>
  283. - 1.0.2
  284. * Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
  285. - Add a patch that moves the includes to librsvg-1/librsvg
  286. - in preparation for a later librsvg 2 library.
  287. * Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
  288. - build requires gnome-libs-devel, #49509
  289. * Thu Jul 19 2001 Havoc Pennington <hp@redhat.com>
  290. - own /usr/include/librsvg
  291. * Wed Jul 18 2001 Akira TAGOH <tagoh@redhat.com> 1.0.0-4
  292. - fixed the linefeed problem in multibyte environment. (Bug#49310)
  293. * Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
  294. - put .la file back in package
  295. * Fri Jul 6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  296. - Put changelog at the end
  297. - Move .so files to devel subpackage
  298. - Don't mess with ld.so.conf
  299. - Don't use %%{prefix}, this isn't a relocatable package
  300. - Don't define a bad docdir
  301. - Add BuildRequires
  302. - Use %%{_tmppath}
  303. - Don't define name, version etc. on top of the file (why do so many do that?)
  304. - s/Copyright/License/
  305. * Wed May 9 2001 Jonathan Blandford <jrb@redhat.com>
  306. - Put into Red Hat Build system
  307. * Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
  308. - removed obsoletes from sub packages and added mozilla and trilobite
  309. subpackages
  310. * Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
  311. - created this thing