vala-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381
  1. %global api_ver 0.28
  2. Summary: A modern programming language for GNOME
  3. Summary: GNOME 用のモダンなプログラミング言語
  4. Name: vala
  5. Version: 0.28.1
  6. Release: 1%{?_dist_release}
  7. Group: Development/Languages
  8. # Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
  9. License: LGPLv2+ and BSD
  10. URL: http://live.gnome.org/Vala
  11. Source0: http://download.gnome.org/sources/vala/0.28/vala-%{version}.tar.xz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildRequires: glib2-devel
  14. BuildRequires: flex
  15. BuildRequires: bison
  16. BuildRequires: libxslt
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. %description
  20. Vala is a new programming language that aims to bring modern programming
  21. language features to GNOME developers without imposing any additional
  22. runtime requirements and without using a different ABI compared to
  23. applications and libraries written in C.
  24. valac, the Vala compiler, is a self-hosting compiler that translates
  25. Vala source code into C source and header files. It uses the GObject
  26. type system to create classes and interfaces declared in the Vala source
  27. code. It's also planned to generate GIDL files when gobject-
  28. introspection is ready.
  29. The syntax of Vala is similar to C#, modified to better fit the GObject
  30. type system.
  31. %package devel
  32. Summary: Development files for %{name}
  33. Summary(ja): %{name} の開発用ファイル
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. Requires: pkgconfig
  37. %description devel
  38. Vala is a new programming language that aims to bring modern programming
  39. language features to GNOME developers without imposing any additional
  40. runtime requirements and without using a different ABI compared to
  41. applications and libraries written in C.
  42. This package contains development files for %{name}. This is not necessary for
  43. using the %{name} compiler.
  44. %package tools
  45. Summary: Tools for creating projects and bindings for %{name}
  46. Summary(ja): %{name} のプロジェクト作成やバインディングのためのツール集
  47. Group: Development/Tools
  48. License: LGPLv2+
  49. Requires: %{name} = %{version}-%{release}
  50. Requires: gnome-common intltool libtool
  51. Provides: %{name}-vapigen = %{version}-%{release}
  52. Obsoletes: %{name}-vapigen < %{version}-%{release}
  53. %description tools
  54. Vala is a new programming language that aims to bring modern programming
  55. language features to GNOME developers without imposing any additional
  56. runtime requirements and without using a different ABI compared to
  57. applications and libraries written in C.
  58. This package contains tools to generate Vala projects, as well as API bindings
  59. from existing C libraries, allowing access from Vala programs.
  60. %package doc
  61. Summary: Documentation for %{name}
  62. Summary(ja): %{name} のドキュメント
  63. Group: Documentation
  64. License: LGPLv2+
  65. BuildArch: noarch
  66. Requires: %{name} = %{version}-%{release}
  67. Requires: devhelp
  68. Provides: %{name}-docs = %{version}-%{release}
  69. Obsoletes: %{name}-docs < %{version}-%{release}
  70. %description doc
  71. Vala is a new programming language that aims to bring modern programming
  72. language features to GNOME developers without imposing any additional
  73. runtime requirements and without using a different ABI compared to
  74. applications and libraries written in C.
  75. This package contains documentation in a devhelp HTML book.
  76. %prep
  77. %setup -q
  78. %build
  79. %configure --enable-vapigen
  80. # Don't use rpath!
  81. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  82. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  83. make %{?_smp_mflags}
  84. # checks currently utilize installed Vala, not the one being compiled
  85. #%check
  86. #make check
  87. %install
  88. rm -rf $RPM_BUILD_ROOT
  89. make install DESTDIR=$RPM_BUILD_ROOT
  90. rm $RPM_BUILD_ROOT%{_libdir}/libvala-%{api_ver}.la
  91. %clean
  92. rm -rf $RPM_BUILD_ROOT
  93. %post -p /sbin/ldconfig
  94. %postun -p /sbin/ldconfig
  95. %files
  96. %defattr(-,root,root,-)
  97. %doc AUTHORS ChangeLog COPYING INSTALL MAINTAINERS NEWS README THANKS
  98. %{_bindir}/vala
  99. %{_bindir}/valac
  100. %{_bindir}/vala-%{api_ver}
  101. %{_bindir}/valac-%{api_ver}
  102. %{_datadir}/vala-%{api_ver}
  103. %{_libdir}/libvala-%{api_ver}.so.*
  104. %{_mandir}/*/valac*
  105. %files devel
  106. %defattr(-,root,root,-)
  107. %{_includedir}/vala-%{api_ver}
  108. %{_libdir}/libvala-%{api_ver}.so
  109. %{_libdir}/pkgconfig/libvala-%{api_ver}.pc
  110. %{_datadir}/aclocal/vala.m4
  111. %{_datadir}/aclocal/vapigen.m4
  112. %{_datadir}/pkgconfig/vapigen.pc
  113. %{_datadir}/pkgconfig/vapigen-%{api_ver}.pc
  114. %{_datadir}/vala/Makefile.vapigen
  115. %files tools
  116. %defattr(-,root,root,-)
  117. %{_bindir}/vala-gen-introspect
  118. %{_bindir}/vapicheck
  119. %{_bindir}/vapigen
  120. %{_bindir}/vala-gen-introspect-%{api_ver}
  121. %{_bindir}/vapicheck-%{api_ver}
  122. %{_bindir}/vapigen-%{api_ver}
  123. %{_libdir}/vala-%{api_ver}
  124. %{_mandir}/*/*gen*
  125. %files doc
  126. %defattr(-,root,root,-)
  127. %{_datadir}/devhelp/books/vala-%{api_ver}
  128. %changelog
  129. * Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.1-1
  130. - new upstream release
  131. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.0-1
  132. - new upstream release
  133. * Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.26.2-1
  134. - new upstream release
  135. * Sat Nov 8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.26.1-1
  136. - new upstream release
  137. - moved tools subpackage to Development/Tools Group
  138. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24.0-1
  139. - new upstream release
  140. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.1-1
  141. - new upstream release
  142. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.0-1
  143. - new upstream release
  144. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.20.1-1
  145. - new upstream release
  146. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.1-1
  147. - new upstream release
  148. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.0-1
  149. - new upstream release
  150. * Mon Jun 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-1
  151. - new upstream release
  152. * Sun Apr 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.0-1
  153. - new upstream release
  154. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-1
  155. - new upstream release
  156. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
  157. - new upstream release
  158. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
  159. - new upstream release
  160. - remove BuildRequires: gtk2-devel, xulrunner-devel
  161. - add BuildRequires: glib2-devel, libxslt
  162. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
  163. - new upstream release
  164. - remove BuildRequires: devhelp
  165. * Mon Jan 3 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.2-1
  166. - new upstream release
  167. * Thu Oct 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
  168. - new upstream release
  169. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.0-1
  170. - new upstream release
  171. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
  172. - rebuilt with rpm-4.8.1 for pkg-config
  173. * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.8-1
  174. - new upstream release
  175. - made -doc subpackage noarch
  176. * Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.7-1
  177. - new upstream release
  178. * Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
  179. - new upstream release
  180. * Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
  181. - new upstream release
  182. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
  183. - new upstream release
  184. * Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  185. - new upstream release
  186. - change BuildRequires: gecko-libs -> xulrunner-devel
  187. * Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
  188. - new upstream release
  189. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
  190. - new upstream release
  191. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
  192. - new upstream release
  193. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
  194. - initial build for Vine Linux
  195. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
  196. - Update to 0.7.5
  197. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
  198. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  199. * Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
  200. - Patch broken ModuleInit attribute (upstream bug 587444)
  201. * Tue Jul 7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
  202. - Update to 0.7.4
  203. * Wed Jun 3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
  204. - Update to 0.7.3
  205. * Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
  206. - Update to 0.6.1
  207. * Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
  208. - Update to 0.5.7
  209. * Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
  210. - Update to 0.5.6
  211. * Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
  212. - Update to 0.5.3
  213. * Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
  214. - Fix bug in Emacs version detection
  215. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
  216. - Use buildsystem variables to determine available Emacs version
  217. - BR on gecko-devel >= 1.9, since older version is also in RHEL repo
  218. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
  219. - Update to 0.5.2
  220. * Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
  221. - Update to 0.5.1
  222. * Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
  223. - Update to 0.3.5
  224. * Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
  225. - Add vala-mode for editing Vala code in Emacs
  226. * Tue Jul 1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
  227. - Update to 0.3.4
  228. * Wed Jun 4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
  229. - Update to 0.3.3
  230. * Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
  231. - Update to 0.3.2
  232. * Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
  233. - Update to 0.2.0
  234. * Wed Mar 5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
  235. - Update to 0.1.7
  236. - -tool subpackage now requires gnome-common, intltool and libtoolize
  237. for out-of-the-box vala-gen-project support
  238. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
  239. - Autorebuild for GCC 4.3
  240. * Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
  241. - Update to 0.1.6
  242. - Revert vapi addition, needed declarations have been inlined (r846)
  243. - Rename -docs subpackage to -doc, to comply with guidelines
  244. * Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
  245. - Manually add Gee vapi file to package (bz #428692)
  246. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
  247. - Backport patch to autodetect location of automake shared files
  248. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
  249. - Add build dependency on gtk2-devel
  250. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
  251. - Enable project generator tool
  252. * Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
  253. - Update to 0.1.5
  254. * Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
  255. - Add build dependency on devhelp
  256. * Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
  257. - Update to 0.1.4
  258. - Put newly-added documentation in its own subpackage (depends on devhelp)
  259. * Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
  260. - vapigen subpackage: add missing Require: on perl-XML-Twig
  261. * Sat Sep 8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
  262. - Split -vapigen subpackage. It is functionally self-contained and the license
  263. is more restricted
  264. - Updated license declarations
  265. * Wed Sep 5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
  266. - Licensing and URL updates
  267. * Tue Sep 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
  268. - Enable binding generation tools
  269. * Sun Sep 2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
  270. - Update to 0.1.3
  271. * Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
  272. - Update to 0.0.8
  273. * Wed Mar 7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
  274. - Update to 0.0.7
  275. * Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
  276. - Update to 0.0.6
  277. * Mon Nov 6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
  278. - Initial package