numpy-vl.spec 9.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. # eval to 2.3 if python isn't yet present, workaround for no python in fc4 minimal buildroot
  3. %{!?python_version: %define python_version %(%{__python} -c 'import sys; print sys.version.split(" ")[0]' || echo "2.3")}
  4. Name: numpy
  5. Summary: A fast multidimensional array facility for Python
  6. Version: 1.4.1
  7. Release: 7%{?_dist_release}
  8. Group: Development/Languages
  9. License: BSD
  10. URL: http://numeric.scipy.org/
  11. Source0: http://downloads.sourceforge.net/numpy/%{name}-%{version}.tar.gz
  12. Patch0: numpy-1.0.1-f2py.patch
  13. Patch1: numpy_doublefree.patch
  14. # PyOS_ascii_strtod is deprecated in python 2.7, and the deprecation warning
  15. # outside of the GIL causes python to segfault (rhbz#617384)
  16. # Patch is a combination of upstream changeset 7926 followed by 8387
  17. Patch2: numpy-1.4.1-remove-PyOS_ascii_strtod.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. #BuildRequires: python-devel lapack-devel python-setuptools gcc-gfortran atlas-devel python-nose
  20. BuildRequires: python-devel lapack-devel python-setuptools gcc-gfortran python-nose
  21. Requires: python-nose
  22. %description
  23. NumPy is a general-purpose array-processing package designed to
  24. efficiently manipulate large multi-dimensional arrays of arbitrary
  25. records without sacrificing too much speed for small multi-dimensional
  26. arrays. NumPy is built on the Numeric code base and adds features
  27. introduced by numarray as well as an extended C-API and the ability to
  28. create arrays of arbitrary type.
  29. There are also basic facilities for discrete fourier transform,
  30. basic linear algebra and random number generation. Also included in
  31. this package is a version of f2py that works properly with NumPy.
  32. %package f2py
  33. Summary: f2py for numpy
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. Requires: python-devel
  37. Provides: f2py
  38. Obsoletes: f2py <= 2.45.241_1927
  39. %description f2py
  40. This package includes a version of f2py that works properly with NumPy.
  41. %prep
  42. %setup -q -n %{name}-%{version}
  43. %patch0 -p1 -b .f2py
  44. %patch1 -p0
  45. %patch2 -p1 -b .remove-PyOS_ascii_strtod
  46. %build
  47. env FFTW=%{_libdir} BLAS=%{_libdir} \
  48. LAPACK=%{_libdir} CFLAGS="$RPM_OPT_FLAGS" \
  49. %{__python} setup.py build --fcompiler=gnu95
  50. %install
  51. rm -rf $RPM_BUILD_ROOT
  52. #%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
  53. # skip-build currently broken, this works around it for now
  54. env ATLAS=%{_libdir} FFTW=%{_libdir} BLAS=%{_libdir} \
  55. LAPACK=%{_libdir} CFLAGS="$RPM_OPT_FLAGS" \
  56. %{__python} setup.py install --root $RPM_BUILD_ROOT
  57. rm -rf docs-f2py ; mv $RPM_BUILD_ROOT%{python_sitearch}/%{name}/f2py/docs docs-f2py
  58. mv -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/f2py/f2py.1 f2py.1
  59. rm -rf doc ; mv -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/doc .
  60. install -D -p -m 0644 f2py.1 $RPM_BUILD_ROOT%{_mandir}/man1/f2py.1
  61. pushd $RPM_BUILD_ROOT%{_bindir} &> /dev/null
  62. # symlink for anyone who was using f2py.numpy
  63. ln -s f2py f2py.numpy
  64. popd &> /dev/null
  65. #symlink for includes, BZ 185079
  66. mkdir -p $RPM_BUILD_ROOT/usr/include
  67. ln -s %{python_sitearch}/%{name}/core/include/numpy/ $RPM_BUILD_ROOT/usr/include/numpy
  68. # Remove doc files. They should in in %doc
  69. rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/COMPATIBILITY
  70. rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/DEV_README.txt
  71. rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/INSTALL.txt
  72. rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/LICENSE.txt
  73. rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/README.txt
  74. rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/THANKS.txt
  75. rm -f $RPM_BUILD_ROOT%{python_sitearch}/%{name}/site.cfg.example
  76. %check
  77. pushd doc &> /dev/null
  78. PYTHONPATH="%{buildroot}%{python_sitearch}" %{__python} -c "import pkg_resources, numpy ; numpy.test()" \
  79. %ifarch s390 s390x
  80. || :
  81. %endif
  82. # don't remove this comment
  83. popd &> /dev/null
  84. %clean
  85. rm -rf $RPM_BUILD_ROOT
  86. %files
  87. %defattr(-,root,root,-)
  88. %doc docs-f2py doc/* LICENSE.txt README.txt THANKS.txt DEV_README.txt COMPATIBILITY site.cfg.example
  89. %dir %{python_sitearch}/%{name}
  90. %{python_sitearch}/%{name}/*.py*
  91. %{python_sitearch}/%{name}/core
  92. %{python_sitearch}/%{name}/distutils
  93. %{python_sitearch}/%{name}/fft
  94. %{python_sitearch}/%{name}/lib
  95. %{python_sitearch}/%{name}/linalg
  96. %{python_sitearch}/%{name}/ma
  97. %{python_sitearch}/%{name}/numarray
  98. %{python_sitearch}/%{name}/oldnumeric
  99. %{python_sitearch}/%{name}/random
  100. %{python_sitearch}/%{name}/testing
  101. %{python_sitearch}/%{name}/tests
  102. %{python_sitearch}/%{name}/compat
  103. %{python_sitearch}/%{name}/matrixlib
  104. %{python_sitearch}/%{name}/polynomial
  105. %{python_sitearch}/%{name}-*.egg-info
  106. %{_includedir}/numpy
  107. %files f2py
  108. %defattr(-,root,root,-)
  109. %{_mandir}/man*/*
  110. %{_bindir}/f2py
  111. %{_bindir}/f2py.numpy
  112. %{python_sitearch}/%{name}/f2py
  113. %changelog
  114. * Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.1-7
  115. - Initial build for Vine Linux
  116. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1:1.4.1-6
  117. - actually add the patch this time
  118. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1:1.4.1-5
  119. - fix segfault within %check on 2.7 (patch 2)
  120. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1:1.4.1-4
  121. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  122. * Sun Jul 18 2010 Dan Horák <dan[at]danny.cz> 1.4.1-3
  123. - ignore the "Ticket #1299 second test" failure on s390(x)
  124. * Thu Jun 24 2010 Jef Spaleta <jspaleta@fedoraprject.org> 1.4.1-2
  125. - source commit fix
  126. * Thu Jun 24 2010 Jef Spaleta <jspaleta@fedoraprject.org> 1.4.1-1
  127. - New upstream release. Include backported doublefree patch
  128. * Mon Apr 26 2010 Jon Ciesla <limb@jcomserv.net> 1.3.0-8
  129. - Moved distutils back to the main package, BZ 572820.
  130. * Thu Apr 08 2010 Jon Ciesla <limb@jcomserv.net> 1.3.0-7
  131. - Reverted to 1.3.0 after upstream pulled 1.4.0, BZ 579065.
  132. * Tue Mar 02 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-5
  133. - Linking /usr/include/numpy to .h files, BZ 185079.
  134. * Tue Feb 16 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-4
  135. - Re-enabling atlas BR, dropping lapack Requires.
  136. * Wed Feb 10 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-3
  137. - Since the previous didn't work, Requiring lapack.
  138. * Tue Feb 09 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-2
  139. - Temporarily dropping atlas BR to work around 562577.
  140. * Fri Jan 22 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-1
  141. - 1.4.0.
  142. - Dropped ARM patch, ARM support added upstream.
  143. * Tue Nov 17 2009 Jitesh Shah <jiteshs@marvell.com> - 1.3.0-6.fa1
  144. - Add ARM support
  145. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-6
  146. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  147. * Thu Jun 11 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-5
  148. - Fixed atlas BR, BZ 505376.
  149. * Fri Apr 17 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-4
  150. - EVR bump for pygame chainbuild.
  151. * Fri Apr 17 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-3
  152. - Moved linalg, fft back to main package.
  153. * Tue Apr 14 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-2
  154. - Split out f2py into subpackage, thanks Peter Robinson pbrobinson@gmail.com.
  155. * Tue Apr 07 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-1
  156. - Update to latest upstream.
  157. - Fixed Source0 URL.
  158. * Thu Apr 02 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-0.rc1
  159. - Update to latest upstream.
  160. * Thu Mar 05 2009 Jon Ciesla <limb@jcomserv.net> 1.2.1-3
  161. - Require python-devel, BZ 488464.
  162. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
  163. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  164. * Fri Dec 19 2008 Jon Ciesla <limb@jcomserv.net> 1.2.1-1
  165. - Update to 1.2.1.
  166. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.2.0-2
  167. - Rebuild for Python 2.6
  168. * Tue Oct 07 2008 Jon Ciesla <limb@jcomserv.net> 1.2.0-1
  169. - New upstream release, added python-nose BR. BZ 465999.
  170. - Using atlas blas, not blas-devel. BZ 461472.
  171. * Wed Aug 06 2008 Jon Ciesla <limb@jcomserv.net> 1.1.1-1
  172. - New upstream release
  173. * Thu May 29 2008 Jarod Wilson <jwilson@redhat.com> 1.1.0-1
  174. - New upstream release
  175. * Tue May 06 2008 Jarod Wilson <jwilson@redhat.com> 1.0.4-1
  176. - New upstream release
  177. * Mon Feb 11 2008 Jarod Wilson <jwilson@redhat.com> 1.0.3.1-2
  178. - Add python egg to %%files on f9+
  179. * Wed Aug 22 2007 Jarod Wilson <jwilson@redhat.com> 1.0.3.1-1
  180. - New upstream release
  181. * Wed Jun 06 2007 Jarod Wilson <jwilson@redhat.com> 1.0.3-1
  182. - New upstream release
  183. * Mon May 14 2007 Jarod Wilson <jwilson@redhat.com> 1.0.2-2
  184. - Drop BR: atlas-devel, since it just provides binary-compat
  185. blas and lapack libs. Atlas can still be optionally used
  186. at runtime. (Note: this is all per the atlas maintainer).
  187. * Mon May 14 2007 Jarod Wilson <jwilson@redhat.com> 1.0.2-1
  188. - New upstream release
  189. * Tue Apr 17 2007 Jarod Wilson <jwilson@redhat.com> 1.0.1-4
  190. - Update gfortran patch to recognize latest gfortran f95 support
  191. - Resolves rhbz#236444
  192. * Fri Feb 23 2007 Jarod Wilson <jwilson@redhat.com> 1.0.1-3
  193. - Fix up cpuinfo bug (#229753). Upstream bug/change:
  194. http://projects.scipy.org/scipy/scipy/ticket/349
  195. * Thu Jan 04 2007 Jarod Wilson <jwilson@redhat.com> 1.0.1-2
  196. - Per discussion w/Jose Matos, Obsolete/Provide f2py, as the
  197. stand-alone one is no longer supported/maintained upstream
  198. * Wed Dec 13 2006 Jarod Wilson <jwilson@redhat.com> 1.0.1-1
  199. - New upstream release
  200. * Tue Dec 12 2006 Jarod Wilson <jwilson@redhat.com> 1.0-2
  201. - Rebuild for python 2.5
  202. * Wed Oct 25 2006 Jarod Wilson <jwilson@redhat.com> 1.0-1
  203. - New upstream release
  204. * Tue Sep 06 2006 Jarod Wilson <jwilson@redhat.com> 0.9.8-1
  205. - New upstream release
  206. * Wed Apr 26 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.6-1
  207. - Upstream update
  208. * Thu Feb 16 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.5-1
  209. - Upstream update
  210. * Mon Feb 13 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.4-2
  211. - Rebuild for Fedora Extras 5
  212. * Thu Feb 2 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.4-1
  213. - Initial RPM release
  214. - Added gfortran patch from Neal Becker