libkkc-vl.spec 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141
  1. %define ver 0.1.2
  2. %define rel 1
  3. %define from_git 0
  4. %if %{from_git}
  5. %define githash ccfd5c6d
  6. %endif
  7. %if "%{?_dist_release}" == "vl6"
  8. %define with_vala 0
  9. %else
  10. %define with_vala 1
  11. %endif
  12. Summary: Japanese Kana Kanji conversion library (libkkc)
  13. Name: libkkc
  14. Version: %{ver}
  15. %if %{from_git}
  16. Release: %{rel}.git%{githash}%{_dist_release}
  17. %else
  18. Release: %{rel}%{_dist_release}
  19. %endif
  20. License: GPLv3
  21. Group: System Environment/Libraries
  22. URL: https://bitbucket.org/libkkc/libkkc/
  23. %if %{from_git}
  24. Source0: libkkc-%{githash}.tar.gz
  25. %else
  26. Source0: https://bitbucket.org/libkkc/libkkc/downloads/%{name}-%{version}.tar.gz
  27. %endif
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
  29. %if "%{?_dist_release}" == "vl6"
  30. BuildRequires: libgee-devel
  31. %else
  32. BuildRequires: libgee06-devel
  33. %endif
  34. BuildRequires: json-glib-devel
  35. BuildRequires: marisa-trie-devel
  36. %if %{with_vala}
  37. BuildRequires: vala-devel
  38. BuildRequires: vala-tools
  39. %endif
  40. Vendor: Project Vine
  41. Distribution: Vine Linux
  42. Packager: iwaim
  43. %description
  44. libkkc provides a converter from Kana-string to
  45. Kana-Kanji-mixed-string. It was named after kkc.el in GNU Emacs, a
  46. simple Kana Kanji converter, while libkkc tries to convert sentences
  47. in a bit more complex way using N-gram language models.
  48. %package devel
  49. Summary: Header files and libraries for developing apps which will use libkkc
  50. Group: Development/Libraries
  51. Requires: %{name} = %{version}-%{release}
  52. %description devel
  53. The libkkc-devel package contains the header files and libraries.
  54. %prep
  55. %if %{from_git}
  56. %setup -q -n %{name}-%{githash}
  57. %else
  58. %setup -q
  59. %endif
  60. %build
  61. %if %{from_git}
  62. ./autogen.sh
  63. %endif
  64. %configure --enable-shared \
  65. %if %{with_vala}
  66. --enable-vala=yes \
  67. %else
  68. --enable-vala=no \
  69. %endif
  70. %__make
  71. %install
  72. %__rm -rf $RPM_BUILD_ROOT
  73. %makeinstall
  74. %find_lang %{name}
  75. # remove files
  76. %__rm -f $RPM_BUILD_ROOT%{_libdir}/libkkc.la
  77. %clean
  78. %__rm -rf $RPM_BUILD_ROOT
  79. %post -p /sbin/ldconfig
  80. %postun -p /sbin/ldconfig
  81. %files -f %{name}.lang
  82. %defattr(-,root,root,-)
  83. %doc README ChangeLog COPYING AUTHORS NEWS
  84. %{_bindir}/kkc
  85. %{_libdir}/libkkc.so.*
  86. %{_libdir}/girepository-1.0/Kkc-1.0.typelib
  87. %dir %{_datadir}/libkkc
  88. %{_datadir}/libkkc/rules
  89. %files devel
  90. %defattr(-,root,root,-)
  91. %doc COPYING AUTHORS
  92. %dir %{_includedir}/libkkc
  93. %{_includedir}/libkkc/libkkc.h
  94. %{_libdir}/libkkc.so
  95. %{_libdir}/pkgconfig/kkc-1.0.pc
  96. %{_datadir}/gir-1.0/Kkc-1.0.gir
  97. %{_datadir}/vala/vapi/kkc-1.0.deps
  98. %{_datadir}/vala/vapi/kkc-1.0.vapi
  99. %changelog
  100. * Wed Feb 6 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.2-1
  101. - update to 0.1.2
  102. * Tue Feb 5 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.1-1
  103. - update to 0.1.1
  104. * Fri Feb 1 2013 IWAI, Masaharu <iwai@alib.jp> 0.1.0-1
  105. - update to 0.1.0
  106. - rename libkkc.pc to kkc-1.0.pc by upstream
  107. * Fri Feb 1 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-3.gitccfd5c6d
  108. - update to git ccfd5c6d9f913e0a413fe5d0c45bb70032382f68
  109. - add post and postun script
  110. - add translate file
  111. * Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-2
  112. - support Vine Linux 6
  113. - without Vala
  114. - BR: libgee-devel
  115. * Mon Jan 28 2013 IWAI, Masaharu <iwai@alib.jp> 0.0.3-1
  116. - initial build for Vine Linux