apel-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define origver 10.7
  4. %define origname apel
  5. Summary: A Portable Emacs Library
  6. Summary(ja): Emacs 用の 基礎的な関数を提供するライブラリ
  7. Name: %{origname}
  8. Version: %{origver}
  9. Release: 2%{?_dist_release}
  10. Source0: http://kanji.zinbun.kyoto-u.ac.jp/~tomo/lemi/dist/apel/apel-%{origver}.tar.gz
  11. Source1: apel-install.sh
  12. Source2: apel-remove.sh
  13. Source3: apel-init.el
  14. Patch10: apel-10.3-APEL-ELS.diff
  15. License: 1993-1999 Free Software Foundation, Inc., Dan Rich, Morioka Tomohiko, Kobayashi Shuhei
  16. Group: Applications/Editors/Emacs
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildArch: noarch
  19. Requires(post,preun): emacsen
  20. %prereq_ge emacsen-common
  21. Obsoletes: %{origname}-el
  22. Conflicts: semi <= 1.14.5-0vl2
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. Packager: Kazuhisa TAKEI <takei@vinelinux.org>
  26. %description
  27. This package contains following .el files for emacsen:
  28. APEL %{origver}
  29. APEL stands for "A Portable Emacs Library".
  30. It provides basic functions and macros for emacsen.
  31. Note: in order to rebuild this SRPM package, you need emacsen
  32. and emacsen-common installed.
  33. %description -l ja
  34. このパッケージは GNU Emacs %{emacsver} 上で使用する
  35. 以下の elisp を収めています.
  36. APEL %{origver}
  37. APEL は "A Portable Emacs Library" の略です.
  38. Emacs 環境のための基礎的な関数やマクロを提供します.
  39. 注意:この SRPM パッケージを rebuild するには、emacsen と emacsen-common が
  40. インストールされている必要があります.
  41. %prep
  42. %setup -n %{origname}-%{origver}
  43. %patch10 -p1
  44. %install
  45. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  46. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  47. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
  48. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
  49. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
  50. #
  51. # install el files
  52. #
  53. cp Makefile EMU-* APEL-* *.el %{SOURCE3} \
  54. ${RPM_BUILD_ROOT}/usr/share/emacs/site-lisp/%{origname}
  55. #
  56. # install script( bytecompile el and install elc , remove )
  57. #
  58. %_installemacsenscript %{origname} %{SOURCE1}
  59. %_removeemacsenscript %{origname} %{SOURCE2}
  60. %post
  61. #
  62. # bytecompile and install
  63. #
  64. if [ "$1" = 2 ]; then
  65. %_emacsenPackageRemove %{origname}
  66. fi
  67. %_addemacsenlist %{origname}
  68. %_emacsenPackageInstall %{origname}
  69. %preun
  70. if [ "$1" = 0 ]; then
  71. %_emacsenPackageRemove %{origname}
  72. %_removeemacsenlist %{origname}
  73. fi
  74. %triggerpostun -- apel-el
  75. %_emacsenPackageInstall %{origname}
  76. %clean
  77. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  78. %files
  79. %defattr(-,root,root)
  80. %doc ChangeLog README*
  81. /usr/share/emacs/site-lisp/%{origname}/
  82. /usr/lib/emacsen-common/packages/install/%{origname}
  83. /usr/lib/emacsen-common/packages/remove/%{origname}
  84. %changelog
  85. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 10.7-2
  86. - spec in utf8
  87. * Fri May 2 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.7-1
  88. - applied new versioning policy
  89. * Fri Dec 7 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.7-0vl1
  90. - updated to 10.7
  91. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.6-0vl3
  92. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  93. * Wed Dec 24 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.6-0vl2
  94. - rebuilt
  95. * Tue Jul 8 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 10.6-0vl1
  96. - updated to new upstream version 10.6
  97. * Mon Jun 09 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.5-0vl1
  98. - updated to new upstream version 10.5
  99. * Mon May 19 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 10.4-0vl1
  100. - update.
  101. - Tag Changed(Copyright -> License)
  102. * Fri Jan 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.3-0vl9
  103. - Obsoletes: apel-el now, instead of Conflicts:
  104. - added %%triggerpostun -- apel-el
  105. * Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.3-0vl8
  106. - package name changed apel-el -> apel again
  107. - added Source3 for forthcoming site-start mechanism
  108. * Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.3-0vl7
  109. - activate file-detect and atype (Patch10), especially for xemacs
  110. * Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.3-0vl6
  111. - fixed the target directory for emu modules to be installed
  112. - included missing documents again
  113. - cleanup the spec file
  114. * Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  115. - emacsenize
  116. * Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  117. - 1.14.3-0vl2
  118. - back to Requires: emacs = 20.7 -> emacs >= 20.7 (for emacs-beta)
  119. * Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  120. - 1.14.3-0vl1
  121. - updated to apel-10.3, flim-1.14.3, semi-1.14.3, emh-1.14.1
  122. * Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
  123. - 1.13.7-8
  124. - added %define _noVersionedDependencies 1
  125. * Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
  126. - 1.13.7-7
  127. - modified %files section to handle compressed man page(s)
  128. * Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
  129. - 1.13.7-6
  130. - apel updated to 10.2
  131. * Mon Jan 24 2000 MATSUBAYASHI 'Shaolin' Kohji
  132. - 1.13.7-5
  133. - added patch (see emacs-mime-ja: 00303) to format texinfo correctly
  134. * Thu Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji
  135. - 1.13.7-4
  136. - updated in sync with apel-10.0 / clime-1.13.6 release
  137. * Wed Dec 1 1999 MATSUBAYASHI 'Shaolin' Kohji
  138. - 1.13.7-3
  139. - change Group to Applications/Editors/EmacsLisp
  140. * Mon Nov 29 1999 MATSUBAYASHI 'Shaolin' Kohji
  141. - 1.13.7-2
  142. - added patches (see emacs-mime-ja:00183, emacs-mime-ja:00184)
  143. - now emh-1.10.1 and rmail-mime-1.13.0 are also included
  144. - documentation files are properly stored under /usr/doc directory
  145. * Wed Nov 3 1999 MATSUBAYASHI 'Shaolin' Kohji
  146. - 1.13.7-1
  147. - updated to apel-9.23 / clime-1.13.5 / semi-1.13.7 release
  148. - added Japanese / English info files to be installed